Subject: IPv6 updates & related RA-Guard document

From: RJ Atkinson <[email-masked]>
Date: Tue, 25 Sep 2012 11:01:30 -0400

Hi,

Work on the RA-Guard specification in another IETF WG
drove the creation of two I-Ds currently in this WG:
	- draft-ietf-6man-nd-extension-headers
	- draft-ietf-6man-oversized-header-chain

The RA Guard work in the other IETF WG is currently
*blocked* pending the 6MAN WG approving the 2 I-Ds above.

In turn, the RA Guard work is a high priority for all kinds
of network operators (i.e. not just ISPs), because it provides 
practical risk reduction and risk mitigation for a real-world 
operational security issue.

RA Guard implementers can't really move forward until the
RA Guard I-D is approved by the other WG -- which I believe
is at present blocked on the 2 I-Ds at top being approved 
by the 6MAN WG.

My understanding is that the technical content in these
2 IPv6 Spec update I-Ds has been presented more than once.  

Further, the drafts have been around long enough that active
6MAN WG participants already should have read them.

I am a bit confused about where we stand with these today,
so I have two questions:

- Where does the 6MAN WG stand with these two drafts ?

- How can we move them forward (soon -- i.e. BEFORE the 
  next IETF in-person meeting), so that the other active 
  IETF work (i.e. RA-Guard) can be unblocked ?

- Can these go into WG Last Call now ?

Thanks,

Ran

---

From: Mohacsi Janos <[email-masked]>
Date: Wed, 26 Sep 2012 09:41:20 +0200 (CEST)

>  IETF work (i.e. RA-Guard) can be unblocked ?

RA-guard work mostly done at v6ops.
http://tools.ietf.org/html/draft-ietf-v6ops-ra-guard-08
http://tools.ietf.org/html/draft-ietf-v6ops-ra-guard-implementation-04

Probably drafts should be circulated on v6ops mailing list and have 
support from there.

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Fernando Gont <[email-masked]>
Date: Wed, 26 Sep 2012 15:14:40 +0200

> http://tools.ietf.org/html/draft-ietf-v6ops-ra-guard-implementation-04

draft-ietf-v6ops-ra-guard-implementation cannot be published as RFC
because of normative references to draft-ietf-6man-nd-extension-headers
and draft-ietf-6man-oversized header chains. i.e., the 6man drafts need
to be published as RFCs along or before
draft-ietf-v6ops-ra-guard-implementation.

FWIW, my take is that the aforementioned two 6man documents are ready
for WGLC.

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: RJ Atkinson <[email-masked]>
Date: Wed, 26 Sep 2012 09:43:10 -0400

On 26  Sep 2012, at 03:41 , Mohacsi Janos wrote:
> Probably drafts should be circulated on v6ops mailing list
> and have support from there.

IETF v6ops WG Charter does not include updates to the
IPv6 specifications.  Quoting from this WG Charter:
	"Specifying any protocols or transition 
	mechanisms is out of scope of the WG."

IETF 6MAN WG Charter DOES include updates to the
IPv6 specifications, again quoting from this WG Charter:
	"The working group will address protocol limitations/issues
	discovered during deployment and operation."

This is why the draft-*-ra-guard-* documents (quoted above)
belong in the IETF v6ops WG, while the 2 different I-Ds 
that I mentioned belong here in the IETF 6MAN WG.

Now, in practice, the 2 draft-ietf-6man-* I-Ds that I mentioned 
before already have been reviewed by many folks in v6ops, 
as part of examining the RA Guard documents, and I believe
there is broad support for these updates within v6ops.
However, these 2 protocol specification updates are required 
to be handled by the IETF 6MAN WG, simply as a matter
of the applicable IETF WG charters and usual IETF processes.

Yours

Ran

---

From: Mohacsi Janos <[email-masked]>
Date: Wed, 26 Sep 2012 16:43:23 +0200 (CEST)

> of the applicable IETF WG charters and usual IETF processes.

The situation must be clear for everybody now. I fully support WGLC for 2 
draft-ietf-6man-* I-Ds to move forward.

Best Regards,
 	Janos Mohacsi