Subject: Re: the two other drafts similar to raoptions draft (Was: 6man IETF85 Call for agenda items)

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 05 Nov 2012 19:46:16 +0100

HEllo Behcet,

I pick on this email to reply.

You presented today draft-sarikaya-mif-6man-ra-route-01 in 6man.

There are these other two drafts which do practically the same thing:
route exchange using ND.

draft-jhlee-mext-mnpp-00.txt
draft-petrescu-autoconf-ra-based-routing-02.txt

These latter two are considered in settings for vehicular environments.

Yours,

Alex

Le 24/10/2012 21:19, Behcet Sarikaya a écrit :
> Hi Bob,
>
> I would like to request a slot to present: my draft on IPv6 RA
> Options for Multiple Interface Next Hop Routes at
> http://tools.ietf.org/html/draft-sarikaya-mif-6man-ra-route-01
>
> and also IPv6 RA Options for Translation Multicast Prefixes at
> http://tools.ietf.org/html/draft-sarikaya-softwire-6man-raoptions-00.
>
>  Regards,
>
> Behcet
>
> On Thu, Oct 4, 2012 at 3:24 PM, Bob Hinden <[email-masked]>
> wrote:
>> 6MAN has a 2 1/2 hour slot allocated for Atlanta:
>>
>> 6man Session 1 (2:30:00) 5 November 2012 Monday, Morning Session I
>> 0900-1130 Room Name: Salon D
>>
>> [Note the date and time might change]
>>
>> If you have a draft you would like to discuss, please send your
>> request for agenda time to the 6man chairs.  Please include in the
>> request, the title and file name of the draft, the speakers name
>> (and email), and how much time you need.
>>
>> We will prioritise drafts that are working group items, drafts that
>> have been actively discussed on the list, and other individual
>> submissions in that order.
>>
>> Please have agenda items to us by 15 October 2012 and also note the
>> following deadlines for IETF85:
>>
>> 2012-10-15 (Monday): Internet Draft Cut-off for initial document
>> (-00) submission by UTC 24:00 2012-10-22 (Monday): Internet Draft
>> final submission cut-off by UTC 24:00
>>
>> Regards,
>>
>> Bob & Ole
>>
>> --------------------------------------------------------------------
>>
>>
IETF IPv6 working group mailing list
>> [email-masked] Administrative Requests:
>> https://www.ietf.org/mailman/listinfo/ipv6
>> --------------------------------------------------------------------
>
>>
--------------------------------------------------------------------
> IETF IPv6 working group mailing list [email-masked] Administrative
> Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>
>

---

From: Romain KUNTZ <[email-masked]>
Date: Sat, 10 Nov 2012 15:09:54 +0100

Hello Alexandru,

From what I understand, draft-sarikaya is for hosts only while draft-jhee and draft-petrescu are for routers. 

I'd have a question regarding exchanging MNP reachability between routers: wouldn't it be the job of a routing protocol instead? Any reasons why extending ND instead of using e.g. a MANET-type of protocol for such scenarios?

Regards,
Romain

On Nov 5, 2012, at 19:46 , Alexandru Petrescu <[email-masked]> wrote:

> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 28 Nov 2012 11:39:57 +0100

Le 10/11/2012 15:09, Romain KUNTZ a écrit :
> Hello Alexandru,
>
>> From what I understand, draft-sarikaya is for hosts only while
>> draft-jhee and draft-petrescu are for routers.
>
> I'd have a question regarding exchanging MNP reachability between
> routers: wouldn't it be the job of a routing protocol instead? Any
> reasons why extending ND instead of using e.g. a MANET-type of
> protocol for such scenarios?

I think routing protocols which support some form of dynamic behaviour
(nodes moving around) may be adequate to some very complicated vehicular
communications scenarios.

But ones considered here: single-hop LV to IV communications may not
take much advantage of the loop avoidance shortest path reliable route
buildup which such protocols typically provide.

The protocols considered here (ND, DHCP) as alternatives to
MANET-type of routing protocols have this feature of working closely
with address auto-configuration which is highly needed, whereas
MANET-type protocols do not consider address/prefix auto-configuration
as important requirements.

The ND and DHCP protocols have aspects which are needed in a fast moving
highly dynamic vehicular environment.  For example this RS optionality:
an RA may be broadcasted periodically thus speeding up autoconf and
route exchange, whereas same is not clear about AODV's RREP.

Comparing AODV one also sees this AODV need of sequence numbers which is
good in general cases (several hops) and reliability needs.  This is
absent from ND and works ok on a single hop.

Then, each other MANET protocols is different... not sure which should I
look at more closely.

What do you think?

Yours,

Alex

> Regards, Romain
>> There are these other two drafts which do practically the same
>> thing: route exchange using ND.
>>
Regards,
>>>
>>> Behcet
>>>
>>> On Thu, Oct 4, 2012 at 3:24 PM, Bob Hinden
>>> <[email-masked]> wrote:
>>>> 6man Session 1 (2:30:00) 5 November 2012 Monday, Morning
>>>> Session I 0900-1130 Room Name: Salon D
>>>>
>>>> If you have a draft you would like to discuss, please send
>>>> your request for agenda time to the 6man chairs.  Please
>>>> include in the request, the title and file name of the draft,
>>>> the speakers name (and email), and how much time you need.
>>>>
>>>> We will prioritise drafts that are working group items, drafts
>>>>  that have been actively discussed on the list, and other
>>>> individual submissions in that order.
>>>>
>>>> Please have agenda items to us by 15 October 2012 and also note
>>>> the following deadlines for IETF85:
>>>>
>>>> 2012-10-15 (Monday): Internet Draft Cut-off for initial
>>>> document (-00) submission by UTC 24:00 2012-10-22 (Monday):
>>>> Internet Draft final submission cut-off by UTC 24:00
>>>>
>>>> Regards,
>>>>
>>>> Bob & Ole
>>>>
>>> IETF IPv6 working group mailing list [email-masked]
>>> Administrative Requests: