Subject: Parameterized IP-Specific configuration

From: "Liubing (Leo)" <[email-masked]>
Date: Tue, 20 Nov 2012 02:57:48 +0000

Hi, all

This is not talking about a new idea. The " Parameterized IP-Specific configuration" comes from the 6renum WG item, see http://tools.ietf.org/html/draft-ietf-6renum-gap-analysis-04#page-11

The draft is under 6renum WGLC, according to the comment in the Atlanta meeting, we need your review/comment of whether the "Parameterized IP-specific configuration" is a proper expression.
And if you still have other comments of the document, that would be also appreciated very much.

Thanks a lot.

B.R.
Bing

****For your convenient, abstract the original texts here****
(In draft-ietf-6renum-gap-analysis-04#page-11)

6.3. Parameterized IP-specific Configuration

   Besides the DNS records and the in-host server address entries, there
   are also many places in which the IP addresses are configured, for
   example, filters such as ACL and routing policies, etc. There are
   even more sophisticated cases where the IP addresses are used for
   deriving values, for example, using the unique portion of the
   loopback address to generate an ISIS net ID.

   Ideally, a layer of abstraction for IP-specific configuration within
   various devices (routers, switches, hosts, servers, etc.) is needed.
   However, this cannot be achieved in one step. One possible
   improvement is to make the IP-specific configuration parameterized.
   Two aspects of parameterized configuration could be considered to
   achieve this.
...

Here's an example (not in the draft, just for your easy understanding the above texts.)
First, we define the addresses for a given interface interface gigabitethernet1/1
ipv4 address 192.0.2.10/24
ipv6 address 2001:db8::10/64

Note that these addresses could also be automatically configured using DHCP or SLAAC, perhaps then the example would be:
Interface gigabitethernet1/1
ipv4 address dynamic dhcp
ipv6 address dynamic dhcpv6

then elsewhere in the configuration:

access-list example1
permit ipv4 any [gigabitethernet1/1] mask /24 #this permits any ip address that matches the prefix assigned to the interface in brackets [], in the range defined by the subnet mask at the end of the command permit ipv6 any [gigabitethernet1/1] mask /48 #this is the ipv6 equivalent, but permits any address in the entire /48

Similar examples could be possible for a BGP session, snmp source address, etc. Anywhere else you would hard-code an IP address could use a parameter to invoke an address inherited from an interface.

---

From: Stig Venaas <[email-masked]>
Date: Tue, 20 Nov 2012 09:24:03 -0800

> And if you still have other comments of the document, that would be also appreciated very much.

Looks good to me. Whether "parametrized" is the correct expression I'm
not sure. I cannot really find a good/better term for this. The main
thing is that there is enough detail for people to understand what it is
about. Would it be useful to have an example in the draft (maybe in an
appendix?). Just so it is clear? I think the current text is fairly
clear though.

Stig

---

From: Tim Chown <[email-masked]>
Date: Tue, 20 Nov 2012 18:29:53 +0000

> appendix?). Just so it is clear? I think the current text is fairly

I agree - further comments welcome though.

Tim

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Teco Boot <[email-masked]>
Date: Wed, 21 Nov 2012 13:35:13 +0100

Op 20 nov. 2012, om 18:24 heeft Stig Venaas het volgende geschreven:

>> IP-Specific configuration

What about "IP configuration for dynamic IP addresses"?

Teco

---

From: "George, Wes" <[email-masked]>
Date: Wed, 21 Nov 2012 10:28:25 -0500

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Teco Boot
>
>

[WEG] I'm not keen on that nomenclature because it's not really limited to dynamic IP addresses. The idea is more one of inheritance, where configuration elsewhere uses addresses referenced based on the interface rather than explicitly defined. In other words, use a variable in things like ACLs, instead of the explicit value, and the variable's value is defined based on the interface it references. The addresses themselves can be assigned either via dynamic or static methods, and the idea being discussed here is really agnostic as to which method is used.

Thanks
Wes George

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Tom Taylor <[email-masked]>
Date: Wed, 21 Nov 2012 10:54:54 -0500

Sounds like we're talking about templates.

On 21/11/2012 10:28 AM, George, Wes wrote:
>> From: [email-masked] [mailto:[email-masked]] On
>> Behalf Of Teco Boot
>>
>>
> [WEG] I'm not keen on that nomenclature because it's not really
> limited to dynamic IP addresses. The idea is more one of inheritance,
> where configuration elsewhere uses addresses referenced based on the
> interface rather than explicitly defined. In other words, use a
> variable in things like ACLs, instead of the explicit value, and the
> variable's value is defined based on the interface it references. The
> addresses themselves can be assigned either via dynamic or static
> methods, and the idea being discussed here is really agnostic as to
> which method is used.
>
> Thanks Wes George
>
...

---

From: Teco Boot <[email-masked]>
Date: Wed, 21 Nov 2012 16:58:30 +0100

> [WEG] I'm not keen on that nomenclature because it's not really limited to dynamic IP addresses. The idea is more one of inheritance, where configuration elsewhere uses addresses referenced based o…
OK. But with static IP addresses, the config procedure / tool can parse and actual config can make use of literals. With dynamic IP addresses, this is no option.

I agree on that the variable, used for configuring addresses, could be configured statically somewhere in the config. Can make IP diagrams more readable also, I use p1:: p2:: etc. a lot. With a legend somewhere.

Teco