Subject: first hop routing - visible in user space?

From: Karl Auer <[email-masked]>
Date: Thu, 21 Feb 2013 18:12:03 +1100

Are the data structures involved in first hop routing for IPv6 (see RFC
2461, 4861 and 491 "conceptual models") visible in user space?That is,
is it possible to see what's going on as it happens? If so, how? Or is
it a black box?

Regards, K.

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Karl Auer ([email-masked])
http://www.biplane.com.au/kauer
http://www.biplane.com.au/blog

GPG fingerprint: B862 FB15 FE96 4961 BC62 1A40 6239 1208 9865 5F9A
Old fingerprint: AE1D 4868 6420 AD9A A698 5251 1699 7B78 4EEE 6017

---

From: Mark Smith <[email-masked]>
Date: Thu, 21 Feb 2013 10:57:41 -0800 (PST)

Hi Karl,

----- Original Message -----
> From: Karl Auer <[email-masked]>
> To: IETF IPv6 <[email-masked]>; IPv6 Tech <[email-masked]>
> Cc: 
> Sent: Thursday, 21 February 2013 6:12 PM
> Subject: first hop routing - visible in user space?
> 

Linux exposes some of this information to user space e.g.

ip -6 route show table cache

and the 

ip -6 neigh show

command shows the router flag for neighbors that are routers.

My understanding though is that Linux doesn't implement the described data structures specifically.

Regards,
Mark.