Subject: Re: Why /64

From: Nabil Benamar <[email-masked]>
Date: Fri, 1 Nov 2013 09:38:43 +0000

Hi All,

I think that no one can imagine and predict the shape of the internet in
the upcoming years. Fathers of the Internet themselves didn't expected that
this network will be so huge while they were developing IPv4 addressing
scheme. It is the case actually with IPv6...we say that there are enough
addresses for many years to come but when thinking about IoT or IoE one can
express his reservation !

*Best wishes*
*nabilbenamar.com*

*
--------------------------------------------------------------------------------
*

On Thu, Oct 31, 2013 at 10:31 PM, Usman Latif <[email-masked]> wrote:

> Guys, I think we has this debate many times already
> The only conclusion I could draw was that the current IPv6 addressing
> architecture (with network/host boundaries at /64 or
> allocations/assignments at /48s) is to address the IP address exhaustion
> for the near future (say < 100 years?)and we only care about near future
> What happens two to three hundred years from now - who cares ?? :)
>
> Regards,
> Usman
>
>
> Date: Thu, 31 Oct 2013 22:06:00 +0000
> From: "Manfredi, Albert E" <[email-masked]>
> To: Brian E Carpenter <[email-masked]>
> Cc: IETF IPv6 Mailing List <[email-masked]>
> Subject: RE: Why /64
> Message-ID:
>    <[email-masked]
> >
>
> Content-Type: text/plain; charset="utf-8"
>
> -----Original Message-----
>
> From: Brian E Carpenter [mailto:[email-masked]<[email-masked]>
> ]
>
>
> Because there are trillions of /48s.
>
>
> And we think that is way more than adequate, today. Until the paradigm
> changes, and every vehicle, every street, every building, every person,
> will need its own internal subnet structure. For things like
> vehicle-to-infrastructure comms, vehicle-to-vehicle comms, internal vehicle
> controls and diagnostics (separated into multiple subsystems of course),
> wearable medical sensors, and who knows what else. And space.
>
> I'm just saying, classful IPv4 also seemed like plenty at first. It was a
> mere decade before we knew differently.
>
> Bert
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>
>

---

From: Mark ZZZ Smith <[email-masked]>
Date: Sat, 2 Nov 2013 17:48:57 -0700 (PDT)

>________________________________
> From: Usman Latif <[email-masked]>
>To: "[email-masked]" <[email-masked]> 
>Sent: Friday, 1 November 2013 9:31 AM
>Subject: RE: Why /64
> 
>
>
>The only conclusion I could draw was that the current IPv6 addressing architecture (with network/host boundaries at /64 or allocations/assignments at /48s) is to address the IP address exhaustion for the near future (say < 100 years?)and we only care about near future

Given the experience of the people who've designed IPv6, I'm pretty sure they care for more than the near future.

Some people seem to believe IPv6 was designed by people who had very little experience with the Internet and its growing pains. Those people should look up who the designers are and what their experience is before making that judgment.

>What happens two to three hundred years from now - who cares ?? :)

The existing IPv6 global address space is only 1/8th of the total (2000::/3). Allowing another 1/8th for link-locals/loopbacks/multicast etc., leaves another 6 attempts to get it wrong before we actually run out of IPv6 addresses.

Regards,
Mark.