Subject: Sean Turner's No Objection on draft-ietf-6man-oversized-header-chain-08: (with COMMENT)

From: "Sean Turner" <[email-masked]>
Date: Wed, 20 Nov 2013 18:52:25 -0800

Sean Turner has entered the following ballot position for
draft-ietf-6man-oversized-header-chain-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/draft-ietf-6man-oversized-header-chain/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

This is non-blocking ...

How often does this happen?  I'm asking because I'm curious if there's
now going to be huge surge in ICMP error messages indicating discards.

Also, I guess I'd reword this:

 Whether a host or intermediate system originates this ICMP
   message, its format is identical.

to

The format for the ICMP message is the same regardles of whether a host
or intermediate system originates it.

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 21 Nov 2013 15:00:27 +0000

Sean,

Honestly, we have no idea how often first fragments not containing the entire header chain can be observed on the Internet. However, we do know the following:

- Fragmented IPv6 packets are somewhat because many sites will not accept them at all (regardless of what the first fragment contains). One study observes that 10% of sites do not accept fragments. Another study observes that 40% of sites do not accept fragments. We cannot explain the divergent results. 

- Most implementations rate limit the ICMP messages that they generate to 50 per second.

Also, we will fix the wording as you suggest.

                                          Ron

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Sean Turner
> Sent: Wednesday, November 20, 2013 9:52 PM
> To: The IESG
> Cc: [email-masked]; draft-ietf-6man-oversized-header-
> [email-masked]; [email-masked]
> Subject: Sean Turner's No Objection on draft-ietf-6man-oversized-
> header-chain-08: (with COMMENT)
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Tim Chown <[email-masked]>
Date: Fri, 22 Nov 2013 00:32:40 +0000

Hi Ron,

> - Fragmented IPv6 packets are somewhat because many sites will not accept them at all (regardless of what the first fragment contains). One study observes that 10% of sites do not accept fragments.…

The figures an MSc student discovered using scapy-based tests was nearer 30% against a list of Alexa sites.  I’m getting the tests re-run afresh and will put you (and Fernando) in touch with the person doing this shortly, as he’s started getting some results this week.

Longer header chains within single packets also get a higher failure rate. Regardless, it will be very good to get this draft published and implementations beginning to honour it.

Tim

---

From: Sean Turner <[email-masked]>
Date: Fri, 29 Nov 2013 23:02:37 -0500

> Also, we will fix the wording as you suggest.

Ron,

Thanks for the info.

spt