Subject: I-D Action: draft-ietf-6man-multicast-scopes-01.txt

From: [email-masked]
Date: Mon, 04 Nov 2013 06:46:22 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the IPv6 Maintenance Working Group of the IETF.

	Title           : IPv6 Multicast Address Scopes
	Author(s)       : Ralph Droms
	Filename        : draft-ietf-6man-multicast-scopes-01.txt
	Pages           : 5
	Date            : 2013-11-04

Abstract:
   This document updates the definitions of IPv6 multicast scopes.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-6man-multicast-scopes

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-6man-multicast-scopes-01

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-6man-multicast-scopes-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Ralph Droms <[email-masked]>
Date: Mon, 4 Nov 2013 06:51:54 -0800

I've updated draft-ietf-6man-multicast-scopes-01.txt, based on the discussion of the previous revision that begins here:  http://www.ietf.org/mail-archive/web/ipv6/current/msg19112.html

Please take a look to confirm the new revision correctly reflects the consensus of that discussion.

- Ralph

On Nov 4, 2013, at 6:46 AM 11/4/13, [email-masked] wrote:

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Kerry Lynn <[email-masked]>
Date: Mon, 4 Nov 2013 07:20:19 -0800

On Mon, Nov 4, 2013 at 6:51 AM, Ralph Droms <[email-masked]> wrote:

> I've updated draft-ietf-6man-multicast-scopes-01.txt, based on the
> discussion of the previous revision that begins here:
> http://www.ietf.org/mail-archive/web/ipv6/current/msg19112.html
>
> Hi Ralph,

This looks great.  I think the NEW text in Section 1 does a good job of
clarifying
the previous definition in RFC 4291.

A few comments:

- I'd prefer to substitute "Multilink-Local" everywhere in place of
"Realm-Local" as I
  believe it's a more meaningful name for the new scope.

- It would be good to eliminate the reference to "RPL realm" (as I think no
such term
  is defined) and instead use "RPL Instance" or "RPL DODAG" (if indeed
either of these
  terms is consistent with the automatic definition of a scop 3 zone
boundary).  If you
  refer to RPL, you might also include RFC 6550 in the Normative References.

- There's a minor typo in section 5; "enuring" should be "ensuring".

Regards, -K-

---

From: Ralph Droms <[email-masked]>
Date: Mon, 4 Nov 2013 08:06:56 -0800

Thanks for the quick review.

On Nov 4, 2013, at 7:20 AM, Kerry Lynn <[email-masked]> wrote:

> This looks great.  I think the NEW text in Section 1 does a good job of clarifying
> - I'd prefer to substitute "Multilink-Local" everywhere in place of "Realm-Local" as I

Sounds like a reasonable change.  Is there WG consensus in support?
> 
> - It would be good to eliminate the reference to "RPL realm" (as I think no such term
>   is defined) and instead use "RPL Instance" or "RPL DODAG" (if indeed either of these
>   terms is consistent with the automatic definition of a scop 3 zone boundary).  If you

Well, I had intended to eliminate all references to RPL as the multicast scoping (and, more broadly, the operation) of MPL is independent of RPL...

...which brings me to a final point that the WG needs to consider: where to publish the definition of the zone of scope 3 for networks using IEEE802.15.4.

If the WG chooses to publish that definition in this document, the phrase that currently refers to RPL could be replaced by a new section giving that definition as an exemplar for future definitions.

For example, a new section could be added:

3. Definition of scope 3 for networks using IEEE802.15.4

   In a network using IEEE 802.15.4 radio technology [IEEE802.15.4], the zone
   for scope 3 is defined as the collection of all mutually reachable interfaces that
   share a PAN ID.

- Ralph

---

From: Ole Troan <[email-masked]>
Date: Mon, 4 Nov 2013 23:20:51 +0100

> Sounds like a reasonable change.  Is there WG consensus in support?

if the intention was to be unspecific about what bounded scope 3 (e.g. multilink subnets, or other technologies),
then realm-local is less specific than multilink-local.

cheers,
Ole

---

From: 神明達哉 <[email-masked]>
Date: Mon, 4 Nov 2013 15:23:58 -0800

At Mon, 4 Nov 2013 06:51:54 -0800,

> Please take a look to confirm the new revision correctly reflects the consensus of that discussion.

It looks good to me.  I don't have any opinion on Realm-Local vs
Multilink-Local.

--
JINMEI, Tatuya