Subject: [IANA #725488] Last Call: <draft-ietf-6man-ug-05.txt> (Significance of IPv6 Interface Identifiers) to Proposed Standard

From: "Pearl Liang via RT" <[email-masked]>
Date: Fri, 22 Nov 2013 20:14:22 +0000

(BEGIN IANA LAST CALL COMMENTS)

IESG/Authors/WG Chairs:

IANA has reviewed draft-ietf-6man-ug-05.  Authors should review the comments and/or questions below.  Please report any inaccuracies and respond to any questions as soon as possible.

We received the following comments/questions from the IANA's reviewer:

IANA has some questions about the text of the IANA Considerations section 
of this document.

Should the text in the IANA Considerations section of this document:

"Full deployment of a new reserved IID value would require updates to IID generation code in every deployed IPv6 stack, so the technical justification for such a Standards Action would need to be extremely strong."

be added to the Reserved IPv6 Interface Identifiers registry located at:

http://www.iana.org/assignments/ipv6-interface-ids/

?  Then, should the reference for this registry be updated to [RFC5453]
and [ RFC-to-be ]?

Other than the above questions, IANA understands that, upon approval of this document, there are no IANA Actions that need completion.  IANA requests that the IANA Considerations section of the document remain in place upon publication.

Note:  The actions requested in this document will not be completed 
until the document has been approved for publication as an RFC. 
This message is only to confirm what actions will be performed.  

Thanks,

Pearl Liang
ICANN/IANA

(END IANA LAST CALL COMMENTS)

On Thu Nov 14 07:43:35 2013, [email-masked] wrote:
> 
> The IESG has received a request from the IPv6 Maintenance WG (6man) to
> consider the following document:
> - 'Significance of IPv6 Interface Identifiers'
>   <draft-ietf-6man-ug-05.txt> as Proposed Standard
> 
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2013-11-28. Exceptionally, comments may be
> sent to [email-masked] instead. In either case, please retain the
> beginning of the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>    The IPv6 addressing architecture includes a unicast interface
>    identifier that is used in the creation of many IPv6 addresses.
>    Interface identifiers are formed by a variety of methods.  This
>    document clarifies that the bits in an interface identifier have no
>    meaning and that the entire identifier should be treated as an opaque
>    value.  In particular, RFC 4291 defines a method by which the
>    Universal and Group bits of an IEEE link-layer address are mapped
>    into an IPv6 unicast interface identifier.  This document clarifies
>    that those two bits are significant only in the process of deriving
>    interface identifiers from an IEEE link-layer address, and updates
>    RFC 4291 accordingly.
> 
> 
> 
> 
> The file can be obtained via
> http://datatracker.ietf.org/doc/draft-ietf-6man-ug/
> 
> IESG discussion can be tracked via
> http://datatracker.ietf.org/doc/draft-ietf-6man-ug/ballot/
> 
> 
> No IPR declarations have been submitted directly on this I-D.
> 
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 24 Nov 2013 08:26:40 +1300

Pearl

Thanks for your careful reading of the draft. Please see below.

> ?  Then, should the reference for this registry be updated to [RFC5453]

My personal opinion is that this would be useful. I don't believe that
the current draft should make a formal update to RFC 5453, because
there's nothing wrong with that RFC, but adding the citation in
the registry can only help.

Regards
   Brian Carpenter

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 26 Nov 2013 11:51:37 +1300

Agreed, subject to agreement from the AD and WG Chairs.

Regards
   Brian

On 26/11/2013 09:52, Pearl Liang via RT wrote:
> Hi Brian,
> 
> Thank you for the reply.  So, please confirm the following 
> action upon approval of this document:
> 
> - Add the following note to the registry "Reserved IPv6 Interface 
> Identifiers" located at:
> 
> http://www.iana.org/assignments/ipv6-interface-ids
> 
> - Add this document to the registry.
> 
> Please update the next version with the above updates to the registry.
> 
> Thanks,
> ~pl
> 
> 
> On Sat Nov 23 11:27:07 2013, [email-masked] wrote:
>> Pearl
>>
>>> IANA has reviewed draft-ietf-6man-ug-05.  Authors should review the
>>    comments and/or questions below.  Please report any inaccuracies
>>    and respond to any questions as soon as possible.
>>> "Full deployment of a new reserved IID value would require updates
>>    to IID generation code in every deployed IPv6 stack, so the
>>    technical justification for such a Standards Action would need to
>>    be extremely strong."
>>> Other than the above questions, IANA understands that, upon approval
>>    of this document, there are no IANA Actions that need completion.
>>    IANA requests that the IANA Considerations section of the document
>>    remain in place upon publication.
>>>

---

From: Ole Troan <[email-masked]>
Date: Tue, 26 Nov 2013 00:01:48 +0100

> Agreed, subject to agreement from the AD and WG Chairs.

agreed, this is the IANA action I'd expect.

cheers,
Ole

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Mon, 25 Nov 2013 20:52:40 +0000

Hi Brian,

Thanks,
~pl

---

From: "Pearl Liang via RT" <[email-masked]>
Date: Mon, 25 Nov 2013 23:31:20 +0000

Thank you so much for the prompt replies.  We understand that 
we need to update the registry with the items as described 
below upon approval of this document.  We will await either
the Evaluation review request or the new version of the document.

Cheers,
~pl

On Mon Nov 25 15:20:11 2013, [email-masked] wrote:
> >>>> be added to the Reserved IPv6 Interface Identifiers registry
>    located
> >>>   at:
> >>>>> The IESG has received a request from the IPv6 Maintenance WG
>    (6man)
> >>>   to
> >>>>> final comments on this action. Please send substantive comments
>    to
> >>>   the
> >>>>> [email-masked] mailing lists by 2013-11-28. Exceptionally,
>    comments
> >>>   may be
> >>>>>   document clarifies that the bits in an interface identifier
>    have
> >>>   no

---

From: Brian Haberman <[email-masked]>
Date: Tue, 26 Nov 2013 08:31:44 -0500

Brian,

> agreed, this is the IANA action I'd expect.

I agree as well.

Regards,
Brian