Subject: Pete Resnick's Discuss on draft-ietf-6man-stable-privacy-addresses-16: (with DISCUSS)

From: "Pete Resnick" <[email-masked]>
Date: Wed, 22 Jan 2014 07:57:25 -0800

Pete Resnick has entered the following ballot position for
draft-ietf-6man-stable-privacy-addresses-16: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/draft-ietf-6man-stable-privacy-addresses/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

I'd like to hear mostly from the shepherd, who didn't actually answer the
second part of the first question on the shepherd writeup: "Why is this
the proper type of RFC?"

This looks to me like an algorithm to generate stable, private, and
mostly unique addresses. It looks like it does not affect
interoperability at all if people choose a different method. It looks to
me like you could have accomplished the same task in a number of
different ways. This just seems like a nice method to use if someone
wanted to use it. So it's not clear to me why this isn't just an
Informational document explaining a nice way to generate stable, private,
mostly unique addresses without lots of MUSTs and SHOULDs that are not
really interoperability requirements.

---

From: Bob Hinden <[email-masked]>
Date: Wed, 22 Jan 2014 09:23:47 -0800

Hi Pete,

I am the document shepherd for this document.

> really interoperability requirements.

Several reasons why I think Proposed Standard is appropriate.

The properties for IPv6 interface-identifiers are defined in RFC4291, currently at Draft Standard.  This includes several types of interface-identifiers including EUI-64 based interface-identifiers.  Other types of interface-identifers, such as temporary addresses, SEND CGA, etc., are defined in other standards track RFCs.  This document is consistent with this.

The working group is also working on a recommendation to make Stable Privacy interface-identifiers the default, instead of EUI-64 based interface-identifiers.  The working group is also discussing if it wants to deprecate the EUI-64 based interface-identifiers.   See: 

   http://datatracker.ietf.org/doc/draft-gont-6man-deprecate-eui64-based-addresses/

This is currently in an adoption call, please see the email on the [email-masked] list.  I think it would be confusing to prefer an Informational RFC over Standards track.

Hope this answers your question.

Thanks,
Bob