Subject: Re: router behaviour with prefixes longer than /64

From: Usman Latif <[email-masked]>
Date: Tue, 18 Mar 2014 08:55:18 +1100

I think (although not sure if such a method exists today) that if there was a way to identify looking at specific (reserved?) bits in the upper 64-bit portion of the IPv6 address to tell the routing system whether the lower 64-bits are IID or not, that would probably give best of both worlds to IPv6 addressing and provide a more efficient use of address space..
Thoughts?

Regards,
Usman

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 18 Mar 2014 20:37:17 +1300

> I think (although not sure if such a method exists today) that if there was a way to identify looking at specific (reserved?) bits in the upper 64-bit portion of the IPv6 address to tell the routin…

No, we are definitely not going to waste bits in the routing prefix for this.

   Brian

---

From: Usman Latif <[email-masked]>
Date: Fri, 21 Mar 2014 10:20:30 +1100

> No, we are definitely not going to waste bits in the routing prefix for this.

Okay then we probably need to revisit the statement in 4291 which states that "unicast addresses, except those that start with 000, IIDs are required to be 64-bits long"

If this statement is considered during SW development of any routing system then you could potentially have routing systems that only route based on (0-63) bits of IPv6

If this statement was not there, and both VLSM and EUI-64 coexist, then a routing system would work okay as long as it sticks to the notion of "route first, resolve later" - i.e. unless the routing system is the ultimate router to which a /64 subnet is attached on one of its connected interfaces, it would continue to route.
The same should would work for the VLSM case as well where a subnet may be < /64

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 21 Mar 2014 20:40:05 +1300

> If this statement is considered during SW development of any routing system then you could potentially have routing systems that only route based on (0-63) bits of IPv6

That would be a misinterpretation of the IPv6 architecture. I think all the
IPv6 routing protocols have it right, thought.

> The same should would work for the VLSM case as well where a subnet may be < /64

Of course. That's how IP routing works.

   Brian