Subject: Re: [Fwd: I-D Action: draft-carpenter-6man-why64-01.txt]

From: Jen Linkova <[email-masked]>
Date: Tue, 4 Mar 2014 18:15:36 +0100

I have a comment on section 5.2 which says

'There have been unconfirmed assertions that some routers have a
   performance drop-off for prefixes longer than /64, due to design
   issues.'

I can confirm that there *are* network devices which have issues with
prefixes longer than /64 (such as, for example, seriously limiting
number of such prefixes being installed in FIB etc).

So I'd suggest to replace 'unconfirmed assertions' with smth like
'various observed cases' ;)

On Thu, Feb 6, 2014 at 1:50 AM, Brian E Carpenter
<[email-masked]> wrote:
> Updated following comments on the previous version. This is still incomplete
> and we'd like to get more comments, by email or in London
>
>    Brian
>
> -------- Original Message --------
> Subject: I-D Action: draft-carpenter-6man-why64-01.txt
> Date: Wed, 05 Feb 2014 16:45:02 -0800
> From: [email-masked]
> Reply-To: [email-masked]
> To: [email-masked]
>
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>         Title           : Analysis of the 64-bit Boundary in IPv6 Addressing
>         Authors         : Brian Carpenter
>                           Tim Chown
>                           Fernando Gont
>                           Sheng Jiang
>                           Alexandru Petrescu
>                           Andrew Yourtchenko
>         Filename        : draft-carpenter-6man-why64-01.txt
>         Pages           : 20
>         Date            : 2014-02-05
>
> Abstract:
>    The IPv6 unicast addressing format includes a separation between the
>    prefix used to route packets to a subnet and the interface identifier
>    used to specify a given interface connected to that subnet.
>    Historically the interface identifier has been defined as 64 bits
>    long, leaving 64 bits for the prefix.  This document discusses the
>    reasons for this fixed boundary and the issues involved in treating
>    it as a variable boundary.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-carpenter-6man-why64/
>
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-carpenter-6man-why64-01
>
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-carpenter-6man-why64-01
>
>
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
>
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
>
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

-- 
SY, Jen Linkova aka Furry

---

From: Tore Anderson <[email-masked]>
Date: Thu, 06 Mar 2014 07:34:01 +0100

* Jen Linkova

> number of such prefixes being installed in FIB etc).

Your statement looks very much like an unconfirmed assertion to me...

Could you be more specific? Which vendors, products, software versions,
have what kind of issue(s) specifically with prefixes >/64, exactly?

Tore

---

From: Jen Linkova <[email-masked]>
Date: Wed, 12 Mar 2014 10:37:35 +0100

> have what kind of issue(s) specifically with prefixes >/64, exactly?

Juniper PTX has some h/w limitation so they initially could not
install /65 - /126 into FIB. Currently it is possible but for limited
number of routes.

AFAIR some other cases were mentioned in ipv6-ops@ mailing list while ago
(in the  "point-to-point /64" thread:
http://lists.cluenet.de/pipermail/ipv6-ops/2013-June/008937.html).

On WG session someone else mentioned issues with prefixes longer than
/64 - but I cannot recall who was it..;(

---

From: [email-masked]
Date: Wed, 12 Mar 2014 11:04:44 +0100 (CET)

> install /65 - /126 into FIB. Currently it is possible but for limited

Given the intended target market for PTX (high-end MPLS P routers) the
only IPv6 routes I would expect such a box to have are loopbacks and
maybe links.

Not being able to install such prefixes at all is a problem. Allowing
only a very limited number of such prefixes = "works as intended".

Steinar Haug, AS 2116

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 13 Mar 2014 22:47:29 +1300

OK, s/unconfirmed assertions/reports/ in the next version.

Regards
   Brian