Subject: Re: fe80::/128

From: Tandankwa STANLEY Fon <[email-masked]>
Date: Thu, 3 Apr 2014 02:59:32 -0700 (PDT)

I tried it in our University lab on cisco routers and it works. I however fear for privacy.
Regards
Tandankwa S.

On Sunday, March 30, 2014 9:53 AM, Hiroki Sato <[email-masked]> wrote:
 
[email-masked] wrote
  in <[email-masked]>:

st> > > it is supported for the platform I know best, but require manual configuration as far as I remember.
st> >
st> > Adding to the "facts": on KAME/BSD, you need to manually add the
st> > subnet-router anycast address to the interface for it to work. So, it
st> > can be "supported" if the administrator needs it. Makes total sense IMHO.
st> >
st> > Previous discussion about this here:
st> > http://comments.gmane.org/gmane.ietf.ipv6/18602
st>
st> So maybe the relevant questions are:
st>
st> 1. Is there any platform which enables the subnet router anycast

st> address by default?
st>
st> 2. Does anybody use the subnet router anycast address on a regular
st> basis? Presumably then for something more useful than Ole Troan's ping
st> example?

I sometimes use subnet router anycast adddress as the default router
on BSD when RA cannot be used on that link.  First I used a fixed
link-local address like fe80::1 for this purpose but subnet router
anycast adddress is useful when there are multiple routers on that
link for fail-over.

-- Hiroki

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Mark ZZZ Smith <[email-masked]>
Date: Thu, 3 Apr 2014 13:29:13 -0700 (PDT)

----- Original Message -----
> From: Hiroki Sato <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Sent: Sunday, 30 March 2014 4:24 AM
> Subject: Re: fe80::/128
> 
> [email-masked] wrote
<snip>

> anycast adddress is useful when there are multiple routers on that

For networking people, another possible use would be stateless tunnel end-point redundancy.

One or perhaps both ends of e.g., a stateless GRE tunnel could specify a subnet router anycast address as the underlying destination address. When there are multiple routers at the destination, the outer encapsulation forwarding towards the tunnel endpoint would use the shortest path, and if that router failed, the closest of the other remaining router(s) providing the same subnet router anycast address would take over.

My guess is that the origins of the idea for an always available subnet router anycast address are Appletalk (pg. 4-7, "Inside Appletalk"):

"Node ID 0 indicates any router on the network specified by the network number part of the
node address. Packets addressed to node ID 0 are routed through the internet until they reach the
first router directly connected to a network whose range includes the indicated network number.
The packet is then delivered to that router. This facility is used by NBP."

NBP is the Name Binding Protocol, and is the inspiration behind Multicast DNS and DNS-Service Discovery.

"Requirements for a Protocol to Replace the AppleTalk Name Binding Protocol (NBP)"

http://tools.ietf.org/html/rfc6760

So perhaps people such as the homenet WG, who are interested in the sorts of problems Appletalk solved, might also find uses for it.

Regards,
Mark.