Subject: IPv6 Router Alert Option for LSP Ping/Trace

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Thu, 3 Apr 2014 19:51:56 +0000

Hi 6MANers,

One commonly deployed MPLS OAM tool is LSP Ping/Traceroute (RFC4379).

http://datatracker.ietf.org/doc/rfc4379/?include_text=1

One of the mandatory requirement from the draft is that Router Alert option MUST be set in the IP header.

For IPv4, value zero(0) is used.

https://www.iana.org/assignments/ipv4-routeralert-values/ipv4-routeralert-values.xhtml

For IPv6 ... as vendors are starting to implement MPLS on IPv6 control plane, we have realized that there is no generic IPv6 Router Alert code point which can be used by LSP Ping/Traceroute.

http://www.iana.org/assignments/ipv6-routeralert-values/ipv6-routeralert-values.xhtml

1. There's no need for a generic code point in IPv6 Router Alert option.
2. There's probably no need for a generic OAM code point in IPv6 Router Alert option.
3. There is, however, a need for a code point for LSP Ping/Traceroute, if the tool is to comply with RFC4379.

I spoke to authors of RFC4379, and was suggested that (3) is the way to go.

But before going ahead to write a small draft for this code point allocation (intended for MPLS WG as it updates RFC4379), I wanted to see if 6MANers had any comments/questions/concerns with this.

Appreciate your time in advance.

-Nobo

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Thu, 3 Apr 2014 22:49:49 +0000

Hi Nobo,

This is a good point that RFC 5350 did not seem to catch or rationalize.

To me, option #3 is the way to go.

I will note that this specific gap is not captured in
http://tools.ietf.org/html/draft-george-mpls-ipv6-only-gap-05#section-3.4.2
, and should be captured there.

Further, 
http://tools.ietf.org/html/draft-george-mpls-ipv6-only-gap-05#section-3.4.2
 also highlights another issue with using LSP Ping/Trace in IPv6, which is
the loopback address to be used (3rd paragraph).

Thanks,

‹ Carlos.

-----Original Message-----
From: Nobo Akiya <[email-masked]>
Date: Thursday, April 3, 2014 at 3:51 PM
To: "[email-masked]" <[email-masked]>
Cc: "Kamran Raza (skraza)" <[email-masked]>
Subject: IPv6 Router Alert Option for LSP Ping/Trace

>For IPv6 ... as vendors are starting to implement MPLS on IPv6 control
>plane, we have realized that there is no generic IPv6 Router Alert code
>point which can be used by LSP Ping/Traceroute.
>
>But before going ahead to write a small draft for this code point
>allocation (intended for MPLS WG as it updates RFC4379), I wanted to see
>if 6MANers had any comments/questions/concerns with this.
>
>--------------------------------------------------------------------
>IETF IPv6 working group mailing list
>[email-masked]
>Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
>--------------------------------------------------------------------

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Tue, 8 Apr 2014 17:26:55 +0000

Thanks for comments Carlos!

> >if the tool is to comply with RFC4379.

And submit a draft to MPLS WG. Eventually we will also forward this draft to 6man WG for review.

-Nobo

> From: Carlos Pignataro (cpignata)
> Sent: Thursday, April 03, 2014 6:50 PM
> To: Nobo Akiya (nobo); [email-masked]
> Cc: Kamran Raza (skraza)
> Subject: Re: IPv6 Router Alert Option for LSP Ping/Trace
> 
> Hi Nobo,
> 
>  also highlights another issue with using LSP Ping/Trace in IPv6, which is the
> loopback address to be used (3rd paragraph).
> 
> Thanks,
> 
> < Carlos.
> 
> 
> >https://www.iana.org/assignments/ipv4-routeralert-values/ipv4-routerale
> >rt-
> >values.xhtml
> >
> >http://www.iana.org/assignments/ipv6-routeralert-values/ipv6-routeraler
> >t-v
> >alues.xhtml
> >
> >allocation (intended for MPLS WG as it updates RFC4379), I wanted to
> >see if 6MANers had any comments/questions/concerns with this.
> >