Subject: Re: New Version Notification for draft-sarikaya-6man-next-hop-ra-02.txt

From: Usman Latif <[email-masked]>
Date: Sat, 14 Jun 2014 08:06:35 +1000

Hi,
My comment/query may not be directly related to this subject but what is our current position with regards to portable IPv6 subnets that are permitted for IPv6 Internet?
There was one RFC recommending minimum /48
If that is the case, then we have accepted potentially 2.8 x 10^14 prefixes for the Internet?
There was also an RFC (LISP) which provided a solution for mobility and multihoming/portability but doesn't look to be progressing much in terms of operators implementing ITR/ETRs in their network ...
So is there any additional document/draft that is looking into multihoming/portability and prefix scaling issue if all /48s eventually made it to the IPv6 Internet (similar to how we have almost all /24s appearing in IPv4 Internet table)

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 18 Jun 2014 08:28:00 +1200

Regards
   Brian Carpenter
   http://orcid.org/0000-0001-7924-6182

On 14/06/2014 10:06, Usman Latif wrote:
> Hi, My comment/query may not be directly related to this
> subject 

No

> but what is our current position with regards to
> portable IPv6 subnets that are permitted for IPv6 Internet? 

I don't like the word "portable". After all, IPv6 prefixes are
loaned not given.

> There was one RFC recommending minimum /48 

You may be thinking of obsolete RFC 3177. Please read RFC 6177,
which is a bit more up to date.

> If that is the
> case, then we have accepted potentially 2.8 x 10^14 prefixes
> for the Internet?

As a theoretical possibility, there are many more than that, but
the actual number is of course vastly less and is climbing at a
modest rate (see Geoff Huston's work for the facts).

> There was also an RFC (LISP) which provided
> a solution for mobility and multihoming/portability 

LISP has several RFCs and its own WG, but what it actually
offers is a solution for BGP-4 scaling.

> but
> doesn't look to be progressing much in terms of operators
> implementing ITR/ETRs in their network ... So is there any
> additional document/draft that is looking into
> multihoming/portability and prefix scaling issue if all /48s
> eventually made it to the IPv6 Internet 

I'm on record as suggesting that the real-world concern is a
maximum of something like 10 million prefixes wanting to be
announced in BGP-4. I'll stick to that, but this isn't really
the place for that discussion.

(similar to how we
> have almost all /24s appearing in IPv4 Internet table)

No we don't.

   Brian

---

From: Usman Latif <[email-masked]>
Date: Wed, 18 Jun 2014 10:32:09 +1000

Thanks Brian for your comments,

From both 3177 and 6177 and seeing what is happening in practice, it seems /48 has been accepted as a commonly agreed prefix length (for now) which is accepted between ISPs boundaries today.

My query was mainly to find out: whether we have accepted the fact that the DFZ would be open to however many /48s that are advertised to it or is there work happening (or already happened and I am unaware of) in IETF to devise a protocol that could reduce these advertisements while still allowing end-to-end reachability? 
(route aggregation never seems to be implemented too well in practice and we saw this in IPv4 already)

Regards,
Usman

> On 18 Jun 2014, at 6:28 am, Brian E Carpenter <[email-masked]> wrote:
> 
> 
> Regards
>   Brian Carpenter