Subject: Re: I-D Action: draft-sarikaya-6man-sadr-overview-07.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 10 Jun 2015 09:32:08 +1200

Are we going to discuss this issue in Prague? I feel that it's
been hanging around for a long time and we should either say:
"There's no significant problem at all, forget it",
or:
"There's a problem, let's solve it".

Regards
   Brian

On 10/06/2015 01:23, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : Source Address Dependent Routing and Source Address Selection for IPv6 Hosts: Problem Space Overview
>         Authors         : Behcet Sarikaya
>                           Mohamed Boucadair
> 	Filename        : draft-sarikaya-6man-sadr-overview-07.txt
> 	Pages           : 16
> 	Date            : 2015-06-09
> 
> Abstract:
>    This document presents the source address dependent routing (SADR)
>    problem space from the host perspective.  Both multihomed hosts and
>    hosts with multiple interfaces are considered.  Several network
>    architectures are presented to illustrate why source address
>    selection and next hop resolution in view of source address dependent
>    routing is needed.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-sarikaya-6man-sadr-overview/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-sarikaya-6man-sadr-overview-07
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-sarikaya-6man-sadr-overview-07
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Wed, 10 Jun 2015 15:14:13 +0200

Le 09/06/2015 23:32, Brian E Carpenter a écrit :
> Are we going to discuss this issue in Prague? I feel that it's been
> hanging around for a long time and we should either say: "There's no
> significant problem at all, forget it", or: "There's a problem,
> let's solve it".

On the part "there's a problem let's solve it", I must say that in DMM
WG there is momentum to build on concepts of 3 different kinds of source
addresses, with respect to how much mobility they support ("SUSTAINED,
NOMADIC, FIXED" addresses).
draft-dmm-ondemand-mobility-api-00

If these kinds of addresses are coupled with Source Address Dependent
routing and Source Address Selection for IPv6 Hosts, then there may be
something to do.

On another hand, if we consider that routing is based on destination
address only (not src), and that the level of mobility support is
offered depending on the destination address instead (e.g. depending on
the destination address, use NAT if need a NOMADIC behaviour, or use
Mobile IP if need a FIXED behaviour)... then we would not need source
based routing either.

What I am trying to say is that if we consider this to be a problem that
needs to be solved (routing based on src address), then we may need to
consider all its aspects, like mobility.

Alex

> Regards Brian
>> Title           : Source Address Dependent Routing and Source
>> Address Selection for IPv6 Hosts: Problem Space Overview Authors :
>> Behcet Sarikaya Mohamed Boucadair Filename        :
>> draft-sarikaya-6man-sadr-overview-07.txt Pages           : 16 Date
>> : 2015-06-09
>>
>> Abstract: This document presents the source address dependent
>> routing (SADR) problem space from the host perspective.  Both
>> multihomed hosts and hosts with multiple interfaces are
>> considered. Several network architectures are presented to
>> illustrate why source address selection and next hop resolution in
>> view of source address dependent routing is needed.
>>
>>
>> _______________________________________________ I-D-Announce
>> mailing list [email-masked]
>> https://www.ietf.org/mailman/listinfo/i-d-announce Internet-Draft
>> directories: http://www.ietf.org/shadow.html or
>> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>>
>
> --------------------------------------------------------------------
>  IETF IPv6 working group mailing list [email-masked] Administrative
> Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>
>

---

From: Dan Lüdtke <[email-masked]>
Date: Sun, 14 Jun 2015 09:18:25 +0200

The source address based routing issue has been hanging around here for quite while. In this WG alone we have two competing approaches to it, both based on ICMPv6 options. To see what other WGs are working on would be good to get the general overview, maybe Prague is a good time to understand the bigger picture.

Dan

> On 10 Jun 2015, at 15:14, Alexandru Petrescu <[email-masked]> wrote:
> 
> 
> 
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6