Subject: Re: I-D Action: draft-pskim-iot-ipv6-eui64-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Thu, 02 Jul 2015 09:56:31 +1200

Hi,

Since we are proposing to discourage EUI-64 based IIDs, I suppose 6man
should have an opinion on this draft?

    Brian

On 01/07/2015 17:02, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : IoT-Specific IPv6 Stateless Address Autoconfiguration with Modified EUI-64
>         Author          : Pyung Soo Kim
> 	Filename        : draft-pskim-iot-ipv6-eui64-00.txt
> 	Pages           : 6
> 	Date            : 2015-06-30
> 
> Abstract:
>    An IoT-specific IPv6 stateless address autoconfiguration is
>    suggested for diverse types of IoT devices. Both domain type and
>    device type are defined and combined with 16-bit hexadecimal number,
>    which is called the IoT type identifier. Then, this IoT type
>    identifier is reflected in generating EUI-64 for each IoT device. An
>    IoT-specific IPv6 address is developed using the stateless address
>    autoconfiguration with the network prefix and the modified EUI-64.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-pskim-iot-ipv6-eui64/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-pskim-iot-ipv6-eui64-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Christian Huitema <[email-masked]>
Date: Wed, 1 Jul 2015 23:17:02 +0000

> Since we are proposing to discourage EUI-64 based IIDs, I suppose 6man should
> have an opinion on this draft?

You bet!

I am reading draft-pskim-iot-ipv6-eui64-00.txt. The draft includes a nice paragraph explaining the domain of applicability: "at home, while travelling, when sick, at work,  when jogging and at the gym, just to cite a few." It then goes on to describe an IID format that enriches a 48 bit MAC address with 16 bits describing the domain IOT Device and the identifier in the domain. 

So if I understand correctly, we are expected to carry devices to a variety of locations, let these devices communicate with IPv6, and embed in the IPv6 address the subnet, which provides a device location, and the 48 bit identification of the hardware. Really? That seems like a terrible tradeoff between complexity and privacy.

-- Christian Huitema

---

From: Bob Hinden <[email-masked]>
Date: Wed, 1 Jul 2015 18:47:42 -0700

Christian,

> On Jul 1, 2015, at 4:17 PM, Christian Huitema <[email-masked]> wrote:
> 

The author should read:

http://datatracker.ietf.org/doc/draft-ietf-6man-ipv6-address-generation-privacy/
http://datatracker.ietf.org/doc/draft-ietf-6man-default-iids/

I note they even identify the device type:

   Both intermediate node and end node that are communicating with IoT
   device can recognize both domain and device types of corresponding
   IoT device using 16-bit hexadecimal number in IPv6 address.

Sigh…

Bob

> 
> -- Christian Huitema
> 
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------