Subject: working group last call for draft-ietf-spring-segment-routing

From: "John G. Scudder" <[email-masked]>
Date: Wed, 22 Jul 2015 15:12:16 +0200

Dear SPRING WG (and cc MPLS, OSPF, IS-IS, 6MAN, please include SPRING in replies per the reply-to):

As we discussed at the SPRING meeting yesterday, working group last call has been requested for draft-ietf-spring-segment-routing. Please reply to the list with your comments, including although not limited to whether or not you support advancing the document to RFC. Non-authors are especially encouraged to comment.

In consideration of the fact that a number of WG calls are going on concurrently, we will end the call on August 31, 2015. 

Authors, please indicate whether you are aware of any relevant IPR and if so, whether it has been disclosed. (Please do this even if you've done it before, thanks for your help.)

Thanks,

--Bruno and John

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Wed, 22 Jul 2015 18:16:23 +0000

> Authors, please indicate whether you are aware of any relevant IPR and if so, whether it has been disclosed. (Please do this even if you've done it before, thanks for your help.)

as co-author I confirm IPR has been already disclosed for draft-ietf-spring-segment-routing.

thanks.
s.

> 
> Thanks,
> 
> --Bruno and John
> 
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Rob Shakir <[email-masked]>
Date: Thu, 23 Jul 2015 08:58:02 +0100

Hi Bruno, John,

Whilst I’m an author — I’ll still comment here. It would be good to see the SPRING WG finalise this document. Rapid progress is being made to multi-vendor implementations within live networks of the SPRING technology. It would be good to start getting documents such as this one - which underpins many of the other standards for SR published.

On 22 July 2015 at 14:13:06, John G. Scudder ([email-masked]) wrote:
Authors, please indicate whether you are aware of any relevant IPR and if so, whether it has been disclosed. (Please do this even if you've done it before, thanks for your help.) 
I’m not aware of IPR other than that which has already been disclosed on this document.

Cheers!

r.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 24 Jul 2015 20:49:13 +1200

Hi,

It seems very strange to me that [I-D.previdi-6man-segment-routing-header]
is an Informative reference. Surely it is Normative (i.e., required reading
for an implementer)?

That leads to another comment. As we know, if 6man accepts that I-D, it will
certainly be on the basis that the header is strictly confined to a
"consenting adults" domain (e.g. without middleboxes that can't deal with
strange extension headers, without MTU size & fragmentation problems, etc.).
But in draft-ietf-spring-segment-routing, there seems to be no definition
of a segment-routing domain, what happens at its boundaries, etc. The word
"domain" is used but without clear definition. I believe that is of normative
importance (i.e. it's not a use case issue) and is needed here so that
draft-previdi- can build on it.

    Brian