Subject: Re: ipv6 Digest, Vol 135, Issue 31

From: Usman Latif <[email-masked]>
Date: Tue, 21 Jul 2015 23:34:41 +1000

Why do we want to re-invent the wheel when we already have existing means for traffic engineering available in the MPLS world?
What's the additional benefit of having this segment routing header in native IPv6 ?

Regards,
Usman

> On 21 Jul 2015, at 9:31 pm, [email-masked] wrote:
> 
> Send ipv6 mailing list submissions to
>    [email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web, visit
>    https://www.ietf.org/mailman/listinfo/ipv6
> or, via email, send a message with subject or body 'help' to
>    [email-masked]
> 
> You can reach the person managing the list at
>    [email-masked]
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of ipv6 digest..."
> 
> 
> Today's Topics:
> 
>   1. Re: New Version Notification for
>      draft-previdi-6man-segment-routing-header-07.txt - NAT Srvc
>      (Alexandru Petrescu)
>   2. RE: New Version Notification for
>      draft-previdi-6man-segment-routing-header-07.txt - NAT Srvc
>      (Stefano Previdi (sprevidi))
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Tue, 21 Jul 2015 13:02:29 +0200
> From: Alexandru Petrescu <[email-masked]>
> To: "Stefano Previdi (sprevidi)" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Subject: Re: New Version Notification for
>    draft-previdi-6man-segment-routing-header-07.txt - NAT Srvc
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset=windows-1252; format=flowed
> 
> SR to substitute NAT functionality?  Or SR to complement NAT functionality?
> 
> I have not seen NAT IPv6 in the operators world.
> 
> And, I dont think we want SR to have same drawbacks as NAT.
> 
> Alex
> 
> Le 21/07/2015 11:23, Stefano Previdi (sprevidi) a ?crit :
>> Maybe... but note that in the opetators world there are practical
>> examples where SR is used exactly for that...
>> 
>> s.
>> 
>> -----Original Message-----
>> *From:* Alexandru Petrescu [[email-masked]]
>> *Received:* Tuesday, 21 Jul 2015, 11:21
>> *To:* Stefano Previdi (sprevidi) [[email-masked]]
>> *CC:* [email-masked]} [[email-masked]]
>> *Subject:* Re: New Version Notification for
>> draft-previdi-6man-segment-routing-header-07.txt - NAT Srvc
>> 
>> Content Distribution Networks is an important service in which segment
>> routing may be involved.
>> 
>> But NAT should be removed from there.
>> 
>> Alex
>> 
>> Le 21/07/2015 10:18, Stefano Previdi (sprevidi) a ?crit :
>>> On Jul 21, 2015, at 9:30 AM, Alexandru Petrescu
>>> <[email-masked]> wrote:
>>> 
>>>> Do you mean a Network Address Translation service?
>>> 
>>> 
>>> put whatever is your preferred service. maybe nat is not the best
>>> illustration. Take dpi, webcache, webacc, ...
>>> 
>>> s.
>>> 
>>> 
>>>> That would be qualified as a particular forwarding instruction in
>>>> addresses are substituted.
>>>> 
>>>> Or is this wrong?
>>>> 
>>>> Alex
>>>> 
>>>> Le 20/07/2015 21:44, Stefano Previdi (sprevidi) a ?crit :
>>>>> 
>>>>> On Jul 20, 2015, at 9:18 PM, Alexandru Petrescu
>>>>> <[email-masked]> wrote:
>>>>> 
>>>>>> clarification q: what is "NAT Srvc" designating in Figure 4?
>>>>> 
>>>>> 
>>>>> it's an illustration showing that a segment is not strictly
>>>>> limited to a routing forwarding instruction but could also be
>>>>> related to a service or application.
>>>>> 
>>>>> s.
>>>>> 
>>>>> 
>>>>>> 
>>>>>> Alex
>>>>>> 
>>>>>> 
>>>>>> Le 20/07/2015 21:07, Stefano Previdi (sprevidi) a ?crit :
>>>>>>> Hi,
>>>>>>> 
>>>>>>> as suggested I resubmitted the SRH draft with a new security
>>>>>>> section that includes the content of the former SRH-security
>>>>>>> draft.
>>>>>>> 
>>>>>>> At this stage, I'd re-iterate my question: can the WG
>>>>>>> consider the adoption of
>>>>>>> draft-previdi-6man-segment-routing-header as WG item ?
>>>>>>> 
>>>>>>> Thanks. s.
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>> Begin forwarded message:
>>>>>>>> From: <[email-masked]> Subject: New Version
>>>>>>>> Notification for
>>>>>>>> draft-previdi-6man-segment-routing-header-07.txt Date: July
>>>>>>>> 20, 2015 9:05:11 PM GMT+02:00 To: Eric Vyncke
>>>>>>>> <[email-masked]>, Ida Leung <[email-masked]>,
>>>>>>>> Brian Field <[email-masked]>, Stefano
>>>>>>>> Previdi <[email-masked]>, David Lebrun
>>>>>>>> <[email-masked]>, Ebben Aries <[email-masked]>, Eric
>>>>>>>> Vyncke <[email-masked]>, Clarence Filsfils
>>>>>>>> <[email-masked]>, Stefano Previdi <[email-masked]>,
>>>>>>>> Ida Leung <[email-masked]>, David Lebrun
>>>>>>>> <[email-masked]>, "Brian Field"
>>>>>>>> <[email-masked]>, Clarence Filsfils
>>>>>>>> <[email-masked]>, Ebben Aries <[email-masked]>
>>>>>>>> 
>>>>>>>> 
>>>>>>>> A new version of I-D,
>>>>>>>> draft-previdi-6man-segment-routing-header-07.txt has been
>>>>>>>> successfully submitted by Stefano Previdi and posted to
>>>>>>>> the IETF repository.
>>>>>>>> 
>>>>>>>> Name:            draft-previdi-6man-segment-routing-header Revision:
>>>>>>>> 07 Title:                IPv6 Segment Routing Header (SRH) Document
>>>>>>>> date: 2015-07-20 Group:          Individual Submission Pages:            33
>>>>>>>> URL:
>>>>>>>> https://www.ietf.org/internet-drafts/draft-previdi-6man-segment-routing-header-07.txt
>>>> 
>> Status:
>> https://datatracker.ietf.org/doc/draft-previdi-6man-segment-routing-header/
>>>>>>>> Htmlized:
>>>>>>>> https://tools.ietf.org/html/draft-previdi-6man-segment-routing-header-07
>>>> 
>> Diff:
>> https://www.ietf.org/rfcdiff?url2=draft-previdi-6man-segment-routing-header-07
>>>>>>>> 
>>>>>>>> Abstract: Segment Routing (SR) allows a node to steer a
>>>>>>>> packet through a controlled set of instructions, called
>>>>>>>> segments, by prepending a SR header to the packet.  A
>>>>>>>> segment can represent any instruction, topological or
>>>>>>>> service-based.  SR allows to enforce a flow through any
>>>>>>>> path (topological, or application/service based) while
>>>>>>>> maintaining per-flow state only at the ingress node to the
>>>>>>>> SR domain.
>>>>>>>> 
>>>>>>>> Segment Routing can be applied to the IPv6 data plane with
>>>>>>>> the addition of a new type of Routing Extension Header.
>>>>>>>> This draft describes the Segment Routing Extension Header
>>>>>>>> Type and how it is used by SR capable nodes.
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> Please note that it may take a couple of minutes from the
>>>>>>>> time of submission until the htmlized version and diff are
>>>>>>>> available at tools.ietf.org.
>>>>>>>> 
>>>>>>>> The IETF Secretariat
>>>>>>> 
>>>>>>> --------------------------------------------------------------------
>>>> 
>> IETF IPv6 working group mailing list
>>>>>>> [email-masked] Administrative Requests:
>>>>>>> https://www.ietf.org/mailman/listinfo/ipv6
>>>>>>> --------------------------------------------------------------------
>>>>>> 
>>>>>> 
>>>> 
>> --------------------------------------------------------------------
>>>>>> IETF IPv6 working group mailing list [email-masked]
>>>>>> Administrative Requests:
>>>>>> https://www.ietf.org/mailman/listinfo/ipv6
>>>>>> --------------------------------------------------------------------
>>>>> 
>>> 
> 
> 
> 
> ------------------------------
> 
> Message: 2
> Date: Tue, 21 Jul 2015 11:30:51 +0000
> From: "Stefano Previdi (sprevidi)" <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> Subject: RE: New Version Notification for
>    draft-previdi-6man-segment-routing-header-07.txt - NAT Srvc
> Message-ID:
>    <[email-masked]>
> Content-Type: text/plain; charset="windows-1252"
> 
> No. SR is used to steer the packet towards an application /service instance.
> 
> s.
> 
> -----Original Message-----
> From: Alexandru Petrescu [[email-masked]]
> Received: Tuesday, 21 Jul 2015, 13:02
> To: Stefano Previdi (sprevidi) [[email-masked]]
> CC: [email-masked] [[email-masked]]
> Subject: Re: New Version Notification for draft-previdi-6man-segment-routing-header-07.txt - NAT Srvc
> 
> SR to substitute NAT functionality?  Or SR to complement NAT functionality?
> 
> I have not seen NAT IPv6 in the operators world.
> 
> And, I dont think we want SR to have same drawbacks as NAT.
> 
> Alex
> 
> Le 21/07/2015 11:23, Stefano Previdi (sprevidi) a ?crit :
>> Maybe... but note that in the opetators world there are practical
>> examples where SR is used exactly for that...
>> 
>> s.
>> 
>> -----Original Message-----
>> *From:* Alexandru Petrescu [[email-masked]]
>> *Received:* Tuesday, 21 Jul 2015, 11:21
>> *To:* Stefano Previdi (sprevidi) [[email-masked]]
>> *CC:* [email-masked]} [[email-masked]]
>> *Subject:* Re: New Version Notification for
>> draft-previdi-6man-segment-routing-header-07.txt - NAT Srvc
>> 
>> Content Distribution Networks is an important service in which segment
>> routing may be involved.
>> 
>> But NAT should be removed from there.
>> 
>> Alex
>> 
>> Le 21/07/2015 10:18, Stefano Previdi (sprevidi) a ?crit :
>>> On Jul 21, 2015, at 9:30 AM, Alexandru Petrescu
>>> <[email-masked]> wrote:
>>> 
>>>> Do you mean a Network Address Translation service?
>>> 
>>> 
>>> put whatever is your preferred service. maybe nat is not the best
>>> illustration. Take dpi, webcache, webacc, ...
>>> 
>>> s.
>>> 
>>> 
>>>> That would be qualified as a particular forwarding instruction in
>>>> addresses are substituted.
>>>> 
>>>> Or is this wrong?
>>>> 
>>>> Alex
>>>> 
>>>> Le 20/07/2015 21:44, Stefano Previdi (sprevidi) a ?crit :
>>>>> 
>>>>> On Jul 20, 2015, at 9:18 PM, Alexandru Petrescu
>>>>> <[email-masked]> wrote:
>>>>> 
>>>>>> clarification q: what is "NAT Srvc" designating in Figure 4?
>>>>> 
>>>>> 
>>>>> it's an illustration showing that a segment is not strictly
>>>>> limited to a routing forwarding instruction but could also be
>>>>> related to a service or application.
>>>>> 
>>>>> s.
>>>>> 
>>>>> 
>>>>>> 
>>>>>> Alex
>>>>>> 
>>>>>> 
>>>>>> Le 20/07/2015 21:07, Stefano Previdi (sprevidi) a ?crit :
>>>>>>> Hi,
>>>>>>> 
>>>>>>> as suggested I resubmitted the SRH draft with a new security
>>>>>>> section that includes the content of the former SRH-security
>>>>>>> draft.
>>>>>>> 
>>>>>>> At this stage, I'd re-iterate my question: can the WG
>>>>>>> consider the adoption of
>>>>>>> draft-previdi-6man-segment-routing-header as WG item ?
>>>>>>> 
>>>>>>> Thanks. s.
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>> Begin forwarded message:
>>>>>>>> From: <[email-masked]> Subject: New Version
>>>>>>>> Notification for
>>>>>>>> draft-previdi-6man-segment-routing-header-07.txt Date: July
>>>>>>>> 20, 2015 9:05:11 PM GMT+02:00 To: Eric Vyncke
>>>>>>>> <[email-masked]>, Ida Leung <[email-masked]>,
>>>>>>>> Brian Field <[email-masked]>, Stefano
>>>>>>>> Previdi <[email-masked]>, David Lebrun
>>>>>>>> <[email-masked]>, Ebben Aries <[email-masked]>, Eric
>>>>>>>> Vyncke <[email-masked]>, Clarence Filsfils
>>>>>>>> <[email-masked]>, Stefano Previdi <[email-masked]>,
>>>>>>>> Ida Leung <[email-masked]>, David Lebrun
>>>>>>>> <[email-masked]>, "Brian Field"
>>>>>>>> <[email-masked]>, Clarence Filsfils
>>>>>>>> <[email-masked]>, Ebben Aries <[email-masked]>
>>>>>>>> 
>>>>>>>> 
>>>>>>>> A new version of I-D,
>>>>>>>> draft-previdi-6man-segment-routing-header-07.txt has been
>>>>>>>> successfully submitted by Stefano Previdi and posted to
>>>>>>>> the IETF repository.
>>>>>>>> 
>>>>>>>> Name:            draft-previdi-6man-segment-routing-header Revision:
>>>>>>>> 07 Title:                IPv6 Segment Routing Header (SRH) Document
>>>>>>>> date: 2015-07-20 Group:          Individual Submission Pages:            33
>>>>>>>> URL:
>>>>>>>> https://www.ietf.org/internet-drafts/draft-previdi-6man-segment-routing-header-07.txt
>>>> 
>> Status:
>> https://datatracker.ietf.org/doc/draft-previdi-6man-segment-routing-header/
>>>>>>>> Htmlized:
>>>>>>>> https://tools.ietf.org/html/draft-previdi-6man-segment-routing-header-07
>>>> 
>> Diff:
>> https://www.ietf.org/rfcdiff?url2=draft-previdi-6man-segment-routing-header-07
>>>>>>>> 
>>>>>>>> Abstract: Segment Routing (SR) allows a node to steer a
>>>>>>>> packet through a controlled set of instructions, called
>>>>>>>> segments, by prepending a SR header to the packet.  A
>>>>>>>> segment can represent any instruction, topological or
>>>>>>>> service-based.  SR allows to enforce a flow through any
>>>>>>>> path (topological, or application/service based) while
>>>>>>>> maintaining per-flow state only at the ingress node to the
>>>>>>>> SR domain.
>>>>>>>> 
>>>>>>>> Segment Routing can be applied to the IPv6 data plane with
>>>>>>>> the addition of a new type of Routing Extension Header.
>>>>>>>> This draft describes the Segment Routing Extension Header
>>>>>>>> Type and how it is used by SR capable nodes.
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> Please note that it may take a couple of minutes from the
>>>>>>>> time of submission until the htmlized version and diff are
>>>>>>>> available at tools.ietf.org.
>>>>>>>> 
>>>>>>>> The IETF Secretariat
>>>>>>> 
>>>>>>> --------------------------------------------------------------------
>>>> 
>> IETF IPv6 working group mailing list
>>>>>>> [email-masked] Administrative Requests:
>>>>>>> https://www.ietf.org/mailman/listinfo/ipv6
>>>>>>> --------------------------------------------------------------------
>>>>>> 
>>>>>> 
>>>> 
>> --------------------------------------------------------------------
>>>>>> IETF IPv6 working group mailing list [email-masked]
>>>>>> Administrative Requests:
>>>>>> https://www.ietf.org/mailman/listinfo/ipv6
>>>>>> --------------------------------------------------------------------
>>>>> 
>>> 
> 
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL: <https://mailarchive.ietf.org/arch/browse/ipv6/attachments/20150721/d44cb4e7/attachment.html>
> 
> ------------------------------
> 
> Subject: Digest Footer
> 
> _______________________________________________
> ipv6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ipv6
> 
> 
> ------------------------------
> 
> End of ipv6 Digest, Vol 135, Issue 31
> *************************************

---

From: "Roberta Maglione (robmgl)" <[email-masked]>
Date: Tue, 21 Jul 2015 13:44:44 +0000

Because 
"there are scenarios where MPLS may not be available or deployable for lack of support on network elements or for an operator's design choice.  In such scenarios a
 non-MPLS based solution would be preferred by the network operators of such infrastructures."
Please take a look at SRv6 use cases draft for more details.
  https://tools.ietf.org/html/draft-ietf-spring-ipv6-use-cases-04

Thanks
Roberta

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Usman Latif
Sent: Tuesday, July 21, 2015 3:35 PM
To: [email-masked]
Subject: Re: ipv6 Digest, Vol 135, Issue 31

Regards,
Usman

>> Content Distribution Networks is an important service in which 
>> segment routing may be involved.
>> 
>>>>>>> At this stage, I'd re-iterate my question: can the WG consider 
>>>>>>> the adoption of draft-previdi-6man-segment-routing-header as WG 
>>>>>>> item ?
>>>>>>> 
>>>>>>> Thanks. s.
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>> Begin forwarded message:
>>>>>>>> draft-previdi-6man-segment-routing-header-07.txt Date: July 20, 
>>>>>>>> 2015 9:05:11 PM GMT+02:00 To: Eric Vyncke <[email-masked]>, 
>>>>>>>> Ida Leung <[email-masked]>, Brian Field 
>>>>>>>> <[email-masked]>, Stefano Previdi 
>>>>>>>> <[email-masked]>, David Lebrun <[email-masked]>, 
>>>>>>>> Ebben Aries <[email-masked]>, Eric Vyncke <[email-masked]>, 
>>>>>>>> Clarence Filsfils <[email-masked]>, Stefano Previdi 
>>>>>>>> <[email-masked]>, Ida Leung <[email-masked]>, 
>>>>>>>> David Lebrun <[email-masked]>, "Brian Field"
>>>>>>>> successfully submitted by Stefano Previdi and posted to the 
>>>>>>>> IETF repository.
>>>>>>>> 
>>>>>>>> Abstract: Segment Routing (SR) allows a node to steer a packet 
>>>>>>>> through a controlled set of instructions, called segments, by 
>>>>>>>> prepending a SR header to the packet.  A segment can represent 
>>>>>>>> any instruction, topological or service-based.  SR allows to 
>>>>>>>> enforce a flow through any path (topological, or 
>>>>>>>> application/service based) while maintaining per-flow state 
>>>>>>>> only at the ingress node to the SR domain.
>>>>>>>> 
>>>>>>>> Segment Routing can be applied to the IPv6 data plane with the 
>>>>>>>> addition of a new type of Routing Extension Header.
>>>>>>>> This draft describes the Segment Routing Extension Header Type 
>>>>>>>> and how it is used by SR capable nodes.
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> Please note that it may take a couple of minutes from the time 
>>>>>>>> of submission until the htmlized version and diff are available 
>>>>>>>> at tools.ietf.org.
>>>>>>>> 
>>>>>>>> The IETF Secretariat
>>>>>>> 
>>>>>> IETF IPv6 working group mailing list [email-masked] Administrative 
>>>>>> Requests:
>> Content Distribution Networks is an important service in which 
>> segment routing may be involved.
>> 
>>>>>>> At this stage, I'd re-iterate my question: can the WG consider 
>>>>>>> the adoption of draft-previdi-6man-segment-routing-header as WG 
>>>>>>> item ?
>>>>>>> 
>>>>>>> Thanks. s.
>>>>>>> 
>>>>>>> 
>>>>>>> 
>>>>>>> Begin forwarded message:
>>>>>>>> draft-previdi-6man-segment-routing-header-07.txt Date: July 20, 
>>>>>>>> 2015 9:05:11 PM GMT+02:00 To: Eric Vyncke <[email-masked]>, 
>>>>>>>> Ida Leung <[email-masked]>, Brian Field 
>>>>>>>> <[email-masked]>, Stefano Previdi 
>>>>>>>> <[email-masked]>, David Lebrun <[email-masked]>, 
>>>>>>>> Ebben Aries <[email-masked]>, Eric Vyncke <[email-masked]>, 
>>>>>>>> Clarence Filsfils <[email-masked]>, Stefano Previdi 
>>>>>>>> <[email-masked]>, Ida Leung <[email-masked]>, 
>>>>>>>> David Lebrun <[email-masked]>, "Brian Field"
>>>>>>>> successfully submitted by Stefano Previdi and posted to the 
>>>>>>>> IETF repository.
>>>>>>>> 
>>>>>>>> Abstract: Segment Routing (SR) allows a node to steer a packet 
>>>>>>>> through a controlled set of instructions, called segments, by 
>>>>>>>> prepending a SR header to the packet.  A segment can represent 
>>>>>>>> any instruction, topological or service-based.  SR allows to 
>>>>>>>> enforce a flow through any path (topological, or 
>>>>>>>> application/service based) while maintaining per-flow state 
>>>>>>>> only at the ingress node to the SR domain.
>>>>>>>> 
>>>>>>>> Segment Routing can be applied to the IPv6 data plane with the 
>>>>>>>> addition of a new type of Routing Extension Header.
>>>>>>>> This draft describes the Segment Routing Extension Header Type 
>>>>>>>> and how it is used by SR capable nodes.
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> 
>>>>>>>> Please note that it may take a couple of minutes from the time 
>>>>>>>> of submission until the htmlized version and diff are available 
>>>>>>>> at tools.ietf.org.
>>>>>>>> 
>>>>>>>> The IETF Secretariat
>>>>>>> 
>>>>>> IETF IPv6 working group mailing list [email-masked] Administrative 
>>>>>> Requests:
> -------------- next part -------------- An HTML attachment was 
> scrubbed...
> URL: 
> <https://mailarchive.ietf.org/arch/browse/ipv6/attachments/20150721/d4
> 4cb4e7/attachment.html>
> 

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------