Subject: Routing protocols and 6man-multi-homed-host

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 5 Oct 2015 19:06:56 +0000

In reading through draft-baker-6man-multi-homed-host, one of the recommendations was unclear to me.

"2.2.  Expectations of multihomed networks

   The direct implication of Section 2.1 is that routing protocols used
   in multihomed networks SHOULD be capable of source-prefix based
   egress routing, and that multihomed networks SHOULD deploy them."

Is the final SHOULD a recommendation that
If a multihomed network deploys a routing protocol, the network SHOULD deploy a routing protocol capable of source-prefix based egress routing.
or
A multihomed network SHOULD deploy a routing protocol capable of source-prefix based egress routing.

Barbara

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 6 Oct 2015 11:34:52 +1300

Hi Barbara,
> A multihomed network SHOULD deploy a routing protocol capable of source-prefix based egress routing.

Yes, that's sloppy writing, sorry. I drafted that text and I think
I meant the second interpretation. But just to be sure, is there a
class of multihomed networks that do not need a routing protocol?

Yes, there is the case of a single LAN with a single multihomed
CE router, but are there any other cases?

   Brian

---

From: Dave Thaler <[email-masked]>
Date: Mon, 5 Oct 2015 23:19:18 +0000

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Brian E Carpenter
> Sent: Monday, October 5, 2015 3:35 PM
> To: STARK, BARBARA H <[email-masked]>; [email-masked]
> Subject: Re: Routing protocols and 6man-multi-homed-host
> 
> Hi Barbara,
> > Is the final SHOULD a recommendation that If a multihomed network
> > deploys a routing protocol, the network SHOULD deploy a routing protocol
> capable of source-prefix based egress routing.
> > or
> Yes, that's sloppy writing, sorry. I drafted that text and I think I meant the
> second interpretation. But just to be sure, is there a class of multihomed
> networks that do not need a routing protocol?
> 
> Yes, there is the case of a single LAN with a single multihomed CE router, but
> are there any other cases?
> 
>    Brian

Even if that single multihomed CE router has more than a single leaf LAN,
it doesn't need a routing protocol per se.  So I think the key case is a single
router with 1 or more leaf LANs.

Dave

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 5 Oct 2015 23:26:35 +0000

> On Oct 5, 2015, at 12:06 PM, STARK, BARBARA H <[email-masked]> wrote:
> 

The latter. If it deploys no routing protocol, one hopes that the network will be simple enough to not need one. But the point is to be able to do egress routing.

> Barbara
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 6 Oct 2015 16:16:43 +1300

> The latter. If it deploys no routing protocol, one hopes that the network will be simple enough to not need one. But the point is to be able to do egress routing.

Right. But (see Dave Thaler's note) we do need to rephrase a bit to be crystal clear.

   Brian

---

From: Ole Troan <[email-masked]>
Date: Tue, 6 Oct 2015 08:41:59 +0200

> On 06 Oct 2015, at 01:19, Dave Thaler <[email-masked]> wrote:
> 

or two CE routers connected to the same LAN.

cheers,
Ole

---

From: Dave Thaler <[email-masked]>
Date: Tue, 6 Oct 2015 15:38:43 +0000

Ole Troan writes:
>>> Yes, that's sloppy writing, sorry. I drafted that text and I think I 
>>> meant the second interpretation. But just to be sure, is there a 
>>> Yes, there is the case of a single LAN with a single multihomed CE 
>>> router, but are there any other cases?
>>> 
>>>   Brian
>> 
>> Even if that single multihomed CE router has more than a single leaf 
>> LAN, it doesn't need a routing protocol per se.  So I think the key 
>> case is a single router with 1 or more leaf LANs.
>

And I *think* the general rule is that a routing protocol is needed
when the topology is not loop-free, and it is not needed when the
topology is loop-free (e.g., a tree of LANs can work with DHCP-PD).

Dave

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 7 Oct 2015 08:19:54 +1300

> topology is loop-free (e.g., a tree of LANs can work with DHCP-PD).

Yes, that seems right. We will fix the wording for the next revision.

    Brian

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 6 Oct 2015 19:37:58 +0000

> On Oct 5, 2015, at 3:34 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> is there a

Well, yes. Suppose I have DSL and Cable at my house, and deploy a PA prefix from each. In my house, however, I have exactly one LAN and therefore exactly two subnets. I really don't need a routing protocol if, as we have suggested, hosts using a given source prefix send the relevant data to the router offering it.

If the routers muddle the issue by advertising each other's prefixes, they had best have a protocol that will disambiguate it for them, but doing such would be stupidity, making a simple situation unnecessarily complicated.

Nobody would do that, would they?

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Tue, 6 Oct 2015 19:48:11 +0000

> On Oct 5, 2015, at 11:41 PM, Ole Troan <[email-masked]> wrote:
> 

To my way of thinking, if there is only one router, the host has no choice to make. The cases we are discussing in the draft have the host deciding, at minimum, between two routers. So to my mind, the case has to have two CE routers, not just one.

---

From: [email-masked]
Date: Tue, 6 Oct 2015 22:28:25 +0200

> To my way of thinking, if there is only one router, the host has no choice to make. The cases we are discussing in the draft have the host deciding, at minimum, between two routers. So to my mind,…

yes, of course. sorry for muddying the waters.

cheers,
Ole

---

From: Francisco Paletta <[email-masked]>
Date: Tue, 6 Oct 2015 17:45:15 -0300

Fred / Brian,

Despite the adjustments on the text, it's clear to me the information on
this draft. I support.

I'm wondering now how the host should choose among available gateways, with
the prefixes it has, when it's starting a connection to the Internet?

I see a few scenarios:
- Host randomly selects a gateway and sends the packet. If all the hosts
use the same, one link might exhaust and the other remains totally free.
- Host selects the gateway based on the network it's connected to (shortest
path to destination or other routing protocol?).
- Host selects the gateway, sends the packet but the gateway has an up-link
down. (This should be a case for redirection) And therefore the host MUST
use the other prefix and the other gateway.

Is this subject to your draft? Does it exist already in another draft? Or
is it subject to a new draft?

Cheers

Francisco Paletta

2015-10-06 17:28 GMT-03:00 <[email-masked]>:

> LAN,
> > To my way of thinking, if there is only one router, the host has no
> choice to make. The cases we are discussing in the draft have the host
> deciding, at minimum, between two routers. So to my mind, the case has to
> have two CE routers, not just one.
>