Subject: Re: Next Steps on DAD Improvements

From: Erik Nordmark <[email-masked]>
Date: Tue, 6 Oct 2015 23:12:31 -0700

Bob and Ole,

Did you determine any WG consensus on doing or not doing something with 
DAD in 6man?
I didn't see any conclusion to this thread.

Thanks,
    Erik

On 6/8/15 1:02 PM, Bob Hinden wrote:
> At the 6man WG meeting in Dallas there was discussion on what to do (if anything) about duplicate address detection.  The background on this is documented in https://datatracker.ietf.org/doc/draft-yourtchenko-6man-dad-issues/
>
> Should we work on the robustness and efficiency issues of DAD?  For example, improving DAD in environments where nodes sleep and on links with high packet loss.  We think that DAD robustness and efficiency are intertwined and we need solutions that take both into account.
>
> In case the WG wants to address these issues, there is an outline of how they can be addressed in https://datatracker.ietf.org/doc/draft-nordmark-6man-dad-approaches/.  This is probably not the only way they can be addressed, but the draft indicates that the issues are solvable.
>
> The chair would like your feedback on this issue and if there is interest we will schedule an agenda slot in Prague.
>
> Bob and Ole
> 6MAN Chairs
>
>
>
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 7 Oct 2015 07:47:23 +0000

Neither:

I fully support that 6MAN takes the action item. I'm willing to contribute.

Cheers,

Pascal

From: ipv6 [mailto:[email-masked]] On Behalf Of Erik Nordmark
Sent: mercredi 7 octobre 2015 08:13
To: Bob Hinden <[email-masked]>; IPv6 List <[email-masked]>
Subject: Re: Next Steps on DAD Improvements

Bob and Ole,

Did you determine any WG consensus on doing or not doing something with DAD in 6man?
I didn't see any conclusion to this thread.

Thanks,
   Erik

Bob and Ole

6MAN Chairs

[email-masked]<mailto:[email-masked]>

---

From: Sowmini Varadhan <[email-masked]>
Date: Thu, 8 Oct 2015 11:00:29 -0400

>  At the 6man WG meeting in Dallas there was discussion
> on what to do (if anything) about duplicate address
> detection.  The background on this is documented in
> https://datatracker.ietf.org/doc/draft-yourtchenko-6man-dad-issues/
> 
>  Should we work on the robustness and efficiency issues of DAD?
    :
>  In case the WG wants to address these issues,
> there is an outline of how they can be addressed in
> https://datatracker.ietf.org/doc/draft-nordmark-6man-dad-approaches/.
    :

I support 6man taking this on. I'm willing to contribute.

--Sowmini

---

From: Samita Chakrabarti <[email-masked]>
Date: Sat, 10 Oct 2015 02:02:30 +0000

I support  further work on the efficient DAD  solutions.
In addition, I think we need a document on different ND documents available today for different deployment solutions.

ND is a useful tool - but it is under-utilized due to number messaging , DAD issues and ND-DOS problems.
Would like to contribute  to further ND applicability  beyond wired Ethernet simple subnet environment.

-Samita

From: ipv6 [mailto:[email-masked]] On Behalf Of Erik Nordmark
Sent: Tuesday, October 06, 2015 11:13 PM
To: Bob Hinden; IPv6 List
Subject: Re: Next Steps on DAD Improvements

Bob and Ole,

Thanks,
   Erik

Bob and Ole

6MAN Chairs