Subject: Re: 6MAN Adoption Call for: draft-baker-6man-multi-homed-host-03

From: 神明達哉 <[email-masked]>
Date: Thu, 1 Oct 2015 09:37:07 -0700

At Wed, 30 Sep 2015 22:06:28 +0200,
[email-masked] wrote:

> This message starts a two week 6MAN call on adopting:
>
>    Title     : Host routing in a multi-prefix network
>    Authors   : F. Baker, B. Carpenter
>    Filename  : draft-baker-6man-multi-homed-host-03
>    Pages     : 9
>    Date      : 2015-09-03
>
>    http://datatracker.ietf.org/doc/draft-baker-6man-multi-homed-host-03
>
> as a working group item. Substantive comments and statements of support
> for adopting this document should be directed to the mailing
> list.

Support.

--
JINMEI, Tatuya

---

From: "Fred Baker (fred)" <[email-masked]>
Date: Mon, 5 Oct 2015 17:32:24 +0000

I'm in favor, but I'm biased; I'm one of the authors.

One outcome that I would really like to see here is that the draft is as simple as it can be, and no simpler. One of the questions I have asked myself during the working group discussion is whether the proposed discussion has anything to do with "hi; I'm a host, I have a packet in my hot little hand, I have more than one IPv6 address I can source it from, and I have chosen one by some algorithm. What do I do with the packet?". To my small mind, the answer to any other question is a great subject for a different draft.

I sincerely hope that the working group agrees on the scope...

> On Sep 30, 2015, at 1:06 PM, [email-masked] wrote:
> 
> list. Editorial suggestions can be sent to the authors.  This adoption
> call will end on October 14th, 2015.
> 
> Regards,
> 
> Bob Hinden & Ole Trøan
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 5 Oct 2015 20:14:06 +0200

I agree with adoption, based on the desire to keep it simple.

I agree with the scope.

Le 05/10/2015 19:32, Fred Baker (fred) a écrit :
[...]
> "hi; I'm a host, I have a packet in my hot little hand, I have more
> than one IPv6 address I can source it from, and I have chosen one by
> some algorithm. What do I do with the packet?".

One delivers it to the router whose PIO matched exactly the plen bits of 
the chosen src address.

(I must say I have difficulty calling it a 'default' router, since it's 
not selected just because everything else failed - it's matched on 
something; but that is maybe only me...)

One can also deliver it to the default router last found in a list of 
such default routers.  This corresponds to many implementations.

As for applicability: (1) the same problem described in the draft for a 
Host is valid for the MAG router of the PMIPv6 protocol: instead of 
sourcing a packet the MAG forwards packets to default routes via tunnel 
interfaces, based on their source addresses; w/o this behaviour in this 
draft the PMIPv6 MAG doesnt work. (2) it applies to smartphones with 
WiFi and 4G up simultaneously and which break if they dont do what this 
draft tells to.

Alex

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Mon, 5 Oct 2015 18:54:09 +0000

I agree with adoption and scope.
Barbara

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Fred Baker (fred)
> Sent: Monday, October 05, 2015 1:32 PM
> To: [email-masked]
> Cc: 6man Chairs; 6man WG
> Subject: Re: 6MAN Adoption Call for: draft-baker-6man-multi-homed-host-
> 03
> 
> One outcome that I would really like to see here is that the draft is as simple
> as it can be, and no simpler. One of the questions I have asked myself during
> the working group discussion is whether the proposed discussion has
> anything to do with "hi; I'm a host, I have a packet in my hot little hand, I have
> more than one IPv6 address I can source it from, and I have chosen one by
> some algorithm. What do I do with the packet?". To my small mind, the
> answer to any other question is a great subject for a different draft.
> 
> > as a working group item. Substantive comments and statements of
> > support for adopting this document should be directed to the mailing