Subject: a comment on draft-stenberg-mif-mpvd-dns-00

From: 神明達哉 <[email-masked]>
Date: Tue, 3 Nov 2015 15:56:44 +0900

I have one quick comment on draft-stenberg-mif-mpvd-dns-00: about the
use of TXT RR.  From a quick read it seems to me to violate the
general guidance of avoiding abuse of TXT as described in RFC5507.  Is
there any specific reason why this must be TXT despite the
recommendation of the RFC?  If there is, I think the draft should
explain it more explicitly; if not, I'd suggest getting and using a
new type of RR for this purpose.

--
JINMEI, Tatuya

---

From: Markus Stenberg <[email-masked]>
Date: Tue, 3 Nov 2015 16:52:13 +0900

> On 3.11.2015, at 15.56, 神明達哉 <[email-masked]> wrote:

We needed a way to get key=value structure to the clients, where the guidance (conflict with other uses being an issue) isn't an issue because we start the lookup (at quite problematic) _pvd.<reverse> place for a PTR. Similarly as we did not want to create a TLV registry, the encoding efficiency problem really isn't there.

However, as DNS wildcarding does not work with the _pvd.*.ip6.arpa (first part has to be the wildcard still I guess?), _that_ I consider more controversial choice, possibly _there_ would be demand for e.g. PVDPTR type that would be just at the <reverse>.ip6.arpa and point elsewhere..

Another reason we used existing types was to make implementation simpler due to not having to invent new encoders and decoders; hacking together prototype was very easy with these at least.

Cheers,

-Markus

---

From: 神明達哉 <[email-masked]>
Date: Mon, 16 Nov 2015 10:04:35 -0800

At Tue, 3 Nov 2015 16:52:13 +0900,
Markus Stenberg <[email-masked]> wrote:

> We needed a way to get key=value structure to the clients, where the
> guidance (conflict with other uses being an issue) isn't an issue
> because we start the lookup (at quite problematic) _pvd.<reverse>
> place for a PTR. Similarly as we did not want to create a TLV
> registry, the encoding efficiency problem really isn't there.

Okay.  I suggest explaining it explicitly.

On the other hand,

> Another reason we used existing types was to make implementation simpler due to not having to invent new encoders and decoders; hacking together prototype was very easy with these at least.

while understandable I suspect this is one major reason why people
have "abused" TXT, resulting in RFC5507, and so I suspect you won't be
able to justify the use of TXT with this reason in the publication
process.

> However, as DNS wildcarding does not work with the _pvd.*.ip6.arpa (first part has to be the wildcard still I guess?),

Correct: queries for _pvd.foo.ip6.arpa won't match _pvd.*.ip6.arpa.

--
JINMEI, Tatuya