Subject: RE: HBH Obsolete? (was Review of draft-ietf-6man-hbh-header-handling-01)

From: Ronald Bonica <[email-masked]>
Date: Sun, 3 Apr 2016 15:04:31 +0000

Brian,

Even of somebody saw a Jumbogram at an IXP, it wouldn't be so bad. The IPv6 header would have:

- a packet length of 0
- a next header of HBH

If the receiving node didn't recognize Jumbograms, wouldn't it discard the packet and send an ICMP Parameter Problem to the source?

                                                                                                        Ron

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Brian E Carpenter
> Sent: Friday, March 25, 2016 11:06 PM
> To: Michael Richardson <[email-masked]>; ipv6 <[email-masked]>
> Cc: C. M. Heard <[email-masked]>
> Subject: Re: HBH Obsolete? (was Review of draft-ietf-6man-hbh-header-
> handling-01)
> 
> On 26/03/2016 07:35, Michael Richardson wrote:
> >
> > C. M. Heard <[email-masked]> wrote:
> >     > Indeed, the question arises whether allowing a router to ignore these
> >     > options beaks them, or not.  Clearly so for Jumbo Payload,
> 
> I dispute that, as far as the real world goes. Nobody ever expected the
> jumbo payload to be used outside a "consenting adults" scenario; the
> requirement to send back ICMP on discard is really icing on the jumbo cake.
> As some words in
> RFC3765 tells you, the path has to be pretty much hand-crafted:
> 
> "  On links with configurable MTUs, the MTU must not be configured to a
>    value greater than 65,575 octets if there are nodes attached to that
>    link that do not support the Jumbo Payload option and it can not be
>    guaranteed that the Jumbo Payload option will not be sent to those
>    nodes."
> 
> So in practice, it really doesn't matter what the non-supporting router does.
> Did anybody ever see one of these things at a peering link or an IXP? I very
> much doubt it.
> 
>     Brian
> 
> 
> >     > but it's
> >     > unclear to me why RPL, MPL, and DFF need to be specified as other
> than
> >     > ignore if unrecognized.
> >
> > I agree that it's unclear if there is real benefit.
> >
> > --
> > Michael Richardson <[email-masked]>, Sandelman Software
> Works
> > -= IPv6 IoT consulting =-
> >
> >
> >
> >
> >
> > --------------------------------------------------------------------
> > IETF IPv6 working group mailing list
> > [email-masked]
> > Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> > --------------------------------------------------------------------
> >
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 4 Apr 2016 08:32:56 +1200

> If the receiving node didn't recognize Jumbograms, wouldn't it discard the packet and send an ICMP Parameter Problem to the source?

Most likely. But my point really was: who cares? Anyone who sends Jumbograms
without knowing that the path supports them will lose anyway.

     Brian
                                                                                                        Ron
> .