Subject: RE: ipv6 Digest, Vol 142, Issue 35 - Routing packets from hosts in a multi-prefix network

From: "Mudric, Dusan (Dusan)" <[email-masked]>
Date: Wed, 6 Apr 2016 19:40:13 +0000

Hi Brian,

"Routing packets from hosts in a multi-prefix network" says:
   A router
   that advertises a prefix indicates that it is able to appropriately
   route packets with source addresses within that prefix, regardless of
   the setting of the L and A flags in the PIO.

   a host SHOULD NOT ignore a PIO simply because both L and
   A flags are cleared; a router SHOULD be able to send such a PIO.

   A host SHOULD select
   default routers for each prefix it is assigned an address in.

The prefix list is used to find out if the destination address is on-link. 

If the router can route the packets from a host with the source address using L=0 prefix, theoretically off-link prefix can be used for SLAAC address. The problem is that L=0 prefix might be used on other links and if the host creates SLAAC address using L=0 prefix, the host will not be able to detect if the address is in use (DAD does not work between different router links). For that reason looks like L=0 prefix should not be used for SLAAC. If L=0 prefix is not use for SLAAC, there will be no source address with L=0 prefix and L=0 prefixes will not help host to find the first hop router. Consequently, hosts can ignore L=0 prefixes.

Am I missing something about L=0 prefixes?

Thanks,
Dusan.

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, February 22, 2016 3:00 PM
To: [email-masked]
Subject: ipv6 Digest, Vol 142, Issue 35

Send ipv6 mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ipv6&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=v1A6AVqb1WxYJro1_L-5y_b6bHxnWZjMZr_jE55X9Fo&e=
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific than "Re: Contents of ipv6 digest..."

Today's Topics:

   1. I-D Action: draft-ietf-6man-multi-homed-host-05.txt
      ([email-masked])
   2. I-D Action: draft-ietf-6man-multi-homed-host-06.txt
      ([email-masked])

----------------------------------------------------------------------

Message: 1
Date: Mon, 22 Feb 2016 10:32:52 -0800
From: [email-masked]
To: <[email-masked]>
Cc: [email-masked]
Subject: I-D Action: draft-ietf-6man-multi-homed-host-05.txt
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="utf-8"

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 Maintenance of the IETF.

        Title           : Routing packets from hosts in a multi-prefix network
        Authors         : Fred Baker
                          Brian Carpenter
	Filename        : draft-ietf-6man-multi-homed-host-05.txt
	Pages           : 13
	Date            : 2016-02-22

Abstract:
   This document describes expected IPv6 host behavior in a network that
   has more than one prefix, each allocated by an upstream network that
   implements BCP 38 ingress filtering, when the host has multiple
   routers to choose from.  It also applies to other scenarios such as
   the usage of stateful firewalls that effectively act as address-based
   filters.  This host behavior may interact with source address
   selection in a given implementation, but logically follows it.  Given
   that the network or host is, or appears to be, multihomed with
   multiple provider-allocated addresses, that the host has elected to
   use a source address in a given prefix, and that some but not all
   neighboring routers are advertising that prefix in their Router
   Advertisement Prefix Information Options, this document specifies to
   which router a host should present its transmission.  It updates RFC
   4861.

The IETF datatracker status page for this draft is:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost_&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=PUqjeSn4pUOrtWVBsNjNailsRew5_ZvzDS1STFtTjDg&e= 

There's also a htmlized version available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost-2D05&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=Wqnr6PzhAWzCUOMlH0v2MPK87KyhpIfl1sDF96UNhP4&e= 

A diff from the previous version is available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost-2D05&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=vPYONcimyGIvGJFl1Th6RV-kSJv79qPXaULdoyeOHEo&e= 

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=DKDpwbqKxZRyMXqgSklNxE-zP1DZtdIAKnrO9nDBWis&e= 

------------------------------

Message: 2
Date: Mon, 22 Feb 2016 10:55:30 -0800
From: [email-masked]
To: <[email-masked]>
Cc: [email-masked]
Subject: I-D Action: draft-ietf-6man-multi-homed-host-06.txt
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="utf-8"

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 Maintenance of the IETF.

        Title           : Routing packets from hosts in a multi-prefix network
        Authors         : Fred Baker
                          Brian Carpenter
	Filename        : draft-ietf-6man-multi-homed-host-06.txt
	Pages           : 13
	Date            : 2016-02-22

Abstract:
   This document describes expected IPv6 host behavior in a network that
   has more than one prefix, each allocated by an upstream network that
   implements BCP 38 ingress filtering, when the host has multiple
   routers to choose from.  It also applies to other scenarios such as
   the usage of stateful firewalls that effectively act as address-based
   filters.  This host behavior may interact with source address
   selection in a given implementation, but logically follows it.  Given
   that the network or host is, or appears to be, multihomed with
   multiple provider-allocated addresses, that the host has elected to
   use a source address in a given prefix, and that some but not all
   neighboring routers are advertising that prefix in their Router
   Advertisement Prefix Information Options, this document specifies to
   which router a host should present its transmission.  It updates RFC
   4861.

The IETF datatracker status page for this draft is:
https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost_&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=PUqjeSn4pUOrtWVBsNjNailsRew5_ZvzDS1STFtTjDg&e= 

There's also a htmlized version available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_html_draft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost-2D06&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=lGfMGfWC7GV6V-rewMLkuXhmMv8qCGBHIxhCsFmkOnY&e= 

A diff from the previous version is available at:
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcdiff-3Furl2-3Ddraft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost-2D06&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=UFS97FbjEQDBE-DJBZaJF7J3umdmn66PA1Z4yc95xjU&e= 

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_internet-2Ddrafts_&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=DKDpwbqKxZRyMXqgSklNxE-zP1DZtdIAKnrO9nDBWis&e= 

------------------------------

Subject: Digest Footer

_______________________________________________
ipv6 mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_ipv6&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=v1A6AVqb1WxYJro1_L-5y_b6bHxnWZjMZr_jE55X9Fo&e= 

------------------------------

End of ipv6 Digest, Vol 142, Issue 35
*************************************

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 7 Apr 2016 13:49:46 +1200

Dusan,

As far as I know we are only changing the A=L=0 case. If A=0, the
prefix is not used for SLAAC at all, and if L=0 the prefix should not
be added to the on-link prefix list.

To be clear, L=0 doesn't mean the prefix is off-link. It just means
"I'm not telling you it's on-link".

So previously a host could simply ignore the PIO with A=L=0. But now it
will be a useful next-hop router signal to the host, if addresses in that
prefix have been assigned in another way, typically by DHCPv6.

Does that make sense?

   Brian

---

From: "Mudric, Dusan (Dusan)" <[email-masked]>
Date: Mon, 11 Apr 2016 16:28:58 +0000

Hi Brian,

Should the draft be more specific explaining where the A=L=0 prefix should be stored and how the prefix should be used? Like:
- Should A=L=0 prefix be added to the prefix list and use for on-link determination? (you said no)
- Should A=L=0 prefix used for SLAAC? (you said no)
- How is A=L=0 prefix going to help the first hop router selection?

Thanks,
Dusan.

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Wednesday, April 06, 2016 9:50 PM
To: Mudric, Dusan (Dusan); 神明達哉
Cc: [email-masked]
Subject: draft-ietf-6man-multi-homed-host - Routing packets from hosts in a multi-prefix network

Dusan,

As far as I know we are only changing the A=L=0 case. If A=0, the prefix is not used for SLAAC at all, and if L=0 the prefix should not be added to the on-link prefix list.

To be clear, L=0 doesn't mean the prefix is off-link. It just means "I'm not telling you it's on-link".

So previously a host could simply ignore the PIO with A=L=0. But now it will be a useful next-hop router signal to the host, if addresses in that prefix have been assigned in another way, typically by DHCPv6.

Does that make sense?

   Brian

On 07/04/2016 07:40, Mudric, Dusan (Dusan) wrote:
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mail
> man_listinfo_ipv6&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3
> iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq
> 530&s=v1A6AVqb1WxYJro1_L-5y_b6bHxnWZjMZr_jE55X9Fo&e=
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.
> org_doc_draft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost_&d=BQICAg&c=BFpWQw8
> bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o
> 3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=PUqjeSn4pUOrtWVBsNjNailsRew5_Z
> vzDS1STFtTjDg&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> ml_draft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost-2D05&d=BQICAg&c=BFpWQw8b
> suKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3
> sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=Wqnr6PzhAWzCUOMlH0v2MPK87KyhpIf
> l1sDF96UNhP4&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcd
> iff-3Furl2-3Ddraft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost-2D05&d=BQICAg&
> c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY
> &m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=vPYONcimyGIvGJFl1Th6R
> V-kSJv79qPXaULdoyeOHEo&e=
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_intern
> et-2Ddrafts_&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhI
> oUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s
> =DKDpwbqKxZRyMXqgSklNxE-zP1DZtdIAKnrO9nDBWis&e=
> 
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.
> org_doc_draft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost_&d=BQICAg&c=BFpWQw8
> bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o
> 3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=PUqjeSn4pUOrtWVBsNjNailsRew5_Z
> vzDS1STFtTjDg&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> ml_draft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost-2D06&d=BQICAg&c=BFpWQw8b
> suKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3
> sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=lGfMGfWC7GV6V-rewMLkuXhmMv8qCGB
> HIxhCsFmkOnY&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_rfcd
> iff-3Furl2-3Ddraft-2Dietf-2D6man-2Dmulti-2Dhomed-2Dhost-2D06&d=BQICAg&
> c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhIoUWB8YLZU23029sMQGQ2kY
> &m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s=UFS97FbjEQDBE-DJBZaJF
> 7J3umdmn66PA1Z4yc95xjU&e=
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=ftp-3A__ftp.ietf.org_intern
> et-2Ddrafts_&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3iCrhI
> oUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&s
> =DKDpwbqKxZRyMXqgSklNxE-zP1DZtdIAKnrO9nDBWis&e=
> 
> 
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mail
> man_listinfo_ipv6&d=BQICAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=UT3Bk9cbLeaJxhf3
> iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq
> 530&s=v1A6AVqb1WxYJro1_L-5y_b6bHxnWZjMZr_jE55X9Fo&e=
> 
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 12 Apr 2016 08:12:44 +1200

> - Should A=L=0 prefix used for SLAAC? (you said no)

Yes, it would be reasonable to add a sentence clarifying these two points, which
are more or less the definitions of A=0 and L=0.

> - How is A=L=0 prefix going to help the first hop router selection?

I think that is clear already - i.e., exactly the same as when A=1 or L=1.

   Brian

---

From: "Mudric, Dusan (Dusan)" <[email-masked]>
Date: Tue, 12 Apr 2016 15:01:28 +0000

Hi Brian,

Thanks for updating the draft regarding A=L=0 prefix. 

>I think that is clear already - i.e., exactly the same as when A=1 or L=1.

How is it going to work? SASA will select the source address based on the prefix that was advertised by the first hop router to the given destination. Send algorithm select the first hop router for off-link destinations using a default router list. 

Q1: How is the SASA address prefix going to be compared against A=L=0 prefix during the default router selection?
Q2: It makes sense to store the A=L=1 prefixes for each default router entry and compare them against SASA address prefix during the first hope router selection. A=L=1 prefixes are used to create device addresses. However, A=L=0 prefixes are not used to create device addresses (you agreed on that). It does not make sense, to me, to compare A=L=0 prefixes against SASA address prefix. There will never be a match because none of SLAAC addresses will ever be created using A=L=0 prefixes. I think A=L=0 prefixes are not needed and should not be stored in default router entries.
Q3: I did not notice you mentioned how A=L=1 prefixes are stored during RA and used during the default router selection. This should be clarified, if is not already.

Regards,
Dusan

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Monday, April 11, 2016 4:13 PM
To: Mudric, Dusan (Dusan); 神明達哉
Cc: [email-masked]
Subject: Re: draft-ietf-6man-multi-homed-host - Routing packets from hosts in a multi-prefix network

> - Should A=L=0 prefix used for SLAAC? (you said no)

Yes, it would be reasonable to add a sentence clarifying these two points, which are more or less the definitions of A=0 and L=0.

   Brian

>> iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQww
>> q 530&s=v1A6AVqb1WxYJro1_L-5y_b6bHxnWZjMZr_jE55X9Fo&e=
>> oUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&
>> s =DKDpwbqKxZRyMXqgSklNxE-zP1DZtdIAKnrO9nDBWis&e=
>>
>>
>>
>> oUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQwwq530&
>> s =DKDpwbqKxZRyMXqgSklNxE-zP1DZtdIAKnrO9nDBWis&e=
>>
>>
>>
>> iCrhIoUWB8YLZU23029sMQGQ2kY&m=lhfg8o3sQ_U0qWiAcIO67_OY6ltvVdPyRj2oQww
>> q 530&s=v1A6AVqb1WxYJro1_L-5y_b6bHxnWZjMZr_jE55X9Fo&e=
>>
>>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 13 Apr 2016 14:31:34 +1200

Regards
   Brian Carpenter
   http://orcid.org/0000-0001-7924-6182

On 13/04/2016 03:01, Mudric, Dusan (Dusan) wrote:
> How is it going to work? 

Isn't that the subject of Section 3 in the draft? I'm not understanding
where you see an ambiguity. As far as Section 3 goes, the case A=L=0
isn't special; it's just another PIO.

> SASA will select the source address based on the prefix that was advertised by the first hop router to the given destination. Send algorithm select the first hop router for off-link destinations using a default router list. 
> 

Nothing special - just do what Section 3 says.

> Q2: It makes sense to store the A=L=1 prefixes for each default router entry and compare them against SASA address prefix during the first hope router selection. A=L=1 prefixes are used to create d…

The whole point is they are a signal saying "I know how to source-route from
that prefix." That information needs to be stored. They are not used for
SLAAC and they are not asserted to be on-link, so those two bits of information
are not stored.

> Q3: I did not notice you mentioned how A=L=1 prefixes are stored during RA and used during the default router selection. This should be clarified, if is not already.

I think that is out of scope; we aren't changing what is already done.

    Brian