Subject: <draft-ietf-6man-rfc4291bis-02.txt>

From: Bob Hinden <[email-masked]>
Date: Wed, 27 Apr 2016 12:16:20 -0700

Hi,

I published the third 6man w.g. version (-02) of the RFC4291bis draft.  See links below.

The change in this version is:

      Remove changes made by RFC7371 because there isn't any known
      implementation experience.

A diff from the previous version is available at:

   https://www.ietf.org/rfcdiff?url2=draft-ietf-6man-rfc4291bis-02

This is part of the project to move the core IPv6 specifications to Internet Standard.

Thanks,
Bob

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the IPv6 Maintenance of the IETF.
> 
>        Title           : IP Version 6 Addressing Architecture
>        Authors         : Robert M. Hinden
>                          Stephen E. Deering
> 	Filename        : draft-ietf-6man-rfc4291bis-02.txt
> 	Pages           : 30
> 	Date            : 2016-04-27
> 
> Abstract:
>   This specification defines the addressing architecture of the IP
>   Version 6 (IPv6) protocol.  The document includes the IPv6 addressing
>   model, text representations of IPv6 addresses, definition of IPv6
>   unicast addresses, anycast addresses, and multicast addresses, and an
>   IPv6 node's required addresses.
> 
>   This document obsoletes RFC 4291, "IP Version 6 Addressing
>   Architecture".
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-6man-rfc4291bis/
> 
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-ietf-6man-rfc4291bis-02
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-6man-rfc4291bis-02
>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 28 Apr 2016 08:03:12 +1200

>       implementation experience.

That seems to be correct, but it will leave Proposed Standard RFC7371 in
a rather strange state after 4291bis is published. It (RFC7371) will be listed
as updating an RFC which is itself obsoleted by an RFC that effectively
overrides RFC7371 without saying so.

I have no opinion about the value of RFC7371, but this situation makes
my head hurt slightly.

   7371--updates-->4291
     ^               ^
     |               |
  overrides      obsoletes
      \             /
       \--4291bis--/

   Brian

---

From: Bob Hinden <[email-masked]>
Date: Wed, 27 Apr 2016 14:19:08 -0700

Brian,

> On Apr 27, 2016, at 1:03 PM, Brian E Carpenter <[email-masked]> wrote:
> 

There is the note in the Appendix change log.  I suppose as part of the advancement package we would make RFC7371 historic.

Bob