Subject: Re: I-D Action: draft-gont-6man-address-usage-recommendations-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Mon, 30 May 2016 09:01:06 +1200

Hi,

> 
> 4.  Address Stability Considerations
...
>    Enforcing a maximum lifetime on IPv6 addresses may cause long-lived
>    TCP connections to fail.

That is only one example. Any scenario where a peer expects an address to
remain valid will fail. For example, any p2p application where some kind
of rendezvous or discovery process has occurred, such that the peers know
each other's addresses. Unstable addresses require significant complications
in such applications. The only good news is that mobility generally creates
the same problem, so many applications have already been fixed. (Related
problems were explored in 6renum, of course.)

> 6.  Advice on IPv6 Address Configuration
> 
>    [TBD]
> 
> 7.  Advice on IPv6 Address Usage
> 
>    [TBD]

I think we need to delete those sections. Stating the problem is about all we
can do today. Best, or least-bad, practice will emerge over a number of years.

   Brian

---

From: Fernando Gont <[email-masked]>
Date: Sun, 29 May 2016 23:09:41 -0300

Hi, Brian,

Thanks for your feedback. Comments in-line...

On 05/29/2016 06:01 PM, Brian E Carpenter wrote:
> That is only one example.

Exactly.

> Any scenario where a peer expects an address to
> in such applications. 

Yes, that's why I wonder to what extent one can say "yes, feel free to
go ahead with temp addr only".

> The only good news is that mobility generally creates

Really? If the app doesn't have some concept of session or the like, how
would that happen?

> can do today. Best, or least-bad, practice will emerge over a number of years.

Fair enough. But... at the end of the day, nodes need to do *something*
so... what'd be the advice for them?

P.S.: If we remove Sections 6 and 7, the track should be changed to
"info", I guess.

THanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 30 May 2016 14:48:23 +1200

> Really? If the app doesn't have some concept of session or the like, how

Yes, either a session (think Skype, or RTP traffic) or some kind of
intrinsic keep-alive check. There is quite a lot of such traffic, I think.

    Brian