Subject: draft-ietf-6man-segment-routing-header-01

From: Ronald Bonica <[email-masked]>
Date: Thu, 5 May 2016 16:31:02 +0000

Stephano,

Sections 1 and 2 of draft-ietf-6man-segment-routing-header-01 are, for the most part, redundant with text that can be found in draft-ietf-spring-segment-routing-07.  Please consider replacing those four pages of text with the short paragraphs provided below

                                                                    Ron Bonica

PROPOSED TEXT
============

Segment Routing (SR) [I-D.ietf-spring-segment-routing] specifies procedures through which an upstream node can determine that path that a packet traverses on route to its destination. In segment routing, a path is defined as a list of segments. In order to determine the path that a packet traverse on route to its destination, the upstream node adds a list of segments to the packet. Downstream nodes steer the packet along the segments that are specified in the list.

SR relies on control and forwarding plane components. See [draft-ietf-isis-segment-routing-extensions] and [draft-ietf-ospf-ospfv3-segment-routing-extensions] for a description of control plane components.

On the forwarding plane, SR can be instantiated by MPLS or IPv6. When SR is instantiated by MPLS, the segment list is represented as an MPLS label stack. See [draft-ietf-spring-segment-routing-mpls] for details. When SR is instantiated by IPv6, the segment list is contained by a new IPv6 Routing Header, called the Segment Routing Header (SRH). This document defines the SRH.

The scope of this document is limitted to the SR forwarding plane as it is instantiated by IPv6. Control plane topics are beyond the scope of this document.

---

From: Tim Chown <[email-masked]>
Date: Tue, 10 May 2016 12:53:08 +0000

Hi Ron,

> On 5 May 2016, at 17:31, Ronald Bonica <[email-masked]> wrote:
> 
> Stephano,
> 

This text is not wholly clear on whether ‘contained by’ means insertion of a new header, or an encapsulation approach.  Should it be, or is this intentionally left open?

Tim