Subject: Fwd: I-D Action: draft-carpenter-6man-whats-global-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 8 Jun 2016 13:58:08 +1200

Comments and suggestions welcome, and if there is enough interest
we could perhaps discuss this in Berlin.

   Brian

-------- Forwarded Message --------
Subject: I-D Action: draft-carpenter-6man-whats-global-00.txt
Date: Tue, 07 Jun 2016 18:53:59 -0700
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : What does 'global' mean in IPv6?
        Author          : Brian Carpenter
	Filename        : draft-carpenter-6man-whats-global-00.txt
	Pages           : 4
	Date            : 2016-06-07

Abstract:
   The word 'global' is used in two different ways in various
   IPv6-related RFCs and an IANA registry.  This document describes the
   resulting problem.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-carpenter-6man-whats-global/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-carpenter-6man-whats-global-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: [email-masked]
Date: Wed, 8 Jun 2016 09:31:23 +0200

Brian,

> we could perhaps discuss this in Berlin.

Thanks for writing this up!

I believe if we go back and look at what we tried to achieve it might become easier.

ULAs are globally scoped addresses to ensure that NAT is not needed.
If ULAs were not globally scoped, then connecting to networks together using ULAs could require the use of NAT. We have "defined" ourselves out of that by declaring them to be globally scoped. Reality might be different, but that's the political direction we wanted.

We did not want ULAs to be globally reachable. Which is why there is the by default boundary checks on routing advertisements for example. Using ULAs it would be extremely unlikely that one could engineer global reachability, although among a set of consenting administrative domains they can be routed.

Global scope = We don't need NAT
Not global reachability = Affects SAS/DAS selection, use in DNS and so on.

5.  Rename the registry column from 'Global' to 'Globally reachable' (and update text and RFC 6890 accordingly).

Seems to clarify the meaning of "Global".
Wonder if that could be done just with an Errata.

Cheers,
Ole

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 9 Jun 2016 13:43:04 +1200

> Wonder if that could be done just with an Errata.

As long as the registry could then include words like:

Note that 'globally reachable' is a practical statement about recommended
routing practices. It is different from the formal 'global unicast' scope
defined by [RFC4291bis]. In particular, Unique Local Addresses [RFC4193] have
global unicast scope but are not globally reachable.

   Brian

---

From: [email-masked]
Date: Thu, 9 Jun 2016 09:08:31 +0200

> global unicast scope but are not globally reachable.

I'm fine with that.

in practice the statement about global unicast scope is also a practical statement about recommended practice.

cheers,
Ole

---

From: Brian Haberman <[email-masked]>
Date: Thu, 16 Jun 2016 08:57:34 -0400

On 6/9/16 3:08 AM, [email-masked] wrote:
>>>> Comments and suggestions welcome, and if there is enough
>>>> interest we could perhaps discuss this in Berlin.
>>> 
>>> ULAs are globally scoped addresses to ensure that NAT is not
>>> needed. If ULAs were not globally scoped, then connecting to
>>> networks together using ULAs could require the use of NAT. We
>>> have "defined" ourselves out of that by declaring them to be
>>> globally scoped. Reality might be different, but that's the
>>> political direction we wanted.
>>> 
>>> We did not want ULAs to be globally reachable. Which is why there
>>> is the by default boundary checks on routing advertisements for
>>> example. Using ULAs it would be extremely unlikely that one could
>>> engineer global reachability, although among a set of consenting
>>> administrative domains they can be routed.
>>> 
>>> Global scope = We don't need NAT Not global reachability =
>>> Affects SAS/DAS selection, use in DNS and so on.
>>> 
>>> 5.  Rename the registry column from 'Global' to 'Globally
>>> reachable' (and update text and RFC 6890 accordingly).
>>> 
>>> Seems to clarify the meaning of "Global". Wonder if that could be
>>> done just with an Errata.
>> 
>> Note that 'globally reachable' is a practical statement about
>> recommended routing practices. It is different from the formal
>> 'global unicast' scope defined by [RFC4291bis]. In particular,
>> Unique Local Addresses [RFC4193] have global unicast scope but are
>> not globally reachable.
> 
> I'm fine with that.
> 
> in practice the statement about global unicast scope is also a
> practical statement about recommended practice.

I think the change in the column name and a footnote differentiating
between globally reachable and globally routable is a reasonable
clarification. I think this is a bit more complex than an erratum.

Let me coordinate with the other authors of 6890 to see how quickly
something can be spun.

Regards,
Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 17 Jun 2016 13:33:06 +1200

> Let me coordinate with the other authors of 6890 to see how quickly

That would be excellent. I won't update my little draft unless somebody
requests me to do so.

Thanks
    Brian