Subject: Re: Testing ULAness

From: Brian Haberman <[email-masked]>
Date: Fri, 10 Jun 2016 07:23:25 -0400

Bob,
     The key part of that definition is the last part about "beyond an administrative boundary", which is where the aspects of 4193 come in.

Brian On Jun 9, 2016 7:32 PM, Bob Hinden <[email-masked]> wrote:
>
> Brian, 
>
> > On Jun 9, 2016, at 7:56 AM, Brian Haberman <[email-masked]> wrote: 
> > 
> > Sorry for the delay in responding, but I have been traveling... 
> > 
> > On 6/5/16 12:37 AM, Brian E Carpenter wrote: 
> >> Hi, 
> >> 
> >> The IANA IPv6 Special-Purpose Address Registry* has a column marked "Global". 
> >> For fc00::/7 (ULA) this is set to "False". 
> >> 
> >> That is surely wrong. ULAs are explicitly defined as having global scope. 
> >> 
> >> This has consequences. For example, in the Python ipaddress module, 
> >> the property .is_global returns False on a ULA. The test for ULAness 
> >> turns out to be (x.is_private and not x.is_link_local). 
> >> 
> >> *http://www.iana.org/assignments/iana-ipv6-special-registry/iana-ipv6-special-registry.xhtml 
> >> 
> > 
> > I have not been able to work through this entire thread as of yet, but I 
> > wanted to respond to point above as one of the authors of the RFC that 
> > created the registry. 
> > 
> > Global is False given that, while probably unique, these addresses are 
> > not guaranteed globally routable. 4193 says: 
> > 
> >   Their limitation is in the routability of the prefixes, which is 
> >   limited to a site and any explicit routing agreements with other 
> >   sites to propagate them... 
> > 
> > The authors of 6890 discussed this at length both amongst ourselves and 
> > with the larger community. The consensus was that ULAs are not 
> > guaranteed globally routable. 
>
> You are correct about RFC4193, but the confusion is that the text in RFC6890 that defines Global doesn’t mention globally routable.  It says something much more limited: 
>
> o    Global - A boolean value indicating whether an IP datagram whose 
>      destination address is drawn from the allocated special-purpose 
>      address block is forwardable beyond a specified administrative 
>      domain. 
>
> I read that as covered by "any explicit routing agreements with other sites to propagate”, not globally routable.  Some sort of clarification or errata for this RFC and IANA registry is needed. 
>
> Bob 
>
>
>

---

From: Bob Hinden <[email-masked]>
Date: Fri, 10 Jun 2016 08:37:20 -0700

Brian,

> On Jun 10, 2016, at 4:23 AM, Brian Haberman <[email-masked]> wrote:
> 
> Bob,

I get that, but that can be achieved by two ASs sharing a route for a specific ULA prefix.  If the intent is that global means "global routable” then the RFC should say so in a clear manner.  For example, something like:

o    Global - A boolean value indicating whether an IP datagram whose
     destination address is drawn from the allocated special-purpose
     address block is routed globally.

I could file an errata.

Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 11 Jun 2016 08:21:11 +1200

>      address block is routed globally.

That's insufficient, because it still leaves the word 'global' on its
own having different meanings in different RFCs. That's why I wrote
my quick draft.

    Brian
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: Bob Hinden <[email-masked]>
Date: Fri, 10 Jun 2016 13:25:28 -0700

Brian,

> On Jun 10, 2016, at 1:21 PM, Brian E Carpenter <[email-masked]> wrote:
> 

Your draft could also update RFC6890 as well as the IANA registry.

Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 11 Jun 2016 08:40:08 +1200

> Your draft could also update RFC6890 as well as the IANA registry.

Yes indeed. I will spin the draft nearer the deadline, if anything like
a consensus view has appeared. (We might indeed be able to handle the
whole thing by errata, but it seems useful to have a draft to work from.)

   Brian

---

From: Lorenzo Colitti <[email-masked]>
Date: Sat, 11 Jun 2016 11:40:16 +0900

On Sat, Jun 11, 2016 at 12:37 AM, Bob Hinden <[email-masked]> wrote:

> >     The key part of that definition is the last part about "beyond an
> administrative boundary", which is where the aspects of 4193 come in.
>
> I get that, but that can be achieved by two ASs sharing a route for a
> specific ULA prefix.

But that's also possible (and commonly done) for private IPv4 space, which
we all agree should have Global: false.

The fact that two administrative domains can agree to route bits of address
space between each other does not mean that that address space is global or
even valid (it could be bogon space, for example).

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 11 Jun 2016 15:52:33 +1200

> we all agree should have Global: false.

Afaik, there is no formal definition of global scope for IPv4, as there
is for IPv6. So the confusion I'm complaining about doesn't arise for IPv4.

   Brian

---

From: joel jaeggli <[email-masked]>
Date: Sat, 11 Jun 2016 08:31:07 -0700

On 6/10/16 7:40 PM, Lorenzo Colitti wrote:
> On Sat, Jun 11, 2016 at 12:37 AM, Bob Hinden <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     I get that, but that can be achieved by two ASs sharing a route for
>     a specific ULA prefix.
> 
> 
> But that's also possible (and commonly done) for private IPv4 space,
> which we all agree should have Global: false.
> 
> The fact that two administrative domains can agree to route bits of
> address space between each other does not mean that that address space
> is global or even valid (it could be bogon space, for example).

Consenting adults can get together and do all sorts of things I wouldn't
choose to do myself. unilateral action on the other hand would be met by
best practice filters in most cases.

---

From: Bob Hinden <[email-masked]>
Date: Sun, 12 Jun 2016 11:38:35 -0700

Lorenzo,

> On Jun 10, 2016, at 7:40 PM, Lorenzo Colitti <[email-masked]> wrote:
> 
> I get that, but that can be achieved by two ASs sharing a route for a specific ULA prefix.
> 
> But that's also possible (and commonly done) for private IPv4 space, which we all agree should have Global: false.

This is another example why the text in RFC6890 that defines “global” is not correct.  IMHO, it should have a clear definition.

Bob

> 
> The fact that two administrative domains can agree to route bits of address space between each other does not mean that that address space is global or even valid (it could be bogon space, for example).

---

From: Lorenzo Colitti <[email-masked]>
Date: Mon, 13 Jun 2016 20:28:29 -0700

On Sun, Jun 12, 2016 at 11:38 AM, Bob Hinden <[email-masked]> wrote:

> This is another example why the text in RFC6890 that defines “global” is
> not correct.  IMHO, it should have a clear definition.
>

It does have a clear definition. I think the problem here is that that
definition does not match the definition of "global scope" used in the IPv6
standards.