Subject: Re: Reference to "3333" value of RFC2464 "IPv6 over Ethernet"

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 20 Jul 2016 19:30:19 +0200

Let me start a separate thread to continue this discussion:

Can IS-IS run on IPv6 and if so which MAC multicast address?

Alex

Le 20/07/2016 à 14:52, Hemant Singh a écrit :
>
>
> On Wed, Jul 20, 2016 at 5:49 AM, Alexandre Petrescu
> <[email-masked] <mailto:[email-masked]>> 
> wrote:
>
>
>     >Does IS-IS also make use of 01-00-5E- multicast IANA OUI? (in
>     addition to that C9).
>
>
> No.  For Level-1 adjacencies, the packets are sent to 01-80-C2-00-00-14,
> and for Level-2 adjacencies, the packets are sent to 01-80-C2-00-00-15
>
> Hemant
>

---

From: Karsten Thomann <[email-masked]>
Date: Wed, 20 Jul 2016 19:47:08 +0200

Hi Alex,

IS-IS runs directly on ethernet over clns (iso), as it isn't an IP protocol, even if it can route ipv4 and ipv6.

Karsten

Gesendet von meinem BlackBerry

Von: Alexandre Petrescu

Gesendet: Mittwoch, 20. Juli 2016 19:30

An: IPv6

Betreff: Re: Reference to "3333" value of RFC2464 "IPv6 over Ethernet"

Let me start a separate
thread to continue this discussion:

Can IS-IS run on IPv6 and if so
which MAC multicast address?

Alex

<[email-masked]
<mailto:[email-masked]>>

addition to that C9).

No.  For Level-1 adjacencies, the packets are sent to
01-80-C2-00-00-14,

and for Level-2 adjacencies, the packets are sent to
01-80-C2-00-00-15

Hemant

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 20 Jul 2016 19:49:02 +0200

Le 20/07/2016 à 19:47, Karsten Thomann a écrit :
> Hi Alex,
>
> IS-IS runs directly on ethernet over clns (iso), as it isn't an IP
> protocol, even if it can route ipv4 and ipv6.

I dont understand 'it can route ipv6'.   I wonder whether an IS-IS 
packet can carry an IPv6 header? (something like IPv6-over-ISIS?)

Alex

> *Von: *Alexandre Petrescu
> *Gesendet: *Mittwoch, 20. Juli 2016 19:30
> *An: *IPv6
> *Betreff: *Re: Reference to "3333" value of RFC2464 "IPv6 over Ethernet"
>
>

---

From: Karsten Thomann <[email-masked]>
Date: Wed, 20 Jul 2016 20:02:23 +0200

As it is a routing protocol it is only providing routing information and isn't carrying any IP payload within it's packets.
It's the same with ospf, only that ospf3 and ipv6 share the same layer 3 protocol (ipv6).
Ospf wouldn't transport any payload except routing information, so there is also no ipv6 over ospf‎3.

Gesendet von meinem BlackBerry
  Originalnachricht  
Von: Alexandre Petrescu
Gesendet: Mittwoch, 20. Juli 2016 19:50
An: Karsten Thomann; IPv6
Betreff: Re: AW: Reference to "3333" value of RFC2464 "IPv6 over Ethernet"

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 20 Jul 2016 20:13:58 +0200

Le 20/07/2016 à 20:02, Karsten Thomann a écrit :
> As it is a routing protocol it is only providing routing information
>  and isn't carrying any IP payload within it's packets. It's the same
>  with ospf, only that ospf3 and ipv6 share the same layer 3 protocol
>  (ipv6). Ospf wouldn't transport any payload except routing
> information, so there is also no ipv6 over ospf‎3.

Ah I see what you mean.  So yes there is no collision risk here: IS-IS
uses its MAC multicast address, and IPv6 uses another MAC multicast address.

It's still strange though how the former MAC address is more global
although IS-IS has local operation, whereas the other one is more local
whereas IPv6 can be considered a global protocol.

Alex

>
> Gesendet von meinem BlackBerry Originalnachricht Von: Alexandre
> Petrescu Gesendet: Mittwoch, 20. Juli 2016 19:50 An: Karsten Thomann;
> IPv6 Betreff: Re: AW: Reference to "3333" value of RFC2464 "IPv6 over
> Ethernet"
>
>
>
>> Gesendet von meinem BlackBerry *Von: *Alexandre Petrescu *Gesendet:
>> *Mittwoch, 20. Juli 2016 19:30 *An: *IPv6 *Betreff: *Re: Reference
>> to "3333" value of RFC2464 "IPv6 over Ethernet"
>>
>>
>>> <mailto:[email-masked]>> wrote:
>>>
>>>
>>> 01-80-C2-00-00-14, and for Level-2 adjacencies, the packets are
>>> sent to 01-80-C2-00-00-15
>>>
>>> Hemant
>>>
>>
>

---

From: Karsten Thomann <[email-masked]>
Date: Wed, 20 Jul 2016 21:43:10 +0000

Am Mittwoch, 20. Juli 2016, 20:13:58 schrieb Alexandre Petrescu:
> > information, so there is also no ipv6 over ospf?3.
> 

I think we are getting a bit off-topic for this list, so only a very short answer.

MAC addresses and IP addresses operate at different layers and are assigned and managed by 
different organisations, so there are different meanings for the same word.