Subject: Status of RFC 2473?

From: Brian E Carpenter <[email-masked]>
Date: Wed, 3 Aug 2016 11:50:59 +1200

Hi,

Some discussion about ECN through tunnels over in TSVWG drew my attention
to RFC 2473, which to be honest I had completely forgotten about. Often
when people want a generic reference to IPv6 tunnels they cite RFC 4213.

So here's my question. Is RFC 2473 still valid and useful? There are
things it definitely doesn't cover in an up to date way: ECN, DSCP,
and flow label for example.

Did anyone ever implement the Tunnel Encapsulation Limit option?

Quite a lot of RFCs cite RFC 2473 (see http://www.fenron.com/~fenner/ietf/deps/index.cgi).

Regards
   Brian

P.S. Another question is whether we should be reviewing the validity of every
other IPv6-related RFC. If we get the main documents to Internet Standard,
obsoleting out-of-date documents should also be on the radar.

---

From: [email-masked]
Date: Wed, 3 Aug 2016 08:57:41 +0200

Brian,

> and flow label for example.

It definitely is. It is the fundament for all these recent IPv4 over IPv6 tunnel RFCs out of softwires.

> Did anyone ever implement the Tunnel Encapsulation Limit option?

Nope.

> Quite a lot of RFCs cite RFC 2473 (see http://www.fenron.com/~fenner/ietf/deps/index.cgi).

or
http://www.arkko.com/tools/allstats/citations-rfc2473.html

> obsoleting out-of-date documents should also be on the radar.

Regards,
Ole