Subject: Stephen Farrell's No Objection on draft-ietf-6man-multi-homed-host-07: (with COMMENT)

From: "Stephen Farrell" <[email-masked]>
Date: Tue, 02 Aug 2016 10:21:11 -0700

Stephen Farrell has entered the following ballot position for
draft-ietf-6man-multi-homed-host-07: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-6man-multi-homed-host/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

general: I think this is very verbose, an editing pass
to remove as many words as possible would be good, some
examples below where I think more words confused me more
than was needed...

- Abstract: is bcp38 really crucial here or advisory? If
the latter, then I'd suggest not making it sound like it
is necessary, no matter how much we'd like it deployed.

- intro: "the only consistent solution" may be an
overstatement (unless you can prove there is no other)

- text on p4 after figure 1: it's probably me but I
found reading this a slog, not sure if it's really
needed, but if (part of) it is, making the necessary
bits clearer would seem like a fine plan. If it's not
needed, maybe delete some or all of it.

- 2.1: When you say SLAAC here, are you encompassing use
of privacy addresses? Sometimes those are presented as
an alternative to SLAAC but I'm not sure which is the
more correct terminology. In any case, I assume this
document is intended to fully work with privacy
addresses.

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 3 Aug 2016 08:29:06 +1200

On 03/08/2016 05:21, Stephen Farrell wrote:
....
> examples below where I think more words confused me more

iirc we added words because the WG feedback was that originally
we were too terse in some areas. One cannot win ;-).

> - Abstract: is bcp38 really crucial here or advisory?

We're covering an issue that mainly arises in cases where
BCP38 filters are present. So it's neither crucial nor advisory;
it's an assumption.

> If

I'd buy s/only consistent/only known consistent/. I've been
worriting about IPv6 multihoming for years and I certainly
can't think of any solution except SADR. But it's hard to
prove.

> needed, maybe delete some or all of it.

This is a specific case where the WG asked for more words.

> document is intended to fully work with privacy

SLAAC uses whatever interface identifier the host comes
up with - MAC-based, RFC4941-based (privacy), RFC7217-based
(pseudorandom), or manually configured small integers...

Regards
   Brian