Subject: Results on 6MAN Header Insertion Survey

From: Bob Hinden <[email-masked]>
Date: Tue, 8 Nov 2016 14:01:07 -0800

Hi,

The poll is now closed.  We received 57 responses.  You can see the results at:

    https://www.surveymonkey.com/results/SM-MP3RRBYN/

The chairs conclusions are as follows.

There was not a clear highest priority results between the three choices.  The numbers were

 A) Ban Header Insertion  17
 B) Describe the Problem  17
 C) Not say anything      23

This is consistent with the email and face to face discussions.

Medium Priority showed a clearer difference:

 A) Ban Header Insertion  11
 B) Describe the Problem  36
 C) Not say anything       6

The chairs conclude that there is much stronger support to describe the problem than the other two choices.  Specifically if the we combine the high and medium choices:

 A) Ban Header Insertion  28
 B) Describe the Problem  53
 C) Not say anything      29

We note that of the 57 people who participated in the poll, 53 gave “Describing the Problem” high or medium preference.

With our ADs assistance, we also ran a Condorcet calculator on the survey data.   This also confirmed the B) choice as the result of the poll.  More info on Condorcet is at the end of this email.

Consequently, the chairs declare there is a consensus to include the text that describe the problems with Header Insertion in rfc2460bis.

We will send the proposed text used in the survey out in a separate email.  It is open for improvement as long as it keeps it within the consensus in the w.g.  That is, that it only describes the problems with header insertion.  The goal will be to publish a new draft when the ID repository reopens.

We also think there would be value in a few people writing a new draft that describes the issues with Header Insertion in greater detail than can be accommodated in rfc2460bis.  This would not be part of moving the core IPv6 specs to Internet Standard.

Bob & Ole

--------

The following link has more info on Condorcet:

   https://en.wikipedia.org/wiki/Condorcet_method

We used the calculator at:

   http://ericgorr.net/condorcet/

The raw data from the poll:

A>B>C
B>A>C
B>A>C
B>C>A
A>B>C
A>B>C
A>B>C
C>B>A
A>B>C
C>B>A
C>B>A
C>B>A
C>B>A
A>B>C
A>B>C
C>B>A
B>A>C
A>B>C
C>B>A
C>B>A
C>B>A
B>A>C
B>A>C
C>B>A
C>B>A
C
A>B>C
B>C>A
A>B>C
C>B>A
C>B>A
A>B
A>B>C
C>B>A
C>B>A
C>B>A
C>B>A
C>B>A
B>A>C
B>A>C
B>C>A
A>B>C
B>C>A
B>C
C>B>A
A>B>C
B>A>C
B>A>C
B
C>B>A
B>C>A
A>B
C>B>A
C>B>A
A>B>C
A>B>C
B>A>C

---

From: Mark Smith <[email-masked]>
Date: Thu, 10 Nov 2016 07:55:22 +1100

(Apologies for not deleting most of below, I'm on my phone.)

Regarding a draft about the issues that would be caused by EH insertion,
I've been thinking about one for a few weeks and have been putting together
some notes. I'm happy to take it further if there is enough interest and
would welcome any interested co-authors.

Regards,
Mark.

On 9 Nov. 2016 09:01, "Bob Hinden" <[email-masked]> wrote:

Hi,

The poll is now closed.  We received 57 responses.  You can see the results
at:

There was not a clear highest priority results between the three choices.
The numbers were

The chairs conclude that there is much stronger support to describe the
problem than the other two choices.  Specifically if the we combine the
high and medium choices:

We note that of the 57 people who participated in the poll, 53 gave
“Describing the Problem” high or medium preference.

With our ADs assistance, we also ran a Condorcet calculator on the survey
data.   This also confirmed the B) choice as the result of the poll.  More
info on Condorcet is at the end of this email.

Consequently, the chairs declare there is a consensus to include the text
that describe the problems with Header Insertion in rfc2460bis.

We will send the proposed text used in the survey out in a separate email.
It is open for improvement as long as it keeps it within the consensus in
the w.g.  That is, that it only describes the problems with header
insertion.  The goal will be to publish a new draft when the ID repository
reopens.

We also think there would be value in a few people writing a new draft that
describes the issues with Header Insertion in greater detail than can be
accommodated in rfc2460bis.  This would not be part of moving the core IPv6
specs to Internet Standard.

Bob & Ole

--------

A>B>C
B>A>C
B>A>C
B>C>A
A>B>C
A>B>C
A>B>C
C>B>A
A>B>C
C>B>A
C>B>A
C>B>A
C>B>A
A>B>C
A>B>C
C>B>A
B>A>C
A>B>C
C>B>A
C>B>A
C>B>A
B>A>C
B>A>C
C>B>A
C>B>A
C
A>B>C
B>C>A
A>B>C
C>B>A
C>B>A
A>B
A>B>C
C>B>A
C>B>A
C>B>A
C>B>A
C>B>A
B>A>C
B>A>C
B>C>A
A>B>C
B>C>A
B>C
C>B>A
A>B>C
B>A>C
B>A>C
B
C>B>A
B>C>A
A>B
C>B>A
C>B>A
A>B>C
A>B>C
B>A>C

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------