Subject: SR and loops

From: Hemant Singh <[email-masked]>
Date: Thu, 17 Nov 2016 13:10:59 -0500

This is the SR document I am talking about.

https://tools.ietf.org/html/draft-ietf-spring-segment-routing-09

Here is a high-level perspective.

MPLS uses BGP and has routers maintain state which avoids routing loops.
SR claims to have removed state from the routers for simplification.  If
state is removed, how does SR handle routing loops that could arise when a
link fails in the path?  I don't see the draft addressing such an issue.

I just subscribed to the spring mailer today - am waiting for approval and
thus the email to 6man where protocols for IPv6 are discussed sometimes.

Thanks,

Hemant

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Thu, 17 Nov 2016 20:27:02 +0000

> On Nov 17, 2016, at 7:10 PM, Hemant Singh <[email-masked]> wrote:
> 

well, I think you need clarifications...

mpls is a dataplane technology that relies on the routing control plane. The routing control plane has multiple components among which you may have bgp (but not only that of course).

mpls, in its “classical” form, requires a control plane (LDP, RSVP) in order to establish switching (dataplane) paths.

This mpls control plane has been used for decades and reached its scalability and flexibility.

> SR claims to have removed state from the routers for simplification.  If state is removed, how does SR handle routing loops that could arise when a link fails in the path?  I don't see the draft addressing such an issue. 

segment routing is an extension in the control plane so to include in routing protocols, the necessary bits required by the mpls dataplane. This obsoletes “classical” mpls protocols such as ldp and rsvp.

since SR is about routing extensions, there’s nothing affecting routing loops or whatever other paradigm of the routing layer.

Please have a look at segment-routing.net for all documentation that will allow you to learn more on SR.

s.

> I just subscribed to the spring mailer today - am waiting for approval and thus the email to 6man where protocols for IPv6 are discussed sometimes.  
> 
> Thanks,
> 
> Hemant
>