Subject: draft-ietf-6man-segment-routing-header-02

From: Brian E Carpenter <[email-masked]>
Date: Mon, 19 Dec 2016 16:05:02 +1300

Hi,

I just noticed that draft-ietf-6man-segment-routing-header-02 still says:

>    While the source routing model defined in [RFC2460] doesn't mandate
>    which node is allowed to insert (or modify) the SRH, it is assumed in
>    this document that the SRH is inserted in the packet by its source.

We might have less dissension if this was phrased something like:

It is assumed in this document that the SRH is inserted in the packet by
its source, consistently with the source routing model defined in [RFC2460].

    Brian

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Tue, 20 Dec 2016 14:06:35 +0000

Hi Brian,

> On Dec 19, 2016, at 4:05 AM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 

draft-ietf-6man-segment-routing-header-02 refers to RFC2460 where it is indeed unspecified who is allowed (or not allowed) to insert a header.

When RFC2460bis will be published, we will update the draft accordingly.

s.

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 21 Dec 2016 08:21:52 +1300

Stefano, I think you are missing my point.

The current text in your draft is contentious. Many of us believe that
the wording (and the intention) of RFC 2460 is clear that header insertion
en route is forbidden. In that view, the sentence I quoted is simply false.
My proposed sentence simply removes that contentious point completely from
your draft:

"It is assumed in this document that the SRH is inserted in the packet by
its source, consistently with the source routing model defined in [RFC2460]."

If you change that reference later to 2460bis, you wouldn't need to change
the text at all.

Regards
   Brian

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Wed, 21 Dec 2016 15:26:27 +0000

Brian,

sorry but, yes, probably I miss the point...

draft-ietf-6man-segment-routing-header is _all_ based on encapsulation/tunneling. There’s not a single word about header insertion so I don’t think the draft is controversial. Also, it has been adopted as WG item exactly because any reference to a header insertion has been removed. Now, if you really think these words:

      "While the source routing model defined in [RFC2460] 
       doesn't mandate which node is allowed to insert 
       (or modify)the SRH...”

are unacceptable (looks like a bit extreme to me but...), then I’m fine, once again, to update the draft and remove the offending text.

I will update the draft but wanted to pointed out that:
. at the time the draft has been adopted as WG item nobody commented on these “offending” words.
. We’ve been back and forth on header insertion during the last months and we finally reached consensus on a wording for rfc2560bis. IETF being about rough consensus and running code, well, we have both in this case. I hope to see the debate somehow closed and rfc2460bis published.

Thanks.
s.

> On Dec 20, 2016, at 8:21 PM, Brian E Carpenter <[email-masked]> wrote:
>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 22 Dec 2016 14:05:32 +1300

Thanks.

> . at the time the draft has been adopted as WG item nobody commented on these “offending” words.

No, but WG adoption is only agreement to work on the document; wordsmithing comes later.
I could have saved this for WG Last Call, but I sent it as soon as I noticed it
(while checking over draft-ietf-spring-ipv6-use-cases as requested recently).

> . We’ve been back and forth on header insertion during the last months and we finally reached consensus on a wording for rfc2560bis. IETF being about rough consensus and running code, well, we have both in this case.

The WG has reached rough consensus, yes. The IETF hasn't done so yet.

> I hope to see the debate somehow closed and rfc2460bis published.

We all agree on that. My point is that with the small change I proposed, your
draft doesn't care any more whether it cites 2460 or 2460bis.

    Brian

---

From: 神明達哉 <[email-masked]>
Date: Thu, 22 Dec 2016 11:11:30 -0800

At Thu, 22 Dec 2016 14:05:32 +1300,

> > are unacceptable (looks like a bit extreme to me but...), then I’m fine, once again, to update the draft and remove the offending text.

FWIW, I agree with Brian that the above "While..." text will be
contentious (I don't know if it's "offending" or "unacceptable",
though).  Although what's stated is true in that RFC2460 surely
doesn't mandate it (nor for that matter rfc2460bis will if it passes
the rest of the standardization steps), it *could* read as if the RFC
implicitly allows a non-source node to insert an EH.

Unless such interpretation was actually the intent, it's safer to
avoid stating it this way to avoid misunderstanding, especially given
draft-ietf-6man-segment-routing-header doesn't rely on such
(mis)interpretation.

--
JINMEI, Tatuya