Subject: Question on draft-ietf-6man-segment-routing-header-04 (not needed PHP-Style behavior)

From: Shay Zadok <[email-masked]>
Date: Wed, 1 Feb 2017 13:34:57 +0200

Hi,

As 'Clean-up flag' is omitted from segment-routing-header-04, does this
means that no need to support PHP-Style behavior in the segment before the
last one?
That is, last segment *always* get the SRH header.

Thanks,
Shay

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Wed, 1 Feb 2017 20:12:44 +0000

Hi,

> On Feb 1, 2017, at 12:34 PM, Shay Zadok <[email-masked]> wrote:
> 
> Hi,
> 
> As 'Clean-up flag' is omitted from segment-routing-header-04, does this means that no need to support PHP-Style behavior in the segment before the last one?

the clean-up flag was used when an SRH was “inserted” underneath the IPv6 header by a transit node. In order to be able to deliver the packet without the SRH you needed an indication for the penultimate segment in order to remove the SRH prior to send the packet to the destination (last segment).

The behavior described in draft-04 is different and consists of the addition of both an outer IPv6 header and an SRH (i.e.: encapsulation instead of insertion). In that context, the PHP behavior (cleanup bit) is no longer needed.

s.

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Shay Zadok <[email-masked]>
Date: Thu, 2 Feb 2017 09:19:57 +0200

Hi Stefano,

Thanks for clearing.

I just saw routing-header-05 changed from "insert" to "add".
Which means full tunnel add/remove, and coherent with no need of C-Flag.

Best Regards,
Shay

On Wed, Feb 1, 2017 at 10:12 PM, Stefano Previdi (sprevidi) <
[email-masked]> wrote:

> the clean-up flag was used when an SRH was “inserted” underneath the IPv6
> header by a transit node. In order to be able to deliver the packet without
> the SRH you needed an indication for the penultimate segment in order to
> remove the SRH prior to send the packet to the destination (last segment).
>
> The behavior described in draft-04 is different and consists of the
> addition of both an outer IPv6 header and an SRH (i.e.: encapsulation
> instead of insertion). In that context, the PHP behavior (cleanup bit) is
> no longer needed.
>
> s.
>
>