Subject: RE: Routing directorate review of draft-ietf-6man-rfc2460bis

From: "Papadimitriou, Dimitri (Nokia - BE)" <[email-masked]>
Date: Thu, 2 Mar 2017 21:02:40 +0000

Hello,

I have been selected as the Routing Directorate reviewer for this draft. The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review, and sometimes on special request. The purpose of the review is to provide assistance to the Routing ADs. For more information about the Routing Directorate, please see ​http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgDir

Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.

Document: draft-ietf-6man-rfc2460bis-08.txt
Reviewer: Dimitri Papadimitriou 
Review Date: 01-03-2017
Intended Status: Standards Track

Summary:

I have some minor comments about this document that I think might have to be resolved before publication.

Major Issues: 

No major issues found.

Minor Issues:

Section 4.4: processing of the "segment left" field is left undocumented (shouldn't it be decremented after being processed ?)

Section 4.5: "If insufficient fragments are received to complete reassembly" does "insufficient" means the last fragment ?

Section 4.8: states "New hop-by-hop options are not recommended because nodes may be configured to ignore the Hop-by-Hop Option header, drop packets containing a hop-by-hop header" does this configuration change because options are new or old ? there seems to be confusion here between "new vs. existing" options and "intermediate nodes MAY be configured to ignore/drop packets with these options included". 

Section 8.3: one would have expected a self-consistent formula to determine the max.payload size instead of a relative comparison to IPv4

Section 8.4: automatically reversed or not, this section doesn't state if the response (understood here that the option type is recognized) is to be sent to the source address (directly) or the last entry from the record route for instance (cf. Section 4.4).

Editorials:

p2. s/Internet Protocol/Internet Protocol (IP)

Section 2 defines link for link MTU but doesn't define path for path MTU

p14. s/a source node know/a source node knows

-----

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 3 Mar 2017 10:25:03 +1300

On 03/03/2017 10:02, Papadimitriou, Dimitri (Nokia - BE) wrote:
...
> Section 4.8: states "New hop-by-hop options are not recommended because nodes may be configured to ignore the Hop-by-Hop Option header, drop packets containing a hop-by-hop header" does this config…

Middleboxes *might* be configured to do something sensible with existing HbH options (such as ignoring them) and something annoying with unknown new ones (such as kicking them to the slow path or dropping the packet). So yes, the situation is worse for new options than for ones that have been defined years ago. But they are both risky.

   Brian

---

From: Tom Herbert <[email-masked]>
Date: Thu, 2 Mar 2017 13:36:36 -0800

> Middleboxes *might* be configured to do something sensible with existing HbH options (such as ignoring them) and something annoying with unknown new ones (such as kicking them to the slow path or d…
Right, but in the current state of things any EH has proven hard to
successfully deploy in practice. IMO it's more of an implementation
problem that needs to be addressed rather than a protocol
specification problem. If the recommendation is to not create new HBH
options because of this it seems like this affirms protocol
ossification and maybe we've lost the battle!

Tom