Subject: Re: I-D Action: draft-voyer-6man-extension-header-insertion-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Wed, 29 Mar 2017 07:18:31 +1300

Honestly, this impresses nobody:

>         Authors         : Daniel Voyer
>                           Daniel Bernier
>                           John Leddy
>                           Clarence Filsfils
>                           Stefano Previdi
>                           Stefano Salsano
>                           Antonio Cianfrani
>                           David Lebrun
>                           Olivier Bonaventure
>                           Prem Jonnalagadda
>                           Milad Sharif
>                           Hani Elmalky
>                           Ahmed Abdelsalam
>                           Robert Raszuk
>                           Arthi Ayyangar
>                           Dirk Steinberg
>                           Wim Henderickx

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 29 Mar 2017 07:28:32 +1300

> Hence, a context-less ban of
> IPv6 extension header insertion does not make sense.

RFC2460bis isn't contextless. The context is the Internet and therefore
the requirements for interoperable communication between any two nodes on
the Internet. I don't see any conflict between that and a additional
specification for local use of a feature that does not meet those requirements.

I think this draft would be much easier to consider without that sort
of phrasing.

    Brian

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Wed, 29 Mar 2017 20:55:25 +0000

> On Mar 28, 2017, at 8:18 PM, Brian E Carpenter <[email-masked]> wrote:
> 

honestly, the goal was not to impress you or anyone else.

Having said that, I’m sure you acknowledge the fact that the people here below deserve the expected respect from this community due to the effort they put into the writing of:

draft-ietf-6man-segment-routing-header
draft-voyer-6man-extension-header-insertion
draft-filsfils-spring-srv6-network-programming
draft-bashandy-isis-srv6-extensions

and into the writing of multi-vendor interoperable implementations.

Thanks.
s.

> 
>>        Authors         : Daniel Voyer
>>                          Daniel Bernier
>>                          John Leddy
>>                          Clarence Filsfils
>>                          Stefano Previdi
>>                          Stefano Salsano
>>                          Antonio Cianfrani
>>                          David Lebrun
>>                          Olivier Bonaventure
>>                          Prem Jonnalagadda
>>                          Milad Sharif
>>                          Hani Elmalky
>>                          Ahmed Abdelsalam
>>                          Robert Raszuk
>>                          Arthi Ayyangar
>>                          Dirk Steinberg
>>                          Wim Henderickx
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Wed, 29 Mar 2017 20:55:40 +0000

> On Mar 28, 2017, at 8:28 PM, Brian E Carpenter <[email-masked]> wrote:
> 

since we are in the process of updating rfc2460, your statement above could easily be inserted into rfc2460bis.

s.

---

From: Fernando Gont <[email-masked]>
Date: Wed, 29 Mar 2017 23:02:20 +0200

> since we are in the process of updating rfc2460, your statement above could easily be inserted into rfc2460bis.

My understanding is that that ship has already sailed (IETF LC ended a
while ago).

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 31 Mar 2017 02:49:01 +1300

> since we are in the process of updating rfc2460, your statement above could easily be inserted into rfc2460bis.

As others have said, we a bit far along in the process, but I would actually
agree with that.

    Brian