Subject: I-D Action: draft-ietf-6man-segment-routing-header-06.txt

From: [email-masked]
Date: Mon, 13 Mar 2017 03:04:15 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 Maintenance of the IETF.

        Title           : IPv6 Segment Routing Header (SRH)
        Authors         : Stefano Previdi
                          Clarence Filsfils
                          Kamran Raza
                          John Leddy
                          Brian Field
                          Daniel Voyer
                          Daniel Bernier
                          Satoru Matsushima
                          Ida Leung
                          Jen Linkova
                          Ebben Aries
                          Tomoya Kosugi
                          Eric Vyncke
                          David Lebrun
                          Dirk Steinberg
                          Robert Raszuk
	Filename        : draft-ietf-6man-segment-routing-header-06.txt
	Pages           : 35
	Date            : 2017-03-13

Abstract:
   Segment Routing (SR) allows a node to steer a packet through a
   controlled set of instructions, called segments, by prepending an SR
   header to the packet.  A segment can represent any instruction,
   topological or service-based.  SR allows to enforce a flow through
   any path (topological, or application/service based) while
   maintaining per-flow state only at the ingress node to the SR domain.

   Segment Routing can be applied to the IPv6 data plane with the
   addition of a new type of Routing Extension Header.  This draft
   describes the Segment Routing Extension Header Type and how it is
   used by SR capable nodes.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-6man-segment-routing-header/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header-06

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-6man-segment-routing-header-06

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Bob Hinden <[email-masked]>
Date: Mon, 13 Mar 2017 11:24:20 -0700

Hi,

This draft has quite a long author list.  It grew significantly from the previous version.

The RFC Style Guide (RFC7322) recommends a limit of five authors.  Sixteen is a lot more than five.  The style guide says that drafts with more than five will require specific approval from the stream to have this many authors, in this case the IESG.  From a practical point of view having sixteen authors will make getting through AUTH48 very challenging as each author needs to sign off on the document.

I suggest that the authors figure out a way to reduce the number of listed authors.  For example, move most people to a "contributors" section and leave the document editor or primary authors on the first page.

Thanks,
Bob

> On Mar 13, 2017, at 3:04 AM, [email-masked] wrote:
> 
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Tue, 14 Mar 2017 08:14:35 +0000

Hi Bob,

Before bringing the draft to iesg review, we will trim down the authors list to 5 names and move everybody else into the contributors section.

s.

> On Mar 13, 2017, at 7:24 PM, Bob Hinden <[email-masked]> wrote:
> 
> Hi,
>