Subject: IETF: SixXS is shutting down

From: Pim van Pelt <[email-masked]>
Date: Fri, 24 Mar 2017 14:02:27 +0100

Colleagues,

In 1999, Jeroen and I started SixXS, a project which aimed to provide
IPv6 connectivity to users who wanted to learn about the network
protocol and gain experience operating IPv6 networks. Our vision was
to facilitate migration to IPv6 in content and access providers.

We were able to provide IPv6 to 50’000+ individual users and companies
in 140+ countries, using servers hosted at 40+ Internet providers in
30+ countries. We are incredibly proud of what we’ve accomplished
together, and how many people have gotten to know all about IPv6 due
to our combined efforts.

We have completed a retrospective and rationale document, which
details our experience developing and operating the SixXS tunnelbroker
over the last 18 years. We have worked through our plans with the many
dedicated ISPs that have been involved:

https://www.sixxs.net/sunset/

We have reached out to users recently, giving them 6 weeks to make
alternative plans. We have chosen a somewhat symbolic date of
2017-06-06 to turn down the SixXS service. Our website will remain as
a tombstone.

Please feel free to pass this along to any group or list you feel
would benefit from it, and reach out to <[email-masked]> or to myself
directly <[email-masked]> if you have thoughts you’d like to share
between now and then.

-- 
Pim van Pelt <[email-masked]>
PBVP1-RIPE - http://www.ipng.nl/

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 24 Mar 2017 15:05:16 +0100

Le 24/03/2017 à 14:02, Pim van Pelt a écrit :
> Colleagues,
>
> In 1999, Jeroen and I started SixXS, a project which aimed to
> provide IPv6 connectivity to users who wanted to learn about the
> network protocol and gain experience operating IPv6 networks. Our
> vision was to facilitate migration to IPv6 in content and access
> providers.
>
> We were able to provide IPv6 to 50’000+ individual users and
> companies in 140+ countries, using servers hosted at 40+ Internet
> providers in 30+ countries. We are incredibly proud of what we’ve
> accomplished together, and how many people have gotten to know all
> about IPv6 due to our combined efforts.

Congratulations for past achievements!

> details our experience developing and operating the SixXS

Tunnelbroker ok, but how about ULA generation and registration at sixxs. 
  Is it shut down tombstone too?
https://www.sixxs.net/tools/grh/ula/

And what happens to the registrations?

> over the last 18 years.

Some local calls it "in their youth" :-)

Alex

> We have worked through our plans with the many dedicated ISPs that
> have been involved:
>
> 2017-06-06 to turn down the SixXS service. Our website will remain
> as a tombstone.

> would benefit from it, and reach out to <[email-masked]> or to
> myself directly <[email-masked]> if you have thoughts you’d like to
> share between now and then.
>

---

From: Pim van Pelt <[email-masked]>
Date: Fri, 24 Mar 2017 15:14:20 +0100

Hoi Alex,

> Congratulations for past achievements!
Thank you.

> Tunnelbroker ok, but how about ULA generation and registration at sixxs.  Is
> it shut down tombstone too?
TL/DR: Plan of record is that it will cease to exist.

This registry was for educational purposes, and has no official
status. Importantly, as ULA is random per definition, the chance of
collisions is extremely low. It is fairly straight forward to get a
prefix from one of the RIRs. While that does cost some money, it is an
activity that is not the main charter of SixXS and will be expected to
continue with the RIRs.

> And what happens to the registrations?
Can't quite parse the question - so let me offer three answers (maybe
the answer you're looking for is among them):
Firstly, registrations (new users) has been closed since Q4'15, so we
haven't accepted new registrations since that time.
Secondly, in the lifetime of the project, we have taken privacy and
individually identifiable information very seriously, and to our
knowledge have never suffered an information breach or leek. After
decommissioning the services we run, we will destroy all PII data,
keeping only traffic statistics at the PoP level, and general
statistics of our usage, like the graphs seen in the posted sunset
rationale document.
Finally, the allocations we've received from LIRs (total used space is
about one /33 of assigned and active space, and upwards of a /30 of
allocated space), will be returned to the LIRs and all database
objects deleted.

Happy to discuss this or other things further as we near the lights-out date.

groet,
Pim

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 24 Mar 2017 17:25:27 +0100

Le 24/03/2017 à 15:14, Pim van Pelt a écrit :
[...]
> individually identifiable information very seriously,

Yes.

Now one could use random.org to generate an ULA prefix, instead of the 
sixxs generator.

(provided one trusts random.org, and hoping random.org is reachable on 
IPv6, of course)

Alex

---

From: Fred Baker <[email-masked]>
Date: Fri, 24 Mar 2017 09:40:19 -0700

> On Mar 24, 2017, at 9:25 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> Now one could use random.org to generate an ULA prefix, instead of the sixxs generator.
> 
> (provided one trusts random.org, and hoping random.org is reachable on IPv6, of course)

dhcp-wifi-197:v6ops fred$ dig AAAA random.org +short
2400:cb00:2048:1::6814:2d07
2400:cb00:2048:1::6814:2c07

> Alex
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: "Song Linjian (Davey)" <[email-masked]>
Date: Sun, 26 Mar 2017 09:36:56 -0500

Sigh! When people think IPv6 tunnel become a hinder of IPv6 deployment,  people in China still in the struggle of chicken and egg problem. 

-Davey

> 在 2017年3月24日，08:02，Pim van Pelt <[email-masked]> 写道：
> 
> Colleagues,
> 

------------------------------
Davey Song(宋林健)
BII Lab
[email-masked]

---

From: Jeroen Massar <[email-masked]>
Date: Sun, 26 Mar 2017 16:55:13 +0200

On 2017-03-26 16:36, Song Linjian (Davey) wrote:
> Sigh! When people think IPv6 tunnel become a hinder of IPv6 deployment,
>  people in China still in the struggle of chicken and egg problem. 

Please explain more about your "chicken and egg problem" and how the
last 20 years of IPv6 deployment have not addressed those problems.

Greets,
 Jeroen

---

From: Song Linjian (Davey) <[email-masked]>
Date: Sun, 26 Mar 2017 15:23:58 -0500

Chicken and egg problem is the same : 

ISP complains there is no content in IPv6, no requirement from user for IPv6 connection. ICP complains there is no IPv6 network and IPv6 user 

China is different from India because it can not leap by taking the advantage of IPv6 development of big global ICPs, like Google , Facebook, and Youtube. Besides, most netizens in China do not consume much content in English. Most of people can live well without connections outside. So the only hope is on the local ICP like Baidu , Tencent and Alibaba. But the local ICP and ISP are in the early stage of Chicken and egg problem.

Most IPv6 stories from China are from research and academic network , and some pilots from Telcos supported by national IPv6 developing fundings. But They are for the purpose of research and demonstration of innovation ,not for commercial and productional purpose.

That’s what I am sighing for.

Davey

> 在 2017年3月26日，09:55，Jeroen Massar <[email-masked] <mailto:[email-masked]>> 写道：
> 

------------------------------
Davey Song(宋林健)
BII Lab
[email-masked] <mailto:[email-masked]>

---

From: Christopher Morrow <[email-masked]>
Date: Sun, 26 Mar 2017 18:06:46 -0400

On Sun, Mar 26, 2017 at 4:23 PM, Song Linjian <[email-masked]> wrote:

> ISP complains there is no content in IPv6, no requirement from user for
> IPv6 connection. ICP complains there is no IPv6 network and IPv6 user
>
> China is different from India because it can not leap by taking the
> advantage of IPv6 development of big global ICPs, like Google , Facebook,
> and Youtube. Besides, most netizens in China do not consume much content in
> English. Most
>

some of those ICP are blocked... of course.
Some of them actually do offer local ipv6 versions of their content...
Some of them actually do offer local-language support over the ipv6 even.

Some of the tunnel users in question are probably trying to aboice the
blocks mentioned, right?
ISPs probably can't really enable bypassing filtering, not without
hand-slaps from the larger gov't anyway.

> of people can live well without connections outside. So the only hope is
> on the local ICP like Baidu , Tencent and Alibaba. But the local ICP and
> ISP are in the early stage of Chicken and egg problem.
>
>
what's strange is the story ~10yrs back (more actually) that 'all isps in
china are ipv6 enabled' isn't really true, I guess?
sad :(

---

From: "Song Linjian (Davey)" <[email-masked]>
Date: Mon, 27 Mar 2017 00:31:55 -0500

> what's strange is the story ~10yrs back (more actually) that 'all isps in china are ipv6 enabled' isn't really true, I guess?
> sad :( 

Major ISPs are IPv6 enabled in the aspect of the backbone, not the last mile to users. Some of them deployed IPv6 island that is not connected to the backbone. 

There are two cases I experienced last year : 

1) China mobile is provisioning IPv6 to their users in Beijing over VoLTE, so I can receive IPv6 address in my handset. But I can not ping out (out of China).  

2) The ISP in Fujian province, they deployed IPv6 to the local network. We once setup IPv6-only DNS servers there but we can not pull the zone from the master server in my lab in Beijing.

Now the business of Chinese telcos are impacted by the Internet company, so they are not motivated to move forward and increase the investment in IPv6. The main force of IPv6 guys I know well are from the research department , not from the operational department of these telcos. The later has more voice in decision making from my impression.

CERNET2 is good but the example is not copied to other ISPs. IMHO academic guys spent too much effort on transition protocols and tools as a reward to intellectual challenges. few of them are really deployed in scale. Instead, too many IPv6 transition choices make IPv6 adoption harder for telcos operational people who think IPv6 is not ready for productional network. Even in the research area, there are different voice/noise  to hold back the IPv6 development, like SDN, non-ip solutions, even IPv9 (the freak!!!). 

In policy making layer, there exists some fears and exaggerating opinions with non-trivial group of advocates who try to convince Gov't that IPv6 may introduce new threats and impacts to current censorship,like IPsec, even the fact that IPsec traffic is poor.

In general, there are many challenges for IPv6 guys in China as far as I can tell. More consensus should be reached in the community to take real actions. The good news is that the global IPv6 traffic is reaching 18% of total which exerts pressures on both industry and Gov't. In most Chinese people‘s mind, it seems acceptable that China fall little behind U.S or EU in many areas, but not India and Vietnam.  More IPv6 stories of those countries and regions can really help by hurting the proud : ) 

 I’m expecting to see changes in the coming years.

---

From: Christopher Morrow <[email-masked]>
Date: Mon, 27 Mar 2017 08:17:29 -0600

On Sun, Mar 26, 2017 at 11:31 PM, Song Linjian (Davey) <
[email-masked]> wrote:

> Major ISPs are IPv6 enabled in the aspect of the backbone, not the last
> mile to users. Some of them deployed IPv6 island that is not connected to
> the backbone.
>
>
that doesn't sound like an ipv6 deployment at all. bummer.

> 1) China mobile is provisioning IPv6 to their users in Beijing over VoLTE,
> so I can receive IPv6 address in my handset. But I can not ping out (out of
> China).
>
>
I don't think you can provision ipv<anything> over 'volte' ... volte is
just: 'send voice over ip to handsets'. The LTE standard does speak
strongly about requiring ipv6 though, so probably any LTE deployment does
have ipv6 as a component.

perhaps you mean that?

> 2) The ISP in Fujian province, they deployed IPv6 to the local network. We
> once setup IPv6-only DNS servers there but we can not pull the zone from
> the master server in my lab in Beijing.
>
> Now the business of Chinese telcos are impacted by the Internet company,
> so they are not motivated to move forward and increase the investment in
> IPv6. The main force of IPv6 guys I know well are from the research
> department , not from the operational department of these telcos. The later
> has more voice in decision making from my impression.
>

and again:
  1) some of the examples you provided are not reachable in the PRC,
because of some PRC local decisions/actions
  2) all of the examples you cited (facebook, youtube, google, etc) are
ipv6 enabled for the rest of the world.
  3) some of these properties even provide content from inside the prc,
over ipv6

I am betting there are other, larger, problems with ipv6 deployment in the
PRC, related to things like: "Why can I not get to facebook.com?" while in
the PRC.

> CERNET2 is good but the example is not copied to other ISPs. IMHO academic
> guys spent too much effort on transition protocols and tools as a reward to
> intellectual challenges. few of them are really deployed in scale. Instead,
> too many IPv6 transition choices make IPv6 adoption harder for telcos
> operational people who think IPv6 is not ready for productional network.
> Even in the research area, there are different voice/noise  to hold back
> the IPv6 development, like SDN, non-ip solutions, even IPv9 (the freak!!!).
>
>
the rest of the world basically disagrees though? ipv6 deployment is moving
further and faster every day... except in the PRC, it seems?

> In policy making layer, there exists some fears and exaggerating opinions
> with non-trivial group of advocates who try to convince Gov't that IPv6 may
> introduce new threats and impacts to current censorship,like IPsec, even
> the fact that IPsec traffic is poor.
>
>
maybe don't do the censorship part then?

> In general, there are many challenges for IPv6 guys in China as far as I
> can tell. More consensus should be reached in the community to take real
> actions. The good news is that the global IPv6 traffic is reaching 18% of
> total which exerts pressures on both industry and Gov't. In most Chinese
> people‘s mind, it seems acceptable that China fall little behind U.S or EU
> in many areas, but not India and Vietnam.  More IPv6 stories of those
> countries and regions can really help by hurting the proud : )
>
>
ok

>  I’m expecting to see changes in the coming years.
terrific.

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 27 Mar 2017 12:03:12 -0500

Le 27/03/2017 à 00:31, Song Linjian (Davey) a écrit :
>
>> what's strange is the story ~10yrs back (more actually) that 'all
>> isps in china are ipv6 enabled' isn't really true, I guess? sad :(
>>
>
> Major ISPs are IPv6 enabled in the aspect of the backbone,

You tell major ISPs: the IPv6 blocks they got are mainly for the ISP
clients, and only secondarily for themselves :-)

It worked for me :-)

(basically, when an ISP asks for an IPv6 block to RIR, the RIR asks back
how many clients they have, and subsequently they dimension the size of
these IPv6 blocks; so the ISPs are bound to this).

Alex

> not the last mile to users. Some of them deployed IPv6 island that
> is not connected to the backbone.
>
> 1) China mobile is provisioning IPv6 to their users in Beijing over
> VoLTE, so I can receive IPv6 address in my handset. But I can not
> ping out (out of China).
>
> 2) The ISP in Fujian province, they deployed IPv6 to the local
> network. We once setup IPv6-only DNS servers there but we can not
> pull the zone from the master server in my lab in Beijing.
>
> Now the business of Chinese telcos are impacted by the Internet
> company, so they are not motivated to move forward and increase the
> investment in IPv6. The main force of IPv6 guys I know well are from
> the research department , not from the operational department of
> these telcos. The later has more voice in decision making from my
> impression.
>
> CERNET2 is good but the example is not copied to other ISPs. IMHO
> academic guys spent too much effort on transition protocols and
> tools as a reward to intellectual challenges. few of them are really
> deployed in scale. Instead, too many IPv6 transition choices make
> IPv6 adoption harder for telcos operational people who think IPv6 is
> not ready for productional network. Even in the research area, there
> are different voice/noise  to hold back the IPv6 development, like
> SDN, non-ip solutions, even IPv9 (the freak!!!).
>
> In policy making layer, there exists some fears and exaggerating
> opinions with non-trivial group of advocates who try to convince
> Gov't that IPv6 may introduce new threats and impacts to current
> censorship,like IPsec, even the fact that IPsec traffic is poor.
>
> In general, there are many challenges for IPv6 guys in China as far
> as I can tell. More consensus should be reached in the community to
> take real actions. The good news is that the global IPv6 traffic is
> reaching 18% of total which exerts pressures on both industry and
> Gov't. In most Chinese people‘s mind, it seems acceptable that China
> fall little behind U.S or EU in many areas, but not India and
> Vietnam.  More IPv6 stories of those countries and regions can
> really help by hurting the proud : )
>
> ------------------------------ Davey Song(宋林健) BII Lab
>  IETF IPv6 working group mailing list [email-masked] Administrative
> Requests: https://www.ietf.org/mailman/listinfo/ipv6