Subject: ULA Registration (Was: Re: IETF: SixXS is shutting down)

From: David Farmer <[email-masked]>
Date: Fri, 24 Mar 2017 10:24:14 -0500

On Fri, Mar 24, 2017 at 9:14 AM, Pim van Pelt <[email-masked]> wrote:

> Hoi Alex,
>
> On Fri, Mar 24, 2017 at 3:05 PM, Alexandre Petrescu
> <[email-masked]> wrote:
> > Congratulations for past achievements!
> Thank you.
>
> > Tunnelbroker ok, but how about ULA generation and registration at
> sixxs.  Is
> > it shut down tombstone too?
> > https://www.sixxs.net/tools/grh/ula/
> TL/DR: Plan of record is that it will cease to exist.
>
> This registry was for educational purposes, and has no official
> status. Importantly, as ULA is random per definition, the chance of
> collisions is extremely low. It is fairly straight forward to get a
> prefix from one of the RIRs. While that does cost some money, it is an
> activity that is not the main charter of SixXS and will be expected to
> continue with the RIRs.
>

There are other purposes for registration than just uniqueness, with ULA
such as identification of leaked traffic for instance, but more generally
registration facilitates many forms of operational coordination.  We have
the RIRs use registries because we want more than just a guarantee of
uniqueness, we also want to facilitate operational coordination on many
fronts.

Further, ULA prefixes provide something that RIR allocated GUA prefixes
don't, that is a presumption that they are not routed(or reachable) between
administrative domains.  While they can be routed between administrative
domains, this is really only suppose to happen with one-on-one
coordination. Were as RIR allocated GUA prefixes are presumed to be routed
between all administrative domains.  Their is no guarantee they are
actually routed between any two administrative domains, but it is presumed
to be the case.  And, ULA is presumed to be the exact opposite that.

While ULAs are presumed to not be routed between administrative domains,
that doesn't mean they are not use cases where registration can provide
advantages, especially when ULAs are used for enterprise use cases.  There
are probably much less advantages of ULA registration when all you are
looking for is a semi-stable prefix that isn't dependent on a service
provider, like in typical residential use case, but these are not the only
use cases for ULA.

> And what happens to the registrations?
> Can't quite parse the question - so let me offer three answers (maybe
> the answer you're looking for is among them):
>

I think he means the ULA registrations.  As I mention above, there are
other advantages to registration than just uniqueness.

>From this discussion on another list, here is the count of ULA
registrations in the SixXS database.
+------+-------+
| Year | Count |
+------+-------+
| 2007 |    63 |
| 2008 |   140 |
| 2009 |   321 |
| 2010 |   611 |
| 2011 |   835 |
| 2012 |   742 |
| 2013 |   724 |
| 2014 |  1096 |
| 2015 |  1303 |
| 2016 |   640 |
| 2017 |   143 |
+------+-------+

That is 6618 ULA block that were registered, that seems like that's more
than just a fad. Does this make a case for resurrecting the discussions of
ULA-C? I think it does.  But, what do others think?

Thanks.

Happy to discuss this or other things further as we near the lights-out
> date.
>
> groet,
> Pim
>
> --
> Pim van Pelt <[email-masked]>
> PBVP1-RIPE - http://www.ipng.nl/
>

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815 <(612)%20626-0815>
Minneapolis, MN 55414-3029   Cell: 612-812-9952 <(612)%20812-9952>
===============================================

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 24 Mar 2017 16:51:18 +0100

I was trying for some time to make it happen via a global policy, which needs to be approved in all the RIRs, but didn’t succeeded. May be was too early:

I’m happy to try to run this again if we believe there is some benefit out of it.

https://www.ripe.net/participate/policies/proposals/2007-05

https://www.afrinic.net/library/corporate-documents/264-proposal-for-ipv6-ula-central-afpub-2007-v6-003

https://www.apnic.net/wp-content/uploads/prop-048/assets/prop-048-v001.txt

http://www2.lacnic.net/documentos/politicas/LAC-2007-06-en.pdf

Regards,
Jordi

-----Mensaje original-----
De: ipv6 <[email-masked]> en nombre de David Farmer <[email-masked]>
Responder a: <[email-masked]>
Fecha: viernes, 24 de marzo de 2017, 16:24
Para: Pim van Pelt <[email-masked]>
CC: Alexandre Petrescu <[email-masked]>, 6man WG <[email-masked]>
Asunto: ULA Registration (Was: Re: IETF: SixXS is shutting down)

    Hoi Alex,
    
    Thank you.
    
    > Tunnelbroker ok, but how about ULA generation and registration at sixxs.  Is

    
    There are other purposes for registration than just uniqueness, with ULA such as identification of leaked traffic for instance, but more generally registration facilitates many forms of operational coordination.  We have the RIRs use registries because we want more than just a guarantee of uniqueness, we also want to facilitate operational coordination on many fronts.  
    
    Further, ULA prefixes provide something that RIR allocated GUA prefixes don't, that is a presumption that they are not routed(or reachable) between administrative domains.  While they can be routed between administrative domains, this is really only suppose to happen with one-on-one coordination. Were as RIR allocated GUA prefixes are presumed to be routed between all administrative domains.  Their is no guarantee they are actually routed between any two administrative domains, but it is presumed to be the case.  And, ULA is presumed to be the exact opposite that.
    
    While ULAs are presumed to not be routed between administrative domains, that doesn't mean they are not use cases where registration can provide advantages, especially when ULAs are used for enterprise use cases.  There are probably much less advantages of ULA registration when all you are looking for is a semi-stable prefix that isn't dependent on a service provider, like in typical residential use case, but these are not the only use cases for ULA. 

    
    I think he means the ULA registrations.  As I mention above, there are other advantages to registration than just uniqueness.  
    
    From this discussion on another list, here is the count of ULA registrations in the SixXS database.  
    +------+-------+
    | Year | Count |
    +------+-------+
    | 2007 |    63 |
    | 2008 |   140 |
    | 2009 |   321 |
    | 2010 |   611 |
    | 2011 |   835 |
    | 2012 |   742 |
    | 2013 |   724 |
    | 2014 |  1096 |
    | 2015 |  1303 |
    | 2016 |   640 |
    | 2017 |   143 |
    +------+-------+

    That is 6618 ULA block that were registered, that seems like that's more than just a fad. Does this make a case for resurrecting the discussions of ULA-C? I think it does.  But, what do others think?
     
    Thanks.

    Happy to discuss this or other things further as we near the lights-out date.
    
    groet,
    Pim

    
    
    -- 
    ===============================================
    David Farmer               Email:[email-masked] <mailto:[email-masked]>
    Networking & Telecommunication Services
    Office of Information Technology
    University of Minnesota   
    2218 University Ave SE        Phone: 612-626-0815 <tel:(612)%20626-0815>
    Minneapolis, MN 55414-3029   Cell: 612-812-9952 <tel:(612)%20812-9952>
    =============================================== 

    --------------------------------------------------------------------
    IETF IPv6 working group mailing list
    [email-masked]
    Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
    --------------------------------------------------------------------

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Pim van Pelt <[email-masked]>
Date: Fri, 24 Mar 2017 17:08:58 +0100

Hi David,

On Fri, Mar 24, 2017 at 4:24 PM, David Farmer <[email-masked]> wrote:
> There are other purposes for registration than just uniqueness, ...
I see your point and I agree with the operational benefits of registering.
Scanning back on the archives on ULA-C discussions, there seem to be
two camps, the pragmatic folk who would like to use a registry to
debug operational issues, and the fundamental camp who do not believe
ULA prefixes should be visible, should not be resolvable globally, and
so on. Personally, I'm in the former camp, believing the visibility is
a benefit at times, while the cost of registering is not large.

> ULA-C? I think it does.  But, what do others think?
My question is not should you register the prefixes or not. My questions are:
- what is the status of SixXS as an authority?
- why do the RIRs not assume responsibility?

My first question is somewhat facetious, as the answer is clearly "it
has no authority". The answer to my second question is not captured in
Jordi's reply (thanks for the context, though!) but I'm keenly
interested in it. It seems that if the RIRs did not approve in 2007,
other than closing that gap, why should I do it? I'll wait for others
to reply to David's request for comments but if we are to re-raise the
ULA-C proposal, I'm happy to be involved (surely by transferring our
existing data, but in any other way we believe makes sense).

groet,
Pim

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 24 Mar 2017 17:17:54 +0100

Trying to answer your 2nd question … I think the RIR communities (not the RIRs itself) didn’t got to understand if ULA-C was actually needed or not.

This is at the end, the only reason why policy proposals get approved. The communities understanding the need/problem and agreeing in the proposed solution.

I also tried to see if instead of having the NRO running the ULA-C registry, or one of them on behalf of all, or a “unique” central registry managed by all, may be the way is to ask IANA to run the service with a low fee, just to cover the cost.

As said, if we have a valid reason now, maybe even the same reasons we had before, but now are better understood, I’m happy to revive all the process in all the RIRs, work in an update of the ula-central with original authors or whatever is needed.

Regards,
Jordi

-----Mensaje original-----
De: ipv6 <[email-masked]> en nombre de Pim van Pelt <[email-masked]>
Responder a: <[email-masked]>
Fecha: viernes, 24 de marzo de 2017, 17:08
Para: David Farmer <[email-masked]>
CC: Alexandre Petrescu <[email-masked]>, 6man WG <[email-masked]>
Asunto: Re: ULA Registration (Was: Re: IETF: SixXS is shutting down)

    Hi David,

    
    
    groet,
    Pim

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 24 Mar 2017 17:35:39 +0100

Le 24/03/2017 à 17:17, JORDI PALET MARTINEZ a écrit :
> Trying to answer your 2nd question … I think the RIR communities (not
> the RIRs itself) didn’t got to understand if ULA-C was actually
> needed or not.
>
> This is at the end, the only reason why policy proposals get
> approved. The communities understanding the need/problem and agreeing
> in the proposed solution.
>
> I also tried to see if instead of having the NRO running the ULA-C
> registry, or one of them on behalf of all, or a “unique” central
> registry managed by all, may be the way is to ask IANA to run the
> service with a low fee, just to cover the cost.

If IANA can take it up, all the better.

> As said, if we have a valid reason now, maybe even the same reasons
> we had before, but now are better understood, I’m happy to revive all
> the process in all the RIRs, work in an update of the ula-central
> with original authors or whatever is needed.

Well I am not sure there is other reasoning now for ULA-Centralized: no 
more and no less reasons than before.  I may be wrong though.

But this event does teach important things.

All ULA-C depends a lot on the viability for a central server, its 
lifetime, its funding perenity.

If there is no server for it, there is no ULA-C.

It's impossible to rewind the effort that was spent in the ULA-C 
discussion...

But does one need to update the RFC4193 "ULA" and tell there is no L==1, 
it's always a 0 (?)

This is a significant event.

Alex

>
> Regards, Jordi
>
>
> -----Mensaje original----- De: ipv6 <[email-masked]> en nombre
> de Pim van Pelt <[email-masked]> Responder a: <[email-masked]> Fecha:
> viernes, 24 de marzo de 2017, 17:08 Para: David Farmer
> <[email-masked]> CC: Alexandre Petrescu
> <[email-masked]>, 6man WG <[email-masked]> Asunto: Re:
> ULA Registration (Was: Re: IETF: SixXS is shutting down)
>
> Hi David,
>
> I see your point and I agree with the operational benefits of
> registering. Scanning back on the archives on ULA-C discussions,
> there seem to be two camps, the pragmatic folk who would like to use
> a registry to debug operational issues, and the fundamental camp who
> do not believe ULA prefixes should be visible, should not be
> resolvable globally, and so on. Personally, I'm in the former camp,
> believing the visibility is a benefit at times, while the cost of
> registering is not large.
>
>> That is 6618 ULA block that were registered, that seems like that's
>> more than just a fad. Does this make a case for resurrecting the
>> discussions of ULA-C? I think it does.  But, what do others think?
> My question is not should you register the prefixes or not. My
> questions are: - what is the status of SixXS as an authority? - why
> do the RIRs not assume responsibility?
>
> My first question is somewhat facetious, as the answer is clearly
> "it has no authority". The answer to my second question is not
> captured in Jordi's reply (thanks for the context, though!) but I'm
> keenly interested in it. It seems that if the RIRs did not approve in
> 2007, other than closing that gap, why should I do it? I'll wait for
> others to reply to David's request for comments but if we are to
> re-raise the ULA-C proposal, I'm happy to be involved (surely by
> transferring our existing data, but in any other way we believe makes
> sense).
>
> groet, Pim
>
> -- Pim van Pelt <[email-masked]> PBVP1-RIPE - http://www.ipng.nl/
>
> IETF IPv6 working group mailing list [email-masked] Administrative
> Requests: https://www.ietf.org/mailman/listinfo/ipv6
> ********************************************** IPv4 is over Are you
> ready for the new Internet ? http://www.consulintel.es The IPv6
> Company
>
> This electronic message contains information which may be privileged
> or confidential. The information is intended to be for the use of the
> individual(s) named above. If you are not the intended recipient be
> aware that any disclosure, copying, distribution or use of the
> contents of this information, including attached files, is
> prohibited.
>
>
>
> IETF IPv6 working group mailing list [email-masked] Administrative
> Requests: https://www.ietf.org/mailman/listinfo/ipv6

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 24 Mar 2017 17:52:26 +0100

Le 24/03/2017 à 16:24, David Farmer a écrit :
>
> On Fri, Mar 24, 2017 at 9:14 AM, Pim van Pelt <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hoi Alex,
>
>     <[email-masked] <mailto:[email-masked]>>
>     wrote:
>     <https://www.sixxs.net/tools/grh/ula/>
> such as identification of leaked traffic for instance, but more
> generally registration facilitates many forms of operational
> coordination.  We have the RIRs use registries because we want more than
> just a guarantee of uniqueness, we also want to facilitate operational
> coordination on many fronts.
>
> don't, that is a presumption that they are not routed(or reachable)
> between administrative domains.  While they can be routed between
> administrative domains, this is really only suppose to happen with
> one-on-one coordination. Were as RIR allocated GUA prefixes are presumed
> to be routed between all administrative domains.  Their is no guarantee
> they are actually routed between any two administrative domains, but it
> is presumed to be the case.  And, ULA is presumed to be the exact
> opposite that.
>
> advantages, especially when ULAs are used for enterprise use cases.
> There are probably much less advantages of ULA registration when all you
> are looking for is a semi-stable prefix that isn't dependent on a
> service provider, like in typical residential use case, but these are
> not the only use cases for ULA.
>

Other advantages yes, and inconvenients too, depending on how it's 
implemented.  It should be trustable.

> than just a fad. Does this make a case for resurrecting the discussions
> of ULA-C? I think it does.  But, what do others think?

The numbers look impressive, with a glory period yet now declining. Or
just momentarily declining to only grow bigger in the longer term.

On my side, I hesitated before registering my small ULA prefixes on sixxs.

Now I could still live with randomly-generated ULA prefixes, or
generated from other significant identifiers, controlled by other
authorities relevant in particular use-cases.

But, if in the future very many computers hit this unique-/64 limit,
then ULA-C w/ or w/o NAT66 could become real necessities.

Alex

>     Pim van Pelt <[email-masked] <mailto:[email-masked]>>
> <mailto:[email-masked]>

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 24 Mar 2017 18:01:48 +0000

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Alexandre Petrescu

> On my side, I hesitated before registering my small ULA prefixes

Me too. I think of ULA as functionally equivalent to RFC 1918 addresses. A registry for ULAs, or ULA-C, is not and should not be mandatory. Consequently, such a registry is of limited effectiveness. ULAs are easily identified, so they can be blocked at boundaries between administrative domains (unless the administrative domains have a special agreement), to mitigate the problem David mentioned, of tracking down ULAs that appear on the Internet.

> But, if in the future very many computers hit this unique-/64
> limit, then ULA-C w/ or w/o NAT66 could become real necessities.

Not sure that a ULA registry is needed even in this eventuality. And any decent PRNG should be good enough to generate random prefixes?

Bert

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 25 Mar 2017 07:37:31 +1300

Do I need to justify that? Oh, OK:

1. In the highly unlikely event of two networks merging (i.e. installing
round-the-back private routing between them) and discovering that they
are using the same pseudo-random ULA prefix: yes, they will be put to
a little bother. But this is so unlikely that it really isn't worth any
overhead to avoid it - and it would only be avoidable if at least of the
two networks had bothered to register their prefix.

2. In the rather more likely event of two networks merging and discovering
that they are using the same non-random ULA prefix (fd00::/48 probably),
it's their own silly fault.

3. In the somewhat likely event of a ULA prefix being announced in BGP4,
we will know who's announcing it, so we don't need a registry. And everybody
else will filter it anyway.

Regards
   Brian

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 24 Mar 2017 18:45:19 +0000

+1

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Brian E Carpenter
Sent: Friday, March 24, 2017 14:38
To: [email-masked]
Subject: ULA clashes don't matter [Re: ULA Registration]

Regards
   Brian

---

From: james woodyatt <[email-masked]>
Date: Fri, 24 Mar 2017 13:31:20 -0700

On Mar 24, 2017, at 11:37, Brian E Carpenter <[email-masked]> wrote:
> 
> Do I need to justify that? Oh, OK: […]

4. In the event of the simultaneous merge of a sufficient number of ULA-numbered networks that the statistical chance of Global ID collisions arising would approach a significant level, the entity performing that merge can make its own private arrangements to manage the numbering requirements for the merge. For one thing, there is no apparent and immediate need for a public service to do it, and for another, establishing a registry is not obviously the best way to construct such a service in the event the need arises for one in the unforeseeable future.

--james woodyatt <[email-masked] <mailto:[email-masked]>>

---

From: Simon Hobson <[email-masked]>
Date: Fri, 24 Mar 2017 20:52:09 +0000

> just momentarily declining to only grow bigger in the longer term.

The fall is consistent with SixXS having stopped taking new registrations towards the end of 2015. "business stops selling widgets, widget sales fall"

---

From: Pim van Pelt <[email-masked]>
Date: Fri, 24 Mar 2017 22:08:44 +0100

>> just momentarily declining to only grow bigger in the longer term.
One other thing I'd question is the validity (not the correctness) of
the registrations. Of the 6618 registrations that Jeroen shared
earlier:
- 1066 are invalid, mostly because they are duplicates
- 2473 do not set organisation.
- 3982 do not set website.
- 2249 set neither website nor organisation.

While SixXS does not require website or organisation to be set, I
can't speak to the registrations that don't provide them. I took a
cursory look at the registered e-mail addresses used when registering,
not sure if there's much to learn from it, but JFYI 1127 were
gmail.com, 256 were howfunky.com, 159 were hotmail.com and any other
domain existed less than 100 times. So it does appear to me that the
e-mail addresses used are from a wide variety of users.

> The fall is consistent with SixXS having stopped taking new registrations towards the end of 2015. "business stops selling widgets, widget sales fall"
That's an interesting observation, Simon. It should not in principle
follow the SixXS userbase. If it does, that would imply that SixXS
users "also" registered an ULA while they were at it. I can't find any
data that shows this correlation, so I think it's accidental.

groet,
Pim

---

From: Erik Kline <[email-masked]>
Date: Sun, 26 Mar 2017 14:21:02 -0700

Agreed.

The doc is clear about what is required in order to minimize the chance of
collision.

In the inevitable event two non-randomly generated fd00:: networks merge,
that's their problem.  If this situation were to be cited as a motivation
for standards action, the correct answer IMHO is "they're doing it wrong;
not the IETF's problem".

On 24 March 2017 at 13:31, james woodyatt <[email-masked]> wrote:

> 4. In the event of the simultaneous merge of a sufficient number of
> ULA-numbered networks that the statistical chance of Global ID collisions
> arising would approach a significant level, the entity performing that
> merge can make its own private arrangements to manage the numbering
> requirements for the merge. For one thing, there is no apparent and
> immediate need for a public service to do it, and for another, establishing
> a registry is not obviously the best way to construct such a service in the
> event the need arises for one in the unforeseeable future.
>
> --james woodyatt <[email-masked]>
>
>
>
>