Subject: Hitting the tech news

From: Simon Hobson <[email-masked]>
Date: Thu, 15 Jun 2017 17:35:07 +0100

Decent writeup, and some "interesting" comments

https://www.theregister.co.uk/2017/06/15/carriers_risk_being_railroaded_on_ipv6_consultant_warns/

> Small carriers aren't showing up to IPv6 standards chats, consultant warns
> And that means useful stuff could be left out of customer premises equipment
> 
> Smaller ISPs are dealing themselves out of discussions about the inevitable transition to IPv6, a Spanish consultant warns, and could find their future defined by large telcos.
> 
> Frustrated at their indifference, Jordi Martinez of Consulintel has appealed for just a bit more enthusiasm (and participation) from ISPs in IPv6 decision-making.
> ...

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 15 Jun 2017 18:42:14 +0200

I guess this is due to my recent call for more active participation thru NOG mailing lists …

https://mailman.nanog.org/pipermail/nanog/2017-June/091393.html

The author of the article changed my family name …

Regards,
Jordi

-----Mensaje original-----
De: ipv6 <[email-masked]> en nombre de Simon Hobson <[email-masked]>
Responder a: <[email-masked]>
Fecha: jueves, 15 de junio de 2017, 18:35
Para: 6man WG <[email-masked]>
Asunto: Hitting the tech news

    
    > Frustrated at their indifference, Jordi Martinez of Consulintel has appealed for just a bit more enthusiasm (and participation) from ISPs in IPv6 decision-making.
    
    --------------------------------------------------------------------
    IETF IPv6 working group mailing list
    [email-masked]
    Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
    --------------------------------------------------------------------

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.consulintel.es
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Simon Hobson <[email-masked]>
Date: Thu, 15 Jun 2017 22:57:44 +0100

> The author of the article changed my family name …

I imagine that would be a common problem when dealing with us pesky native english speakers. TBH it's only accidental (having read about it somewhere some time ago) that I know enough to realise what's been done there.

FWIW I completely agree with your call for participation. No offence intended to those that already participate, but it is clear that the discussions are dominated by people working with "big networks" and with a "big network/operation" mentality. Picking up on just one point in your post on the NANOG list, speaking as a technically literate individual - if an ISP insists that I have to use their router, then they don't get my business<period>. Several ISPs in the UK do just that - and I can see some commercial justification for it - but of all the ones that I have any experience with (with my other hat on as an employee of a small IT services provider) have significant "issues" (mostly a crap CPE that just doesn't support anything past "giving internet access to devices").
One example of deficiencies in CPE routers (at least in the IPv4 space) is not having any means to forward anything other than UDP or TCP traffic - which means you can't run a GRE tunnel through them in order to get IPv6 via (in this case) Hurricane Electric's tunnelbroker service. Or with my work hat on, no proper support for site-site VPNs which are really common in the small business world. At least if the ISP supports using another router then you can work around this - but unfortunately at work we've had cases where this limitation only comes to light when you ask for (in our case, usually DSL) access details and the ISP refuses to provide them and it's too late to tell them where to shove they service (in many cases, the customer has ordered the internet service, and we later get tasked with making it do things other than "give internet access to devices").

---

From: Tim Chown <[email-masked]>
Date: Fri, 16 Jun 2017 08:54:32 +0000

> On 15 Jun 2017, at 22:57, Simon Hobson <[email-masked]> wrote:
> 
> FWIW I completely agree with your call for participation. No offence intended to those that already participate, but it is clear that the discussions are dominated by people working with "big networks" and with a "big network/operation" mentality. Picking up on just one point in your post on the NANOG list, speaking as a technically literate individual - if an ISP insists that I have to use their router, then they don't get my business<period>. Several ISPs in the UK do just that - and I can see some commercial justification for it - but of all the ones that I have any experience with (with my other hat on as an employee of a small IT services provider) have significant "issues" (mostly a crap CPE that just doesn't support anything past "giving internet access to devices”).

I’ve come across a few in the UK that say “we won’t support you if you run something other than the router we send you”, which is a little different to insisting you use their equipment.

I noted in Sky’s UKNOF presentation(*) on their UK IPv6 deployment, over 90% of their 5M or so customers had IPv6 enabled, but 2% were using their own equipment, so may or may not have IPv6.  That’s 100,000 users.
 
> One example of deficiencies in CPE routers (at least in the IPv4 space) is not having any means to forward anything other than UDP or TCP traffic - which means you can't run a GRE tunnel through th…

The site-to-site VPN issue is one a very much agree with!

Tim

(*) https://indico.uknof.org.uk/event/35/material/slides/1?contribId=5

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Fri, 16 Jun 2017 11:31:40 +0200

Responding in-line to both, Simon and Tim …

-----Mensaje original-----
De: ipv6 <[email-masked]> en nombre de Tim Chown <[email-masked]>
Responder a: <[email-masked]>
Fecha: viernes, 16 de junio de 2017, 10:54
Para: Simon Hobson <[email-masked]>
CC: 6man WG <[email-masked]>
Asunto: Re: Hitting the tech news

    > I imagine that would be a common problem when dealing with us pesky native english speakers. TBH it's only accidental (having read about it somewhere some time ago) that I know enough to realis…

[Jordi] Not an issue, I explained to the article author, also that he typed something strange instead of CPE and both have been corrected overnight!

    > FWIW I completely agree with your call for participation. No offence intended to those that already participate, but it is clear that the discussions are dominated by people working with "big n…

[Jordi] There is a very simple solution to that. If we have MUST instead of SHOULD in our basic requirements, then all the CPEs will be interoperable, so an ISP will not have a problem with any device (their own device or the one you want to use, in fact they may not notice that you changed it). They may have *additional* functionalities, and that’s why you pay more for one model or the other one (just a few examples more LAN ports, extra WAN ports, support for USB 3, USB C, support for memory cards, backup with an LTE interface, more powerful WiFi, etc., etc.), but also more “software” options, nicer GUI, built in statistics, etc., etc. I’ve worked with some very low cost Chinese products/vendors, and implemented for some trials, using OpenWRT, all the transition mechanism, all the “should” as “must”, etc., etc., etc., and we didn’t had problems with memory, CPU, etc., etc. Those products are available from 20USD (even cheaper if you use 100Mbps Ethernet instead of 1Gig) and I’m sure in high volume prices will drop. Unfortunately, we don't like MUST.

[Jordi] That’s ok, but still non ideal.

[Jordi] Again, may be interoperability issue …

    > One example of deficiencies in CPE routers (at least in the IPv4 space) is not having any means to forward anything other than UDP or TCP traffic - which means you can't run a GRE tunnel throug…

[Jordi] I guess you mean 6in4 (protocol 41, the one used for HE, I run into the same issue many times), not GRE (protocol 47), but in both cases, is a matter of using a “DMZ” or “virtual servers”. In most of the situations I’ve been, this option was available, but not very well documented, or not working for anything different than UDP/TCP/ICMP … Actually, we will need to check if there is an IPv4 CPE RFC which states something about that … never looked at it, to be honest! Same for VPNs … just different protocols.

    Tim