Subject: Documentation prefix notation for a /56

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 30 Oct 2017 13:14:07 +0100

Hello,

What documentation prefix notation should I use when writing about a /56 
prefix in an Internet Draft?

Currently I use 2001:db8:XYZU:TWQR::/56, but it seems too long.

Could I use 2001:db8:XYZU:TW::/56?  It does not seem correct to me.

Alex

---

From: David Farmer <[email-masked]>
Date: Mon, 30 Oct 2017 08:57:06 -0500

> Could I use 2001:db8:XYZU:TW::/56?  It does not seem correct to me.
2001:db8:XYZU:TW00::/56 would be the normal way to denote such a prefix.

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: Michael Richardson <[email-masked]>
Date: Mon, 30 Oct 2017 10:37:11 -0400

David Farmer <[email-masked]> wrote:
    > On Mon, Oct 30, 2017 at 7:14 AM, Alexandre Petrescu
    > <[email-masked]> wrote:

    > Currently I use 2001:db8:XYZU:TWQR::/56, but it seems too long.

Of course, XYZU and TWQR could be zeros.
so you can write 2001:db8::/56, but that might confuse some people.

    > 2001:db8:XYZU:TW00::/56 would be the normal way to denote such a prefix.

I for one, would like to have four or five more documentation prefixes in
IPv6, with very different initial four digits to make to easier for the cases
where we are talking networks under different administrative control.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 30 Oct 2017 16:25:11 +0100

Le 30/10/2017 à 14:57, David Farmer a écrit :
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Hello,
> 
>     What documentation prefix notation should I use when writing about a
>     /56 prefix in an Internet Draft?
> 

Would 2001:db8:XYZU:TWFF::/56 also be normal?

Alex

> David Farmer Email:[email-masked] <mailto:[email-masked]>

---

From: David Farmer <[email-masked]>
Date: Mon, 30 Oct 2017 13:01:48 -0500

On Mon, Oct 30, 2017 at 10:25 AM, Alexandre Petrescu <
[email-masked]> wrote:

>> [email-masked] <mailto:[email-masked]>>
>> wrote:
>>
>>     Hello,
>>

That is not the normalized representation for a prefix, the normalized
representation is to have zeros for all the bit right of the prefix
boundary.

---

From: Bob Hinden <[email-masked]>
Date: Mon, 30 Oct 2017 11:14:16 -0700

Hi,

> That is not the normalized representation for a prefix, the normalized representation is to have zeros for all the bit right of the prefix boundary.
> 

I agree, that would be good for an example for a /64.  For /56 , as noted above, something like:

2001:db8:XYZU:TW00::/56

(where XYZU TW are actual hex digits)

Bob