Subject: AW: I-D Action: draft-foglar-ipv6-ull-routing-00.txt

From: <[email-masked]>
Date: Sun, 12 Nov 2017 22:03:44 +0100

Dears Mark, Brian, Ole, Mikael and Bob,

Thank you for your valuable comments to our draft. 

First of all, I am sorry that the sentence “One of the goals of IPv6 was to have a sufficiently long address to allow grouping in fields to simplify routing decisions.” did cause so much irritation.
The background was: in the mid-nineties I have read a document called “The case for IPv6”, where one of its goals was that the structure of the IPv6 address should simplify routing. I remember this requirement well, because at that time I was working for a chip manufacturer and we considered making a dedicated IPv6 routing chip. Unfortunately, I could not find this document for the original citation.

Answer: I will remove the first two of the chapter sentences and add this simple one:
"The following proposal uses the 64-bit IPv6 address prefix." 

Next, I thank Ole Troan for citing Y. Rekhter: “Addressing can follow topology or topology can follow addressing; choose one”.
Answer: in this case addressing and topology already match perfectly. In short: where more people are living there are more telephone numbers assigned. In case there are not enough addresses there are spare ones: currently only the digits 0…9 are used; by extending to A…F the address space can be almost doubled. 

Finally, there was a comment the proposal means replacing a great deal of existing software and hardware. 
Answer: hardware effort is low, as not all hierarchies must be populated by forwarding nodes. Also, existing infrastructure such as transmission links can be reused. Both are outlined in an example at the end of the draft. 

A corrected draft is uploaded.

With best regards,
Andreas Foglar
InnoRoute CEO
Phone +49-89-4524199-01
Mail [email-masked] <mailto:[email-masked]> 
www.innoroute.com <http://www.innoroute.com> 
Marsstr. 14a, D80335 Munich, Germany

-----Ursprüngliche Nachricht-----
Von: Mark Smith [mailto:[email-masked]] 
Gesendet: Samstag, 16. September 2017 03:07
An: Brian E Carpenter <[email-masked]>
Cc: Ole Troan <[email-masked]>; [email-masked]; 6man WG <[email-masked]>
Betreff: Re: I-D Action: draft-foglar-ipv6-ull-routing-00.txt

On 16 September 2017 at 09:31, Brian E Carpenter <[email-masked] <mailto:[email-masked]> > wrote:
> On 15/09/2017 20:10, Ole Troan wrote:
>>> Re https://tools.ietf.org/html/draft-foglar-ipv6-ull-routing-00
>>>
>>> "One of the goals of IPv6 was to have a sufficiently long address to 
>>> allow grouping in fields to simplify routing decisions."
>>>
>>> What makes you believe that? I don't recall such a goal in the IPng 
>>> process, and I can't see any trace of it in RFC1752 or RFC1726.
>>
>>
>> “Addressing can follow topology or topology can follow addressing; 
>> choose one” - Y Rekhter
>>
>> Goal or no goal, we know of no other way to make the routing system scale.
>
> Sure. I agree with that and with the RIPE policy that Mikael cited. 
> Believe me, everybody in the IPng discussion was acutely aware of the 
> tension between PA and PI addressing and the benefits of aggregation 
> when possible. But that is very different from the quoted "goal", 
> which simply wasn't there. Allowing topological aggregation was a 
> goal, of course, but that's always been a matter of prefix assignment policy, not of the protocol design.
>
> Please note that I did not say that their idea will not work. It's the 
> "alternative fact" that I'm concerned about.

>From what I've read in Christian Huitema's IPv6 book, at one stage
there was a thought of swapping the source and destination address fields so that the DA field was first, to facilitate this sort of cut-through forwarding. From memory, the explanation was that it was decided against was because fields other than the just the DA address have to be processed during layer 3 forwarding.

Regards,
Mark.

>
>     Brian
>
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked] <mailto:[email-masked]> 
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 13 Nov 2017 13:15:22 +1300

> The background was: in the mid-nineties I have read a document called “The case for IPv6”, where one of its goals was that the structure of the IPv6 address should simplify routing. I remember this…

That was a white paper from the ex-vendor Bay Networks that was
transformed into the controversial draft-ietf-iab-case-for-ipv6, which
was never published as an RFC and which even the IETF data tracker
has forgotten. I have a copy of draft-ietf-iab-case-for-ipv6-06
(December 1999).

It does indeed contain the following claim:
" An independent
  IPv6 architecture presents the opportunity to build a fresh,
  hierarchical network address plan that will facilitate connection to
  one or more ISPs.  This simplifies renumbering, route aggregation
  (summarization), and other goals of a routing hierarchy."

I suspect that is one of the main reasons the document was scrapped,
since that isn't how IP routing works in the real world.

Regards
   Brian