Subject: Publication has been requested for draft-ietf-6man-ndpioiana-02

From: Robert Hinden <[email-masked]>
Date: Wed, 10 Jan 2018 09:12:51 -0800

Robert Hinden has requested publication of draft-ietf-6man-ndpioiana-02 as Proposed Standard on behalf of the 6MAN working group.

Please verify the document's state at https://datatracker.ietf.org/doc/draft-ietf-6man-ndpioiana/

---

From: "t.petch" <[email-masked]>
Date: Fri, 12 Jan 2018 10:22:33 -0000

Bob

I see that the author of this I-D is
O. Troean Email: [email-masked]
whereas what I commonly see on the list is
Ole Troan <[email-masked]>

Comprehensible, but I wonder about the change in spelling of the
surname; is there a diacritic missing here?

Tom Petch

----- Original Message -----
From: "Robert Hinden" <[email-masked]>
Sent: Wednesday, January 10, 2018 5:12 PM

> Robert Hinden has requested publication of
draft-ietf-6man-ndpioiana-02 as Proposed Standard on behalf of the 6MAN
working group.
>
> Please verify the document's state at
https://datatracker.ietf.org/doc/draft-ietf-6man-ndpioiana/
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 12 Jan 2018 11:24:48 +0000

> surname; is there a diacritic missing here?

The RFC Editor now supports UTF8, so unless there's another round of
chest beating about BOMs, there shouldn't be a problem with using "Trøan".

Nick

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 12 Jan 2018 12:39:27 +0100

> surname; is there a diacritic missing here?

I stumbled across same problem with a name containing an "ä" in one of 
my drafts.

The problem was and still is in the github.

xml2rfc, emacs, windows file system, email - all support "ä" well, but 
github breaks it.

People worked ok on an API to make submission of a draft from github 
directly into IETF draft submission system, but github still has 
problems with "ä".  I would have preferred that work energy to be put 
into solving "ä" first.

So I use "ae" instead of "ä" in Internet Drafts.

Alex

---

From: Bob Hinden <[email-masked]>
Date: Fri, 12 Jan 2018 07:44:57 -0800

Tom,

> On Jan 12, 2018, at 2:22 AM, t.petch <[email-masked]> wrote:
> 
> Bob
> 

I noticed that as well.  But I figured the author wanted it that way.

He should respond.

Bob

---

From: Ole Troan <[email-masked]>
Date: Fri, 12 Jan 2018 22:27:23 +0100

> I noticed that as well.  But I figured the author wanted it that way.

There is indeed a diacritic missing.

The XML is <?xml version="1.0" encoding="UTF-8"?>
And: <author fullname="Ole Trøan" initials="O" surname="Trøan">

Previous revision I thought the PDF was correct while in the txt 'ø' was mapped to 'oe'.

Either I'm stumbling or the tools around UTF-8 support are a little iffy.

Cheers,
Ole

---

From: Bob Hinden <[email-masked]>
Date: Fri, 12 Jan 2018 13:58:21 -0800

> On Jan 12, 2018, at 1:27 PM, Ole Troan <[email-masked]> wrote:
> 
>>> 

Suggest filing a bug report on this.

Bob