Subject: US patent on an IPv6 geolocation header extension

From: "John R Levine" <[email-masked]>
Date: 15 Jan 2018 13:44:24 -0500

I know there hasn't been much interest in a geolocation header extension, 
but should the topic come up again, see US patent 9,762,683 issued in 
September to A10 which broadly covers adding geolocation data into an IPv6 
header extension.

Copy of patent here:

http://patft.uspto.gov/netacgi/nph-Parser?Sect2=PTO1&Sect2=HITOFF&p=1&u=/netahtml/PTO/search-bool.html&r=1&f=G&l=50&d=PALL&RefSrch=yes&Query=PN/9762683

Legal blog post about policy problems (social policy, not technical 
stuff):

http://blog.ericgoldman.org/archives/2018/01/a-patent-for-geotagging-ip-packets-raises-important-internet-law-questions-guest-blog-post.htm

I have no idea whether this patent would survive if challenged, but as you 
know, even if you win a challenge it's a very expensive exercise.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: "Templin, Fred L" <[email-masked]>
Date: Mon, 15 Jan 2018 19:03:50 +0000

Interesting. We posted a draft on adding geolocation information in Destination
Options in the IPv6 packet header (called: "IPv6GEO") on July 2, 2014 and
announced it on the 6man list on September 15, 2014:

https://datatracker.ietf.org/doc/draft-skeen-6man-ipv6geo/00/
https://www.ietf.org/mail-archive/web/ipv6/current/msg21174.html

There was considerable discussion on the 6man mailing list, and we briefed
the document during the 6man session at IETF91 in November 2014.

I see that this patent application you cited was filed on September 30, 2014.
What do we do now?

Thanks - Fred

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of John R Levine
> Sent: Monday, January 15, 2018 10:44 AM
> To: [email-masked]
> Subject: US patent on an IPv6 geolocation header extension
> 
> http://patft.uspto.gov/netacgi/nph-Parser?Sect2=PTO1&Sect2=HITOFF&p=1&u=/netahtml/PTO/search-
> bool.html&r=1&f=G&l=50&d=PALL&RefSrch=yes&Query=PN/9762683
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 16 Jan 2018 10:32:23 +0100

> I see that this patent application you cited was filed on September 30, 2014.

I am pleasantly surprised of these aspects.

Maybe a member A10 would submit a disclosure, probably at 
https://datatracker.ietf.org/ipr/

I am very curious about the use-case in which they plan to prototype this.

Alex

---

From: Mark Smith <[email-masked]>
Date: Thu, 18 Jan 2018 21:47:23 +1100

On 16 January 2018 at 05:44, John R Levine <[email-masked]> wrote:
> Legal blog post about policy problems (social policy, not technical stuff):
>

Here's some prior art from 2013.

"Enhancing Location Based IP Services"
https://tools.ietf.org/html/draft-add-location-to-ipv6-header-01

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 18 Jan 2018 19:04:21 +0000

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Mark Smith

> https://tools.ietf.org/html/draft-add-location-to-ipv6-header-01

I thought that rang a bell (reminded me of something). Wasn't there some who disliked the idea intensely, just because it disclosed geo location without the use being aware as the user might be, if that feature was in an app? I seem to remember some acrimony involved.

Bert

---

From: Tom Herbert <[email-masked]>
Date: Thu, 18 Jan 2018 11:25:19 -0800

> I thought that rang a bell (reminded me of something). Wasn't there some who disliked the idea intensely, just because it disclosed geo location without the use being aware as the user might be, if…

Right, my first question would be "How is users' privacy protected?".
Geo-location of individuals is very sensitive data. In fact, one of
the goals of ILA is to eliminate the possibility of inferring any
accurate location of a node from IP addresses.

Tom

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 18 Jan 2018 19:33:49 +0000

> Right, my first question would be "How is users' privacy protected?".

One solution is to conceal the geo information via VPN encryption for
transmission over public networks like the Internet. In private networks
such as a corporate enterprise, the geo information could go in the clear.

Fred

> From: ipv6 [mailto:[email-masked]] On Behalf Of Tom Herbert
> Sent: Thursday, January 18, 2018 11:25 AM
> To: Manfredi, Albert E <[email-masked]>
> Cc: 6man WG <[email-masked]>
> Subject: Re: US patent on an IPv6 geolocation header extension
> 
> > I thought that rang a bell (reminded me of something). Wasn't there some who disliked the idea intensely, just because it disclosed
> geo location without the use being aware as the user might be, if that feature was in an app? I seem to remember some acrimony
> involved.
>

---

From: Tom Herbert <[email-masked]>
Date: Thu, 18 Jan 2018 11:47:19 -0800

> such as a corporate enterprise, the geo information could go in the clear.
Or alternatively encrypt or at least obfuscate the location
information so only trusted parties can read it. That would be similar
to the intent of tickets in our FAST proposal
(https://tools.ietf.org/html/draft-herbert-fast-00) where data in
extension headers is only interpretable by the origin network. Now
that I think about it, geo-location could be probably be encoded in a
FAST ticket.

Tom

---

From: joel jaeggli <[email-masked]>
Date: Thu, 18 Jan 2018 11:52:00 -0800

> I thought that rang a bell (reminded me of something). Wasn't there some who disliked the idea intensely, just because it disclosed geo location without the use being aware as the user might be, if…
If you add this sort of thing at an intermediate hop, you have all of
the attendant problems of unstated or lack of consent that go along with
adding host identifiers of any kind (we largely have IETF consensus not
to work on host-identiers). If you add it only on the endpoint, consent
can be achieved in various ways. Protecting that information from
mid-point observers is an important consideration that would tend to
preclude embedding it for use by the network or transport layers.

Applications have no problems reporting to each other where they are
without recourse to lower-layer signaling.

---

From: Mark Smith <[email-masked]>
Date: Fri, 19 Jan 2018 07:17:29 +1100

---------- Forwarded message ----------
From: "Mark Smith" <[email-masked]>
Date: 19 Jan. 2018 07:14
Subject: Re: US patent on an IPv6 geolocation header extension
To: "joel jaeggli" <[email-masked]>
Cc:

On 19 Jan. 2018 06:52, "joel jaeggli" <[email-masked]> wrote:

On 1/18/18 11:04 AM, Manfredi, Albert E wrote:
> I thought that rang a bell (reminded me of something). Wasn't there some
who disliked the idea intensely, just because it disclosed geo location
without the use being aware as the user might be, if that feature was in an
app? I seem to remember some acrimony involved.
If you add this sort of thing at an intermediate hop, you have all of
the attendant problems of unstated or lack of consent that go along with
adding host identifiers of any kind (we largely have IETF consensus not
to work on host-identiers). If you add it only on the endpoint, consent
can be achieved in various ways. Protecting that information from
mid-point observers is an important consideration that would tend to
preclude embedding it for use by the network or transport layers.

+1

I think it does raise the question of whether i this information is better
in an application rather than the network layer.

If conveyed within non-specific applications is not reliable or universal
enough, than a specific geolocation conveying application would be the
alternative that doesn't require a new EH. Whether to run the app or not is
expressing the geolocation privacy choice.

Devices that are required to run it, e.g. corporate devices, will have that
enforced by the device administrators preventing device end-users from
disabling it.

Regards,
Mark.

---

From: "Templin, Fred L" <[email-masked]>
Date: Thu, 18 Jan 2018 20:21:08 +0000

> I think it does raise the question of whether i this information is better in an application rather than the network layer.

We have already been down this path – see the list archives.

Fred

From: ipv6 [mailto:[email-masked]] On Behalf Of Mark Smith
Sent: Thursday, January 18, 2018 12:17 PM
To: 6man WG <[email-masked]>
Subject: Fwd: Re: US patent on an IPv6 geolocation header extension

---------- Forwarded message ----------
From: "Mark Smith" <[email-masked]<mailto:[email-masked]>>
Date: 19 Jan. 2018 07:14
Subject: Re: US patent on an IPv6 geolocation header extension
To: "joel jaeggli" <[email-masked]<mailto:[email-masked]>>
Cc:

On 19 Jan. 2018 06:52, "joel jaeggli" <[email-masked]<mailto:[email-masked]>> wrote:

On 1/18/18 11:04 AM, Manfredi, Albert E wrote:
> From: ipv6 [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Mark Smith
>

+1

I think it does raise the question of whether i this information is better in an application rather than the network layer.

If conveyed within non-specific applications is not reliable or universal enough, than a specific geolocation conveying application would be the alternative that doesn't require a new EH. Whether to run the app or not is expressing the geolocation privacy choice.

Devices that are required to run it, e.g. corporate devices, will have that enforced by the device administrators preventing device end-users from disabling it.

Regards,
Mark.

> [email-masked]<mailto:[email-masked]>