Subject: I-D Action: draft-ietf-6man-segment-routing-header-11.txt

From: [email-masked]
Date: Wed, 28 Mar 2018 22:50:11 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IPv6 Maintenance WG of the IETF.

        Title           : IPv6 Segment Routing Header (SRH)
        Authors         : Stefano Previdi
                          Clarence Filsfils
                          John Leddy
                          Satoru Matsushima
                          Daniel Voyer
	Filename        : draft-ietf-6man-segment-routing-header-11.txt
	Pages           : 34
	Date            : 2018-03-28

Abstract:
   Segment Routing (SR) allows a node to steer a packet through a
   controlled set of instructions, called segments, by prepending an SR
   header to the packet.  A segment can represent any instruction,
   topological or service-based.  SR allows to enforce a flow through
   any path (topological, or application/service based) while
   maintaining per-flow state only at the ingress node to the SR domain.

   Segment Routing can be applied to the IPv6 data plane with the
   addition of a new type of Routing Extension Header.  This draft
   describes the Segment Routing Extension Header Type and how it is
   used by SR capable nodes.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-6man-segment-routing-header/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-6man-segment-routing-header-11
https://datatracker.ietf.org/doc/html/draft-ietf-6man-segment-routing-header-11

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-6man-segment-routing-header-11

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Darren Dukes (ddukes)" <[email-masked]>
Date: Thu, 29 Mar 2018 12:50:44 +0000

Hello everyone.  This version contains the following updates as requested in London:
1 - adds an implementation section including Linux, Cisco, Barefoot, FD.io/VPP<http://FD.io/VPP>, Juniper.
  Linux code details are available here http://www.segment-routing.org/index.php/Implementation/Installation
  FD.io<http://FD.io> code details are available here https://docs.fd.io/vpp/17.07/srv6_doc.html
2 - made RFC7855 and RFC8300 normative references.
3 - Removed the normative text referring to draft-filsfils-spring-srv6-network-programming. Now it is referenced as informational, not required to implement this specification.

Darren

On Mar 29, 2018, at 1:50 AM, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------