Subject: Re: New version of <draft-ietf-6man-ipv6only-flag-01.txt> published

From: Bob Hinden <[email-masked]>
Date: Sun, 1 Jul 2018 08:41:23 -0700

HTML and diff working now.  Diff file is:

https://tools.ietf.org/rfcdiff?url2=draft-ietf-6man-ipv6only-flag-01.txt

Bob

> On Jun 30, 2018, at 8:36 PM, Bob Hinden <[email-masked]> wrote:
> 
> Hi,
> 
> We published a new version of draft-ietf-6man-ipv6only-flag-01.txt.  The changes, based on recent list discussion, are:
> 
>      *  Added text to section 4 that defines what IPv6-Only includes to
>         clarify that only other version of the Internet protocol are in
>         scope.
>      *  Added clarification if the lifetime of all routers expire.
>      *  Editorial changes.
> 
> Please review, links below.
> 
> Bob & Brian
> 
> p.s. The diff and html version don’t seem to be available at the moment.  I have notified the secretariat.  Hopefully it will be fixed soon.
> 
> 
> ———--------------
> 
> Begin forwarded message:
> 
> From: [email-masked]
> Subject: I-D Action: draft-ietf-6man-ipv6only-flag-01.txt
> Date: June 30, 2018 at 8:20:31 PM PDT
> To: <[email-masked]>
> Cc: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the IPv6 Maintenance WG of the IETF.
> 
>       Title           : IPv6 Router Advertisement IPv6-Only Flag
>       Authors         : Robert M. Hinden
>                         Brian Carpenter
> 	Filename        : draft-ietf-6man-ipv6only-flag-01.txt
> 	Pages           : 11
> 	Date            : 2018-06-30
> 
> Abstract:
>  This document specifies a Router Advertisement Flag to indicate to
>  hosts that the administrator has configured the router to advertise
>  that the link is IPv6-Only.  This document updates RFC5175.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-6man-ipv6only-flag/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-ietf-6man-ipv6only-flag-01
> https://datatracker.ietf.org/doc/html/draft-ietf-6man-ipv6only-flag-01
> 
> A diff from the previous version is available at:
> https://www.ietf.org/rfcdiff?url2=draft-ietf-6man-ipv6only-flag-01
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
>

---

From: David Farmer <[email-masked]>
Date: Sun, 1 Jul 2018 23:19:10 -0500

I agree that this flag should only be set if the router is configured to do
so by an administrator. However, regardless of the configuration, the flag
MUST NOT be set if the router has an IPv4 configuration for the interface
in question. Put another way; it should not be possible to configure the
router to lie.

Maybe change the second paragraph of section 6 to something like the
following;

The intent is that the administrator of the router configures the router to
set the IPv6-Only flag if she/he wants to tell the hosts on the link that
the link is IPv6-Only. This is a configuration flag; it is not something
that the router decides on its own. However, regardless of its
configuration, the router MUST NOT set the flag if there is an IPv4
configuration on, or one is added to, the interface in question. If
configured to set the flag and there is an IPv4 configuration on the
interface in question, the router MAY also locally log a configuration
error.

Thanks

On Sat, Jun 30, 2018 at 10:36 PM, Bob Hinden <[email-masked]> wrote:

> Hi,
>
> We published a new version of draft-ietf-6man-ipv6only-flag-01.txt.  The
> changes, based on recent list discussion, are:
>
> p.s. The diff and html version don’t seem to be available at the moment.
> I have notified the secretariat.  Hopefully it will be fixed soon.
>
>
> ———--------------
>
> Begin forwarded message:
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>
>

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: Bob Hinden <[email-masked]>
Date: Mon, 2 Jul 2018 12:36:40 -0700

David,

> On Jul 1, 2018, at 9:19 PM, David Farmer <[email-masked]> wrote:
> 
> I agree that this flag should only be set if the router is configured to do so by an administrator. However, regardless of the configuration, the flag MUST NOT be set if the router has an IPv4 configuration for the interface in question. Put another way; it should not be possible to configure the router to lie.
> 
> Maybe change the second paragraph of section 6 to something like the following;
> 
> The intent is that the administrator of the router configures the router to set the IPv6-Only flag if she/he wants to tell the hosts on the link that the link is IPv6-Only. This is a configuration flag; it is not something that the router decides on its own. However, regardless of its configuration, the router MUST NOT set the flag if there is an IPv4 configuration on, or one is added to, the interface in question. If configured to set the flag and there is an IPv4 configuration on the interface in question, the router MAY also locally log a configuration error.

I worry that covering possible configuration errors will be problematic.   For example, what if the router administrator just turned off IPv4, but left the rest of the configuration of IPv4 on the router?   A lot of this is going to be implementation dependent and hard to specify in a document like this.

I think the focus should be on what the desired behavior is on the wire.

Bob

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 3 Jul 2018 10:27:21 +1200

> I worry that covering possible configuration errors will be problematic.   For example, what if the router administrator just turned off IPv4, but left the rest of the configuration of IPv4 on the…

I tend to agree with Bob. Also, the best approach may depend on
the design of the router and its management interface.  I could
imagine a SOHO router in which it might be better to fully
automate things. So probably we should put all this at a SHOULD
level.

   Brian