Subject: Re: Fwd: New Version Notification for draft-farmer-6man-exceptions-64-00.txt

From: David Farmer <[email-masked]>
Date: Fri, 3 Aug 2018 04:02:54 -0500

Thanks for the comments, see inline;

On Tue, Jul 24, 2018 at 7:49 PM, Alexandre Petrescu <
[email-masked]> wrote:

> I have read many parts of the draft.
>
> I like it gives freedom to IPv6-over-foo to use 65 if so it wants.
>

Please read it carefully, you can't use an IID length of 65 just because
you want too.  An IPv6-over-foo document needs to provide real
justification, for something other than 64. Further, you can't just simply
use a 65 in an 802.1 framing with 0x86dd as the Ethertype as this will
cause confusion on the ID length to use, Now maybe you could assign a
different Ethertype, or cook something else up. But you can't create
confusion about the valid IID length for link-types already defined, that
breaks stuff.

I find it shares the idea of a dichotomy 'subnet assignment prefix -
> on-link prefix', with a draft from author jinmei, who calls it 'SLAAC
> subnet prefix - on-link prefix'.  This means there could be convergence on
> that idea.  I may not agree with the idea, but others could.
>
> I do not agree with the section Operational Guidance.
>
> This sentence is maybe too short (it does not parse to me):
>
>>    Further, unlike IPv4 where there is a single subnet mask parameter
>>    with the two aspects of a subnet, address assignment and on-link
>>    determination, tightly coupled together.
>>
>
> Other than non parsing, I can say that in IPv4 too there is a dichotomy
> between various prefix lenghts: I could have two distinct prefix lengths on
> the same subnet: one for DHCP and one for manually assigned addresses, at
> the same time.
>

If you mean overlapping subnets that's a misconfiguration, if you mean two
separate non-overlapping subnets, sure but they are two different subnets.

If a subnet assignment prefix is assigned it must be 128 - N, where N = 64,
or the IID length defined by a link-type if not 64, and the on-link prefix
must be 128 - N or shorter.

If a subnet assignment prefix is not assigned the on-link prefix can be any
length, but 128 - N is recommended.

Because of this possibility, I think the comparison to IPv4 is not relevant.

Please read RFC5942, what I'm saying is simply paraphrased from it.

>
> Alex
>
> Le 24/07/2018 à 07:28, David Farmer a écrit :
>
>> I didn't get this in before the meeting cut-off at the beginning of the
>> month, but that gave me a few extra weeks to work on it though.
>>
>> A quick summary; IPv6 subnets are defined by two separate parameters,
>> acting independently, the subnet assignment prefix (PIO with A flag set)
>> and the on-link prefix (PIO with L flag set). And, when configured using
>> subnet assignment prefixes, IPv6 subnets are required to be 64-bits in
>> length.  Otherwise, when configured solely using on-link prefixes, IPv6
>> subnets are only recommended to be 64-bits in length.
>>
>> I think this walks the line between the factions, and it is consistent
>> with on how both SLAAC and IPv6 ND are defined and implemented.
>>
>> Thanks
>>
>> ---------- Forwarded message ----------
>> From: ** <[email-masked] <mailto:[email-masked]>>
>> Date: Mon, Jul 23, 2018 at 10:59 PM
>> Subject: New Version Notification for draft-farmer-6man-exceptions-6
>> 4-00.txt
>> To: David Farmer <[email-masked] <mailto:[email-masked]>>
>>
>>
>>
>> A new version of I-D, draft-farmer-6man-exceptions-64-00.txt
>> has been successfully submitted by David Farmer and posted to the
>> IETF repository.
>>
>> Name:           draft-farmer-6man-exceptions-64
>> Revision:       00
>> Title:          Exceptions to the 64-bit Boundary in IPv6 Addressing
>> Document date:  2018-07-23
>> Group:          Individual Submission
>> Pages:          13
>> URL: https://www.ietf.org/internet-drafts/draft-farmer-6man-excep
>> tions-64-00.txt <https://www.ietf.org/internet
>> -drafts/draft-farmer-6man-exceptions-64-00.txt>
>> Status: https://datatracker.ietf.org/doc/draft-farmer-6man-exceptions-64/
>> <https://datatracker.ietf.org/doc/draft-farmer-6man-exceptions-64/>
>> Htmlized: https://tools.ietf.org/html/draft-farmer-6man-exceptions-64-00
>> <https://tools.ietf.org/html/draft-farmer-6man-exceptions-64-00>
>> Htmlized: https://datatracker.ietf.org/doc/html/draft-farmer-6man-exce
>> ptions-64 <https://datatracker.ietf.org/doc/html/draft-farmer-6man-exc
>> eptions-64>
>>
>>
>> Abstract:
>>     This document clarifies exceptions to the 64-bit boundary in IPv6
>>     addressing.  The exceptions include, unicast IPv6 addresses with the
>>     first three bits 000, manually configured addresses, DHCPv6 assigned
>>     addresses, IPv6 on-link determination, and the possibility of an
>>     exception specified in separate IPv6 link-type specific documents.
>>     Further, operational guidance is provided and Appendix A. discusses
>>     the valid options for configuring IPv6 subnets
>>
>>
>>
>>
>> Please note that it may take a couple of minutes from the time of
>> submission
>> until the htmlized version and diff are available at tools.ietf.org <
>> http://tools.ietf.org>.
>>
>> The IETF Secretariat
>>
>>
>>
>>
>> --
>> ===============================================
>> David Farmer Email:[email-masked] <mailto:[email-masked]>
>> Networking & Telecommunication Services
>> Office of Information Technology
>> University of Minnesota
>> 2218 University Ave SE        Phone: 612-626-0815
>> Minneapolis, MN 55414-3029   Cell: 612-812-9952
>> ===============================================
>>
>>
>> --------------------------------------------------------------------
>> IETF IPv6 working group mailing list
>> [email-masked]
>> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
>> --------------------------------------------------------------------
>>
>>

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: David Farmer <[email-masked]>
Date: Fri, 3 Aug 2018 08:17:55 -0500

Thinking about this some more;

> confusion about the valid IID length for link-types already defined, that

We could also change how SLAAC works, but that is beyond the scope of an
execption put into a IPv6-over-foo document. that would be defining a
SLAACv2 or something.

> If a subnet assignment prefix is assigned it must be 128 - N, where N =
> 64, or the IID length defined by a link-type if not 64, and the on-link
> prefix must be 128 - N or shorter.
>
> If a subnet assignment prefix is not assigned the on-link prefix can be
> any length, but 128 - N is recommended.
>
>>> Status: https://datatracker.ietf.org/doc/draft-farmer-6man-exception
>>> s-64/ <https://datatracker.ietf.org/doc/draft-farmer-6man-exceptions-64/
>>> >