Subject: IPmix I-D version 01.

From: Khaled Omar <[email-masked]>
Date: Tue, 13 Nov 2018 14:40:24 +0000

Hi all,

Your feedback will be appreciated for the submitted version of the IPmix I-D.

https://datatracker.ietf.org/doc/draft-omar-ipmix/

Regards,

Khaled Omar

---

From: "Bless, Roland (TM)" <[email-masked]>
Date: Wed, 14 Nov 2018 09:37:33 +0100

Hi Omar,

> Your feedback will be appreciated for the submitted version of the IPmix

I couldn't see any substantial changes, so there are
still the same issues with this proposal:
- The draft states: "It solves the issue of allowing IPv6 only hosts to
  communicate to IPv4 only hosts and vice versa in a simple and very
  efficient way."
  => This is simply wrong: "IPv4 only" and "IPv6 only" hosts would not
  be able to speak IPmix by definition of "only". This is a fundamental
  contradiction in your proposal.
  If an IPv4 host would be upgraded with IPmix, there is no reason to
  not let it upgrade to IPv6 and be it a dual stack host. Problem
  solved.
- Introducing something like IPmix would be more difficult than simply
  deploying IPv6.
- IPv4 only hosts would never be able to reach the whole IPv6 address
  space
- For IPv6 only hosts we have NAT64/DNS64 to let them talk to the IPv4
  world

All these issues have been mentioned before. If you don't consider
them, don't expect any more comments.

BTW: There are still remnants of IPv.. in the document (sections 4.2 and
7). Please remove them in any future versions as it will confuse people
outside the IETF.

Regards
 Roland

---

From: Khaled Omar <[email-masked]>
Date: Wed, 14 Nov 2018 11:04:14 +0000

Hi Roland,

Let's take it step by step, first I'm not asking the IETF to publish the document as an RFC as version 01, there are more to add.

> This is simply wrong: "IPv4 only" and "IPv6 only" hosts would not be able to speak IPmix by definition of "only". This is a fundamental contradiction in your proposal. 

"Only" means the assigned IP address for the host is either IPv4 only or IPv6 only.

> If an IPv4 host would be upgraded with IPmix, there is no reason to not let it upgrade to IPv6 and be it a dual stack host. Problem solved.

IPmix is not an address as IPv6 to be assigned, the host will not be upgraded but it will be updated.
IPv6 requires efforts from the client side that's why IPv6 took more than 23 years and until now no full action are taken, IPmix does not, clients are not required to do anything, if you are using IPv4 only, keep using it, but the "system" should be updated to support IPmix, which is easier than deploying IPv6.

> Introducing something like IPmix would be more difficult than simply deploying IPv6.

For now, these are the requirements to call a host an IPmix host:
For IPv4-only hosts --> The only requirement is that the IPv4 packet be replaced by the IPv6 packet and the IPv4 address be replaced by the IPv4-embedded IPv6 address and the host can understand an IPv6 address and insert it in the destination IP address (system update).
For IPv6-only hosts --> The only requirement is that the host can understand an IPv4 address and replace it by an IPv4-embedded IPv6 address and the host can handle the packet normally (system update).

All these two requirements requires no efforts from the client side, they don't have to do anything more than accepting the updates.

> IPv4 only hosts would never be able to reach the whole IPv6 address space.

Who said never, it is achieved in this I-D, it is true without modification to the IPv4 host.
 
> For IPv6 only hosts we have NAT64/DNS64 to let them talk to the IPv4 world.

Does this support communication using IP address rather than hostnames?
Does this requires a "public IPv4 address" on the external interface of the NAT64 device?

> BTW: There are still remnants of IPv.. in the document (sections 4.2 and 7). Please remove them in any future versions as it will confuse people outside the IETF.

Modified.

Regards,

Khaled Omar

-----Original Message-----
From: Bless, Roland (TM) [mailto:[email-masked]] 
Sent: Wednesday, November 14, 2018 10:38 AM
To: Khaled Omar <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: IPmix I-D version 01.

Hi Omar,

> Your feedback will be appreciated for the submitted version of the 

I couldn't see any substantial changes, so there are still the same issues with this proposal:

All these issues have been mentioned before. If you don't consider them, don't expect any more comments.

BTW: There are still remnants of IPv.. in the document (sections 4.2 and 7). Please remove them in any future versions as it will confuse people outside the IETF.

Regards
 Roland

---

From: Sander Steffann <[email-masked]>
Date: Wed, 14 Nov 2018 13:23:26 +0100

Hi,

> "Only" means the assigned IP address for the host is either IPv4 only or IPv6 only.

"Only" doesn't just refer to the addresses, it refers to the entire protocol stack.

> IPmix is not an address as IPv6 to be assigned, the host will not be upgraded but it will be updated.

An "update" that is more complex than an "upgrade" to IPv6. It requires changes to routers to handle the packets, it requires changes to hosts to handle the packets, it requires changes to routing etc etc etc.

This draft doesn't help in any way, and therefore should be dropped.

Cheers,
Sander

PS: you have tried this before, and since you don't seem to get the message let me be blunt: this whole idea is BS, you don't seem to have a clue about protocol design, implementation, interactions and deployment, so please withdraw this and stop wasting our time.

PPS: sorry to the rest of the list for the bluntness

---

From: Gert Doering <[email-masked]>
Date: Wed, 14 Nov 2018 13:38:19 +0100

Hi,

> This draft doesn't help in any way, and therefore should be dropped.

This.

> PPS: sorry to the rest of the list for the bluntness

Dutch-style clear and unambiguous wording. :-)

Gert Doering
        -- NetMaster
-- 
have you enabled IPv6 on something today...?

SpaceNet AG                      Vorstand: Sebastian v. Bomhard, Michael Emmer
Joseph-Dollinger-Bogen 14        Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen                 HRB: 136055 (AG Muenchen)
Tel: +49 (0)89/32356-444         USt-IdNr.: DE813185279

---

From: Khaled Omar <[email-masked]>
Date: Wed, 14 Nov 2018 13:07:52 +0000

Hi,

> An "update" that is more complex than an "upgrade" to IPv6. It requires changes to routers to handle the packets, it requires changes to hosts to handle the packets, it requires changes to routing…

Updating --> does not depends on clients (can we try to decrease the changes?).
Upgrading --> depends on clients (will we keep waiting them until the end of days!).

P.S. clients have the right not to upgrade, there are no benefits, it is not their problem that people who designed IPv4 didn't make the address large enough to cover the huge expansion, so they shouldn't solve a problem that is not their own, this is how they think.

Khaled

-----Original Message-----
From: Sander Steffann [mailto:[email-masked]] 
Sent: Wednesday, November 14, 2018 2:23 PM
To: Khaled Omar <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [v6ops] IPmix I-D version 01.

Hi,

Cheers,
Sander

---

From: Sander Steffann <[email-masked]>
Date: Wed, 14 Nov 2018 14:10:48 +0100

> Upgrading --> depends on clients (will we keep waiting them until the end of days!).

Clients will need to work with the new packet header, therefore they need changes, therefore your idea depends on changes in clients.

Please drop this and stop wasting our time. This will be my last reply to you.
Sander

---

From: Khaled Omar <[email-masked]>
Date: Wed, 14 Nov 2018 13:41:12 +0000

> Clients will need to work with the new packet header, therefore they need changes, therefore your idea depends on changes in clients.

For now, at the host, the system will change the IPv4 address to an IPv4-embedded IPv6 address, how this depends on clients!

Khaled

---

From: Gert Doering <[email-masked]>
Date: Wed, 14 Nov 2018 17:39:00 +0100

Hi,

> For now, at the host, the system will change the IPv4 address to an IPv4-embedded IPv6 address, how this depends on clients!

And how will the software on the host do this?  Without changes?

Gert Doering
        -- NetMaster

---

From: Khaled Omar <[email-masked]>
Date: Wed, 14 Nov 2018 17:58:12 +0000

Hi,

> And how will the software on the host do this?  Without changes?

I mean who will do the changes, clients will do nothing, the IPv4 packet will be replaced by the IPv6 packet, the IPv4 address will be configured the same but it will be translated into an IPv4-embedded IPv6 address in the IPv6 packet, this is what I call IPmix host.

Khaled

-----Original Message-----
From: Gert Doering [mailto:[email-masked]] 
Sent: Wednesday, November 14, 2018 6:39 PM
To: Khaled Omar <[email-masked]>
Cc: Sander Steffann <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [v6ops] IPmix I-D version 01.

Hi,

Gert Doering
        -- NetMaster

---

From: Bob Hinden <[email-masked]>
Date: Wed, 14 Nov 2018 10:52:33 -0800

Khaled,

The 6man working group chairs think a discussion of IPmix is out of scope for the [email-masked] list (and suspect the same for v6ops list as well).   We request that the you not send email on this topic to these lists and anyone responding remove these lists from the cc:.

Thanks,
Bob & Ole

> On Nov 13, 2018, at 6:40 AM, Khaled Omar <[email-masked]> wrote:
> 
> Hi all,
> 
> 
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Khaled Omar <[email-masked]>
Date: Wed, 14 Nov 2018 19:31:30 +0000

Does this means that I should not expect more ideas, comments or discussions from these WGs regarding the next version of IPmix?!

Khaled

-----Original Message-----
From: Bob Hinden [mailto:[email-masked]] 
Sent: Wednesday, November 14, 2018 8:53 PM
To: Khaled Omar <[email-masked]>
Cc: Bob Hinden <[email-masked]>; [email-masked]; IPv6 List <[email-masked]>; [email-masked]; Suresh Krishnan <[email-masked]>
Subject: Re: IPmix I-D version 01.

Khaled,

Thanks,
Bob & Ole

---

From: Bob Hinden <[email-masked]>
Date: Wed, 14 Nov 2018 12:09:51 -0800

Khaled,

> On Nov 14, 2018, at 11:31 AM, Khaled Omar <[email-masked]> wrote:
> 

If there is more discussion, it should be somewhere else.  Not on the IPv6 list.

Bob

---

From: Khaled Omar <[email-masked]>
Date: Wed, 14 Nov 2018 20:17:18 +0000

I hope there will be a discussion somewhere else.

Khaled

Best Regards
Khaled Omar

________________________________
From: Bob Hinden <[email-masked]>
Sent: Wednesday, November 14, 2018 10:09:51 PM
To: Khaled Omar
Cc: Bob Hinden; [email-masked]; IPv6 List; [email-masked]; Suresh Krishnan
Subject: Re: IPmix I-D version 01.

Khaled,

Bob