Subject: Apology

From: Lee Howard <[email-masked]>
Date: Thu, 21 Feb 2019 15:36:12 -0500

The other day, I had some harsh words for Ole. I apologize.

I have strong opinions on parts of this thread, and have not felt 
"heard," which is no excuse for my message to the list. I agree with Bob 
that I was unreasonable in my interpretation of Ole's position, and my 
email was unfair.

I respect Ole, and appreciate the depth of his knowledge and the 
significant contribution he makes and has made to this working group. I 
also like him, and have enjoyed discussion and collaboration with him. 
In this case, I let my frustration that we seemed not to be developing 
consensus color my response to him.

I'm sorry for degrading the conversation with that message. I will stay 
focused on the technical topics, and try to find ways to understand and 
be understood. If I have concerns about leadership in any part of the 
IETF in the future, I will raise those concerns privately. I'm sorry, 
Ole, for being a jerk to you.

Sincerely,

Lee Howard

---

From: Ole Troan <[email-masked]>
Date: Mon, 25 Feb 2019 09:37:35 +0100

Dear Lee,

No apology needed. Thank you, and accepted (of course).

You do bring up some valid points though and conflict triggers soul searching.
For myself, I have taken it for granted that it is obvious when I express my views as a WG participant, and when I do it as a chair.
To clarify, the protocol I follow: By default I act as an individual working group participants. Communication as a chair should be signed with that, and typically comes from both Bob and me. This is similar to the case in live meetings where we join the floor microphone queue, instead of talking from the podium.

See also https://tools.ietf.org/html/rfc2418#section-6.1

I think it would be very unfortunate if the chairs could not participate in the work of the working group, but were relegated to a pure management/administrative role.

There is of course an area of conflict where a chair’s personal view, conflicts with the consensus position of the working group. I hope you still trust that between the chairs and our AD, that we manage to do the right thing.

6man is a long lived working group, tasked with maintaining the IPv6 specifications. That’s different from the typical IETF working group. Perhaps it is time to have a wider debate about how the working group should function and what it’s role should be.

Best regards,
Ole

> On 21 Feb 2019, at 21:36, Lee Howard <[email-masked]> wrote:
> 
> I have strong opinions on parts of this thread, and have not felt "heard," which is no excuse for my message to the list. I agree with Bob that I was unreasonable in my interpretation of Ole's position, and my email was unfair.
> 
> I respect Ole, and appreciate the depth of his knowledge and the significant contribution he makes and has made to this working group. I also like him, and have enjoyed discussion and collaboration with him. In this case, I let my frustration that we seemed not to be developing consensus color my response to him.
> 
> I'm sorry for degrading the conversation with that message. I will stay focused on the technical topics, and try to find ways to understand and be understood. If I have concerns about leadership in any part of the IETF in the future, I will raise those concerns privately. I'm sorry, Ole, for being a jerk to you.
> 
> Sincerely,
> 
> Lee Howard
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Jan Zorz - Go6 <[email-masked]>
Date: Tue, 26 Feb 2019 16:35:46 +0100

Dear @all,

On 25/02/2019 09:37, Ole Troan wrote:> 6man is a long lived working 
group, tasked with maintaining the IPv6
> specifications. That’s different from the typical IETF working group.
> Perhaps it is time to have a wider debate about how the working group
> should function and what it’s role should be.

This is an important discussion to have. Can we define first what 
exactly "maintaining the IPv6 specifications" mean?

Is this about being a guardian making sure that IPv6 protocol doesn't 
change? IPv6 was defined many many years ago and meanwhile the reality 
of networking architectures and deployments changed a lot...

In my mind, protocol development should go in circles...

Protocol development and standardization (IETF) -> Vendors 
implementation in HW/SW -> Operators deployment in networks -> Feedback 
from real world back to IETF from operators (through vendors or direct) 
-> IETF adjusts protocol to real world requirements -> Vendors -> etc...

Where did things go wrong? Why? Did they go wrong in first place? ;)

Cheers, Jan

---

From: Fernando Gont <[email-masked]>
Date: Tue, 26 Feb 2019 13:00:45 -0300

> exactly "maintaining the IPv6 specifications" mean?

Normally maintenance has to do with addressing problems/flaws found in
the specs and/or operationally. -- which is essentially what we are
doing here.

As a datapoint, e.g., tcpm, for one of the most widely-deployed
protocols (almost 40 years old) there has been a fair share of work,
ranging from generation and processing of sequence numbers and ack
numbers (e.g. RFC6528 and RFC5961), definitions of new options,
deprecation of features (e.g. URG indications), changing the initial
window, changing RTO values, etc.

Not sure what the debate wuld be about with respect to what
"maintenance" is about.

Thanks,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Jan Zorz - Go6 <[email-masked]>
Date: Tue, 26 Feb 2019 19:57:15 +0100

> Not sure what the debate wuld be about with respect to what

Well, my response was aimed at Ole's "Perhaps it is time to have a wider 
debate about how the working group should function and what it’s role 
should be."

Maybe the first thing to figure out is what version of meaning of 
"maintenance" we would like to use and that could set a nice path 
forward for a discussion that Ole proposed.

Cheers, Jan

---

From: Bob Hinden <[email-masked]>
Date: Tue, 26 Feb 2019 13:40:06 -0800

Might start with looking at the working group charter:

https://datatracker.ietf.org/wg/6man/about/

Bob

> On Feb 26, 2019, at 10:57 AM, Jan Zorz - Go6 <[email-masked]> wrote:
> 
> Well, my response was aimed at Ole's "Perhaps it is time to have a wider debate about how the working group should function and what it’s role should be."
> 
> Maybe the first thing to figure out is what version of meaning of "maintenance" we would like to use and that could set a nice path forward for a discussion that Ole proposed.
> 
> Cheers, Jan
>

---

From: Jan Zorz - Go6 <[email-masked]>
Date: Wed, 27 Feb 2019 13:03:24 +0100

> https://datatracker.ietf.org/wg/6man/about/

Bob, hi...

Charter seems to say the right things ;)

Cheers, Jan

---

From: Ole Troan <[email-masked]>
Date: Wed, 27 Feb 2019 13:35:07 +0100

Renaming this thread.

And just as a note, I think more than me find references to “real world requirements” a little taxing.
It insinuates that some people live in the real world, and understand what’s going on there, and some others aren’t.
While reality is probably more along the lines of lots of paralell universes with somewhat conflicting requirements… ;-)

Cheers,
Ole

> On 26 Feb 2019, at 16:35, Jan Zorz - Go6 <[email-masked]> wrote:
> 
> Dear @all,
> 
> On 25/02/2019 09:37, Ole Troan wrote:> 6man is a long lived working group, tasked with maintaining the IPv6
> This is an important discussion to have. Can we define first what exactly "maintaining the IPv6 specifications" mean?
> 
> Is this about being a guardian making sure that IPv6 protocol doesn't change? IPv6 was defined many many years ago and meanwhile the reality of networking architectures and deployments changed a lot...
> 
> Protocol development and standardization (IETF) -> Vendors implementation in HW/SW -> Operators deployment in networks -> Feedback from real world back to IETF from operators (through vendors or direct) -> IETF adjusts protocol to real world requirements -> Vendors -> etc...
>

---

From: Lorenzo Colitti <[email-masked]>
Date: Wed, 27 Feb 2019 22:36:38 +0900

I agree that "making sure that IPv6 protocol doesn't change" is not the
goal. But there is some of that. I do think that one important role of 6man
is to preserve the IPv6 design from change requests by operators that do
not have enough (or, in some cases, any) real-world experience with
deploying it. If we don't do that, we'll end up with a copy of IPv4, just
because it's what everybody knows.

On Wed, Feb 27, 2019 at 9:35 PM Ole Troan <[email-masked]> wrote:

> It insinuates that some people live in the real world, and understand
> what’s going on there, and some others aren’t.
> While reality is probably more along the lines of lots of paralell
> universes with somewhat conflicting requirements… ;-)
>
> Cheers,
> Ole
>
> change? IPv6 was defined many many years ago and meanwhile the reality of
> networking architectures and deployments changed a lot...
> >
> from real world back to IETF from operators (through vendors or direct) ->
> IETF adjusts protocol to real world requirements -> Vendors -> etc...
> >