Subject: 6man w.g. last call for <draft-ietf-6man-ra-pref64-03>

From: Ole Troan <[email-masked]>
Date: Thu, 25 Jul 2019 16:37:14 -0400

Hello,

This message starts a new two week 6MAN Working Group Last Call on advancing:

  Title    : Discovering PREF64 in Router Advertisements
  Author   : J. Linkova, L. Colitti
  Filename : draft-ietf-6man-ra-pref64-03
  Pages    : 11
  Date     : 2019-07-24

    https://datatracker.ietf.org/doc/draft-ietf-6man-ra-pref64/

as a Proposed Standard.  

Substantive comments and statements of support for publishing this document should be directed to the mailing list. Editorial suggestions can be sent to the author. This last call will end on the 8th of August 2019.

To improve document quality and ensure that bugs are caught as early as possible, we would require at least two reviewers to do a complete review of the document.  Please let the chairs know if you are willing to be a reviewer.

Thanks,
Bob & Ole, 6man co-chairs

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 25 Jul 2019 16:45:45 -0400

Happy to review it.

Regards,
Jordi
@jordipalet

El 25/7/19 16:37, "ipv6 en nombre de Ole Troan" <[email-masked] en nombre de [email-masked]> escribió:

    Hello,

    
    
    as a Proposed Standard.  

    
    Thanks,
    Bob & Ole, 6man co-chairs
    --------------------------------------------------------------------
    IETF IPv6 working group mailing list
    [email-masked]
    Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
    --------------------------------------------------------------------

**********************************************
IPv4 is over
Are you ready for the new Internet ?
http://www.theipv6company.com
The IPv6 Company

This electronic message contains information which may be privileged or confidential. The information is intended to be for the exclusive use of the individual(s) named above and further non-explicilty authorized disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited and will be considered a criminal offense. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, even if partially, including attached files, is strictly prohibited, will be considered a criminal offense, so you must reply to the original sender to inform about this communication and delete it.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 26 Jul 2019 00:51:54 -0400

> https://datatracker.ietf.org/doc/draft-ietf-6man-ra-pref64/

I have read this version and previous versions, and I wish it
published, as it will lead to the universal deployment of IPv6 on Edge
Networks.

-- 
]               Never tell me the odds!                 | ipv6 mesh networks [ 
]   Michael Richardson, Sandelman Software Works        | network architect  [ 
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Tommy Pauly <[email-masked]>
Date: Fri, 26 Jul 2019 16:40:25 -0400

I have reviewed the most recent version of the document, and sent an editorial nit to the authors. I believe this document is well-written, clear, and a useful addition.

Specifically as a client OS implementer, having such functionality will make discovery of prefixes for synthesizing IPv4 addresses much simpler, and avoid times in which we effectively have only a partly-provisioned interface configuration.

Thanks for this work!

Best,
Tommy

> On Jul 25, 2019, at 4:37 PM, Ole Troan <[email-masked]> wrote:
> 
> Hello,
>

---

From: David Farmer <[email-masked]>
Date: Fri, 26 Jul 2019 17:22:21 -0500

I support this document moving forward and eagerly await its implementation
in routers and hosts.

Thank you to the authors for working on this.

On Thu, Jul 25, 2019 at 3:37 PM Ole Troan <[email-masked]> wrote:

> Substantive comments and statements of support for publishing this
> document should be directed to the mailing list. Editorial suggestions can
> be sent to the author. This last call will end on the 8th of August 2019.
>
> To improve document quality and ensure that bugs are caught as early as
> possible, we would require at least two reviewers to do a complete review
> of the document.  Please let the chairs know if you are willing to be a
> reviewer.
>
> Thanks,

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota
2218 University Ave SE        Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: Ca By <[email-masked]>
Date: Fri, 26 Jul 2019 18:22:24 -0700

> of the document.  Please let the chairs know if you are willing to be a

I have read the document and support it moving forward.

As a network operator using RFC7050 today, i look forward to deploying
this.

Regards,
CB

---

From: "Chongfeng Xie" <[email-masked]>
Date: Sun, 28 Jul 2019 10:11:14 +0800

I have reviewed this draft, which is interesting, and I support its progress. However, I don't think NAT64 has not been widely-deployed, as far as I know, only a few carriers has deployed it, so I hope the first sentence of the section 1 can be changed. 

Best 
Chongfeng

From: Tommy Pauly
Date: 2019-07-27 04:40
To: Ole Troan; 6man WG
Subject: Re: 6man w.g. last call for <draft-ietf-6man-ra-pref64-03>
I have reviewed the most recent version of the document, and sent an editorial nit to the authors. I believe this document is well-written, clear, and a useful addition.

Thanks for this work!
 
Best,
Tommy

---

From: "Chongfeng Xie" <[email-masked]>
Date: Sun, 28 Jul 2019 10:37:03 +0800

There is an editorial mistake in my previous mail, so I correct it as below, sorry for this,

I have reviewed this draft, which is interesting, and I support its progress. However, I don't think NAT64 has been widely-deployed, as far as I know, only a few carriers have deployed it, so I hope the first sentence in section 1 can be changed. 

Best 
Chongfeng

From: Tommy Pauly
Date: 2019-07-27 04:40
To: Ole Troan; 6man WG

Thanks for this work!
 
Best,
Tommy

---

From: David Lamparter <[email-masked]>
Date: Sun, 28 Jul 2019 09:42:01 +0200

I agree that this draft should proceed and have pushed out an
implementation for FRRouting:
https://github.com/FRRouting/frr/pull/4741/commits/7b93e502b58c5c4d264beda23c696ba020d3a1fd
(Since there is no codepoint allocated to the new ICMPv6 option yet, the
PR cannot be merged at this point.)

Cheers,

-David

P.S.: It doesn't check other RAs as suggested in section 8;  our RA code
is rather shitty and needs an overall cleanup so I rather do that after
the cleanup.  Still, if you want to try it and need a RA sender, it
works.

---

From: Jen Linkova <[email-masked]>
Date: Thu, 1 Aug 2019 16:49:27 +1000

Hi Chongfeng,

Thank you for reviewing the document!

> I have reviewed this draft, which is interesting, and I support its progress. However, I don't think NAT64 has been widely-deployed, as far as I know, only a few carriers have deployed it, so I hop…

Well, I guess it depends on how you define 'widely'. I can name a
number of large mobile operators deploying it:
- T-Mobile
- Reliance Jio
- Telstra

I'd say if you have IPv6-only hosts, then NAT64 is your only option to
provide access to IPv4-only resources so for Ipv6-only devices NAT64
seems to be widely deployed...;)

-- 
SY, Jen Linkova aka Furry