Subject: FW: New Version Notification for draft-fz-6man-ipv6-alt-mark-08.txt

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 30 Apr 2020 08:36:56 +0000

Dear All,
We published this new revision of the draft and it includes the changes that have been agreed with Bob, Ole and Magnus after the interim meeting.
In particular we have now described in detail how the alternate marking method can work for IPv6, in order to move RFC 8321 from normative to informative reference. A new Section "Alternate Marking Method Operation" has been introduced for this purpose.
In addition we have added more considerations about the use of HBH to address the outcome of the discussion with Eric, Ole and Tom on the mailing list.

We would really appreciate hearing your thoughts and inputs.

Best Regards,

Giuseppe and Tianran

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, April 30, 2020 9:19 AM
To: Fengwei Qin <[email-masked]>; Giuseppe Fioccola <[email-masked]>; Tianran Zhou <[email-masked]>; Mauro Cociglio <[email-masked]>
Subject: New Version Notification for draft-fz-6man-ipv6-alt-mark-08.txt

A new version of I-D, draft-fz-6man-ipv6-alt-mark-08.txt
has been successfully submitted by Giuseppe Fioccola and posted to the IETF repository.

Name:		draft-fz-6man-ipv6-alt-mark
Revision:	08
Title:		IPv6 Application of the Alternate Marking Method
Document date:	2020-04-30
Group:		Individual Submission
Pages:		13
URL:            https://www.ietf.org/internet-drafts/draft-fz-6man-ipv6-alt-mark-08.txt
Status:         https://datatracker.ietf.org/doc/draft-fz-6man-ipv6-alt-mark/
Htmlized:       https://tools.ietf.org/html/draft-fz-6man-ipv6-alt-mark-08
Htmlized:       https://datatracker.ietf.org/doc/html/draft-fz-6man-ipv6-alt-mark
Diff:           https://www.ietf.org/rfcdiff?url2=draft-fz-6man-ipv6-alt-mark-08

Abstract:
   This document describes how the Alternate Marking Method can be used
   as the passive performance measurement tool in an IPv6 domain and
   reports implementation considerations.  It proposes how to define a
   new Extension Header Option to encode alternate marking technique and
   also the Segment Routing case is discussed.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Bob Hinden <[email-masked]>
Date: Thu, 30 Apr 2020 11:52:24 -0700

Giuseppe and Tianran,

Good to see most of the issues discussed on the list accounted for in this version.

I continue to think it’s inappropriate to include any mention of using this option in SRH TLVs.   The draft is proposing to standardize its use as a SRH TLV and includes an IANA request to allocate a code point.  This was not the intended use for TLVs when SRH was standardized in 6MAN.

I think all mention of its use as a SRH TLV should be removed from the document.

Bob

> On Apr 30, 2020, at 1:36 AM, Giuseppe Fioccola <[email-masked]> wrote:
> 
> Dear All,
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------