Subject: Re: [Technical Errata Reported] RFC8028 (6035)

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 1 Apr 2020 07:49:45 +0000

[replying without my AD hat as Erik Kline is the responsible AD for 6man]

Fernando,

May I add an errata on your errata ? ;-)

As I am afraid that you use router B instead of router A in " And Router A should be employed as the preferred next hop for packets sourced from the prefix 2001:db8::/64, since it advertises the prefix with a non-zero Valid Lifetime and non-zero Preferred Lifetime (as opposed to Router B)."

Hope this helps

-éric

-----Original Message-----
From: RFC Errata System <[email-masked]>
Date: Wednesday, 1 April 2020 at 04:25
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, Eric Vyncke <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: [Technical Errata Reported] RFC8028 (6035)

    The following errata report has been submitted for RFC8028,
    "First-Hop Router Selection by Hosts in a Multi-Prefix Network".
    
    --------------------------------------
    You may review the report below and at:
    https://www.rfc-editor.org/errata/eid6035
    
    --------------------------------------
    Type: Technical
    Reported by: Fernando Gont <[email-masked]>
    
    Section: 3.1
    
    Original Text
    -------------

    Corrected Text
    --------------
    In the context of this document, it is clear that the prefix information becomes more associated with the sending router, than with the link as a whole. As such, the PIO lifetimes should be interpreted to indicate the view of the router sending the Router Advertisement, as opposed to absolute information about a prefix.
    
    For example, if two routers (say, router A and Router B), advertise the prefix 2001:db8::/64 as:
    
    * Router A:
    A=1, L=1, PIO: 2001:db8::/64, Valid Lifetime=0, Preferred Lifetime=0
    
    * Router B:
    A=1, L=1, PIO: 2001:db8::/64, Valid Lifetime=X, Preferred Lifetime=Z
    
    then, addresses should be configured/maintained with a Valid Lifetime of X, and a Preferred Lifetime of Z. Furthermore, the prefix should be considered on-link with a Valid Lifetime of X. And Router A should be employed as the preferred next hop for packets sourced from the prefix 2001:db8::/64, since it advertises the prefix with a non-zero Valid Lifetime and non-zero Preferred Lifetime (as opposed to Router B).
    
    As long as one router on the local subnet considers a prefix to be Valid (and possibly Preferred), the prefix should be considered Valid (and Preferred, if applicable). Similarly, as long as one router on the local subnet considers the prefix to be on-link and/or usable for auto-configuration, the prefix should be considered as such.

    Notes
    -----
    This is not a bug in RFC8028, but rather a clarification on what's likely a desired behavior. As such, and if considered appropriate, this errata is meant to be "held for document update".
    
    i would like to thank Fred Baker and Brian Carpenter for taking the time to answer my questions on RF8028.
    
    Instructions:
    -------------
    This erratum is currently posted as "Reported". If necessary, please
    use "Reply All" to discuss whether it should be verified or
    rejected. When a decision is reached, the verifying party  
    can log in to change the status and edit the report, if necessary. 
    
    --------------------------------------
    RFC8028 (draft-ietf-6man-multi-homed-host-10)
    --------------------------------------
    Title               : First-Hop Router Selection by Hosts in a Multi-Prefix Network
    Publication Date    : November 2016
    Author(s)           : F. Baker, B. Carpenter
    Category            : PROPOSED STANDARD
    Source              : IPv6 Maintenance
    Area                : Internet
    Stream              : IETF
    Verifying Party     : IESG

---

From: Fernando Gont <[email-masked]>
Date: Wed, 1 Apr 2020 05:07:54 -0300

On 1/4/20 04:49, Eric Vyncke (evyncke) wrote:
> May I add an errata on your errata ? ;-) >

haha.. good grief! -- I produced the errata quickly.. so there you go. 
:-) I should have double-checked better!

Thanks!

P.S.: I will excercise a new procedure, then: looks like errata's of 
erratas are directed to the rfc-ed...

Cheers,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Suresh Krishnan <[email-masked]>
Date: Wed, 1 Apr 2020 09:05:39 -0400

Hi Fernando,

> On Apr 1, 2020, at 4:07 AM, Fernando Gont <[email-masked]> wrote:
> 
> haha.. good grief! -- I produced the errata quickly.. so there you go. :-) I should have double-checked better!
> 
> Thanks!
> 
> P.S.: I will excercise a new procedure, then: looks like errata's of erratas are directed to the rfc-ed...

They can edit the Erratum in place. No need to file a separate one. Please send them a note with the OLD: and NEW: text.

Regards
Suresh

---

From: Megan Ferguson <[email-masked]>
Date: Wed, 1 Apr 2020 08:00:38 -0700

Hi Fernando,

Suresh is right - just send us the Old/New clearly showing your update and I can implement for you.

Thank you.

RFC Editor/mf

---

From: Megan Ferguson <[email-masked]>
Date: Wed, 1 Apr 2020 08:17:33 -0700

Hi Fernando,

And now I see you’ve already sent with a different subject - sorry!  Copying below to keep in the same thread:

> Hello, RFC-Editor,
> 
> Yesterday I filled Errata 6035 (https://www.rfc-editor.org/errata/eid6035) on RFC 8026.
> 
> However, I realize the erratum contains an error.
> 
> The text
> "And Router A should be employed as the preferred next hop for packets sourced from the prefix 2001:db8::/64, since it advertises the prefix with a non-zero Valid Lifetime and non-zero Preferred Lifetime (as opposed to Router B)."
> 
> should really say:
> 
> "And Router B should be employed as the preferred next hop for packets sourced from the prefix 2001:db8::/64, since it advertises the prefix with a non-zero Valid Lifetime and non-zero Preferred Lifetime (as opposed to Router A)."
> 
> (note that "A" and "B" are swapped.
> 
> Is it possible to correct this in the erratum?
> 
> Thanks!
> 
> Cheers,
> -- 
> Fernando Gont
> e-mail: [email-masked] || [email-masked]
> PGP Fingerprint: 7809 84F5 322E 45C7 F1C9 3945 96EE A9EF D076 FFF1

We have updated as requested.  

Please review our changes at https://www.rfc-editor.org/errata/eid6035 (please be sure to refresh) and let us know if any further updates are necessary.

Thank you!

RFC Editor/mf

---

From: Fred Baker <[email-masked]>
Date: Wed, 1 Apr 2020 10:13:38 -0700

It would be interesting to see whether this happens in practice; at the moment it sounds somewhat theoretical. But I don't have a problem adding a sentence or two if and when RFC 8028 is updated if it's a real issue.

> On Mar 31, 2020, at 7:25 PM, RFC Errata System <[email-masked]> wrote:
>