Subject: RE: draft-ietf-6man-spring-srv6-oam-05

From: Parag Kaneriya <[email-masked]>
Date: Thu, 25 Jun 2020 17:57:50 +0000

Hello,

I have gone though the draft, below are the few point which is not clear .

  1.  From draft version 5, doesn't have any END.OTP/OP sids which was define in previous version.  What was the reason for removal of these sids
  2.  Section 3.1.2  describe ping remote SID without Flavors.  When Pinging SID with USD Flavor , does Ping packet need to encapsulated while sending out ?

Regards
Parag

Juniper Business Use Only

---

From: "Zafar Ali (zali)" <[email-masked]>
Date: Thu, 25 Jun 2020 18:08:56 +0000

Hi Parag,

Many thanks for your review.

Please see in-line.

Thanks

Regards … Zafar

From: ipv6 <[email-masked]> on behalf of Parag Kaneriya <pkaneria=[email-masked]>
Date: Thursday, June 25, 2020 at 2:01 PM
To: "[email-masked]" <[email-masked]>
Subject: RE: draft-ietf-6man-spring-srv6-oam-05

Hello,

  1.  From draft version 5, doesn’t have any END.OTP/OP sids which was define in previous version.  What was the reason for removal of these sids

As I mentioned in the summary of the diffs email, https://mailarchive.ietf.org/arch/msg/ipv6/BPy-Il0JPw1I71bMBAClN6Bi2Rc/:

There was an outstanding comment from Greg in https://mailarchive.ietf.org/arch/msg/ipv6/esi3EWdjWMEu9zSP-pjzxI2gEmw/. Specifically, Greg asked: Isn't using assigned by IANA port number sufficient to identify active IP OAM packets? Wouldn't the same be applicable in SRv6 OAM? Removed END.OP SID and the associated changes in the illustration section to address this comment.

  1.  Section 3.1.2  describe ping remote SID without Flavors.  When Pinging SID with USD Flavor , does Ping packet need to encapsulated while sending out ?

The encapsulation of the ping packet needs to mimic encapsulation of the data traffic for any SID/ flavor.

Regards
Parag

---

From: Ron Bonica <[email-masked]>
Date: Thu, 25 Jun 2020 18:31:04 +0000

Zafar,

What is that port number? Shouldn't some reference to it appear in the document?

                                                           Ron

Juniper Business Use Only
From: ipv6 <[email-masked]> On Behalf Of Zafar Ali (zali)
Sent: Thursday, June 25, 2020 2:09 PM
To: Parag Kaneriya <pkaneria=[email-masked]>; [email-masked]
Subject: Re: draft-ietf-6man-spring-srv6-oam-05

[External Email. Be cautious of content]

Hi Parag,

Please see in-line.

Thanks

Regards ... Zafar

From: ipv6 <[email-masked]<mailto:[email-masked]>> on behalf of Parag Kaneriya <pkaneria=[email-masked]<mailto:pkaneria=[email-masked]>>
Date: Thursday, June 25, 2020 at 2:01 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-ietf-6man-spring-srv6-oam-05

Hello,

As I mentioned in the summary of the diffs email, https://mailarchive.ietf.org/arch/msg/ipv6/BPy-Il0JPw1I71bMBAClN6Bi2Rc/<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/ipv6/BPy-Il0JPw1I71bMBAClN6Bi2Rc/__;!!NEt6yMaO-gk!VSoC94EOjccCYRiOkjAbgvJGW7xndVGRMP0fcpKFe9LXvNYTmbrbum48r7yclu1u$>:

There was an outstanding comment from Greg in https://mailarchive.ietf.org/arch/msg/ipv6/esi3EWdjWMEu9zSP-pjzxI2gEmw/<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/ipv6/esi3EWdjWMEu9zSP-pjzxI2gEmw/__;!!NEt6yMaO-gk!VSoC94EOjccCYRiOkjAbgvJGW7xndVGRMP0fcpKFe9LXvNYTmbrbum48r_TIKJw6$>. Specifically, Greg asked: Isn't using assigned by IANA port number sufficient to identify active IP OAM packets? Wouldn't the same be applicable in SRv6 OAM? Removed END.OP SID and the associated changes in the illustration section to address this comment.

Regards
Parag

---

From: Parag Kaneriya <[email-masked]>
Date: Fri, 26 Jun 2020 04:13:28 +0000

Hello Zafar,

Thanks for your reply.

It would be good to mentioned SID flavor behavior also in draft,  in order to remove ambiguity across different vender implementation

Regards
Parag

Juniper Business Use Only
From: Zafar Ali (zali) <zali=[email-masked]>
Sent: Thursday, June 25, 2020 11:39 PM
To: Parag Kaneriya <[email-masked]>; [email-masked]
Cc: Zafar Ali (zali) <[email-masked]>
Subject: Re: draft-ietf-6man-spring-srv6-oam-05

Hi Parag,

Please see in-line.

Thanks

Regards ... Zafar

Hello,

As I mentioned in the summary of the diffs email, https://mailarchive.ietf.org/arch/msg/ipv6/BPy-Il0JPw1I71bMBAClN6Bi2Rc/<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/ipv6/BPy-Il0JPw1I71bMBAClN6Bi2Rc/__;!!NEt6yMaO-gk!WlpBKxVY_xUqpwi55tN3mzaZV94ItmbNhqty50ZrqhtTmQu8Y7-LHzJ8ove_77rw$>:

There was an outstanding comment from Greg in https://mailarchive.ietf.org/arch/msg/ipv6/esi3EWdjWMEu9zSP-pjzxI2gEmw/<https://urldefense.com/v3/__https:/mailarchive.ietf.org/arch/msg/ipv6/esi3EWdjWMEu9zSP-pjzxI2gEmw/__;!!NEt6yMaO-gk!WlpBKxVY_xUqpwi55tN3mzaZV94ItmbNhqty50ZrqhtTmQu8Y7-LHzJ8oklwzWQR$>. Specifically, Greg asked: Isn't using assigned by IANA port number sufficient to identify active IP OAM packets? Wouldn't the same be applicable in SRv6 OAM? Removed END.OP SID and the associated changes in the illustration section to address this comment.

Regards
Parag

---

From: "G. Sri Karthik Goud" <[email-masked]>
Date: Tue, 30 Jun 2020 06:36:11 +0000

Hello Zafar,

The OAM draft doesn't talk about how various SIDs(END/END.X) and their flavors(USP, USD) need to be handled. This can lead to ambiguities across vendors. Wouldn't it be good to call for a standard adoption by calling out the behavior expected in the draft?

Thanks,
Karthik

Juniper Business Use Only
From: ipv6 <[email-masked]> On Behalf Of Parag Kaneriya
Sent: Thursday, June 25, 2020 9:13 PM
To: Zafar Ali (zali) <zali=[email-masked]>; [email-masked]
Subject: RE: draft-ietf-6man-spring-srv6-oam-05

Hello Zafar,

Thanks for your reply.

Regards
Parag

Juniper Business Use Only
From: Zafar Ali (zali) <zali=[email-masked]<mailto:zali=[email-masked]>>
Sent: Thursday, June 25, 2020 11:39 PM
To: Parag Kaneriya <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Zafar Ali (zali) <[email-masked]<mailto:[email-masked]>>
Subject: Re: draft-ietf-6man-spring-srv6-oam-05

Hi Parag,

Please see in-line.

Thanks

Regards ... Zafar

Hello,

Regards
Parag