Subject: FW: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 1 Jun 2020 16:51:49 +0000

Dear all

I applied the changes proposed by Carsten and held the change to informational status for now, per the latest with Brian.
Many thanks to both of you!

Pascal

-----Original Message-----
From: [email-masked] <[email-masked]> 
Sent: lundi 1 juin 2020 18:47
To: Pascal Thubert (pthubert) <[email-masked]>
Subject: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

A new version of I-D, draft-thubert-6man-ipv6-over-wireless-06.txt
has been successfully submitted by Pascal Thubert and posted to the IETF repository.

Name:		draft-thubert-6man-ipv6-over-wireless
Revision:	06
Title:		IPv6 Neighbor Discovery on Wireless Networks
Document date:	2020-06-01
Group:		Individual Submission
Pages:		23
URL:            https://www.ietf.org/internet-drafts/draft-thubert-6man-ipv6-over-wireless-06.txt
Status:         https://datatracker.ietf.org/doc/draft-thubert-6man-ipv6-over-wireless/
Htmlized:       https://tools.ietf.org/html/draft-thubert-6man-ipv6-over-wireless-06
Htmlized:       https://datatracker.ietf.org/doc/html/draft-thubert-6man-ipv6-over-wireless
Diff:           https://www.ietf.org/rfcdiff?url2=draft-thubert-6man-ipv6-over-wireless-06

Abstract:
   This document describes how the original IPv6 Neighbor Discovery and
   Wireless ND (WiND) can be applied on various abstractions of wireless
   media.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 1 Jun 2020 17:13:22 +0000

Pascal, I see this document suggests "NBMA", "wireless" and "IPv6 ND". We have
been working within that realm in civil aviation and other areas for a long time and
have come up with the AERO and OMNI proposals. We think we have something
good; do you think you have something better - or are they just different?

Thanks - Fred

> From: ipv6 [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
> Sent: Monday, June 01, 2020 9:52 AM
> To: Carsten Bormann <[email-masked]>; 'Brian E Carpenter' <[email-masked]>
> Cc: '6man WG' <[email-masked]>
> Subject: FW: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt
> 
> Dear all
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 1 Jun 2020 14:05:22 -0500

Hi Pascal,

I suggest changing the draft name from draft-thubert-6man-ipv6-over-wireless
to draft-thubert-6man-ipv6nd-over-wireless

Regards,
Behcet

On Mon, Jun 1, 2020 at 11:52 AM Pascal Thubert (pthubert) <pthubert=
[email-masked]> wrote:

> Dear all
>
> I applied the changes proposed by Carsten and held the change to
> informational status for now, per the latest with Brian.
> Subject: New Version Notification for
> draft-thubert-6man-ipv6-over-wireless-06.txt
>
>
> URL:
> https://www.ietf.org/internet-drafts/draft-thubert-6man-ipv6-over-wireless-06.txt
> Status:
> https://datatracker.ietf.org/doc/draft-thubert-6man-ipv6-over-wireless/
> Htmlized:
> https://tools.ietf.org/html/draft-thubert-6man-ipv6-over-wireless-06
> Htmlized:
> https://datatracker.ietf.org/doc/html/draft-thubert-6man-ipv6-over-wireless
> Diff:
> https://www.ietf.org/rfcdiff?url2=draft-thubert-6man-ipv6-over-wireless-06
>
> Abstract:
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at
> tools.ietf.org.
>
> The IETF Secretariat
>
>

---

From: Gyan Mishra <[email-masked]>
Date: Mon, 1 Jun 2020 19:23:46 -0400

Pascal 

I agree that this is an important topic that 6MAN should take up. 

As for draft name I agree with standards track and the name shown in the subject heading 
draft-thubert-6man-ipv6-over-wireless-06 is good.

You maybe familiar with an inherent issue that exist with multicast over WiFi where the multicast packets are transmitted at the lowest connection speed of all hosts associated to an SSID and thus the connection bandwidth ends up being low.  Dual band 5G with 802.11ac does help as devices not supporting AC cannot connect and have to connect to the single band SSID.  However older devices on single band still are subject to the significant step down to the lowest speed.  

Since IPV6 uses multicast for ND, all ND packets automatically get throttled and stepped down to the lowest bandwidth of all connected devices.  This step down issue exists for IPv4 multicast packets, however I have not tried with IPv6 but i am guessing the issue does exist.

There are WIFI vendor implementation that exist to circumvent the step down issue by taking incoming multicast steam and unicast out to all WiFi clients.  Drawback is bandwidth consumption with unicast over shared WIFI channel. 

Kind Regards 

Gyan

Sent from my iPhone

> On Jun 1, 2020, at 3:05 PM, Behcet Sarikaya <[email-masked]> wrote:
> 
> 
> Hi Pascal,
> 
>> On Mon, Jun 1, 2020 at 11:52 AM Pascal Thubert (pthubert) <pthubert=[email-masked]> wrote:
>> Dear all
>>

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 1 Jun 2020 23:44:33 +0000

I don’t think it is time for this yet. The document calls for multilink subnets,
care-of addresses and Mobile IP whereas AERO and OMNI do not. There
is a point to be made that Pascal’s doc considers multihop primarily whereas
AERO/OMNI consider multiple links primarily. But, I think it would be a pretty
simple extension to get AERO/OMNI to do multihop using your favorite
choice of MANET or other technology.

Thanks - Fred

From: ipv6 [mailto:[email-masked]] On Behalf Of Gyan Mishra
Sent: Monday, June 01, 2020 4:24 PM
To: [email-masked]
Cc: Pascal Thubert (pthubert) <pthubert=[email-masked]>; 6man WG <[email-masked]>
Subject: Re: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Pascal

You maybe familiar with an inherent issue that exist with multicast over WiFi where the multicast packets are transmitted at the lowest connection speed of all hosts associated to an SSID and thus the connection bandwidth ends up being low.  Dual band 5G with 802.11ac does help as devices not supporting AC cannot connect and have to connect to the single band SSID.  However older devices on single band still are subject to the significant step down to the lowest speed..

Kind Regards

Gyan

Sent from my iPhone

On Jun 1, 2020, at 3:05 PM, Behcet Sarikaya <[email-masked]<mailto:[email-masked]>> wrote:

Hi Pascal,

Regards,
Behcet

On Mon, Jun 1, 2020 at 11:52 AM Pascal Thubert (pthubert) <pthubert=[email-masked]<mailto:[email-masked]>> wrote:
Dear all

Pascal

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: lundi 1 juin 2020 18:47
To: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Status:         https://datatracker.ietf.org/doc/draft-thubert-6man-ipv6-over-wireless/<https://datatracker.ietf..org/doc/draft-thubert-6man-ipv6-over-wireless/>

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Jun 2020 07:42:25 +0000

Hello Fred

I do not see why we’d need to wait for AERO to be RFC to adopt this draft.

Still, applying overlays on wireless is certainly useful, there’s AERO, and there’s also RAW. So I agree with you that discussing only MIP / NEMO is not sufficient. But hey, this is not WG LC, just adoption.

I’d be happy to extend the scope to accommodate a section on AERO if that is what you have in mind and what the WG wants. As I’d be inclined to discuss more on RAW. But I’d need your help for that text, and we’d have to present those things as more advanced / WIP activities.

Keep safe,

Pascal

From: Templin (US), Fred L <[email-masked]>
Sent: mardi 2 juin 2020 01:45
To: Gyan Mishra <[email-masked]>; [email-masked]
Cc: Pascal Thubert (pthubert) <[email-masked]>; 6man WG <[email-masked]>
Subject: RE: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Thanks - Fred

From: ipv6 [mailto:[email-masked]] On Behalf Of Gyan Mishra
Sent: Monday, June 01, 2020 4:24 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Pascal Thubert (pthubert) <pthubert=[email-masked]<mailto:pthubert=[email-masked]>>; 6man WG <[email-masked]<mailto:[email-masked]>>
Subject: Re: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Pascal

Kind Regards

Gyan

Sent from my iPhone

Hi Pascal,

Regards,
Behcet

Pascal

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: lundi 1 juin 2020 18:47
To: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Abstract:

The IETF Secretariat

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Jun 2020 08:24:07 +0000

Hello Behcet,

I see what you’re saying, it makes sense considering the current text. Still, it’s not just ND but mostly on the underlying concepts of links and subnets. If we logically extend to AERO and stuff, there will be overlays as well. At which point we’re way beyond ND.

The scope is to be determined by the WG at adoption, and based in that we’ll accommodate the name. I’m not inclined in resetting the counter with a new name now, done that in the past and created confusion.

Take care,

Pascal

From: Behcet Sarikaya <[email-masked]>
Sent: lundi 1 juin 2020 21:05
To: Pascal Thubert (pthubert) <[email-masked]>
Cc: Carsten Bormann <[email-masked]>; Brian E Carpenter <[email-masked]>; 6man WG <[email-masked]>
Subject: Re: FW: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Hi Pascal,

Regards,
Behcet

Pascal

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: lundi 1 juin 2020 18:47
To: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Abstract:

The IETF Secretariat

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Jun 2020 11:56:11 +0000

My oups, I meant OMNI. Getting confused with acronyms… For those interested in digging, AERO is exp RFC 6706, OMNI is the bump in the stack that may have common interests with RAW, https://tools.ietf.org/html/draft-templin-atn-aero-interface, if I have it right.

From: Pascal Thubert (pthubert)
Sent: mardi 2 juin 2020 09:42
To: 'Templin (US), Fred L' <[email-masked]>; Gyan Mishra <[email-masked]>; [email-masked]
Cc: 6man WG <[email-masked]>
Subject: RE: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Hello Fred

Keep safe,

Pascal

From: Templin (US), Fred L <[email-masked]<mailto:[email-masked]>>
Sent: mardi 2 juin 2020 01:45
To: Gyan Mishra <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>; 6man WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Thanks - Fred

Pascal

Kind Regards

Gyan

Sent from my iPhone

Hi Pascal,

Regards,
Behcet

Pascal

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: lundi 1 juin 2020 18:47
To: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Abstract:

The IETF Secretariat

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 2 Jun 2020 15:09:34 +0000

Pascal, while it is true that OMNI and AERO do conform to overlay principles, on
the access network proper the OMNI interface uses unencapsulated IPv6 ND
messages in a manner that achieves what your draft is asking except in a
different way. Your draft seems to be asking for a “get a care-of address from
infrastructure” approach, whereas OMNI is “bring your own address”.

BTW, the correct URLs were given in an earlier message but here they are again:

https://datatracker.ietf.org/doc/draft-templin-6man-omni-interface/
https://datatracker.ietf.org/doc/draft-templin-intarea-6706bis/

Note that the current OMNI draft includes “6man” in the name, and that RFC6706
is to be obsoleted by the (bis) named above.

Thanks - Fred

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Tuesday, June 02, 2020 12:42 AM
To: Templin (US), Fred L <[email-masked]>; Gyan Mishra <[email-masked]>; [email-masked]
Cc: 6man WG <[email-masked]>
Subject: RE: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Hello Fred

Keep safe,

Pascal

Thanks - Fred

Pascal

Kind Regards

Gyan

Sent from my iPhone

Hi Pascal,

Regards,
Behcet

Pascal

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: lundi 1 juin 2020 18:47
To: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Abstract:

The IETF Secretariat

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Jun 2020 15:40:26 +0000

Hello Fred

Thanks for the new pointers.

I really need to dig more to understand the whole AERO story. I’m a bit confused at the moment if omni tunnels and how, how that compares to say, MONAMI MCoA (https://tools.ietf.org/html/draft-ietf-monami6-multiplecoa-14). But that’s another thread.

At the end of the day, my draft is supposed to be agnostic to the way the address is formed. So the AERO approach should be represented too, mostly if it is well on the way to std track. Just that I cannot write that text at my current level of understanding. So if you are interested in having the AERO/OMNI approach discussed in the draft, you’ll have to take the pen again…

Take care,

Pascal

From: Templin (US), Fred L <[email-masked]>
Sent: mardi 2 juin 2020 17:10
To: Pascal Thubert (pthubert) <[email-masked]>; Gyan Mishra <[email-masked]>; [email-masked]
Cc: 6man WG <[email-masked]>
Subject: RE: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Thanks - Fred

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Tuesday, June 02, 2020 12:42 AM
To: Templin (US), Fred L <[email-masked]<mailto:[email-masked]>>; Gyan Mishra <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: 6man WG <[email-masked]<mailto:[email-masked]>>
Subject: RE: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Hello Fred

Keep safe,

Pascal

Thanks - Fred

Pascal

Kind Regards

Gyan

Sent from my iPhone

Hi Pascal,

Regards,
Behcet

Pascal

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: lundi 1 juin 2020 18:47
To: Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>
Subject: New Version Notification for draft-thubert-6man-ipv6-over-wireless-06.txt

Abstract:

The IETF Secretariat