Subject: draft-thubert-6man-ipv6-over-wireless-06 running counter to RFC4903?

From: Etienne-Victor Depasquale <[email-masked]>
Date: Tue, 2 Jun 2020 19:04:20 +0200

Hello,

Please bear with me as I put this question; I'm afraid it may have been
thrashed out long ago.

RFC4903 states that:

"A multi-link subnet model should be avoided. IETF working groups
using, or considering using, multi-link subnets today should
investigate moving to one of the other models."

Now, draft-thubert-6man-ipv6-over-wireless-06 states that:
"routers federate the links between nodes
that belong to the subnet, the subnet is not on-link and it extends
beyond any of the federated links"

Is it correct to conclude that the draft runs counter to RFC4903?

Cheers,

Etienne
-- 
Ing. Etienne-Victor Depasquale
Assistant Lecturer
Department of Communications & Computer Engineering
Faculty of Information & Communication Technology
University of Malta
Web. https://www.um.edu.mt/profile/etiennedepasquale

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 2 Jun 2020 17:11:37 +0000

Yes, Etienne-Victor.

Pascal

Le 2 juin 2020 à 19:07, Etienne-Victor Depasquale <[email-masked]> a écrit :

Hello,

Please bear with me as I put this question; I'm afraid it may have been thrashed out long ago.

RFC4903 states that:

Cheers,

Etienne
--
Ing. Etienne-Victor Depasquale
Assistant Lecturer
Department of Communications & Computer Engineering
Faculty of Information & Communication Technology
University of Malta
Web. https://www.um.edu.mt/profile/etiennedepasquale
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 2 Jun 2020 19:24:13 +0000

That makes you just as bad as me, Pascal - but with good intentions, I am sure!

But, my real reason for replying is to inform the community that we are going
to have a terminology collision between the ICAO and IETF domains. In ICAO,
the term “multilink” refers to an aircraft that has multiple wireless transmission
interfaces that can be used simultaneously to carry packets having the same
IP source address/prefix. That is very different than what “multilink subnet”
has come to be known as in the IETF.

Fred

From: ipv6 [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Tuesday, June 02, 2020 10:12 AM
To: Etienne-Victor Depasquale <[email-masked]>
Cc: [email-masked]
Subject: [EXTERNAL] Re: draft-thubert-6man-ipv6-over-wireless-06 running counter to RFC4903?

This message was sent from outside of Boeing. Please do not click links or open attachments unless you recognize the sender and know that the content is safe.

Yes, Etienne-Victor.

Pascal

Le 2 juin 2020 à 19:07, Etienne-Victor Depasquale <[email-masked]<mailto:[email-masked]>> a écrit :

Hello,

RFC4903 states that:

Cheers,

Etienne
[email-masked]<mailto:[email-masked]>