Subject: RE: [v6ops] draft-ietf-6man-grand : saving lookups

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 11 Aug 2020 16:48:13 +0000

On Aug 11, 2020, at 10:54 AM, Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> wrote:
Some NBMA links can be *very* large, with all nodes on the link as candidates for receiving
link-scoped multicast. However, with proper controls on limiting the transmission of link
scoped multicast, the transmissions can be effectively propagated to exactly that (small)
group of nodes on the link that actually need to receive them. So, if there is going to be a
draft please make sure to add a note to the effect that properly engineered NBMA links
are an exception, and can in fact support a very large broadcast domain.

This seems related to the notion that rather than doing unacknowledged multicasts on WiFi, the AP should simply unicast the multicast packet to all interested stations serially.

That is more or less the principle for NBMA, yes. But take a conservatively-sized NBMA
link with 1M nodes on the link but only 2-3 of them need to receive the multicast then
serially unicasting seems pretty efficient and does not disturb the vast majority of
nodes that don’t care.

Thanks - Fred

---

From: Ted Lemon <[email-masked]>
Date: Tue, 11 Aug 2020 13:02:59 -0400

> serially unicasting seems pretty efficient and does not disturb the vast majority of

Indeed, I was not expressing this as a criticism. I wonder if there’s a way to get that kind of reduction for regular NS/NA pairs. I think for the “I want to send a packet to foo” case, this is easy; the question is, what about during SLAAC?

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 17 Aug 2020 09:38:35 +0000

Hello Fred:

100% agree. If the size of the multicast table is roughly that of the routing table, it looks particularly inefficient to maintain a multicast table for the sole purpose of DAD and lookup. We take great care in hiding that simple truth under the carpet by saying that’s a L2 problem. But it does not seem that L2 has taken the bait, has it.

As another case of what you’re describing,  fabrics are optimized to use a routing protocol (e.g., BGP with eVPN) and broadcast is the last resort, but there is no multicast in between. Sadly it is still there, because the fabric is lacking a clear view of what’s there.

Note also that the routing protocol is better suited to announce reachability than to perform DAD.

This is where some help from the host would be needed in place of the useless IGMP games. The host can help the fabric by providing accurate information on the addresses it is effectively using, a sense of duration, a sense of order in movements, and a proof of ownership. This information should be enough to differentiate a case of multihoming / anycast with a movement.

All the best

Pascal

On Aug 11, 2020, at 12:48 PM, Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> wrote:
That is more or less the principle for NBMA, yes. But take a conservatively-sized NBMA
link with 1M nodes on the link but only 2-3 of them need to receive the multicast then
serially unicasting seems pretty efficient and does not disturb the vast majority of
nodes that don’t care.

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 17 Aug 2020 14:08:58 +0000

Hi Pascal,

See below for inlines:

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Monday, August 17, 2020 2:39 AM
To: Templin (US), Fred L <[email-masked]>
Cc: IPv6 List <[email-masked]>; [email-masked]
Subject: [EXTERNAL] RE: [v6ops] draft-ietf-6man-grand : saving lookups
Hello Fred:

It depends on the L2. If the L2 is a physical media like a fabric of Ethernet switches then
penetration down to L2 may not be happening. But, if the L2 is a virtual topology that
is manifested by encapsulation (e.g., and overlay) then the point may be moot.

You seem to be assuming that the end system is a host that does SLAAC. I am assuming
an end system model that does link-local-only with unique LLAs where no SLAAC nor
DAD are necessary.

Thanks – Fred

All the best

Pascal

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 17 Aug 2020 14:40:54 +0000

Hello Fred

Le 17 août 2020 à 16:09, Templin (US), Fred L <[email-masked]> a écrit :

Hi Pascal,

See below for inlines:

Not sure what you mean.

As it goes, the host does not participate to the encapsulation. This is done at the ingress router that needs to resolve the egress router.

If it is known to the fabric we obtain it from tables that are maintained by the likes of BGP or LISP. Trouble is if not.

If there was a multicast state then we could send the lookup to only the routers that face the SNMA group.

But that would pretty much double the size of our tables, and though it is better, the MLD games still do not match the needs.

So we have to broadcast. Till the hosts implement a better host to router protocol as I described in the text quoted below.

True, though LLA have nothing to do there.

The bottom line is that if an address is globally unique by construction then it does not need DAD. We leverage that in IoT (6LoWPAN).

But you still need to announce the address to the routing system. If your host participâtes to the routing you are all set. We also leverage that in IoT (RPL).

But none of that applies to classical hosts that connect to your WiFi or your campus fabric.

Until the hosts implement something more suited there will be broadcast. This is quite detrimental to the perception of IPv6, even vs. IPv4.

Keep safe,

Thanks – Fred

All the best

Pascal

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 17 Aug 2020 15:01:42 +0000

Pascal, I think our discussion is diverging. I think where we differ is you seem to be
assuming a host model for the end system, whereas I am assuming a multi-addressed
mobile node (MN) that does link-local-only on the access network. The OMNI interface
allows the MN to interact with the routing system by signing its RS messages with a
coded LLA that prompts the receiving router to inject a Mobile Network Prefix (MNP)
for the MN into the BGP routing system. But, the MN itself does not participate in BGP.

Again, the only multicast aspects of ND that need managing are Solicited-Node
multicast for NS(AR), All-Nodes multicast for RA and unsolicited NA, and All-Routers
multicast for RS. In each case, the multicasts are serially-unicast to exactly that (very)
small set of nodes that needs to receive them and no others. So, the NBMA multicast
domain can be as large as the number of nodes on the link.

Fred

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Monday, August 17, 2020 7:41 AM
To: Templin (US), Fred L <[email-masked]>
Cc: IPv6 List <[email-masked]>; [email-masked]
Subject: [EXTERNAL] Re: [v6ops] draft-ietf-6man-grand : saving lookups

Hello Fred

Le 17 août 2020 à 16:09, Templin (US), Fred L <[email-masked]<mailto:[email-masked]>> a écrit :

Hi Pascal,

See below for inlines:

From: Pascal Thubert (pthubert) [mailto:[email-masked]]
Sent: Monday, August 17, 2020 2:39 AM
To: Templin (US), Fred L <[email-masked]<mailto:[email-masked]>>
Cc: IPv6 List <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [EXTERNAL] RE: [v6ops] draft-ietf-6man-grand : saving lookups
Hello Fred:

Not sure what you mean.

Keep safe,

Thanks – Fred

All the best

Pascal