Subject: Questions about draft-li-6man-app-aware-ipv6-network-02

From: Linda Dunbar <[email-masked]>
Date: Fri, 25 Sep 2020 18:22:59 +0000

Zhenbin, et al,

I have some questions on the draft-li-6man-app-aware-ipv6-network-02:

Page 5: App-aware Edge Device: This network device receives packets from IPv6 enabled applications and obtains the application characteristic information.

I am curious how does App-aware Edge Device derives the application characteristics information ?  Your draft mentioned VLAN tagging, How VLAN tagging can provide Application characteristics information?

Page 6: Is the Application-aware ID another extension field? Or part of existing extension header? Like a subTLV within the Hop-by-hop options Header Type?

Questions about the  Application-Aware ID structure in Figure 4:
Why not use IPv6 Header "Priority/Traffic class" field to represent the SLA Level?

Can you use IPv6 Header's "Flow Label" field to represent the App ID and Flow ID?

How can network acquire the information about "USER" information? I would think most applications encrypt their user information.

What kind of functions do you envision to be listed in the Figure 6's Function ID?

Thank you very much.

Linda Dunbar

---

From: Lizhenbin <[email-masked]>
Date: Mon, 28 Sep 2020 17:33:06 +0000

Hi Linda,
Please refer to my reply inline. APN mailing list is copied.

Best Regards,
Zhenbin (Robin)

From: Linda Dunbar [mailto:[email-masked]]
Sent: Saturday, September 26, 2020 2:23 AM
To: IPv6 List <[email-masked]>; [email-masked]
Subject: Questions about draft-li-6man-app-aware-ipv6-network-02

Zhenbin, et al,

I am curious how does App-aware Edge Device derives the application characteristics information ?  Your draft mentioned VLAN tagging, How VLAN tagging can provide Application characteristics information?
[Robin] There are different ways for VLAN tagging to provide application characteristics information. Here I propose one example: the user hosts/apps can connect to the home gateway which can add different VLANs called S-VLAN to identify the different services. For example VLAN1 is used for Internet service and VLAN2 is used for IPTV service. The home gateway will connect to the DSLAM on which the VLAN call C-VLAN will be added to identify the home user. So when the IP-based edge network device receives the packet, it can derive the user ID and service type information from the VLAN tagging. We have explained that the APN work focuses on the limited domains rather than open Internet. The VLAN tagging shows that there is similar practice in the access network.

Page 6: Is the Application-aware ID another extension field? Or part of existing extension header? Like a subTLV within the Hop-by-hop options Header Type?
[Robin] Application-aware ID is an option which can be used in DOH/HBH/SRH. It is part of existing extension headers. It can be seen as a type of TLV.

Questions about the  Application-Aware ID structure in Figure 4:
Why not use IPv6 Header "Priority/Traffic class" field to represent the SLA Level?
[Robin] The design is to take integrity into account. That is, all the information can be obtained from the single Application-aware ID. Traditionally we can get different parts' information to compose some type of tuple. The process has effect on the forwarding performance and the scalability of forwarding entries.

Can you use IPv6 Header's "Flow Label" field to represent the App ID and Flow ID?
[Robin] Integrity is the same reason for the problem. In addition "flow label" will be used for ECMP. Reusing it may cause the compatibility issue.

How can network acquire the information about "USER" information? I would think most applications encrypt their user information.
[Robin] The above example shows that C-VLAN can be used to acquire USER information. Though the application may encrypt their user information, not only APN needs the USER information, but also the carriers need to learn the USER information for accounting to get revenue. There already exists the possible way to solve the issue.

What kind of functions do you envision to be listed in the Figure 6's Function ID?
[Robin] Figure 6 is to reuse the SRv6 SID. The function ID means just the functions supported by the existing SRv6. The Application-aware ID is put into the arguments of the SRv6 SID. The function ID part will not have effect on the Application-aware ID.

[Robin] Thanks for your comments and questions. Now the draft is in the early phase. The usage of the Application-aware ID option can be further discussed.

Thank you very much.

Linda Dunbar

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Tue, 29 Sep 2020 08:07:24 +0000

Robin,

About Linda’s interesting questions about APN, I also wonder why using VLAN tagging as this tag will be lost quickly after a couple of hops while the IPv6 prefix will be kept (this is what DT Terastream did if not mistaken).

Else, I agree with you that Flow-Id should not be used as it is assumed to be opaque.

Still puzzled though about the ‘user’ information as if the traffic is encrypted it is also often to hide the user identity.

Regards

-éric

From: ipv6 <[email-masked]> on behalf of Lizhenbin <[email-masked]>
Date: Monday, 28 September 2020 at 19:33
To: Linda Dunbar <[email-masked]>, IPv6 List <[email-masked]>, "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: RE: Questions about draft-li-6man-app-aware-ipv6-network-02

Hi Linda,

Best Regards,
Zhenbin (Robin)

Zhenbin, et al,

Questions about the  Application-Aware ID structure in Figure 4:
Why not use IPv6 Header “Priority/Traffic class” field to represent the SLA Level?
[Robin] The design is to take integrity into account. That is, all the information can be obtained from the single Application-aware ID. Traditionally we can get different parts’ information to compose some type of tuple. The process has effect on the forwarding performance and the scalability of forwarding entries.

Can you use IPv6 Header’s “Flow Label” field to represent the App ID and Flow ID?
[Robin] Integrity is the same reason for the problem. In addition “flow label” will be used for ECMP. Reusing it may cause the compatibility issue.

How can network acquire the information about “USER” information? I would think most applications encrypt their user information.
[Robin] The above example shows that C-VLAN can be used to acquire USER information. Though the application may encrypt their user information, not only APN needs the USER information, but also the carriers need to learn the USER information for accounting to get revenue. There already exists the possible way to solve the issue.

What kind of functions do you envision to be listed in the Figure 6’s Function ID?
[Robin] Figure 6 is to reuse the SRv6 SID. The function ID means just the functions supported by the existing SRv6. The Application-aware ID is put into the arguments of the SRv6 SID. The function ID part will not have effect on the Application-aware ID.

Thank you very much.

Linda Dunbar