Subject: Re: I-D Action: draft-troan-6man-p2p-ethernet-00.txt

From: Brian E Carpenter <[email-masked]>
Date: Thu, 15 Oct 2020 18:20:46 +1300

Hi,

An interesting draft on an important topic, but I think it oversimplifies the problem in (at least) two ways:

1. Even if we had new improved switches and hosts, they would for many years be mixed with unimproved switches and hosts on the old (emulated yellow cable) model. It's already bad enough when you mix switches that do MLD with dumb switches that really do only emulate yellow cable.

2. I think we should be expect mesh rather than hub and spoke in the quite near future.

Which all takes us back to homenet, doesn't it?

Regards
   Brian

On 07-Oct-20 01:27, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
>         Title           : IP Point to Point Ethernet subnet model
>         Author          : O. Troan
> 	Filename        : draft-troan-6man-p2p-ethernet-00.txt
> 	Pages           : 7
> 	Date            : 2020-10-06
> 
> Abstract:
>    Ethernet topology is no longer a shared medium.  It is a long time
>    since Ethernet has been a thick yellow cable snaking its way from
>    station to station.  Ethernet is now effectively deployed in a hub
>    and spoke topology.  With a point to point link between a host and
>    the network device.  This memo describes a set of simplications for
>    how to run IP over such links, where the physical topology is exposed
>    in the network layer topology.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-troan-6man-p2p-ethernet/
> 
> There are also htmlized versions available at:
> https://tools.ietf.org/html/draft-troan-6man-p2p-ethernet-00
> https://datatracker.ietf.org/doc/html/draft-troan-6man-p2p-ethernet-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: [email-masked]
Date: Thu, 15 Oct 2020 08:47:05 +0200

Hi Brian,

Thanks for reading it, and apologies for it being in a hand-wavy form still.

> 1. Even if we had new improved switches and hosts, they would for many years be mixed with unimproved switches and hosts on the old (emulated yellow cable) model. It's already bad enough when you m…

The draft assumes a "suspension of disbelief". a "what if we took IP routing all the way to the edge?".
I'd imagine this would be another tool in the toolbox rather than replacing large L2s wholesale.

You could in theory use this mechanism on a bridged network too, but then you'd lose link state notifications, add more security issues...)

A candidate for this could be the home router. That is typically packaged as a router with a tightly coupled bridge and AP.
No host changes are required, so you could deploy this with a feature upgrade of a single device.

> Which all takes us back to homenet, doesn't it?

Yes, this depends on homenet.
It removes the ability to extend the network on L2, so for a p2p ethernet to be extendable it needs homenet.

Best regards,
Ole

---

From: Bob Hinden <[email-masked]>
Date: Thu, 15 Oct 2020 11:31:12 -0700

Brian, Ole,

> On Oct 14, 2020, at 10:20 PM, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 

I also think it is interesting.

> 1. Even if we had new improved switches and hosts, they would for many years be mixed with unimproved switches and hosts on the old (emulated yellow cable) model. It's already bad enough when you m…

On my home network, the switches making up the wired portion of the network are not managed nor are they routers.    The mesh router/APs are routers, I suspect that the two Ethernet ports on each node are routed.   I suspect that most home and SME switches are not routers.

I suspect this approach might be better for medium to large enterprise style networks where the switches are more capable.

> 2. I think we should be expect mesh rather than hub and spoke in the quite near future.

Agree.

> Which all takes us back to homenet, doesn't it?

At least as much as it needs to deal with a mix of what I will call routers with a lot of ports, and generic L2 switches.

Bob

> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------