Subject: Re: Starlink --- "simpler than IPv6"

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 19 Oct 2020 15:20:32 +0000

Seems like an “IPv6-over-foo” document might be in order; anyone care to
join me on that?

Fred

From: Behcet Sarikaya [mailto:[email-masked]]
Sent: Monday, October 19, 2020 8:14 AM
To: Michael Richardson <[email-masked]>; 6man WG <[email-masked]>
Cc: Templin (US), Fred L <[email-masked]>
Subject: Re: Starlink --- "simpler than IPv6"

Thanks Michael, I'd like to know as much as possible how IPv6 works in Starlink.

Behcet

On Fri, Oct 16, 2020 at 3:47 PM Michael Richardson <[email-masked]<mailto:[email-masked]>> wrote:
Anyone read anything more specific about what Starlink is doing that is
"simpler than IPv6"?

I'd sure like to know that it permits end-terminal to end-terminal
communicatons without a trip through a data center.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        |    IoT architect   [
]     [email-masked]<mailto:[email-masked]>  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 19 Oct 2020 10:58:39 -0500

> Seems like an “IPv6-over-foo” document might be in order; anyone care to

IPv6-over-foo on Starlink
section would look like

TBD until more is revealed

Behcet

> Fred
>
>
>
> *From:* Behcet Sarikaya [mailto:[email-masked]]
> *Sent:* Monday, October 19, 2020 8:14 AM
> *To:* Michael Richardson <[email-masked]>; 6man WG <[email-masked]>
> *Cc:* Templin (US), Fred L <[email-masked]>
> *Subject:* Re: Starlink --- "simpler than IPv6"
>
>
>
>
>
> On Fri, Oct 16, 2020 at 3:47 PM Michael Richardson <[email-masked]>
> wrote:
>
> ]     [email-masked]  http://www.sandelman.ca/        |   ruby on
> rails    [
>
>
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 19 Oct 2020 18:11:49 +0200

Le 19/10/2020 à 17:58, Behcet Sarikaya a écrit :
> 
> 
> On Mon, Oct 19, 2020 at 10:20 AM Templin (US), Fred L 
> <[email-masked] <mailto:[email-masked]>>
> wrote:
> 
> Seems like an “IPv6-over-foo” document might be in order; anyone care
> to____
> 
> join me on that?____
> 
> __
> 
> 
> IPv6-over-foo on Starlink section would look like
> 

One in USA could look at the regulator's public database and find which
frequency channel is allocated for Tesla for Starlink.  From that, one
could find which encoders are available on that frequency.  From that
one could find which protocols are on it.  It makes for a 'foo' in 'IPv6
over foo'.  The link layer.

Alex

> 
> Behcet
> 
> __
> 
> Fred____
> 
> __ __
> 
> *From:*Behcet Sarikaya [mailto:[email-masked] 
> <mailto:[email-masked]>] *Sent:* Monday, October 19, 2020
> 8:14 AM *To:* Michael Richardson <[email-masked] 
> <mailto:[email-masked]>>; 6man WG <[email-masked] 
> <mailto:[email-masked]>> *Cc:* Templin (US), Fred L
> <[email-masked] <mailto:[email-masked]>> 
> *Subject:* Re: Starlink --- "simpler than IPv6"____
> 
> __ __
> 
> ____
> 
> Thanks Michael, I'd like to know as much as possible how IPv6 works 
> in Starlink.____
> 
> __ __
> 
> Behcet____
> 
> __ __
> 
> On Fri, Oct 16, 2020 at 3:47 PM Michael Richardson <[email-masked] 
> <mailto:[email-masked]>> wrote:____
> 
> Anyone read anything more specific about what Starlink is doing that
> is "simpler than IPv6"?
> 
> -- ]               Never tell me the odds!                 | ipv6 
> mesh networks [ ]   Michael Richardson, Sandelman Software Works
> |    IoT architect   [ ] [email-masked] <mailto:[email-masked]> 
> http://www.sandelman.ca/ <http://www.sandelman.ca/>        | ruby on
> rails    [
> 
> 
> ____
> 
> 
> -------------------------------------------------------------------- 
> IETF IPv6 working group mailing list [email-masked] Administrative
> Requests: https://www.ietf.org/mailman/listinfo/ipv6 
> --------------------------------------------------------------------
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 19 Oct 2020 14:17:24 -0500

On Mon, Oct 19, 2020 at 11:12 AM Alexandre Petrescu <
[email-masked]> wrote:

> frequency channel is allocated for Tesla for Starlink.

It is 12GHz

>From that, one
I don't know how to do these?

Behcet

> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6

---

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 20 Oct 2020 12:58:23 +0200

Le 19/10/2020 à 21:17, Behcet Sarikaya a écrit :
> 
> 
> On Mon, Oct 19, 2020 at 11:12 AM Alexandre Petrescu 
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> 
>      > <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>      > wrote:
>      >

One would ask the ATN email list of IETF, to find which protocol runs on 
Starlink satellite links?  Or maybe which protocol runs on typical cheap 
data on satellite links?  Because there was already a draft posted there 
about links for aeronautics draft-maeurer-raw-ldacs-04
One would also ask the email list of the DRIP WG of IETF because that 
involves drones around air traffic control, which might depend 
peripherally on satellite data links.

One would check the user guides of devices implementing data 
communications on satellite links.  It's true that the name of a device 
is somehow difficult to find.

An old example is Q4000 made by Quake Global.  It is an old device that 
I studied about 10 years ago.  It uses RS-232 over the satellite link. 
That would be the 'encoder'.  That means one could put Serial Line 
Internet Protocol (SLIP) on it.   IPv6 works ok over SLIP, even though 
there is no RFC for it.  One might take advantage of the situation to 
write one.  The user manual of that device is at 
https://fccid.io/PB596XXCS/User-Manual/Datasheet-Q4000-1626630

Another device is Gateworks' current modem for Iridium, the "GW16130 
Mini-PCIe Satellite Modem - Datasheet".  It is at 1.6GHz (not 12GHz). 
That mentions 'UART' which again is an 'encoder' to me.  Among the 
features it says 'Supports E-mail messages or HTTP POST'.  That means it 
might support IP.  It also says 'Max Message payload: 340 bytes upload, 
270 bytes download'.  That means if one wants to put IPv6 minimum MTU 
1280 bytes then one might need to implement IPv6 Fragmentation extension 
headers.

During these searches I found that maybe SpaceX launched devices for 
Iridium in the past, so it might be that current Starlink are acting a 
little bit like Iridium, or so.

But it is all speculations.

Alex

>     <mailto:[email-masked]>
>      > <mailto:[email-masked] <mailto:[email-masked]>>]
>     *Sent:* Monday, October 19, 2020
>     <mailto:[email-masked]>
>      > <mailto:[email-masked] <mailto:[email-masked]>>>; 6man WG
>     <[email-masked] <mailto:[email-masked]>
>      > <mailto:[email-masked] <mailto:[email-masked]>>> *Cc:* Templin
>     (US), Fred L
>      > <[email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked] <mailto:[email-masked]>>>
>      > On Fri, Oct 16, 2020 at 3:47 PM Michael Richardson
>     <[email-masked] <mailto:[email-masked]>
>      > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:____
>      >
>      > |    IoT architect   [ ] [email-masked]
>     <mailto:[email-masked]> <mailto:[email-masked]
>     <mailto:[email-masked]>>
>      > http://www.sandelman.ca/ <http://www.sandelman.ca/>
>     <http://www.sandelman.ca/ <http://www.sandelman.ca/>>        | ruby on
>      > rails    [
>      >
>      >
>      > ____
>      >
>      >
>      > IETF IPv6 working group mailing list [email-masked]
>     <mailto:[email-masked]> Administrative
>     <https://www.ietf.org/mailman/listinfo/ipv6>
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/ipv6>

---

From: "Templin (US), Fred L" <[email-masked]>
Date: Tue, 20 Oct 2020 11:54:28 +0000

Alex,

> 1280 bytes then one might need to implement IPv6 Fragmentation extension

That is what the OMNI Adaptation Layer (OAL) does (and/or the link could
use link-specific segmentation and reassembly).

Thanks - Fred

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
> Sent: Tuesday, October 20, 2020 3:58 AM
> To: [email-masked]
> Cc: 6man WG <[email-masked]>
> Subject: [EXTERNAL] Re: Starlink --- "simpler than IPv6"
> 
> This message was sent from outside of Boeing. Please do not click links or open attachments unless you recognize the sender and
> know that the content is safe.
> 
> 
> 
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 21 Oct 2020 18:17:40 +0200

Le 19/10/2020 à 21:17, Behcet Sarikaya a écrit :
>> Seems like an “IPv6-over-foo” document might be in order; anyone
>> care to____
>> 
>> join me on that?____
>> 
>> __
>> 
>> 
> One in USA could look at the regulator's public database and find
> which frequency channel is allocated for Tesla for Starlink.
> 
> 
> 
> It is 12GHz

It seems you know that for sure?  How?

I could find some approved applications at FCC and they say more
frequency bands (around 18GHz, 19GHz, 28GHz and 30GHz), but not 12GHz.
https://fcc.report/IBFS/SES-LIC-INTR2020-03068

There is a listof applications from this company to FCC, visible at
https://fcc.report/company/SpaceX-Services-Inc

One would check themm all, to find out the frequencies and the names of
the manufacturers of devices.  After that, one could see for the device
specifications.

It might also be that the end user does not talk to satellite (like
Iridium users do) but to ground stations on WiFi, which them do talk to
satellites.  At that point there would be no interest of
"IPv6-over-starlink" but a simpler "IPv6-over-WiFi-at-5GHz-in-USA".

Alex

> 
> From that, one could find which encoders are available on that
> frequency.  From that one could find which protocols are on it.  It
> makes for a 'foo' in 'IPv6 over foo'.  The link layer.
> 
> 
>> Thanks Michael, I'd like to know as much as possible how IPv6
>> works in Starlink.____
>> 
>> __ __
>> 
>> Behcet____
>> 
>> __ __
>> 
>> Anyone read anything more specific about what Starlink is doing
>> that is "simpler than IPv6"?
>> 
>> mesh networks [ ]   Michael Richardson, Sandelman Software Works |
>> IoT architect   [ ] [email-masked]
> <mailto:[email-masked]> Administrative Requests:
> https://www.ietf.org/mailman/listinfo/ipv6

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 22 Oct 2020 10:45:56 -0500

SpaceX IB Ex Parte (10-15-20).pdf
<https://ecfsapi.fcc.gov/file/101548191460/SpaceX%20IB%20Ex%20Parte%20(10-15-20).pdf>

https://ecfsapi.fcc.gov/file/101548191460/SpaceX%20IB%20Ex%20Parte%20(10-15-20).pdf

This is their latest FCC application.

Behcet

---

From: Bob Hinden <[email-masked]>
Date: Thu, 22 Oct 2020 10:27:29 -0700

Thanks, I can try with the email in the letter.

Bob

> On Oct 22, 2020, at 8:45 AM, Behcet Sarikaya <[email-masked]> wrote:
> 
> On Wed, Oct 21, 2020 at 11:17 AM Alexandre Petrescu <[email-masked]> wrote:
> 
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Fri, 23 Oct 2020 08:57:05 +0200

Thank you very much for the pointers.

Bob, please allow me this last post and then I pause.

The pdf contains an IP address on the lower left of page 6, titled
'SpaceX Starlink' which does reply to ping with an RTT of 145ms from
here.  Traceroute might hint at some things as well since that IP
resolves inversely.

Alex

Le 22/10/2020 à 17:45, Behcet Sarikaya a écrit :
> On Wed, Oct 21, 2020 at 11:17 AM Alexandre Petrescu 
>> <[email-masked]
> <mailto:[email-masked]> 
> <mailto:[email-masked] 
> <mailto:[email-masked]>>>
>> wrote:
>> 
>> 
>> 
> <mailto:[email-masked]
> <mailto:[email-masked]>>
>> <mailto:[email-masked]
>> <mailto:[email-masked]> 
>> <mailto:[email-masked]
> <mailto:[email-masked]>>>>
>>> wrote:
>>> 
> frequency bands (around 18GHz, 19GHz, 28GHz and 30GHz), but not
> 12GHz. https://fcc.report/IBFS/SES-LIC-INTR2020-03068 
> <https://fcc.report/IBFS/SES-LIC-INTR2020-03068>
> 
> <https://fcc.report/company/SpaceX-Services-Inc>
> 
> One would check themm all, to find out the frequencies and the names
> of the manufacturers of devices.  After that, one could see for the
> device specifications.
> 
> Iridium users do) but to ground stations on WiFi, which them do talk
> to satellites.  At that point there would be no interest of 
>> frequency.  From that one could find which protocols are on it.
>> It makes for a 'foo' in 'IPv6 over foo'.  The link layer.
>> 
>> 
>> <mailto:[email-masked] <mailto:[email-masked]>>
>>> <mailto:[email-masked] <mailto:[email-masked]>
> <mailto:[email-masked] <mailto:[email-masked]>>>]
>> <mailto:[email-masked] <mailto:[email-masked]>>
>>> <mailto:[email-masked] <mailto:[email-masked]>
> <mailto:[email-masked] <mailto:[email-masked]>>>>; 6man WG
>> <[email-masked] <mailto:[email-masked]> <mailto:[email-masked]
> <mailto:[email-masked]>>
>>> <mailto:[email-masked] <mailto:[email-masked]>
> <mailto:[email-masked] <mailto:[email-masked]>>>> *Cc:* Templin
>> (US), Fred L
> <mailto:[email-masked]
> <mailto:[email-masked]>>
>> <mailto:[email-masked]
>> <mailto:[email-masked]> 
>> <mailto:[email-masked]
> <mailto:[email-masked]>>>>
> <mailto:[email-masked] <mailto:[email-masked]>>
>>> <mailto:[email-masked] <mailto:[email-masked]>
> <mailto:[email-masked] <mailto:[email-masked]>>>> wrote:____
>>> 
>>> I'd sure like to know that it permits end-terminal to
>>> end-terminal communicatons without a trip through a data center.
>>> 
>>> -- ]               Never tell me the odds!                 |
>>> ipv6 mesh networks [ ]   Michael Richardson, Sandelman Software
>>> Works | IoT architect   [ ] [email-masked]
>> <mailto:[email-masked] <mailto:[email-masked]>>
> <mailto:[email-masked] <mailto:[email-masked]>
>> <mailto:[email-masked] <mailto:[email-masked]>>>
> <http://www.sandelman.ca/ <http://www.sandelman.ca/>>
>> <http://www.sandelman.ca/ <http://www.sandelman.ca/>
> <http://www.sandelman.ca/ <http://www.sandelman.ca/>>>        | ruby
>> on
>>> rails    [
>>> 
>>> 
>>> ____
>>> 
>>> 
> <mailto:[email-masked]>
>> <mailto:[email-masked] <mailto:[email-masked]>> Administrative
>> <https://www.ietf.org/mailman/listinfo/ipv6
> <https://www.ietf.org/mailman/listinfo/ipv6>>
> <mailto:[email-masked]>
>> <mailto:[email-masked] <mailto:[email-masked]>> Administrative
> Requests:
>> <https://www.ietf.org/mailman/listinfo/ipv6
> <https://www.ietf.org/mailman/listinfo/ipv6>>