Subject: Re: Starlink --- "simpler than IPv6"

From: "Templin (US), Fred L" <[email-masked]>
Date: Mon, 19 Oct 2020 19:24:33 +0000

Behcet,

It is 12GHz

Would that frequency spectrum be compatible for use on mobile vehicular platforms
(e.g., cars, drones, helicopters, planes, etc.). Because it comes from Tesla, can we
expect at least cars?

Thanks - Fred

From: ipv6 [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Monday, October 19, 2020 12:17 PM
To: Alexandre Petrescu <[email-masked]>
Cc: 6man WG <[email-masked]>
Subject: Re: Starlink --- "simpler than IPv6"

On Mon, Oct 19, 2020 at 11:12 AM Alexandre Petrescu <[email-masked]<mailto:[email-masked]>> wrote:

Le 19/10/2020 à 17:58, Behcet Sarikaya a écrit :
>
>
> On Mon, Oct 19, 2020 at 10:20 AM Templin (US), Fred L
> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
> wrote:
>
> Seems like an “IPv6-over-foo” document might be in order; anyone care
> to____
>
> join me on that?____
>
> __
>
>
> IPv6-over-foo on Starlink section would look like
>
> TBD until more is revealed

One in USA could look at the regulator's public database and find which
frequency channel is allocated for Tesla for Starlink.

It is 12GHz

From that, one
could find which encoders are available on that frequency.  From that
one could find which protocols are on it.  It makes for a 'foo' in 'IPv6
over foo'.  The link layer.

I don't know how to do these?

Behcet
Alex

>
> Behcet
>
> __
>
> Fred____
>
> __ __
>
> *From:*Behcet Sarikaya [mailto:[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>] *Sent:* Monday, October 19, 2020
> 8:14 AM *To:* Michael Richardson <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>>; 6man WG <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> *Cc:* Templin (US), Fred L
> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
> *Subject:* Re: Starlink --- "simpler than IPv6"____
>
> __ __
>
> ____
>
> Thanks Michael, I'd like to know as much as possible how IPv6 works
> in Starlink.____
>
> __ __
>
> Behcet____
>
> __ __
>
> On Fri, Oct 16, 2020 at 3:47 PM Michael Richardson <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:____
>
> Anyone read anything more specific about what Starlink is doing that
> is "simpler than IPv6"?
>
> I'd sure like to know that it permits end-terminal to end-terminal
> communicatons without a trip through a data center.
>
> -- ]               Never tell me the odds!                 | ipv6
> mesh networks [ ]   Michael Richardson, Sandelman Software Works
> |    IoT architect   [ ] [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
> http://www.sandelman.ca/ <http://www.sandelman.ca/>        | ruby on
> rails    [
>
>
> ____
>
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list [email-masked]<mailto:[email-masked]> Administrative
> Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 20 Oct 2020 09:56:53 -0500

Hi Fred,

> (e.g., cars, drones, helicopters, planes, etc.). Because it comes from

Yes, Starlink certainly aims at connecting Tesla cars to their network,
they are currently connected with 4G links

Do you think that 12GHz causes issues on mobile vehicular platforms?

Behcet

> Thanks - Fred
>
>
>
> *From:* ipv6 [mailto:[email-masked]] *On Behalf Of *Behcet Sarikaya
> *Sent:* Monday, October 19, 2020 12:17 PM
> *To:* Alexandre Petrescu <[email-masked]>
> *Cc:* 6man WG <[email-masked]>
> *Subject:* Re: Starlink --- "simpler than IPv6"
>
>
>
>
>
> On Mon, Oct 19, 2020 at 11:12 AM Alexandre Petrescu <
> [email-masked]> wrote:
>
>
>
> > <[email-masked] <mailto:[email-masked]>>
> > wrote:
> >
> > *From:*Behcet Sarikaya [mailto:[email-masked]
> > <mailto:[email-masked]>] *Sent:* Monday, October 19, 2020
> > 8:14 AM *To:* Michael Richardson <[email-masked]
> > <mailto:[email-masked]>>; 6man WG <[email-masked]
> > <mailto:[email-masked]>> *Cc:* Templin (US), Fred L
> > <[email-masked] <mailto:[email-masked]>>
> > On Fri, Oct 16, 2020 at 3:47 PM Michael Richardson <[email-masked]
> > <mailto:[email-masked]>> wrote:____
> >
> > |    IoT architect   [ ] [email-masked] <mailto:[email-masked]>
> > IETF IPv6 working group mailing list [email-masked] Administrative
> [email-masked]

---

From: Bob Hinden <[email-masked]>
Date: Tue, 20 Oct 2020 09:50:14 -0700

Can anyone point to a specification on Starlink?

Without that, this thread seems pretty content free.

Bob

> On Oct 20, 2020, at 7:56 AM, Behcet Sarikaya <[email-masked]> wrote:
> 
> Hi Fred,
> 
> On Mon, Oct 19, 2020 at 2:24 PM Templin (US), Fred L <[email-masked]> wrote:
> Behcet,
> 
> 
> 
> It is 12GHz
> 
> 
> 
> Yes, Starlink certainly aims at connecting Tesla cars to their network, they are currently connected with 4G links
> 
> On Mon, Oct 19, 2020 at 11:12 AM Alexandre Petrescu <[email-masked]> wrote:
> 
> 
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 21 Oct 2020 10:11:43 -0500

Hi Bob,

> Without that, this thread seems pretty content free.
I had started this thread with a mail to Fred thinking that as a person
from a major vendor in aviation industry, he Or someone in this list may
have something technical.
That includes yourself as the chair.

Behcet

---

From: Bob Hinden <[email-masked]>
Date: Wed, 21 Oct 2020 08:30:56 -0700

Behcet,

> On Oct 21, 2020, at 8:11 AM, Behcet Sarikaya <[email-masked]> wrote:

> I had started this thread with a mail to Fred thinking that as a person from a major vendor in aviation industry, he Or someone in this list may have something technical.

Thanks, actually I did some searches and couldn’t find anything.  Also couldn’t find an email to try to contact someone at Starlink.  If someone knows anyone there on the technical side, I would be happy to try to see what I could find out.

Bob

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 21 Oct 2020 18:07:15 +0200

Le 21/10/2020 à 17:30, Bob Hinden a écrit :
>> On Tue, Oct 20, 2020 at 11:50 AM Bob Hinden <[email-masked]>
>> wrote: Can anyone point to a specification on Starlink?
>> 
>> I had started this thread with a mail to Fred thinking that as a
>> person from a major vendor in aviation industry, he Or someone in
>> this list may have something technical. That includes yourself as
>> the chair.
> 
> Thanks, actually I did some searches and couldn’t find anything.
> Also couldn’t find an email to try to contact someone at Starlink.
> If someone knows anyone there on the technical side, I would be happy
> to try to see what I could find out.

Thanks for the explanation.

I heard these discussions about Starlink Beta testing available to 
someone situated in USA.  It's said that it is probably sufficient to 
subscribe to a newsletter and then they might contact back.

Alex

>>> <[email-masked]> wrote:
>>> 
>>> Hi Fred,
>>> 
>>> On Mon, Oct 19, 2020 at 2:24 PM Templin (US), Fred L
>>> <[email-masked]> wrote: Behcet,
>>> 
>>> 
>>> 
>>> It is 12GHz
>>> 
>>> 
>>> 
>>> Yes, Starlink certainly aims at connecting Tesla cars to their
>>> network, they are currently connected with 4G links
>>> 
>>> Behcet Thanks - Fred
>>> From: ipv6 [mailto:[email-masked]] On Behalf Of Behcet
>>> Sarikaya Sent: Monday, October 19, 2020 12:17 PM To: Alexandre
>>> Petrescu <[email-masked]> Cc: 6man WG
>>> <[email-masked]> Subject: Re: Starlink --- "simpler than IPv6"
>>> 
>>> 
>>> 
>>> 
>>> 
>>>> Seems like an “IPv6-over-foo” document might be in order;
>>>> anyone care to____
>>>> 
>>>> join me on that?____
>>>> 
>>>> __
>>>> 
>>>> 
>>> One in USA could look at the regulator's public database and find
>>> which frequency channel is allocated for Tesla for Starlink.
>>> 
>>> 
>>> 
>>> 
>>> 
>>> It is 12GHz
>>> 
>>> 
>>> 
>>> From that, one could find which encoders are available on that
>>> frequency.  From that one could find which protocols are on it.
>>> It makes for a 'foo' in 'IPv6 over foo'.  The link layer.
>>> 
>>> 
>>> 
>>>> <mailto:[email-masked]>] *Sent:* Monday, October 19,
>>>> 2020 8:14 AM *To:* Michael Richardson <[email-masked] 
>>>> Thanks Michael, I'd like to know as much as possible how IPv6
>>>> works in Starlink.____
>>>> 
>>>> __ __
>>>> 
>>>> Behcet____
>>>> 
>>>> __ __
>>>> 
>>>> On Fri, Oct 16, 2020 at 3:47 PM Michael Richardson
>>>> <[email-masked] <mailto:[email-masked]>> wrote:____
>>>> 
>>>> Anyone read anything more specific about what Starlink is doing
>>>> that is "simpler than IPv6"?
>>>> 
>>>> I'd sure like to know that it permits end-terminal to
>>>> end-terminal communicatons without a trip through a data
>>>> center.
>>>> 
>>>> -- ]               Never tell me the odds!                 |
>>>> ipv6 mesh networks [ ]   Michael Richardson, Sandelman Software
>>>> Works |    IoT architect   [ ] [email-masked]
>>>> <mailto:[email-masked]> http://www.sandelman.ca/
>>>> <http://www.sandelman.ca/>        | ruby on rails    [
>>>> 
>>>> 
>>>> ____
>>>> 
>>>>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 21 Oct 2020 18:19:59 +0200

Le 20/10/2020 à 16:56, Behcet Sarikaya a écrit :
> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Behcet,____
> 
>     __ __
> 
>     It is 12GHz ____
> 
>     __ __
> 
>     Would that frequency spectrum be compatible for use on mobile
>     vehicular platforms____
> 
>     (e.g., cars, drones, helicopters, planes, etc.). Because it comes
>     from Tesla, can we____
> 
>     expect at least cars?____
> 
>     __
> 
> 

There is a question to be raised on whether the Tesla car talks to 
satellite or talks to ground station.  In this latter case, that I think 
more likely, it would be like when a Tesla car talks to a 4G Base Station.

> Do you think that 12GHz causes issues on mobile vehicular platforms?

12GHz is higher than anything a typical car uses.

Not sure what kind of issues that could cause.

Alex
> 
> Behcet
> 
>     __
> 
>     Thanks - Fred____
> 
>     __ __
> 
>     *From:*ipv6 [mailto:[email-masked]
>     <mailto:[email-masked]>] *On Behalf Of *Behcet Sarikaya
>     *To:* Alexandre Petrescu <[email-masked]
>     <mailto:[email-masked]>>
>     *Cc:* 6man WG <[email-masked] <mailto:[email-masked]>>
>     On Mon, Oct 19, 2020 at 11:12 AM Alexandre Petrescu
>     <[email-masked] <mailto:[email-masked]>>
>     wrote:____
> 
> 
> 
>         > <[email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked]
>         <mailto:[email-masked]>>>
>         > wrote:
>         > 
>         frequency channel is allocated for Tesla for Starlink. ____
> 
>     __ __
> 
>     __ __
> 
>     It is 12GHz ____
> 
>     __ __
> 
>          From that, one
>         over foo'.  The link layer.____
> 
>     __ __
> 
>     I don't know how to do these?____
> 
>     __ __
> 
>     Behcet ____
> 
>         Alex
> 
> 
>         > 
>         > Behcet
>         > 
>         > __
>         > 
>         > Fred____
>         > 
>         > __ __
>         > 
>         > *From:*Behcet Sarikaya [mailto:[email-masked] <mailto:[email-masked]>
>         > <mailto:[email-masked] <mailto:[email-masked]>>] *Sent:*
>         Monday, October 19, 2020
>         > 8:14 AM *To:* Michael Richardson <[email-masked] <mailto:[email-masked]>
>         > <mailto:[email-masked] <mailto:[email-masked]>>>; 6man WG
>         <[email-masked] <mailto:[email-masked]>
>         > <mailto:[email-masked] <mailto:[email-masked]>>> *Cc:* Templin (US), Fred L
>         > <[email-masked] <mailto:[email-masked]>
>         <mailto:[email-masked]
>         <mailto:[email-masked]>>>
>         > On Fri, Oct 16, 2020 at 3:47 PM Michael Richardson <[email-masked] <mailto:[email-masked]>
>         > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:____
>         > 
>         <mailto:[email-masked] <mailto:[email-masked]>>
>         > http://www.sandelman.ca/ <http://www.sandelman.ca/>
>         <http://www.sandelman.ca/ <http://www.sandelman.ca/>>        |
>         ruby on
>         > rails    [
>         > 
>         > 
>         > ____
>         > 
>         > 
>         > IETF IPv6 working group mailing list [email-masked] <mailto:[email-masked]> Administrative
>         <https://www.ietf.org/mailman/listinfo/ipv6>
>         [email-masked] <mailto:[email-masked]>
>         Administrative Requests:
>         https://www.ietf.org/mailman/listinfo/ipv6
>         <https://www.ietf.org/mailman/listinfo/ipv6>
>         --------------------------------------------------------------------____
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 21 Oct 2020 18:43:44 +0200

on another hand, some reports of reports of reports, seem to mention 
that the antenna is fixed and steered by motors somehow.  The photos 
show the classical 'dishes'.

This kind of antenna does not work if situated in an automobile, while 
the automobile moves at typical speeds.  There is another kind of 
antenna which is necessary: flat and with 'beam-forming'.

Alex

Le 21/10/2020 à 18:19, Alexandre Petrescu a écrit :
>>         >         >         > On Mon, Oct 19, 2020 at 10:20 AM Templin 
>> (US), Fred L         > <[email-masked] 
>> <mailto:[email-masked]>
>>         > wrote:
>>         >         > Seems like an “IPv6-over-foo” document might be in 
>> order; anyone care
>>         > to____
>>         >         > join me on that?____
>>         >         > __
>>         >         >         > IPv6-over-foo on Starlink section would 
>> look like
>>         >         > TBD until more is revealed
>>
>>         >         > Behcet
>>         >         > __
>>         >         > Fred____
>>         >         > __ __
>>         >         > *From:*Behcet Sarikaya 
>> [mailto:[email-masked] <mailto:[email-masked]>
>>         > <mailto:[email-masked] 
>> <mailto:[email-masked]>>] *Sent:*
>>         Monday, October 19, 2020
>>         > 8:14 AM *To:* Michael Richardson <[email-masked] 
>> <mailto:[email-masked]>
>>         > <mailto:[email-masked] <mailto:[email-masked]>>>; 6man WG
>>         > <mailto:[email-masked] <mailto:[email-masked]>>> *Cc:* Templin 
>> (US), Fred L
>>         > <[email-masked] <mailto:[email-masked]>
>>         > *Subject:* Re: Starlink --- "simpler than IPv6"____
>>         >         > __ __
>>         >         > ____
>>         >         > Thanks Michael, I'd like to know as much as 
>> possible how IPv6 works         > in Starlink.____
>>         >         > __ __
>>         >         > Behcet____
>>         >         > __ __
>>         >         > On Fri, Oct 16, 2020 at 3:47 PM Michael Richardson 
>> <[email-masked] <mailto:[email-masked]>
>>         > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:____
>>         >         > Anyone read anything more specific about what 
>> Starlink is doing that
>>         > is "simpler than IPv6"?
>>         >         > I'd sure like to know that it permits end-terminal 
>> to end-terminal         > communicatons without a trip through a data 
>> center.
>>         >         > -- ]               Never tell me the odds!        
>>          | ipv6         > mesh networks [ ]   Michael Richardson, 
>> Sandelman Software Works
>>         > |    IoT architect   [ ] [email-masked] 
>> <mailto:[email-masked]>
>>         > http://www.sandelman.ca/ <http://www.sandelman.ca/>
>>         > rails    [
>>         >         >         > ____
>>         >         >         > 
>>         > IETF IPv6 working group mailing list [email-masked] 
>> <mailto:[email-masked]> Administrative
>>         > Requests: https://www.ietf.org/mailman/listinfo/ipv6
>>         > 
>>         >

---

From: Bob Hinden <[email-masked]>
Date: Wed, 21 Oct 2020 09:52:07 -0700

Alex,

> On Oct 21, 2020, at 9:07 AM, Alexandre Petrescu <[email-masked]> wrote:
> 
> 
> I heard these discussions about Starlink Beta testing available to someone situated in USA.  It's said that it is probably sufficient to subscribe to a newsletter and then they might contact back.

I signed up for the beta, but haven’t heard back.  I will report back if I learn anything.

Suggest we pause this conversation until we get some data.

Bob