Subject: Re: Embedding IP information in an IPv6 address (OMNI)

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 15 Oct 2020 18:40:25 +0000

Hi Bob,

> -----Original Message-----
> From: Bob Hinden [mailto:[email-masked]]
> Sent: Thursday, October 15, 2020 11:33 AM
> To: Templin (US), Fred L <[email-masked]>
> Cc: Bob Hinden <[email-masked]>; Ole Trøan <[email-masked]>; IPv6 List <[email-masked]>; [email-masked]
> Subject: Re: Embedding IP information in an IPv6 address (OMNI)
> 
> > On Oct 15, 2020, at 11:14 AM, Templin (US), Fred L <[email-masked]> wrote:
> >
> > Hi Ole,
> >
> >> -----Original Message-----
> >> From: [email-masked] [mailto:[email-masked]]
> >> Sent: Thursday, October 15, 2020 10:40 AM
> >> To: Templin (US), Fred L <[email-masked]>
> >> Cc: Philip Homburg <[email-masked]>; 6man WG <[email-masked]>; [email-masked]
> >> Subject: Re: [atn] [EXTERNAL] Re: Embedding IP information in an IPv6 address (OMNI)
> >> Fred,
> >>
> >>> There are many reasons why I like what we have already, but one that I will point out
> >>> is the ease of constructing a routable OMNI site-local address (SLA) from a non-routable
> >>> OMNI link-local address (LLA). For an OMNI LLA such as fe80:2001:db8:1:2:: all that is
> >>> needed to turn it into an OMNI SLA is to set bit #9 to yield fec0:2001:db8:1:2::. That is
> >>> computationally very simple and allows a single-bit translation between LLAs and SLAs
> >>> (to get an LLA, clear bit #9 and to get an SLA se bit #9). If instead the LLA had the
> >>> embedded prefix in bits 64 thru 127, the translation between SLAs and LLAs would
> >>> be much more expensive.
> >>
> >> The use of site locals also sets limitations of addressing/routing in the underlay.
> >
> > This is rather about addressing/routing in the *overlay*.
> >
> >> With regards to performance. Is the conversion between SLA/LLA something you do per packet?
> >> If not, I'm unsure I see why optimising that is beneficial.
> >
> > Per-packet - a simple bit-flip changes the address from SLA to LLA or vice-versa.
> 
> Umm, that would break the transport protocol checksum.

Good point, and that brings into focus the need for RFC2473 encapsulation.
If you want a packet with IPv6 link-local addresses (LLAs) to go more than
one hop, encapsulate it in an IPv6 header with the same LLAs and then
flip the bit to turn them into SLAs. Then, present the (encapsulated) packet
to the IPv6 overlay routing system.

Thanks - Fred

> Bob
> 
> 
> >
> > Thanks - Fred
> >
> >> Cheers,
> >> Ole=
> >
> > --------------------------------------------------------------------
> > IETF IPv6 working group mailing list
> > [email-masked]
> > Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> > --------------------------------------------------------------------

---

From: Bob Hinden <[email-masked]>
Date: Thu, 15 Oct 2020 11:43:12 -0700

Fred,

> On Oct 15, 2020, at 11:40 AM, Templin (US), Fred L <[email-masked]> wrote:
> 
>>>>> 
>>>> 

If you want the packets to go more than one hop, then don’t use link-local addresses.

Bob