Subject: Re: [v6ops] Scope of Unique Local IPv6 Unicast Addresses (Fwd: New Version Notification for draft-gont-6man-ipv6-ula-scope-00.txt)

From: "Templin (US), Fred L" <[email-masked]>
Date: Thu, 18 Feb 2021 19:46:03 +0000

Fernando,

Intending to answer both your message and the previous from David together:

> -----Original Message-----
> From: Fernando Gont [mailto:[email-masked]]
> Sent: Thursday, February 18, 2021 11:28 AM
> To: Templin (US), Fred L <[email-masked]>; IPv6 Operations <[email-masked]>; [email-masked]
> Subject: Re: [v6ops] Scope of Unique Local IPv6 Unicast Addresses (Fwd: New Version Notification for draft-gont-
> 6man-ipv6-ula-scope-00.txt)
>
> Hi, Fred,
> 
> On 18/2/21 16:11, Templin (US), Fred L wrote:
> [...]
> >> On 18/2/21 14:37, Templin (US), Fred L wrote:
> >>> Another aspect I failed to mention is that the use of (H)HITs does not
> >>> necessarily  mean that all aspects of the HIP protocol must be used. (H)HITs could be
> >>> used with the AERO/OMNI services instead, for example.
> >>
> >> Questions: Are these addresses globally-unique?
> >
> > Yes - global uniqueness is a key objective of (H)HIT. Aggregation is not within
> > scope, however.
> 
> If that's the case, then, according to RFC4007, they are global addresses.

I actually think HITs are a bit of a gray area. According to RFC7343, they are
formed from the GUA prefix 2001:20::/28 but the remaining bits following
the ::/28 prefix are cryptographically generated and hence non-aggregatable.
That means that there is no way to represent a group of them in the routing
system using any other prefix length than /128.
 
> (I'd argue that if they cannot be aggregated, that's because they
> resulting "addresses" are not really topologically-dependent, in which
> case you might probably argue that they are not addresses in the first
> place :-) )

Not in terms of routing across the global Internet, no, because it would not
scale to inject large numbers of /128's into the global Internet routing system.
But, on a limited scale, that may not be so much of a concern - for example,
in a small Mobile Ad-hoc Network (MANET) where there may be some small
numbers of 10's of nodes each wanting to inject their own /128 into the
MANET routing protocol.

In that case, the node might be able to use its HIT for MANET-local addressing,
i.e., use it as the source/destination address of IPv6 packets within the scope
of the MANET as long as they do not leak out into the public Internet. That is
not to say that the node might not want to get a true GUA for itself as well;
for example, via DHCPv6 from an infrastructure node that the MANET
connects to.

So, then the node could get two different types of GUAs; a HIT for MANET-local
(infrastructure-less) communications and a true GUA for communications with
Internet nodes. So, two different types of GUAs - each with a different scope.

Fred

> 
> Thanks,
> --
> Fernando Gont
> SI6 Networks
> e-mail: [email-masked]
> PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492
> 
> 
>

---

From: Fernando Gont <[email-masked]>
Date: Thu, 18 Feb 2021 16:52:48 -0300

On 18/2/21 16:46, Templin (US), Fred L wrote:
[...]
> the ::/28 prefix are cryptographically generated and hence non-aggregatable.

BUt according to RFC4007, the scope is defined by the topological span 
where the address is meaningful....

> system using any other prefix length than /128.

That's not a requirement when it comes to "scope".

> scale to inject large numbers of /128's into the global Internet routing system.

The thing is that if they don't represent a location in the network 
topology, they don't seem to qualify as an address, anyway.

An address is supposed to be a topologically-dependent identifier -- 
i.e., to convey information of location ("where?").

Thanks,

---

From: Ted Lemon <[email-masked]>
Date: Thu, 18 Feb 2021 16:05:47 -0500

> system using any other prefix length than /128.

RFC 4007 doesn’t say that they can be aggregated. It just says that they are globally unique.