Subject: Murray Kucherawy's Discuss on draft-ietf-6man-ipv6-alt-mark-08: (with DISCUSS and COMMENT)

From: Murray Kucherawy via Datatracker <[email-masked]>
Date: Wed, 11 Aug 2021 23:18:07 -0700

Murray Kucherawy has entered the following ballot position for
draft-ietf-6man-ipv6-alt-mark-08: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-6man-ipv6-alt-mark/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

A procedural question about the IPR disclosures, which I expect we can clear up
during the telechat in a few hours:

Though there have been two IPR disclosures on this document, the shepherd
writeup conspicuously claims there has been no discussion about either.  For at
least one of them the licensing terms indicate a fee may apply.  As this is
seeking Proposed Standard status, I'd like to inquire about this.  In
particular, Section 4 of BCP 79 says:

      A working group may take into
      consideration the results of this procedure in evaluating the
      technology, and the IESG may defer approval when a delay may
      facilitate obtaining such assurances.

I note the "may", but still it feels like an important step was missed here. 
So: Was there an implicit conclusion that the IPR claims don't hinder the
technology?  Or did nobody check it out?  Or did the WG decide consciously not
to worry about it?  Or is it actually fine to just ignore them?

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I support the DISCUSS positions of Lars, Warren, Martin, and Roman.  I'm
particularly interested in Martin's DISCUSS point about the two Experimental
references and their statuses.

That's a lot right there, so in addition from me, just some minor things:

The answer to question 1 of the shepherd document is not complete.

Section 1:

* "... an on-path telemetry technique and consists in synchronizing ..." --
s/in/of/

* "... and therefore divide the packet ..." -- s/divide/dividing/ (must match
"synchronizing" and "switching" earlier in the sentence)

OLD:
   The threat model for the application of the Alternate Marking Method
   in an IPv6 domain is reported in Section 6.  As for all the on-path
   telemetry technique, the only definitive solution is that this
   methodology MUST be applied in a controlled domain and therefore the
   application to untrusted domain is NOT RECOMMENDED.
NEW:
   The threat model for the application of the Alternate Marking Method
   in an IPv6 domain is reported in Section 6.  As with all on-path
   telemetry techniques, the only definitive solution is that this
   methodology MUST be applied in a controlled domain and therefore
   application to untrusted domains is NOT RECOMMENDED.

Sections 2, 4, and 6 variably use "behavior" and "behaviour".  I think you need
to pick one and use it consistently.  Same for "analyze" and "analyse" (though
in different sections).

---

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 12 Aug 2021 12:47:06 +0000

Dear Murray,
Thank you for your review. 
Please find my replies inline tagged as [GF].

Regards,

Giuseppe

-----Original Message-----
From: Murray Kucherawy via Datatracker <[email-masked]> 
Sent: Thursday, August 12, 2021 8:18 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Murray Kucherawy's Discuss on draft-ietf-6man-ipv6-alt-mark-08: (with DISCUSS and COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

A procedural question about the IPR disclosures, which I expect we can clear up during the telechat in a few hours:

Though there have been two IPR disclosures on this document, the shepherd writeup conspicuously claims there has been no discussion about either.  For at least one of them the licensing terms indicate a fee may apply.  As this is seeking Proposed Standard status, I'd like to inquire about this.  In particular, Section 4 of BCP 79 says:

I note the "may", but still it feels like an important step was missed here. 
So: Was there an implicit conclusion that the IPR claims don't hinder the technology?  Or did nobody check it out?  Or did the WG decide consciously not to worry about it?  Or is it actually fine to just ignore them?

[GF]: Regarding the discussion on IPRs, I can add that the IPRs related to this document have already been licensed at fair conditions to other companies, so it is most likely that the same conditions will be applied for all the other companies interested to implement such technology. For this reason, I don't think it can hinder the technology development.

I support the DISCUSS positions of Lars, Warren, Martin, and Roman.  I'm particularly interested in Martin's DISCUSS point about the two Experimental references and their statuses.

[GF]: Ok, maybe you can have a look at my answers to them to follow up.

Section 1:

* "... an on-path telemetry technique and consists in synchronizing ..." -- s/in/of/

[GF]: Ok.

* "... and therefore divide the packet ..." -- s/divide/dividing/ (must match "synchronizing" and "switching" earlier in the sentence)

[GF]: Ok.

OLD:

[GF]: Ok. I will replace it.

Sections 2, 4, and 6 variably use "behavior" and "behaviour".  I think you need to pick one and use it consistently.  Same for "analyze" and "analyse" (though in different sections).

[GF]: Sure, I will harmonize the wording.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Thu, 12 Aug 2021 08:21:27 -0700

Hi Giuseppe,

On Thu, Aug 12, 2021 at 5:47 AM Giuseppe Fioccola <
[email-masked]> wrote:

> A procedural question about the IPR disclosures, which I expect we can
> clear up during the telechat in a few hours:
>
> writeup conspicuously claims there has been no discussion about either.
> For at least one of them the licensing terms indicate a fee may apply.  As
> this is seeking Proposed Standard status, I'd like to inquire about this.
> In particular, Section 4 of BCP 79 says:
>
> technology?  Or did nobody check it out?  Or did the WG decide consciously
> not to worry about it?  Or is it actually fine to just ignore them?
>
> [GF]: Regarding the discussion on IPRs, I can add that the IPRs related to
> this document have already been licensed at fair conditions to other
> companies, so it is most likely that the same conditions will be applied
> for all the other companies interested to implement such technology. For
> this reason, I don't think it can hinder the technology development.
>

Thanks for the followup.  The WG doesn't actually have to deal with an IPR
claim directly, but the fact that the shepherd called it out on the
writeup, highlighting that the WG didn't discuss it at all, seemed like a
possible attempt to draw attention to it, so I felt it prudent to make sure
it got a second look.

My DISCUSS ballot is now a "No Objection".

-MSK

---

From: Giuseppe Fioccola <[email-masked]>
Date: Fri, 13 Aug 2021 09:04:12 +0000

Hi Murray,
Thank you for raising this point on the IPRs. I also think it is important to highlight.

Regards,

Giuseppe

From: Murray S. Kucherawy <[email-masked]>
Sent: Thursday, August 12, 2021 5:21 PM
To: Giuseppe Fioccola <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: Murray Kucherawy's Discuss on draft-ietf-6man-ipv6-alt-mark-08: (with DISCUSS and COMMENT)

Hi Giuseppe,

On Thu, Aug 12, 2021 at 5:47 AM Giuseppe Fioccola <[email-masked]<mailto:[email-masked]>> wrote:
----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Thanks for the followup.  The WG doesn't actually have to deal with an IPR claim directly, but the fact that the shepherd called it out on the writeup, highlighting that the WG didn't discuss it at all, seemed like a possible attempt to draw attention to it, so I felt it prudent to make sure it got a second look.

-MSK