Subject: Alvaro Retana's No Objection on draft-ietf-6man-ipv6-alt-mark-08: (with COMMENT)

From: Alvaro Retana via Datatracker <[email-masked]>
Date: Tue, 10 Aug 2021 09:12:02 -0700

Alvaro Retana has entered the following ballot position for
draft-ietf-6man-ipv6-alt-mark-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-6man-ipv6-alt-mark/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

(1) I support the DISCUSS positions from Lars, Roman, and Martin.

(1a) Of special concern to me is Martin's point about the relationship between
this document and rfc8321/8889, and the potential ability to reference this
work without proper review by the ippm WG.  Note that neither RFC is explicit
about the criteria to complete the respective experiments; the Shepherd writeup
for rfc8321 [a] states that "the measurement utility of this extension still is
to be demonstrated at a variety of scales in a plurality of network
conditions." Furthermore, I am not aware of discussions about the maturity of
rfc8321 in the ippm WG.

[a] https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/shepherdwriteup/

(2) There are several references to I-D.fioccola-v6ops-ipv6-alt-mark, which was
replaced by draft-fz-6man-ipv6-alt-mark and ultimately by this document.  IOW,
it looks like this document refers to an old version of itself.  Since the
references are mostly about analysis made in the early drafts, it may be better
to include some of that in an appendix instead.

---

From: Giuseppe Fioccola <[email-masked]>
Date: Wed, 11 Aug 2021 07:43:05 +0000

Dear Alvaro,
Thank you for your review. 
Please find my answers inline tagged as [GF].

Regards,

Giuseppe

-----Original Message-----
From: Alvaro Retana via Datatracker <[email-masked]> 
Sent: Tuesday, August 10, 2021 6:12 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Alvaro Retana's No Objection on draft-ietf-6man-ipv6-alt-mark-08: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

(1a) Of special concern to me is Martin's point about the relationship between this document and rfc8321/8889, and the potential ability to reference this work without proper review by the ippm WG.  Note that neither RFC is explicit about the criteria to complete the respective experiments; the Shepherd writeup for rfc8321 [a] states that "the measurement utility of this extension still is to be demonstrated at a variety of scales in a plurality of network conditions." Furthermore, I am not aware of discussions about the maturity of
rfc8321 in the ippm WG.

[GF]: We already had an offline discussion last year with 6MAN chairs, IPPM chairs and ADs (in particular with Magnus Westerlund). RFC 8321 was originally labeled as Experimental because it came from an experimental deployment. Indeed the initial application of the method was done by using marking fields that are not intended for performance measurements (in case of IPv4, we used two bits from the DSCP fields or the unused bit of the IPv4 header). For this reason, we could not follow the Standards Track in IPPM and the document was considered Experimental, even if the description of the methodology is protocol agnostic and can be applicable to different protocols. Regarding the maturity, I think the experiment, started in 2010, is done (https://datatracker.ietf.org/doc/html/rfc8321#section-5.1) and now the methodology is mature to make it applicable and standard for IPv6. We discussed last year the relationship between this document and RFC 8321 / RFC 8889 with the IPPM chairs (Tommy Pauly and Ian Swett), and they suggested to have RFC 8321 as informative reference. We also asked Mirja Kühlewind, that did the AD review for RFC 8889, and she gave a similar advice. It was also highlighted that, in the case of RFC 8321, Experimental and Informational can be considered at the same maturity level. For this reason, the detailed description of the methodology in RFC8321 has been included in this document to enable the informative reference.

(2) There are several references to I-D.fioccola-v6ops-ipv6-alt-mark, which was replaced by draft-fz-6man-ipv6-alt-mark and ultimately by this document.  IOW, it looks like this document refers to an old version of itself.  Since the references are mostly about analysis made in the early drafts, it may be better to include some of that in an appendix instead.

[GF]: I see. I can remove this reference and report the relevant considerations in the document.

---

From: Alvaro Retana <[email-masked]>
Date: Wed, 11 Aug 2021 04:22:29 -0700

On August 11, 2021 at 3:43:06 AM, Giuseppe Fioccola wrote:

Giuseppe:

Hi!

...
> (1a) Of special concern to me is Martin's point about the relationship
> between this document and rfc8321/8889, and the potential ability to
> reference this work without proper review by the ippm WG. Note that neither
> RFC is explicit about the criteria to complete the respective experiments;
> the Shepherd writeup for rfc8321 [a] states that "the measurement utility of
> this extension still is to be demonstrated at a variety of scales in a
> plurality of network conditions." Furthermore, I am not aware of discussions
> about the maturity of rfc8321 in the ippm WG.
>
> [GF]: We already had an offline discussion last year with 6MAN chairs, IPPM
> chairs and ADs (in particular with Magnus Westerlund). RFC 8321 was
> originally labeled as Experimental because it came from an experimental
> deployment. Indeed the initial application of the method was done by using
> marking fields that are not intended for performance measurements (in case
> of IPv4, we used two bits from the DSCP fields or the unused bit of the IPv4
> header). For this reason, we could not follow the Standards Track in IPPM
> and the document was considered Experimental, even if the description of the
> methodology is protocol agnostic and can be applicable to different
> protocols. Regarding the maturity, I think the experiment, started in 2010,
> is done (https://datatracker.ietf.org/doc/html/rfc8321#section-5.1) and now
> the methodology is mature to make it applicable and standard for IPv6. We
> discussed last year the relationship between this document and RFC 8321 /
> RFC 8889 with the IPPM chairs (Tommy Pauly and Ian Swett), and they
> suggested to have RFC 8321 as informative reference. We also asked Mirja
> Kühlewind, that did the AD review for RFC 8889, and she gave a similar
> advice. It was also highlighted that, in the case of RFC 8321, Experimental
> and Informational can be considered at the same maturity level. For this
> reason, the detailed description of the methodology in RFC8321 has been
> included in this document to enable the informative reference.

Just to be clear, my concern is not about how you're referencing
rfc8321/8889, or even that you're referencing them at all.

My concern is that the contents of this documents related to the
marking methodology have not been explicitly (and publicly) reviewed
by the ippm WG.  The review in 6man seems to have only focused on the
IPv6-specific aspects (headers, etc.), as it should.

This concern goes hand in hand with Martin's point about updating or
obsoleting the original RFCs.  Either action (with the review that it
would require) would also solve any concerns I have.  I'll leave the
discussion to Martin.

Thanks!

Alvaro.

---

From: Giuseppe Fioccola <[email-masked]>
Date: Wed, 11 Aug 2021 12:15:04 +0000

Dear Alvaro,
Please find my reply inline tagged as [GF].

Regards,

Giuseppe

-----Original Message-----
From: Alvaro Retana <[email-masked]> 
Sent: Wednesday, August 11, 2021 1:22 PM
To: Giuseppe Fioccola <[email-masked]>; Martin Duke <[email-masked]>
Cc: The IESG <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: Alvaro Retana's No Objection on draft-ietf-6man-ipv6-alt-mark-08: (with COMMENT)

Giuseppe:

Hi!

...
> reference this work without proper review by the ippm WG. Note that 
> neither RFC is explicit about the criteria to complete the respective 
> experiments; the Shepherd writeup for rfc8321 [a] states that "the 
> measurement utility of this extension still is to be demonstrated at a 
> variety of scales in a plurality of network conditions." Furthermore, 
> I am not aware of discussions about the maturity of rfc8321 in the ippm WG.
>
> [GF]: We already had an offline discussion last year with 6MAN chairs, 
> IPPM chairs and ADs (in particular with Magnus Westerlund). RFC 8321 
> was originally labeled as Experimental because it came from an 
> experimental deployment. Indeed the initial application of the method 
> was done by using marking fields that are not intended for performance 
> measurements (in case of IPv4, we used two bits from the DSCP fields 
> or the unused bit of the IPv4 header). For this reason, we could not 
> follow the Standards Track in IPPM and the document was considered 
> Experimental, even if the description of the methodology is protocol 
> agnostic and can be applicable to different protocols. Regarding the 
> maturity, I think the experiment, started in 2010, is done 
> (https://datatracker.ietf.org/doc/html/rfc8321#section-5.1) and now 
> the methodology is mature to make it applicable and standard for IPv6. 
> We discussed last year the relationship between this document and RFC 
> 8321 / RFC 8889 with the IPPM chairs (Tommy Pauly and Ian Swett), and 
> they suggested to have RFC 8321 as informative reference. We also 
> asked Mirja Kühlewind, that did the AD review for RFC 8889, and she 
> gave a similar advice. It was also highlighted that, in the case of 
> RFC 8321, Experimental and Informational can be considered at the same 
> maturity level. For this reason, the detailed description of the methodology in RFC8321 has been included in this document to enable the informative reference.

Just to be clear, my concern is not about how you're referencing rfc8321/8889, or even that you're referencing them at all.

My concern is that the contents of this documents related to the marking methodology have not been explicitly (and publicly) reviewed by the ippm WG.  The review in 6man seems to have only focused on the IPv6-specific aspects (headers, etc.), as it should.

This concern goes hand in hand with Martin's point about updating or obsoleting the original RFCs.  Either action (with the review that it would require) would also solve any concerns I have.  I'll leave the discussion to Martin.

[GF]: I see your point. I think the approach to update the original RFCs is a viable solution. I don't think this document can obsolete RFC 8321 and RFC 8889, indeed they includes additional techniques which are not mentioned in this document but can be used in future applications of the methodology.

Thanks!

Alvaro.