Subject: Murray Kucherawy's No Objection on draft-ietf-6man-ipv6-alt-mark-08: (with COMMENT)

From: Murray Kucherawy via Datatracker <[email-masked]>
Date: Thu, 12 Aug 2021 07:28:11 -0700

Murray Kucherawy has entered the following ballot position for
draft-ietf-6man-ipv6-alt-mark-08: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-6man-ipv6-alt-mark/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I support the DISCUSS positions of Lars, Warren, Martin, and Roman.  I'm
particularly interested in Martin's DISCUSS point about the two Experimental
references and their statuses.

That's a lot right there, so in addition from me, just some minor things:

The answer to question 1 of the shepherd document is not complete.

Section 1:

* "... an on-path telemetry technique and consists in synchronizing ..." --
s/in/of/

* "... and therefore divide the packet ..." -- s/divide/dividing/ (must match
"synchronizing" and "switching" earlier in the sentence)

OLD:
   The threat model for the application of the Alternate Marking Method
   in an IPv6 domain is reported in Section 6.  As for all the on-path
   telemetry technique, the only definitive solution is that this
   methodology MUST be applied in a controlled domain and therefore the
   application to untrusted domain is NOT RECOMMENDED.
NEW:
   The threat model for the application of the Alternate Marking Method
   in an IPv6 domain is reported in Section 6.  As with all on-path
   telemetry techniques, the only definitive solution is that this
   methodology MUST be applied in a controlled domain and therefore
   application to untrusted domains is NOT RECOMMENDED.

Sections 2, 4, and 6 variably use "behavior" and "behaviour".  I think you need
to pick one and use it consistently.  Same for "analyze" and "analyse" (though
in different sections).

---

From: Giuseppe Fioccola <[email-masked]>
Date: Thu, 12 Aug 2021 15:06:12 +0000

Dear Murray,
Thank you! As mentioned in my previous reply I will address your comments in the next version.

Regards,

Giuseppe

-----Original Message-----
From: Murray Kucherawy via Datatracker <[email-masked]> 
Sent: Thursday, August 12, 2021 4:28 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Murray Kucherawy's No Objection on draft-ietf-6man-ipv6-alt-mark-08: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

I support the DISCUSS positions of Lars, Warren, Martin, and Roman.  I'm particularly interested in Martin's DISCUSS point about the two Experimental references and their statuses.

Section 1:

* "... an on-path telemetry technique and consists in synchronizing ..." -- s/in/of/

* "... and therefore divide the packet ..." -- s/divide/dividing/ (must match "synchronizing" and "switching" earlier in the sentence)

OLD:

Sections 2, 4, and 6 variably use "behavior" and "behaviour".  I think you need to pick one and use it consistently.  Same for "analyze" and "analyse" (though in different sections).