Subject: RE: Adoption Call for <draft-dong-6man-enhanced-vpn-vtn-id>

From: "[email-masked]" <[email-masked]>
Date: Sun, 30 Jan 2022 15:52:10 +0800

Hello All,

I have read this doc and support its adoption with the following conserns.
1. Can we use color and policy consisting of resource aware SIDs to implement VPN+? Here color acts as the VTN resource ID in this doc and segment list of corresponding policy is the path from ingress node to the egress node in the VTN.
2. The title of section 3.1 is VTN Option Insertion. However the method used is encapsulation. Please update the title.

Best Regards,
Zhenqiang Li

[email-masked]
 
From: Huzhibo
Date: 2022-01-29 17:35
To: Bob Hinden; IPv6 List
Subject: RE: Adoption Call for <draft-dong-6man-enhanced-vpn-vtn-id>
Hi WG,
 
I support the adoption of this draft.
 
It defines a simple approach to identify the network-wide isolated resources, which can be useful for network slicing.
 
The VTN resource ID needs to be processed hop-by-hop, thus I think this document is in the right direction.
 
Thanks
Zhibo
> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Bob Hinden
> Sent: Thursday, January 27, 2022 1:49 PM
> To: IPv6 List <[email-masked]>
> Cc: Bob Hinden <[email-masked]>
> Subject: Adoption Call for <draft-dong-6man-enhanced-vpn-vtn-id>
>
> This message starts a two week 6MAN call on adopting:
>
>  Title:          Carrying Virtual Transport Network (VTN) Identifier in IPv6
> Extension
>                  Header
>  Authors:        J. Dong, Z. Li, C. Xie, C. Ma, G. Mishra
>  File Name:      draft-dong-6man-enhanced-vpn-vtn-id-06
>  Document date:  October 24, 2021
>
> https://datatracker.ietf.org/doc/html/draft-dong-6man-enhanced-vpn-vtn-id-06
>
> as a working group document.  Substantive comments and statements of
> support for adopting this document should be sent to the mailing list.
> Editorial suggestions can be sent to the authors.  This adoption call will end on
> 10 February 2022.
>
> Further, if you are willing to work on this document, either as contributor,
> author, or reviewer please notify the list.   This will provide the chairs with an
> indication of the energy level in the working group to work on this document.
>
> Bob & Ole
> 6man Chairs
 
--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Sun, 30 Jan 2022 08:40:05 +0000

Hi Zhenqiang,

Thanks for your support and comment.

Please see some replies inline:

Best regards,
Jie

From: ipv6 [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Sunday, January 30, 2022 3:52 PM
To: Hinden <[email-masked]>; [email-masked]
Subject: RE: Adoption Call for <draft-dong-6man-enhanced-vpn-vtn-id>

Hello All,

[Jie] The mechanism with resource aware SR SIDs is another data plane option for providing VPN+. For scenarios where a relatively large number of VTNs is needed, the resource-aware SID mechanism requires to allocate and maintain a large number of SIDs. The VTN resource ID based data plane provides a more scalable approach in that case.

2. The title of section 3.1 is VTN Option Insertion. However the method used is encapsulation. Please update the title.
[Jie] What we described in section 3.1 is the behavior of the domain edge node to add VTN option to the packet. As you pointed out it may be confused with the insertion/encapsulation modes of SRv6, then we could rephrase it as "Adding VTN Option to Packet". Hope this makes it clearer.

Happy Chinese New Year!

Best regards,
Jie
________________________________
Best Regards,
Zhenqiang Li

[email-masked]<mailto:[email-masked]>

From: Huzhibo<mailto:huzhibo=[email-masked]>
Date: 2022-01-29 17:35
To: Bob Hinden<mailto:[email-masked]>; IPv6 List<mailto:[email-masked]>
Subject: RE: Adoption Call for <draft-dong-6man-enhanced-vpn-vtn-id>
Hi WG,

Thanks
Zhibo
> To: IPv6 List <[email-masked]<mailto:[email-masked]>>
> Cc: Bob Hinden <[email-masked]<mailto:[email-masked]>>

--------------------------------------------------------------------
IETF IPv6 working group mailing list
[email-masked]<mailto:[email-masked]>
Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
--------------------------------------------------------------------