Subject: Close - Adoption calls on HBH drafts

From: [email-masked]
Date: Tue, 18 Jan 2022 11:50:36 +0100

As the 6man chair for this adoption call, I have concluded that there is sufficient interest to adopt both of these documents.

Title: IPv6 Hop-by-Hop Options Processing Procedures
Authors: R. Hinden, G. Fairhurst
File name: draft-hinden-6man-hbh-processing-01

Title: Limits on Sending and Processing IPv6 Extension Headers
Authors: T Herbert
File name: draft-herbert-6man-eh-limits-00

There were quite a few concerns raised during the adoption call, especially regarding limiting protocol extensibility, some quotes below.
I look forward to the working groups considerations on these.

Can the authors of the documents submit draft-6man-*-00 revisions please.

-----
I have concerns about these drafts as standards track documents. They both really mix up pragmatic operational concerns with standardization issues, and they both might prove restrictive for future development if they were committed to the standards track and ended up constraining implementations and procurements.

Just to pick on an example, both of them rely on the concept of "fast path". Maybe a few years from now, the dominant strain of routers will not have a fast path distinct from a "slow path". Also, maybe we will see a transformational change in the MTU problem space.

I don't think the IETF's crystal ball is accurate enough to know where the technology will be ten or twenty years from now. I think all we can do is make some practical recommendations (small "r") for the next few years, as a 6man/v6ops collaboration. There is a lot of good input to that discussion in both these drafts.
-----
Limiting different lengths and options would limit the future of the protocol
But would not help with the current problem that companies do not have a business case to just 1 option of minimal length.
-----
Hope this helps (and sorry for Bob, Gorry, and Tom: good text on a real problem, but I cannot support work that blocks the IP extensions)
-----
The whole activity looks like an attempt to push HbH for the scale of the Internet.
IMHO: it would never happen. Who would pay for additional processing? No business case.
-----

Best regards,
Ole, 6man chair

---

From: Bob Hinden <[email-masked]>
Date: Fri, 21 Jan 2022 08:18:55 -0800

Ole,

Gorry and I are working on a revision to be the first w.g. draft <draft-ietf-6man-hbh-processing-00>.   We should be able to submit it next week.

Bob

> On Jan 18, 2022, at 2:50 AM, [email-masked] wrote:
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

---

From: Tom Herbert <[email-masked]>
Date: Fri, 21 Jan 2022 10:06:23 -0800

Ole,

I will also update draft-herbert-6man-eh-limits-00 and rename next week

Tom