Subject: Call for agenda items IETF 113

From: [email-masked]
Date: Thu, 17 Feb 2022 09:11:49 +0100

The 6MAN chairs are starting the planning for the 6man meetings at IETF 113.
The meeting will be a hybrid one, with some participants in the room and some remote.
I expect to be there physically, while Bob will be chairing the meeting remotely.

If you have a draft you would like to discuss, please send your request for agenda time to the 6man chairs.
Please include in the request, the title of the presentation, file name of the draft, the speaker's name (and email), and how much time you would like.

We will prioritize drafts that are working group items and drafts that have been actively discussed on the IPv6 list. We expect at least half of each talk’s presentation time to be used for open discussion, please plan your presentation accordingly. That is, not too many slides for the time slot.

New drafts not discussed on the mailing list prior to the meeting, or drafts that do not appear to have support from the working group are unlikely to get time at the meeting.

Please send your proposed agenda items to the chairs by 2021-03-09 (March 9th).
Remember the draft cut-off date for all Internet Drafts is 2021-03-07 (March 7th) UTC 23:59.

Best regards,
Bob & Ole

---

From: Ted Lemon <[email-masked]>
Date: Thu, 17 Feb 2022 09:30:17 -0500

I don't have a draft for this, although I suppose I could write one. But we
did have an extended discussion about the issue of longest-match preferring
a foreign ULA that isn't reachable over a GUA that is. I would like to have
a discussion of that if that's okay. I can write up a presentation. The
reason there isn't a draft is that I'm still not sure that what I think
about this is correct, hence the desire for a discussion. If you would
prefer to have a draft, please let me know ASAP since I'll have to get
legal review before publishing. But it should be short and easy to write,
so I don't mind if that's what you prefer.

On Thu, Feb 17, 2022 at 3:13 AM <[email-masked]> wrote:

> Please include in the request, the title of the presentation, file name of
> the draft, the speaker's name (and email), and how much time you would like.
>
> We will prioritize drafts that are working group items and drafts that
> have been actively discussed on the IPv6 list. We expect at least half of
> each talk’s presentation time to be used for open discussion, please plan
> your presentation accordingly. That is, not too many slides for the time
> slot.
>
> New drafts not discussed on the mailing list prior to the meeting, or
> drafts that do not appear to have support from the working group are
> unlikely to get time at the meeting.
>
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------
>

---

From: [email-masked]
Date: Thu, 17 Feb 2022 16:29:58 +0100

Hi Ted,

> I don't have a draft for this, although I suppose I could write one. But we did have an extended discussion about the issue of longest-match preferring a foreign ULA that isn't reachable over a GUA that is. I would like to have a discussion of that if that's okay. I can write up a presentation. The reason there isn't a draft is that I'm still not sure that what I think about this is correct, hence the desire for a discussion. If you would prefer to have a draft, please let me know ASAP since I'll have to get legal review before publishing. But it should be short and easy to write, so I don't mind if that's what you prefer.

If Bob concurs, I don't mind if there is a draft as long as there is some way allowing people to prepare for the session.
That can be posting the presentation early or an email summarizing the previous mail thread / problem.

From a bystander perspective, _my_ reaction to this is along the lines of:
"you can't possibly build networks this way, and this is not a problem source address selection was ever intended to solve".
Assuming I'm not alone, some justification of the problem and desired solution might be a good place to start the session.

Thanks for the request. You didn't mention how much time you need? I would imagine this being a topic that could fill the whole slot. :-)

Best regards,
Ole

---

From: Bob Hinden <[email-masked]>
Date: Thu, 17 Feb 2022 08:26:59 -0800

Ole, Ted,

I am fine with just a presentation on this topic.  It would be good if the presentation could be completed a week before the IETF meeting, we could upload it to make it available to the w.g.

An alternative would be to write a draft that describes the problem (without proposing a solution).

Bob

> On Feb 17, 2022, at 7:29 AM, [email-masked] wrote:
> 
> Hi Ted,
>

---

From: Ted Lemon <[email-masked]>
Date: Thu, 17 Feb 2022 12:01:19 -0500

On Thu, Feb 17, 2022 at 11:27 AM Bob Hinden <[email-masked]> wrote:

> I am fine with just a presentation on this topic.  It would be good if the
> presentation could be completed a week before the IETF meeting, we could
> upload it to make it available to the w.g.
>

That sounds doable. I will do that unless Ole objects strongly. :)

On Feb 17, 2022, at 7:29 AM, [email-masked] wrote:

> "you can't possibly build networks this way, and this is not a problem
> source address selection was ever intended to solve".
> Assuming I'm not alone, some justification of the problem and desired
> solution might be a good place to start the session.
>

I can't argue with that. The goal is more prevention of
difficult-for-laypersons-to-debug outcomes than any advice on good network
design.

> Thanks for the request. You didn't mention how much time you need? I would
> imagine this being a topic that could fill the whole slot. :-)
>

I'd suggest putting it at the end except that risks not having time. I
guess I'll propose 20 minutes, and keep the presentation to five, and you
can see how much time you actually have and counter accordingly. :)