Subject: [ire] Data escrow deposit validation tool

From: Gustavo Lozano <[email-masked]>
Date: Wed, 13 Mar 2013 06:52:27 -0700

Colleagues,

The Internet Draft: http://www.ietf.org/id/draft-arias-noguchi-dnrd-objects-mapping-02.txt, describes a "Data escrow agent extended verification" process.

The data escrow deposits are valuable if they can be used when needed, basically during an emergency.

The creation of an open source data escrow deposit validation tool is an important step to mitigate risks related to the quality of the escrow deposit. This tool could be used by data escrow agents, registries and EBEROs.

Who is interested in participating in the development of such a tool?

Basically, the tool should receive as input a full and optionally several differential deposits. After applying the deltas the tool should perform the tests listed in the draft. The tool should be able to handle deposits of at least several millions of objects.

Regards,
Gustavo

---

From: "Gould, James" <[email-masked]>
Date: Wed, 13 Mar 2013 21:35:53 +0000

Gustavo,

The "Data escrow agent extended verification" fundamentally changes the responsibilities of a data escrow provider, which can and will increase the cost of the data escrow.  Data escrow providers today are responsible for ensuring the completeness of the deposits and for storing them.  They have no idea of the data content including its syntactic and semantic structure.  Right now the extended validation process is optional in the draft, but if and when it becomes a requirement for the data escrow providers, it would need to be vetted out by the broader community.

If extended validation does become a requirement, then a standardized open source tool is a good idea and is  a minimum requirement to ensure that all data escrow providers execute the same validation.  We may be able to contribute to this effort.

Thanks,

--

JG

James Gould
Principal Software Engineer
[email-masked]

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

From: Gustavo Lozano <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 13, 2013 9:52 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [ire] Data escrow deposit validation tool

Colleagues,

Regards,
Gustavo

---

From: Gustavo Lozano <[email-masked]>
Date: Thu, 21 Mar 2013 12:11:17 -0700

James,

For new gTLDs, the extended verification process has been part of the AGB for a long time.

See Specification 2, Part A, 8, (5):
" (5) If [1] includes a verification process, that will be applied at this step.
If any discrepancy is found in any of the steps, the Deposit will be considered incomplete."

For current gTLDs, several escrow specifications have similar provisions. For example, .org has the following:
"4. Escrow Agent will run a program (to be supplied by ICANN) on the Deposit file (without report) that will ..."

As part of the application for becoming a new gTLD data escrow agent, the prospect escrow agent must implement the extended verification process:
"If this application is approved, Applicant will implement (or use the official ICANN open source developed data escrow deposit testing suite) the extended verification procedure of the data escrow deposit files in less than 30 days after publication by ICANN." (http://newgtlds.icann.org/en/announcements-and-media/announcement-07mar13-en)

ICANN has the responsibility to preserve the security and stability of the DNS, the EBERO program for example is part of this commitment for new gTLDs. The risk of not usable data escrow deposit is a risk worth mitigating. The extended verification process is one of the mitigation strategies for this risk.

As mentioned before, we are willing to contribute to an open source tool to verify the escrow deposits.

Regards,
Gustavo

From: <Gould>, James <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 13, 2013 2:35 PM
To: Gustavo Lozano <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ire] Data escrow deposit validation tool

Gustavo,

Thanks,

--

JG

James Gould
Principal Software Engineer
[email-masked]<mailto:[email-masked]>

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

Colleagues,

Regards,
Gustavo

---

From: "Gould, James" <[email-masked]>
Date: Thu, 21 Mar 2013 19:26:53 +0000

Gustavo,

The AGB doesn't say anything about an "extended" verification as you describe.  The verification process in the AGB could be a verification of the completeness and the syntax of the deposits, so your claim that it has been part of the AGB for a long time is not true.  I'm not going to comment on the contents of the gTLD data escrow agent application.

Jim

________________________________
From: Gustavo Lozano [[email-masked]]
Sent: Thursday, March 21, 2013 3:11 PM
To: Gould, James; [email-masked]
Subject: Re: [ire] Data escrow deposit validation tool

James,

Regards,
Gustavo

From: <Gould>, James <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 13, 2013 2:35 PM
To: Gustavo Lozano <[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [ire] Data escrow deposit validation tool

Gustavo,

Thanks,

--

JG

James Gould

703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

From: Gustavo Lozano <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 13, 2013 9:52 AM
To: "[email-masked]<mailto:[email-masked]>>
Subject: [ire] Data escrow deposit validation tool

Colleagues,

Regards,
Gustavo