Subject: [ire] Escrow deposit watermark

From: James Mitchell <[email-masked]>
Date: Wed, 20 Mar 2013 11:38:18 +1100

All,

This email is primarily targeted towards ICANN and the draft registry agreement, however posting here for feedback from others who are implementing escrow.

Our proposed escrow solution would produce deposits for all transactions committed up to the point in time that the extract is generated. This may be considered contrary to the base agreement, where deposits must reflect the state of the registry as at 00:00 UTC. As we will generate full deposits every day, each deposit would include the state of the registry as at 00:00, plus the state of the registry including transactions committed up until the generation of the deposit. We do not perceive this as a lesser service, given the escrowed data is more up-to-date, unless there are other reasons for the 00:00 requirement that are unknown to us. Is the proposed solution considered acceptable given the requirements outlined in the base agreement?

It should be noted that acceptance of the above will require that escrow deposit validation does not check for the presence of date-times, for example domain creation date, that are after 00:00 UTC. If date-time validation is deemed required, the validator should ensure that no date-time is greater than the watermark.

Further to this, we seek confirmation that in the event of a failed deposit, a subsequent full deposit representing the current state of the registry database would constitute remedy. ARI would not provide a full deposit of the state of the registry database as at the time of the previous failed deposit.

Comments/feedback welcome.

Regards,
James

---

From: Francisco Obispo <[email-masked]>
Date: Tue, 19 Mar 2013 18:57:26 -0700

Hi James,

We have thought about this as well, and I agree with you. The requirement should be of a daily deposit (full or incremental), I don't see a value of having the state of the registry at a specific time.

> Our proposed escrow solution would produce deposits for all transactions committed up to the point in time that the extract is generated. This may be considered contrary to the base agreement, wher…

Francisco Obispo 
Director of Applications and Services - ISC
email: [email-masked]
Phone: +1 650 423 1374 || INOC-DBA *3557* NOC
PGP KeyID = B38DB1BE

---

From: Bhadresh Modi <[email-masked]>
Date: Wed, 20 Mar 2013 10:01:41 -0400

We've had the same concern and some of our account managers have raised the
issue before with icann.

Another thing to point out is that even if all processes to esrow all
registries are started at 00:00 UTC with that watermark, there may be a
problem which causes an escrow to fail.  Restarting the process then will
begin a new escrow but it may be impossible to return to the state at
exactly 00:00 UTC.  Again as pointed out before, this new deposit file
would contain all information as of 00:00 UTC and also include any new
transactions taken place after that time.

The validation should be that no date/times within the escrow file are
newer than the watermark, and that the watermark is for the correct day
(not some date/time in the future).

Regards,
Bhadresh Modi
[email-masked]

On Tue, Mar 19, 2013 at 9:57 PM, Francisco Obispo <[email-masked]> wrote:

> Hi James,
>
> We have thought about this as well, and I agree with you. The requirement
> should be of a daily deposit (full or incremental), I don't see a value of
> having the state of the registry at a specific time.
>
>
>
>
> On Mar 19, 2013, at 5:38 PM, James Mitchell <
> [email-masked]> wrote:
>
> > Our proposed escrow solution would produce deposits for all transactions
> committed up to the point in time that the extract is generated. This may
> be considered contrary to the base agreement, where deposits must reflect
> the state of the registry as at 00:00 UTC. As we will generate full
> deposits every day, each deposit would include the state of the registry as
> at 00:00, plus the state of the registry including transactions committed
> up until the generation of the deposit. We do not perceive this as a lesser
> service, given the escrowed data is more up-to-date, unless there are other
> reasons for the 00:00 requirement that are unknown to us. Is the proposed
> solution considered acceptable given the requirements outlined in the base
> agreement?
> >
>
> Francisco Obispo
> _______________________________________________
> ire mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ire
>

---

From: Gustavo Lozano <[email-masked]>
Date: Thu, 21 Mar 2013 16:16:59 -0700

James,

Comments inline.

Regards,
Gustavo

From: James Mitchell <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, March 19, 2013 5:38 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [ire] Escrow deposit watermark

All,

Unfortunately no.

The reason for this requirement is our audit process. One of the projected tests is the correlation of data from different sources: monthly reports, escrow deposits, bulk registration data and DNS zone.

Regards,
James