Subject: [ire] New versions of data escrow drafts

From: Gustavo Lozano <[email-masked]>
Date: Tue, 12 Mar 2013 07:54:46 -0700

Colleagues,

Two new versions of the data escrow drafts have been
published:
* http://www.ietf.org/id/draft-arias-noguchi-dnrd-objects-mapping-02.txt
* http://www.ietf.org/id/draft-arias-noguchi-registry-data-escrow-05.txt

These drafts incorporate feedback received in this list and
private emails.

The authors of draft-arias-noguchi-dnrd-objects-mapping and
draft-gould-thippeswamy-dnrd-csv-mapping agreed to merge both drafts to
create
a single specification that supports XML only and XML+CSV.

The data elements/objects in both drafts have been
normalized.

The authors of draft-gould-thippeswamy-dnrd-csv-mapping will
publish a new version of the CSV draft before the merge of both drafts.

The new version (03) of the draft draft-arias-noguchi-dnrd-objects-mapping
is going to include both models (XML only and XML+CSV).

Version 03 should include only minor changes to the data
escrow specification.

If you are attending the IETF 86 meeting and want to talk
about data escrow, please send me an email and we can arrange an informal
meeting.

Regards,
Gustavo Lozano

---

From: Chris Wright <[email-masked]>
Date: Wed, 13 Mar 2013 11:35:14 +1100

Thanks Gustavo,

We are still a little unsure as to why it is XML + CSV, and not just simply CSV?

The choices should be XML or CSV..

Thanks

Chris

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Gustavo Lozano
Sent: Wednesday, 13 March 2013 1:55 AM
To: [email-masked]
Subject: [ire] New versions of data escrow drafts

Colleagues,

These drafts incorporate feedback received in this list and private emails.

The authors of draft-arias-noguchi-dnrd-objects-mapping and draft-gould-thippeswamy-dnrd-csv-mapping agreed to merge both drafts to create a single specification that supports XML only and XML+CSV.

The data elements/objects in both drafts have been normalized.

The authors of draft-gould-thippeswamy-dnrd-csv-mapping will publish a new version of the CSV draft before the merge of both drafts.

Version 03 should include only minor changes to the data escrow specification.

If you are attending the IETF 86 meeting and want to talk about data escrow, please send me an email and we can arrange an informal meeting.

Regards,
Gustavo Lozano

_______________________________________________
ire mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ire

---

From: Francisco Obispo <[email-masked]>
Date: Tue, 12 Mar 2013 19:46:52 -0700

Or just simply xml!

I've done my testing and the resulting compressed xml files are similar if not smaller than the csv alternative

Sent from my iPhone

---

From: Wil Tan <[email-masked]>
Date: Wed, 13 Mar 2013 14:21:11 +1100

> not smaller than the csv alternative

Did you test compressed xml against plain or compressed csv?

.wil

---

From: Francisco Obispo <[email-masked]>
Date: Tue, 12 Mar 2013 20:23:49 -0700

Yes, of course.

I loaded 400k domains into my database, exported using both formats, compressed both results with bz2, the end files ended up being about 10MB. (over 300MB compressed).

> Did you test compressed xml against plain or compressed csv?

Francisco Obispo 
Director of Applications and Services - ISC
email: [email-masked]
Phone: +1 650 423 1374 || INOC-DBA *3557* NOC
PGP KeyID = B38DB1BE

---

From: Francisco Obispo <[email-masked]>
Date: Tue, 12 Mar 2013 20:30:56 -0700

300 MB uncompressed I meant.

Francisco Obispo

---

From: "Gould, James" <[email-masked]>
Date: Wed, 13 Mar 2013 12:11:49 +0000

Francisco,

I had done some testing a while back that showed that the XML is much
larger uncompressed and is larger compressed.  Compression does a great
job with XML, so the variance is not huge after compression.  The
compressed size is not the only factor in deciding between XML and CSV.  I
believe that we've debated this at length on prior postings, where the
goal now is to merge the drafts into a single draft that supports both
models with a common set of objects and object attributes.

-- 
 
JG

James Gould
Principal Software Engineer
[email-masked]
 
703-948-3271 (Office)
12061 Bluemont Way
Reston, VA 20190
VerisignInc.com

On 3/12/13 11:30 PM, "Francisco Obispo" <[email-masked]> wrote:

>> I loaded 400k domains into my database, exported using both formats,
>>compressed both results with bz2, the end files ended up being about
>>10MB. (over 300MB compressed).
>
>Francisco Obispo

---

From: Gustavo Lozano <[email-masked]>
Date: Wed, 13 Mar 2013 06:14:47 -0700

Thanks Chris,

It's possible that for some objects there may not be a mapping for CSV
(e.g. EPP parameters, IDN practices, header object). We (authors of both
drafts) have not yet made a decission about this.

We just want to leave the door open for the scenario of a data escrow
deposit with some objects in CSV and others in XML.

Regards,

Gustavo

On 3/12/13 5:35 PM, "Chris Wright" <[email-masked]> wrote:

>create a single specification that supports XML only and XML+CSV.
> 
>
>The authors of draft-gould-thippeswamy-dnrd-csv-mapping will publish a
>new version of the CSV draft before the merge of both drafts.
> 
>
>If you are attending the IETF 86 meeting and want to talk about data
>escrow, please send me an email and we can arrange an informal meeting.
> 
>
>Regards,
>Gustavo Lozano
>

---

From: "Gould, James" <[email-masked]>
Date: Wed, 13 Mar 2013 13:17:43 +0000

That is correct.  Objects that are mainly static content like the EPP parameters can be represented in the XML definition file.  

Jim
________________________________________
From: [email-masked] [[email-masked]] on behalf of Gustavo Lozano [[email-masked]]
Sent: Wednesday, March 13, 2013 9:14 AM
To: [email-masked]; [email-masked]
Subject: Re: [ire] New versions of data escrow drafts

Thanks Chris,

Regards,

Gustavo

---

From: Francisco Obispo <[email-masked]>
Date: Tue, 19 Mar 2013 17:28:04 -0700

I just went over the new drafts and found something interesting:

The example XML documents in the draft reference the rdeDomain namespace:

   <rdeDom:domain>
     <rdeDom:name>example1.test</rdeDom:name>
     <rdeDom:roid>Dexample1-TEST</rdeDom:roid>
     <rdeDom:status s="ok"/>
     <rdeDom:registrant>jd1234</rdeDom:registrant>
     <rdeDom:contact type="admin">sh8013</rdeDom:contact>
     <rdeDom:contact type="tech">sh8013</rdeDom:contact>
     <rdeDom:ns>
       <domain:hostObj>ns1.example.com</domain:hostObj>
       <domain:hostObj>ns1.example1.test</domain:hostObj>
     </rdeDom:ns>
     <rdeDom:clID>RegistrarX</rdeDom:clID>
     <rdeDom:crRr client="jdoe">RegistrarX</rdeDom:crRr>
     <rdeDom:crDate>1999-04-03T22:00:00.0Z</rdeDom:crDate>
     <rdeDom:exDate>2015-04-03T22:00:00.0Z</rdeDom:exDate>
   </rdeDom:domain>

but the XML schema is referencing the EPP (Domain) namespace for validation:

(example validation of one of my escrow dump)

[][][][]_2013-03-20_full_S1_R0.ryde:1: element pw: Schemas validity error : Element '{urn:ietf:params:xml:ns:rdeDomain-1.0}pw': This element is not expected. Expected is one of ( {urn:ietf:params:xml:ns:domain-1.0}pw, {urn:ietf:params:xml:ns:domain-1.0}ext ).

So it seems like the schema will need to be modified to include the elements from the EPP schema, (or re-define them), otherwise the schema validation will fail.

Or should I be using the EPP Domain NS instead?

This is part of my escrow dump:

      <rdeDomain:domain>
        <rdeDomain:name>deleteme.[][][][]</rdeDomain:name>
        <rdeDomain:roid>DO_c13a4e438c6471d8ead63a8031d41698-ISC</rdeDomain:roid>
        <rdeDomain:status s="inactive"/>
        <rdeDomain:rgpStatus s="ok"/>
        <rdeDomain:registrant>updateme03</rdeDomain:registrant>
        <rdeDomain:clID>foobar</rdeDomain:clID>
        <rdeDomain:crID>foobar</rdeDomain:crID>
        <rdeDomain:crDate>2013-03-19T16:36:31.961Z</rdeDomain:crDate>
        <rdeDomain:exDate>2014-03-19T16:36:31.961Z</rdeDomain:exDate>
        <rdeDomain:authInfo>
          <rdeDomain:pw>OhXahpatahriomi6</rdeDomain:pw>
        </rdeDomain:authInfo>
      </rdeDomain:domain>

Francisco

Francisco Obispo

---

From: David Kipling <[email-masked]>
Date: Wed, 20 Mar 2013 09:27:47 +0000

Hi Francisco,

You need to use the domain-1.0 namespace for the pw element e.g. if you have xmlns:domain=" urn:ietf:params:xml:ns:domain-1.0" declared then I would expect the change below from:

        <rdeDomain:authInfo>
               < rdeDomain:pw>OhXahpatahriomi6</rdeDomain:pw>
        </rdeDomain:authInfo>

To:

      <rdeDomain:authInfo>
        <domain:pw> OhXahpatahriomi6</domain:pw>
      </rdeDomain:authInfo>

This is because the pw element is declared in domain-1.0 schema and not the rdeDomain-1.0 schema or the eppcom-1.0 schema.  The pw element just conforms to the eppcom-1.0 type of pwAuthInfoType rather than is part of the eppcom-1.0 schema.

I hope this helps

Regards

David

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Francisco Obispo
Sent: 20 March 2013 00:28
To: Gustavo Lozano
Cc: [email-masked]
Subject: Re: [ire] New versions of data escrow drafts

   <rdeDom:domain>

      <rdeDomain:domain>

Francisco

On Mar 12, 2013, at 7:54 AM, Gustavo Lozano <[email-masked]> wrote:

> *
> http://www.ietf.org/id/draft-arias-noguchi-dnrd-objects-mapping-02.txt
> *
> http://www.ietf.org/id/draft-arias-noguchi-registry-data-escrow-05.txt
>
>
> draft-gould-thippeswamy-dnrd-csv-mapping agreed to merge both drafts
> to create a single specification that supports XML only and XML+CSV.
>
>

Francisco Obispo
Director of Applications and Services - ISC
email: [email-masked]
Phone: +1 650 423 1374 || INOC-DBA *3557* NOC PGP KeyID = B38DB1BE

________________________________

David Kipling
Solutions Architect
NCC Group
Manchester Technology Centre,
Oxford Road
Manchester, M1 7EF

Telephone: +44 161 209 5430
Mobile:
Fax:
Website: www.nccgroup.com<http://www.nccgroup.com>
Email:  [email-masked]<mailto:[email-masked]>
        [http://www.nccgroup.com/media/192418/nccgrouplogo.jpg]  <http://www.nccgroup.com/>
________________________________

This email is sent for and on behalf of NCC Group. NCC Group is the trading name of NCC Services Limited (Registered in England CRN: 2802141). Registered Office: Manchester Technology Centre, Oxford Road, Manchester, M1 7EF. The ultimate holding company is NCC Group plc (Registered in England CRN: 4627044).

Confidentiality: This e-mail contains proprietary information, some or all of which may be confidential and/or legally privileged. It is for the intended recipient only. If an addressing or transmission error has misdirected this e-mail, please notify the author by replying to this e-mail and then delete the original. If you are not the intended recipient you may not use, disclose, distribute, copy, print or rely on any information contained in this e-mail. You must not inform any other person other than NCC Group or the sender of its existence.

For more information about NCC Group please visit www.nccgroup.com<http://www.nccgroup.com>

P Before you print think about the ENVIRONMENT

For more information please visit <a href="http://www.mimecast.com">http://www.mimecast.com<br>
This email message has been delivered safely and archived online by Mimecast.
</a>