Subject: RE: [Isis-wg] LSP Buffersize

From: Les Ginsberg <[email-masked]>
Date: Mon, 29 Jan 2001 14:45:51 -0800

I believe what Jeff P. is looking at is the latest draft for Edition 2 of
ISO 10589 as created by the new editor (Micah Bartell) over the past year.
As has been discussed intermittently on this list, an ISO project is in
progress to create a new second edition draft which avoids the pitfalls of
the first attempt back in 1998. This draft is to include the various defect
reports which have been filed via ISO against the spec since 1992 as well as
some new work done by SIF. This work includes changes to detect MTU size
misconfiguration - which was/is a real problem in SONET networks. The paper
Jeff L. refers to is the solution which has been incorporated into the new
draft.

A copy of this draft was posted to this list a few months back. Since that
time a number of comments have been submitted to the editor. At last report
he was creating a comments document for submission along with the draft
which has been scheduled to be voted on by ISO next month. Any further
update on the document status will have to come from the editor.

As far as Jeff P.'s original question - I do not know of any implementation
using this TLV - but I still believe it is a worthwhile addition to the
protocol.

   Les

> -----Original Message-----
> From: Jeff Learman [mailto:[email-masked]]
> Sent: Monday, January 29, 2001 2:06 PM
> To: Jeff Parker; [email-masked]'
> Subject: Re: [Isis-wg] LSP Buffersize
> 
> 
> 
> The buffer size mismatch can be a serious problem in networks
> with varying MTU sizes -- the checks in the standard (1992) version
> of ISO 10589 are not sufficient to detect the problem, and the
> spec does not say what an implementation should do when encountering
> the problem.  For a description of this problem and a recommended
> solution, see Les Ginsberg's paper,
> "http://www.atis.org/pub/sif/arch/ar820310.doc".
> 
> I suspect that Jeff is looking at the draft spec for 10589
> rather than the standard.  The draft spec (the one available at
> the IETF ISIS WG site) has NOT been adopted and MUST NOT be
> considered authoratative.  It is only posted on the site for 
> discussion
> purposes.  That said, the TLV to find the buffer size mismatch
> probably corresponds to Les's recommendation.
> 
> Regards,
> Jeff
> 
> At 03:53 PM 01/29/2001 -0500, Jeff Parker wrote:
> >	IS-IS has a couple of checks to make sure that all routers
> >in the networks can deal with a common LSP buffersize.  First, 
> >(some) Hello packets are padded to at least the LSP buffersize,
> >to verify the MTU on a link.  
> >	But since the Hello size is the Max(LSP Buffersize, link MTU),
> >it is possible for two adjacent routers A and B to form an
> >adjacency, even though A's LSP Buffersize is 512, and B's is 
> >1492.  Radia has pointed out that this allows routers to verify 
> >that a next hop has a common link MTU.  
> >
> >	10589 specifies an LSP TLV 12 that could help spot a
> >mismatch between LSP Buffersizes.  (See below)  
> >	Does anyone know of an implementation that uses 
> >this feature?  
> >
> >- jeff parker
> >
> >
> >From page 57, 10589.  
> >
> >	-	originatingL1LSPBufferSize - the local value 
> >			for originatingL1LSPBufferSize
> >
> >	This may appear only once in an LSP with any LSP 
> >	number.  ....It is recommended that this option 
> >	be used only in the LSP with LSP number zero.  	
> >
> >		x CODE - 12
> >		x LENGTH - 2
> >		x VALUE - 512-1492
> >_______________________________________________
> >Isis-wg mailing list  -  [email-masked]
> >http://external.juniper.net/mailman/listinfo/isis-wg
> 
> 
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://external.juniper.net/mailman/listinfo/isis-wg
> 
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Mon, 29 Jan 2001 18:25:45 -0500

> I believe what Jeff P. is looking at is the latest draft for 
> Edition 2 of ISO 10589....

> I still believe it is a worthwhile addition to the protocol.
> 
>    Les

Jeff L. and Les are right on the mark.  I was searching
the 9/1/2000 edition, and not checking my paper copy of 
1992 version, even after Les's frequent advice.  I should
be flogged mercilessly with a wet spec.  

I agree that the TLV addresses an issue that the 1992
protocol does not.  Ran's example is one of several
interesting mistakes waiting to happen.  

- jeff parker