Subject: RE: [Isis-wg] RE: Encoding of TE Sub-TLVs

From: Les Ginsberg <[email-masked]>
Date: Wed, 3 Jan 2001 13:26:48 -0800

I admit that I don't have any clever name for the "7 byte thingie", but I do
think it would be VERY BAD if we picked anything that suggested that the "7
byte thingie" was in any way an identifier for the system since a system may
have a lot of "7 byte thingies" which belong to it.

The first six bytes serve very well as a System ID thank you. The 7th byte
is officially the "pseudonodeID" according to 10589. It is sometimes also
thought of as a local circuit ID, though in reality that description does
not align with actual implementations. In any event it is definitely not
some sort of system thing and I am afraid that all of Jeff's suggestions
imply that in some way - at least to me.

In the absence of something clever, I can live with "System ID Length + 1" 

  Les

> 	What I think you are asking for is agrement
> that System ID has length 6, and a term
> that we could define to be the 7 byte quantity above.
> Something like "Virtual System ID", but without
> all the baggage Virtual suggests.  Using Pseudo in
> the name is also bad, as it would suggest that it 
> does not apply to real router IDs.  Some suggestions  
> 
> 	System Descriptor
> 	OSI Router ID
> 	Universal Name (Universal Identifier?)
> 	Vertex Identifier (Vertex Name? Universal Vertex Name?)
> 	Universal Forwarding OID (UFO)
> 	...
> 
> Then we could talk about the "System Descriptor length"
> rather than having to say "System ID Length + 1".  
> 
> - jeff parker
> 	
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Jeff Learman <[email-masked]>
Date: Wed, 03 Jan 2001 16:53:01 -0500

That's why "vertex ID" is so appealing.  What the heck is a vertex?
Well ... it's the thing identified by a vertex ID, of course!

Jeff