Subject: RE: [Isis-wg] RE: Encoding of TE Sub-TLVs

From: Radia Perlman - Boston Center for Networking <[email-masked]>
Date: Wed, 3 Jan 2001 14:29:36 -0500 (EST)

Re: Jeff's reply assuming I was suggesting a less awkward word
for the 7-byte quantity.

Actually, in my note I was talking about how the system ID specified
in DECnet Phase V as 6 bytes got changed
by ISO to be variable length, with a kludge field
in the hellos and maybe also LSPs to indicate what "ID length" was,
and so everything in the spec that specified a system ID had to say it was
"ID length" rather than 6 bytes. Everyone in the domain has
to have the same value for ID length or you refuse to talk.
Completely unnecessary flexibility I always thought. Along with
the "max area addresses", which was the constant 3 in DECnet,
and got changed by ISO
to be variable, along with a similar field in
hellos stating your value of "max area addresses". Aside
from both of these things just being unnecessary complexity, it
violated something I'd always strived for which was making
parameters changable node by node in a running net. Like
the hello interval is. So I was hoping that someone would at
some point get rid of both those parameters and fix
ID length at 6, and max area addresses at 3, and get rid
of all the verbiage and fields for specifying otherwise. Otherwise,
to fit with the way the IS-IS spec is currently written, the line
"7 octets of system Id and pseudonode number" would have to
be changed to "ID length+1 octets of system Id and pseudonode number"

But even though it wasn't what my note was about,
your suggestion of coming up with a word for the 7-byte thing
is good. The one I like the best of your proposals
is "vertex identifier", or perhaps "node identifier".
I agree with you that "virtual" and
"pseudo" have confusing connotations. "System descriptor" I'd
think would include what version OS it was running, what type
hardware it was, etc. "Universal name" sounds like a URN and
might be confusing. I've never been able to get too
enthusiastic about coming up with names for
things. I couldn't think of a good name for what
wound up being called "adjacency". I'm pretty sure it was Mike
Shand who thought up that one, and I really like it, so maybe
he can think of a good word for the 7 (err. ID length+1) byte thingie,
though we've lived without it OK
for 15 years or so.

Radia

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Mike Shand <[email-masked]>
Date: Thu, 04 Jan 2001 11:07:47 +0000

>be changed to "ID length+1 octets of system Id and pseudonode number"

Yes, its a shame we had to let that get changed, but there was very strong 
pressure to do it at the time, and it was only by compromising there that 
we could get the spec to make progress at all. At least it was done in a 
way that didn't damage the original design too much. Its interesting to 
note that despite all the vocal "requirements" for this "flexibility" 
nobody has ever made use of it (to my knowledge).

>though we've lived without it OK

I'm afraid it wasn't me. I always thought it was you! According to the 
revision history of the DECnet PhaseIV spec, the term "adjacency" was 
introduced then

" The concept of lines became two concepts - circuits and adjacencies".

So that was before my time.

As for the 7 byte thingy. I agree that giving everything a name isn't 
necessarily necessary. In my mind this "thingy" is always a system ID + a 
pseudonode identifier. I guess vertex ID is the closest we can come to 
something meaningful.

                 Mike