Subject: [Isis-wg] IS-IS Traffic Engineering Extensions

From: Ben Abarbanel <[email-masked]>
Date: Tue, 17 Apr 2001 10:02:58 -0400

Hi guys:
   I was looking at the draft "IS-IS extensions for Traffic Engineering"
 <draft-ietf-isis-traffic-02.txt>.
 
 I looked at TLV type 135 (The Extented IP Reachability TLV) section 4.0  it
 mentions that there would be additional support for subTLVs. I was
wondering if  
 there is definition for these SubTLVs. A few big vendors have implemented
these   
 subTLVs but I have not seen any public disclosure of them.
 
 Any help will be appreciated,
 Ben
 
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: Danny McPherson <[email-masked]>
Date: Tue, 17 Apr 2001 08:47:37 -0600

Jeff P. proposed some text for the layout of the sub-TLVs 
a while back, though well after the -02 version of the draft 
was issued.  Perhaps they'll find their way into the *next* 
version of the draft...  Henk?

I've included Jeff's message below, you can find it (and the 
rest of the thread) in the archives.

Of course, this doesn't necessarily mean that what you've
seen floating around conforms in any way.

-danny 

>  Any help will be appreciated,

[snip]
From: Jeff Parker <[email-masked]>
To: "'Tony Li'" <[email-masked]>
Cc: "[email-masked]'" <[email-masked]>,
        "[email-masked]'" <[email-masked]>
MIME-Version: 1.0
Content-Type: text/plain;
	charset="iso-8859-1"
Subject: [Isis-wg] RE: Encoding of TE Sub-TLVs
Sender: [email-masked]
Errors-To: [email-masked]
X-BeenThere: [email-masked]
X-Mailman-Version: 2.0rc1
Precedence: bulk
List-Help: <mailto:[email-masked]?subject=help>
List-Post: <mailto:[email-masked]>
List-Subscribe: <http://external.juniper.net/mailman/listinfo/isis-wg>,
	<mailto:[email-masked]?subject=subscribe>
List-Id: IETF IS-IS working group <isis-wg.external.juniper.net>
List-Unsubscribe: <http://external.juniper.net/mailman/listinfo/isis-wg>,
	<mailto:[email-masked]?subject=unsubscribe>
List-Archive: <http://external.juniper.net/pipermail/isis-wg/>
Date: Wed, 3 Jan 2001 09:59:36 -0500

Tony, Henk -

	This is offered to try to make the draft 
unambiguous to implement.  You do refer to the values
as "sub-TLV" throughout.  However, there have been 
enough questions about the need for L in TLV on this and
other lists recently that it would be good to remove doubt.

This draft is being cited by a number of other drafts, so
the effort to make it clear is worthwhile.  

In section in 4.0

   The proposed extended IP reachability TLV contains a new data
   structure, consisting of:
        4 bytes of metric information
        1 byte of control information, consisting of
             1 bit of up/down information
             1 bit indicating the existence of sub-TLVs
             6 bits of prefix length
        0-4 bytes of IPv4 prefix
        0-250 optional octets of sub-TVLs, if present consisting of
             1 octet of length of sub-TLVs
             0-249 octets of sub-TLVs

you could replace the last line with

		 0-249 octets of sub-TLVs, consisting of
			a sequence of
				1 octet of sub-type
				1 octet of length
				1-247 octets of value

and the phrase in section 5.0

   The proposed extended IS reachability TLV contains a new data
   structure, consisting of
        7 octets of system Id and pseudonode number
        3 octets of default metric
        1 octet of length of sub-TLVs
        0-244 octets of sub-TLVs

could be extended by

        0-244 octets of sub-TLVs, consisting of
		a sequence of
			1 octet of sub-type
			1 octet of length
			1-242 octets of value

An example would help: either before section 4.0
or in a final section.  

   For example, the sequence of 41 octets below

	0x16 0x27
		0xAAAA AAAA AAAA 00	0x00000A	0x06	0x03 0x04
0x01020304
		0xBBBB BBBB BBBB 00	0x00000A	0x00
		0xCCCC CCCC CCCC 00	0x00000A	0x00

   is a TLV which describes three IS-IS neighbors.  The first of these has 
   an administrative color, defined by subtype 3, which consists of 4 octets

   of information.

Someone could make the case that this is not prescriptive enough:
it simply describes what should be done in a couple of cases.  Such
a person could argue for a special section describing the rules for 
a sub-TLV.  

- - jeff parker
	
> Not doing a TLV is unthinkable, as that would completely 
> break the spirit
> of the IS-IS design.
> 
> If you would like to propose text, that's fine.  It's 
> probably best to give
> it to Henk as he has a bit more spare time than I do at present.
> 
>  | All of the examples given are fixed length, allowing an unwary 
>  | implementor to imagine that they might be implemented as TV's 
>  | rather than TLVs (that is, one is at risk of imagining that 
>  | the length could be omitted).  I can propose text to the list, 
>  | but won't do so if this has been described someplace.    
>  | 
>  | - jeff parker
>  | - axiowave networks
> 

------- End of Forwarded Message