Subject: RE: [Isis-wg] Other than 6 octet ID ?

From: "Martin, Christian" <[email-masked]>
Date: Tue, 12 Jun 2001 12:42:11 -0400

I recall Radia saying at one point that the variable length system ID was a
bad idea.  I wonder if the new 10589 spec will change this to make it static
at 6 octets?

 -chris

> -----Original Message-----
> From: mike shand [mailto:[email-masked]]
> Sent: Monday, June 11, 2001 8:50 AM
> To: David Hudek
> Cc: [email-masked]
> Subject: Re: [Isis-wg] Other than 6 octet ID ?
> 
> 
> At 20:00 10/06/2001 -0700, David Hudek wrote:
> >Hi all,
> >
> >As I understand it, the ISIS specification allows the ID field
> >of a NET to vary from between 1 to 8 octets, with the constraint
> >that everyone within a routing domain must use the same ID size.
> >
> >Is anyone anywhere actually using an ID size other than 6 octets?
> >Would it be correct to say that as a practical matter the
> >ID is fixed at 6 octets?
> 
> I believe that is the case, unless someone can prove me wrong.
> 
>          Mike
> 
> >   Or are alternate ID sizes commonly
> >deployed in real networks?
> >
> >adTHANKSvance,
> >dave h
> >_______________________________________________
> >Isis-wg mailing list  -  [email-masked]
> >http://external.juniper.net/mailman/listinfo/isis-wg
> 
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://external.juniper.net/mailman/listinfo/isis-wg
> 
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: mike shand <[email-masked]>
Date: Tue, 12 Jun 2001 17:59:45 +0100

>bad idea.  I wonder if the new 10589 spec will change this to make it static

Of course it was a bad idea, but at the time there were those on the ISO 
committee who wanted it. There were actually two camps. Those who wanted a 
shorter ID (3 octets as I recall), and those who wanted a longer (8 
octets). The only way to get the standards to progress was to accommodate 
them in such a way that it didn't change the normal 6 octet usage.

However, I'd be very surprised in V2 could reverse this. It really doesn't 
matter provided that nobody implements it.

         Mike

---

From: Micah Bartell <[email-masked]>
Date: Tue, 12 Jun 2001 13:26:24 -0500

Christian,

Section 7.1.3.2 will read:

ID     System identifier  a variable length field from 1 to 8 octets 
(inclusive). Each routeing domain employing this protocol shall select a 
single size for the ID field and all Intermediate systems in the routeing 
domain shall use this length for the system IDs of all systems in the 
routeing domain.

The set of ID lengths supported by an implementation is an implementation 
choice, provided that at least one value in the permitted range can be 
accepted. The routeing domain administrator must ensure that all ISs 
included in a routeing domain are able to use the ID length chosen for that 
domain.

As you can see, we are still allowing variable length, but it is 
implementation dependent on what size you support.  It just so happens that 
6 is what everyone supports.  Variable length systemID's are definitely of 
questionable value, but since we have not had an issue with it, it is 
easier to let it just remain.

/mpb

---

From: Radia Perlman - Boston Center for Networking <[email-masked]>
Date: Mon, 11 Jun 2001 13:29:58 -0400 (EDT)

>Would it be correct to say that as a practical matter the
	
That is a frill that I was unhappy about ISO adding. It's not clear why
it would be useful, and it certainly won't work if nodes within
a domain are configured for different ID sizes. It would be nice
if it could be set to be constant 6, and remove the field in the LSP
that states what you think the ID size is, and remove all
mention of it in the spec
like the size of things being IDlength+2.

I'd also advocate for doing the same for number of area addresses,
and fix that at 3.

Radia