Subject: [Isis-wg] Doubts regarding encapsulation.

From: "Sachidananda K" <[email-masked]>
Date: Wed, 18 Jul 2001 07:05:41 -0000

Hello,

I'm a student studying the networking and routing concepts. My doubts are 
related to the packet formats used for IS-IS PDUs. I had also gone through 
the RFC 1142 and RFC 1195 for the same. Having gone through the 2 RFCs I am 
confused as to whether the IS-IS PDUs are encapsulated within the IP 
datagram or are they encapsulated using CLNP header. If anyone could please 
tell me as to how does the IS-IS PDU looks like in the physical media (let 
me be specific to say in ethernet frame).
I shall be obliged to get any response on this issue.

Thanking you in advance for all the early replies that I get.
Sachi
_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Jeff Learman" <[email-masked]>
Date: Wed, 18 Jul 2001 22:36:03 -0400

IS-IS PDUs are sent directly over the link layer.
For example, on Ethernet, the format is

  802.3 MAC header:
    6-byte dest MAC address
    6-byte src  MAC address
    2-byte length
  LLC header:
    FE  (dest LSAP = OSI)
    FE  (src LSAP = OSI)
    03  (I frame)
  IS-IS stuff:
    84 (IS-IS NLPID)
    ...
    
The exceptions to this are (a) partition repair uses
IS-IS / CLNP tunnels, but ignore that because it
doesn't work (it'll be fixed in next IS-IS version), and
(b) there was a draft RFC for IS-IS in IP encapsulation,
but that was not popular and I don't recommend it.

Jeff