Subject: Re: [Isis-wg] Dual IS-IS

From: stefano previdi <[email-masked]>
Date: Tue, 31 Jul 2001 16:58:11 +0200

At 16:48 31/07/2001, Sachidananda K wrote:
>Hello,
>
>I have some doubts related to the the working of dual IS-IS.
>
>My question:
>Is the link state database maintained seperately for both OSI addresses 
>and IP addresses or is it one and the same.

Topology database and shortest path tree computation is a matter
of implementation as long as the Dijkstra algorithm is used
consistently across the whole area/domain.

You may want to have different topologies for different address
families (IPv4, IPv6, OSI, ucast/mcast, QoS, ...).

s.

>I am not aware of any standard or draft giving any clue about this. Please 
>help me understand this aspect of IS-IS.
>
>I shall be obliged to get an early help in this respones.
>
>Thanking in advance for all the responses.
>Sachi
>
>_________________________________________________________________
>Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp
>
>_______________________________________________
>Isis-wg mailing list  -  [email-masked]
>http://external.juniper.net/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Sachidananda K" <[email-masked]>
Date: Tue, 31 Jul 2001 14:48:32 +0000

Hello,

My question:
Is the link state database maintained seperately for both OSI addresses and 
IP addresses or is it one and the same. I am not aware of any standard or 
draft giving any clue about this. Please help me understand this aspect of 
IS-IS.

---

From: Jeff Learman <[email-masked]>
Date: Tue, 31 Jul 2001 13:05:33 -0400

From an external perspective, the LSP database for
OSI and IP is integrated -- that is, the LSPs can carry
both types of information, and the ordering rules apply
to IS and ES Neighbors options without regard for
protocol, and the IS and ES Neighbors options do not
indicate which protocol they apply to (according to
RFC 1195, that is handled by the "protocols supported"
options in conjunction with the deployment rules).
And an IS is required to save all LSPs verbatim -- at
least they must appear to do so from external behavior,
e.g., when sending another system's LSP to a neighbor because
of the information in the neighbor's SNPs.

While some system may choose to place certain IP information
in different LSP numbers than OSI information, there are
limitations to what they could do because of special
requirements for LSP zero -- you can't have an OSI LSP zero
and an IP LSP zero unless you're running completely separate
instances of ISIS (and let's not go there, because this is
not an advanced course).

Regards,
Jeff

Opinions expressed are not necessarily those of my employer,
and I am not working in IS-IS at Cisco.

At 10:48 AM 7/31/2001, Sachidananda K wrote:
>Is the link state database maintained seperately for both OSI addresses and IP addresses or is it one and the same. I am not aware of any standard or draft giving any clue about this. Please help me understand this aspect of IS-IS.
>