Subject: Re: SV: [Isis-wg] More vendor data on IP/GigE MTU

From: "Rajesh Hegde" <[email-masked]>
Date: Tue, 3 Jul 2001 18:40:25 -0700

Hi,

What to we do for supporting ethernet jumboframes ?
Do we go ahead with padding hellos to mtu-size ?
What will happen to the LSP buffersize ? Does it need to be increased beyond 1492 bytes?
Or else try to establish the adjacency with small hellos without bothering to the padding of hellos to mtu-size ?

thanks and Regards,
Rajesh

>  Back to ISIS, do we really need LSP datagrams with sizes over 1492?

  No, ISIS doesn't need larger LSPs.

  The problem was this:
 *) Some router vendors support "jumboframes" over GE.
 *) IP packets are encapsulated in EthernetII frames. (*)
 *) Encapsulation of EthernetII frames in such jumboframes is easy.
 *) ISIS sends hellos padded to mtu size, to do early detection
    of mtu mismatches, and other problems.
 *) Some ISPs wanted this early detection to keep working even over
    GE with jumboframes.
 *) Therefor, ISIS must send hellos padded up to "jumboframe mtu"
 *) ISIS packets are encapsulated in 802.3/802.2 frames. (*)
 *) 802.3/802.2 frames can not be longer than 1500 bytes.
 *) Therefor ISIS can not use jumboframes.
 *) To solve this problem (and IMHO only this problem of padded hellos)
    draft-ietf-isis-ext-eth-00.txt was written.

  Possible solutions:
 1) Change ethernet specs.
 2) Make IS-IS use EthernetII encapsulation.
 3) Make IS-IS use IP encapsulation.
 4) Forget about padding IS-IS hellos to mtu-size.
                
  It seems proposal 1) encountered more opposition than envisioned. :-)
 Proposals 2) and 3) are gonna introduce lots and lots of interoperability
 problems. Not worthwile, IMHO.

  Doing 4) seems a nice and simple solution. And it has the benefit that
 ISIS will  keep working on bridged networks of GE and other flavors
 of Ethernet.

  I never understood why ISPs insisted on keeping ISIS to pad its hellos
 to mtu-size. OSPF sends small hellos, and that does not seem to give
 many more headaches.

     henk.

--
PS.(*) I know this terminology is not the proper lingo anymore. If you know
how to call those 2 encapsulation methods, please educate me. Thanks.
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

____________________________________________________
Buy Feng Shui Package for Rs. 151/- only, at 
http://shopping.rediff.com/shopping/fengshui_mailer.htm

------------------------------------------------------------
WWW.COM - Where the Web Begins! http://www.www.com
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://external.juniper.net/mailman/listinfo/isis-wg

---

From: "Rajesh Hegde" <[email-masked]>
Date: Tue, 3 Jul 2001 22:38:36 -0700

Hi,

What to we do for supporting ethernet jumboframes ?
Do we go ahead with padding hellos to mtu-size ?
What will happen to the LSP buffersize ? Does it need to be increased beyond 
1492 bytes?
Or else try to establish the adjacency with small hellos without bothering to 
the padding of hellos to mtu-size ?
What will happen to LSP bufer size in case of data link interfaces having link MTU size lesser than 1500 bytes (for ex. DC interfaces) ?

Thanks and Regards,
Rajesh