Subject: RE: [Isis-wg] new potential issue with Proprietary / Private TLV numbers?

From: "Gray, Eric" <[email-masked]>
Date: Tue, 23 Jul 2002 11:36:03 -0400

Radia,

	I think the issue is that anyone defining a TLV
extension needs to consider security implications of
its misuse.  It may be the case that protocols that
define TLV extensibility should probably talk about 
what kinds of security implications anyone extending
the protocol needs to consider.

Eric W. Gray
Systems Architect
Celox Networks, Inc.
[email-masked]
508 305 7214

-----Original Message-----
From: Radia Perlman - Boston Center for Networking
[mailto:[email-masked]] 
Sent: Tuesday, July 23, 2002 11:29 AM
To: [email-masked]
Subject: [Isis-wg] new potential issue with Proprietary / Private TLV
numbers?

I wasn't in Yokohama. But here's an extract from the IPsec WG minutes:

>>Steve Bellovin, Security Area Director, strongly commented that any drafts

>>that contained specific vendor extensions would cause the IESG to be 
>>concerned and may even cause it to be rejected.  He states this in his 
>>capacity of Area Director, not as a co-author of the JFK draft.

Does anyone know what this is about? I'd imagine that IESG might be
annoyed at certain companies claiming they're using a standard, but
using private extensions that make things noninteroperable.

But as Philip's "TLV for Proprietary Use"
draft so eloquently says, extensibility has turned out
to be really powerful.

So is the IESG saying that TLV's should be illegal unless each "T" is
assigned by IANA? Or that there will be no more TLV extensible protocols,
or what?

Anyway, if that snippet from the IPsec minutes is accurate, perhaps
there will be a problem with getting this spec through the IESG.

Radia

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Tue, 23 Jul 2002 14:49:43 -0400

> Perhaps we should ask Steve.  Anyone have his address?
> 
> Jeff

http://www.research.att.com/info/smb

[email-masked]