Subject: RE: [Isis-wg] Proprietary / Private TLV numbers?

From: "Philip Christian" <[email-masked]>
Date: Tue, 11 Jun 2002 12:01:12 +0100

So I am just writing something at the moment based on OUIs.

Two questions.

1. What TLV number shall be assigned as the proprietary TLV?

2. Does the "locally assigned" bit have any significance in an OUI as it
does in a MAC address?

IEEE assigned OUIs are no problem for vendors, but I am thinking that there
is no harm in allowing an individual to use an OUI with "locally assigned"
bit set (or something similar) if they do not have an IEEE assigned OUI.

One scenario is maybe a college student doing a university project for
example.  An absolute requirement for an IEEE assigned OUI would be a big
deal for them, whilst maybe the loss of an absolute guarantee of uniqueness
would not cause them a serious problem.  In any case they can put their own
"key" somewhere in the TLV to statistically reduce the problem to next to
nothing, for example.

The draft could clearly state that this SHOULD NOT be used for commercial
products intended for deployment in the Internet, if that helps.

Put another way, it might just stop a student / lab guy from just picked
your OUI at random and trampling on it, just because he thinks that it will
never get out of the lab...

Thoughts?

Philip

> -----Original Message-----
> From: Tony Przygienda [mailto:[email-masked]]
> Sent: Monday, June 10, 2002 5:44 PM
> To: Christian, Philip [HAL02:GI50:EXCH]
> Cc: 'Mike Truskowski'; [email-masked]; [email-masked]
> Subject: Re: [Isis-wg] Proprietary / Private TLV numbers?
> 
> 
> Yes, the proposals have been made before and nohting has been written 
> down. I am
> for using the official OUI, this would be aligned with Frame 
> Relay, ATM 
> and so on.
> The /32 may fly but unfortunately IP address space is a 
> volatile thing 
> compared to
> OUIs. I assume any vendor building sophisticated networking gear with 
> ISIS on it
> will at a certain point have an OUI, I see little value in having a
> /32-address-based-cottage-industry-of-ISIS-extensions ...
> 
> So, this time any takers to write it down ?
> 
>     thanks
> 
>     -- tony
> 
> 
> Philip Christian wrote:
> 
> > A vendor code of 4 octets could be an IPv4 address.
> > Then no-one would have to assign them. The vendor just uses 
> a global 
> > IPv4 address that he has.
> >
> > Even the smallest vendor can buy a /32 IP address for this purpose.
> >
> > That would work.
> >
> > Philip
> >
> > > -----Original Message-----
> > > From: Mike Truskowski [ mailto:[email-masked] ]
> > > Sent: Monday, June 10, 2002 2:42 PM
> > > To: [email-masked]
> > > Cc: Christian, Philip [HAL02:GI50:EXCH]; 
> [email-masked]
> > > Subject: Re: [Isis-wg] Proprietary / Private TLV numbers?
> > >
> > >
> > > Why not just do the following?
> > >
> > > +-------------------------------------------------+
> > > | Type   |  Length  |       Value                 |
> > > +-------------------------------------------------+
> > > | TLV #  |  Length  |  vendor code  |   "value"   |
> > > +-------------------------------------------------+
> > >
> > > Where the vendor code is a fixed 3-4 octets?
> > >
> > > I guess one could do this on their own... couldn't they?
> > >
> > > The major problem I see here is what Philip said he 
> wanted to fix...
> > >
> > > If vendors are doing this already and this is trying to avoid
> > > interoperability
> > > problems... then it would seem reasonable that the carrier
> > > would go back and
> > > install new images or force the vendor to fix the embedded
> > > base..  but they
> > > won't do either.. thus leaving the problem to stumble 
> over some day...
> > >
> > > Mike
> > >
> > > > At 13:43 10/06/2002 +0100, Philip Christian wrote:
> > > >
> > > > >I suppose that we could define different sub-TLVs, a
> > > sub-TLV if the
> > > > >identifier is an IPv4 address, a different sub-TLV if it
> > > is a MAC address, etc
> > > > >
> > > > >Then folks could use whichever mechanism they prefer, as
> > > long as it is a
> > > > >globally unique identifier.
> > > > >
> > > > >Or is that too complex?
> > > >
> > > > Yes! That's how NSAP addresses got to be so awful :-)
> > > >
> > > >          Mike
> > > >
> > > >
> > > >
> > > > >Philip
> > > > >
> > > > > > -----Original Message-----
> > > > > > From: mike shand
> > > [<mailto:[email-masked] >mailto:[email-masked] ]
> > > > > > Sent: Monday, June 10, 2002 12:24 PM
> > > > > > To: Christian, Philip [HAL02:GI50:EXCH]
> > > > > > Cc: [email-masked]
> > > > > > Subject: Re: [Isis-wg] Proprietary / Private TLV numbers?
> > > > > >
> > > > > >
> > > > > > At 11:29 10/06/2002 +0100, Philip Christian wrote:
> > > > > > >Looking at 
> draft-ietf-isis-wg-tlv-codepoints-02.txt I notice
> > > > > > that there is
> > > > > > >not really any mechanism for private or proprietary
> > > use of a TLV.
> > > > > > >
> > > > > > >Thus various companies (including my own) have just pcked
> > > > > > one and used it
> > > > > > >for their own purpose.  Eventually this will create an
> > > > > > interop problem,
> > > > > > >but what else is a company to do?
> > > > > > >
> > > > > > >Is there a way that we could define that a certain TLV
> > > number is for
> > > > > > >private / proprietary / experimental purposes?
> > > > > > >
> > > > > > >This would then stop people just picking one.
> > > > > > >
> > > > > > >I am thinking that there would have to be some sort of
> > > > > > entity identifier
> > > > > > >in there so that when you see this TLV you know whether it
> > > > > > is yours or not.
> > > > > > >
> > > > > > >Maybe we could define that the first four bytes are an IP
> > > > > > address for
> > > > > > >example.  Any entity large enough to want to use a
> > > > > > proprietary TLV would
> > > > > > >have a public IP address to put in there, I would have
> > > > > > thought. After the
> > > > > > >first for bytes then the rest would be free.
> > > > > > >
> > > > > > >Or maybe there is a better way to identify a particular
> > > > > > company / entity
> > > > > > >(like a MAC address)?  Maybe ISO 8348?
> > > > > > >
> > > > > > >What do people think?
> > > > > > >
> > > > > > >Philip
> > > > > > >
> > > > > >
> > > > > > This has been suggested before, but never came to 
> anything. I
> > > > > > think if it
> > > > > > WERE to be done then using something link the MAC OUI would
> > > > > > probably work.
> > > > > > What do you mean by ISO 8348? Do you mean ISO 6523? I
> > > hope not :-)
> > > > > >
> > > > > >          Mike
> > > > > >
> > > >
> > > > _______________________________________________
> > > > Isis-wg mailing list  -  [email-masked]
> > > > http://spider.juniper.net/mailman/listinfo/isis-wg
> > > >
> > >
> > >
> >
> 
> 
>

---

From: Tony Przygienda <[email-masked]>
Date: Wed, 03 Jul 2002 13:18:25 -0700

> 1. What TLV number shall be assigned as the proprietary TLV?
you like 250?

> 2. Does the "locally assigned" bit have any significance in an OUI as 
> it does in a MAC address?
>
> IEEE assigned OUIs are no problem for vendors, but I am thinking that 
> there is no harm in allowing an individual to use an OUI with "locally 
> assigned" bit set (or something similar) if they do not have an IEEE 
> assigned OUI.
>
> example.  An absolute requirement for an IEEE assigned OUI would be a 
> big deal for them, whilst maybe the loss of an absolute guarantee of 
> uniqueness would not cause them a serious problem.  In any case they 
> can put their own "key" somewhere in the TLV to statistically reduce 
> the problem to next to nothing, for example.
>
> The draft could clearly state that this SHOULD NOT be used for 
> commercial products intended for deployment in the Internet, if that 
> helps.
>
> Put another way, it might just stop a student / lab guy from just 
> picked your OUI at random and trampling on it, just because he thinks 
> that it will never get out of the lab...
>
I looked at your draft and looks ok. Actually, MAC addresses have a 
'local-valid-only' bit but I forgot whether it
was in OUI or not or maybe that's the bit you found.

small comment on draft, pls find a reference to OUI description and 
include it. Many people don't know the
concept

    thanks

    -- tony

---

From: Jeff Learman <[email-masked]>
Date: Wed, 03 Jul 2002 17:35:18 -0400

There are only 4 million OUIs, not 16.  Two bits are reserved
for "globally vs. locally assigned" and "multicast vs. unicast".

Practically speaking, if you own an OUI, you own two values, one
with the multicast bit clear and one with it set.  HOWEVER, I wouldn't
put it past IEEE to sell a special kind of OUIs that are NOT valid for
use in making MAC addresses (because the local or mcast bit
is set) so it is probably risky to use an OUI with this bit set for
any other purpose.

Use of an OUI with the locally-administered bit set is probably
fine for use in a lab.  However, you might want to ask IEEE before
committing this to an RFC.

When defining OUI you might want to include this URL:
"http://standards.ieee.org".  It's easy to find OUI from there, and
I hope that this URL is stable enough to document.

Jeff

At 04:18 PM 7/3/2002, Tony Przygienda wrote:

>>2. Does the "locally assigned" bit have any significance in an OUI as it does in a MAC address?
>>
>>IEEE assigned OUIs are no problem for vendors, but I am thinking that there is no harm in allowing an individual to use an OUI with "locally assigned" bit set (or something similar) if they do not have an IEEE assigned OUI.
>>
>>One scenario is maybe a college student doing a university project for example.  An absolute requirement for an IEEE assigned OUI would be a big deal for them, whilst maybe the loss of an absolute guarantee of uniqueness would not cause them a serious problem.  In any case they can put their own "key" somewhere in the TLV to statistically reduce the problem to next to nothing, for example.
>>
>>The draft could clearly state that this SHOULD NOT be used for commercial products intended for deployment in the Internet, if that helps.
>>
>>Put another way, it might just stop a student / lab guy from just picked your OUI at random and trampling on it, just because he thinks that it will never get out of the lab...
>I looked at your draft and looks ok. Actually, MAC addresses have a 'local-valid-only' bit but I forgot whether it
>small comment on draft, pls find a reference to OUI description and include it. Many people don't know the
>concept
>
>   thanks
>
>   -- tony
>
>
>

---

From: Jeff Learman <[email-masked]>
Date: Wed, 03 Jul 2002 17:44:46 -0400

Have you updated the text since the round of comments after your
post on 6/12?

Jeff