Subject: Re: [Isis-wg] Proprietary / Private TLV numbers Security Considerati ons

From: Jeff Learman <[email-masked]>
Date: Thu, 11 Jul 2002 13:52:46 -0400

At 12:55 PM 7/11/2002, Jeff Parker wrote:
>Philip -
>        Here is an attempt to reword things to address 
>Ran's observations.  I'm out the door, but you have 
>the active support of the group to bang this into shape.  
>
>Ran -
>        I've used the term 'mischief' as a place holder.
>Can you suggest a better word to cover the threats that 
>Virii and Trojan horses represent?
>
>- jeff parker 
>
>5. Security Considerations 
>
>   The contents of IS-IS PDUs are not protected by encryption,
>   so the contents of TLVs in LSPs are visible throughout the
>   routing area or domain, while the contents of Hello Packets,
>   CSNPs, and PSNPs are visible to observers on the link they 
>   are sent to.  The addition of MD5 authentication, as described
>   in [draft mumble] can increase the integrity of TLVs, while
>   encryption could increase their confidentiality.  

If we need this paragraph for this RFC, we need it for all other
IS-IS RFCs.  This is true for all IS-IS TLVs, not just this one.
So I don't think it's necessary.  Of course, it does no harm.

>   The general extensibility of the TLV mechanism has always allowed
>   the addition of new information, and the possibility of conflicting
>   interpretations of such information by different implementations.  
>   This proposal does not introduce a new quality of information: it 
>   simply allows an increase in the quantity of such additions.  As 
>   such, it represents no new potential for mischief.  

I agree.  I think we should point out that it is the responsibility
of someone creating a new TLV using this mechanism to address any
security issues raised by the new feature.

>_______________________________________________
>Isis-wg mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: RJ Atkinson <[email-masked]>
Date: Fri, 12 Jul 2002 00:50:02 -0400

> IS-IS RFCs.  This is true for all IS-IS TLVs, not just this one.

Absolutely.  A bug in the other documents, IMHO.  YMMV. :-) :-)

ASIDE:
	As a general concept, a good "Security Considerations" outlines
all the known risks, along with whatever security mechanisms
(or other risk mitigation mechanisms) exist, suggests approaches
to consider to reduce risk, and makes clear to the reader
what the residual risks are.  There is an I-D elsewhere
in the IETF that tries to make it more clear to the whole
community how to write a good security considerations.

Ran
[email-masked]

---

From: Jeff Learman <[email-masked]>
Date: Fri, 12 Jul 2002 08:26:53 -0400

>community how to write a good security considerations.

Perhaps that would be a good Informational RFC for IS-IS in general.
That's where the security issues reside.  This RFC doesn't change
the security issues.