Subject: RE: [Isis-wg] Proprietary / Private TLV numbers?

From: Jeff Parker <[email-masked]>
Date: Wed, 3 Jul 2002 18:10:52 -0400

Thanks to Jeff L's link, I wandered over an grabbed the file.
Most of the entries start with 00.  However, there are addresses
with the second bit set.  Here are a few...

- jeff parker

02-07-01   (hex)		RACAL-DATACOM
020701     (base 16)		RACAL-DATACOM
				LAN INTERNETWORKING DIVISION
				155 SWANSON ROAD
				BOXBOROUGH MA 01719

02-1C-7C   (hex)		PERQ SYSTEMS CORPORATION
021C7C     (base 16)		PERQ SYSTEMS CORPORATION
				2600 LIBERTY AVENUE
				P.O. BOX 2600
				PITTSBURGH PA 15230

02-60-86   (hex)		LOGIC REPLACEMENT TECH. LTD.
026086     (base 16)		LOGIC REPLACEMENT TECH. LTD.
				14 ARKWRIGHT ROAD
				READING BERKS RG2OLS
				UNITED KINGDOM

02-60-8C   (hex)		3COM CORPORATION
02608C     (base 16)		3COM CORPORATION
				2081 N. SHORLINE BLVD.
				MOUNTAIN VIEW CA 94043

- jeff parker
- axiowave networks
- My most important job is to defend the homeland, to protect innocent
Americans from the deaths of the killers.
- G. W. Bush

> -----Original Message-----
> From: Jeff Learman [mailto:[email-masked]]
> Sent: Wednesday, July 03, 2002 5:35 PM
> To: Tony Przygienda
> Cc: Philip Christian; [email-masked]
> Subject: Re: [Isis-wg] Proprietary / Private TLV numbers?
> 
> 
> 
> There are only 4 million OUIs, not 16.  Two bits are reserved
> for "globally vs. locally assigned" and "multicast vs. unicast".
> 
> Practically speaking, if you own an OUI, you own two values, one
> with the multicast bit clear and one with it set.  HOWEVER, I wouldn't
> put it past IEEE to sell a special kind of OUIs that are NOT valid for
> use in making MAC addresses (because the local or mcast bit
> is set) so it is probably risky to use an OUI with this bit set for
> any other purpose.
> 
> Use of an OUI with the locally-administered bit set is probably
> fine for use in a lab.  However, you might want to ask IEEE before
> committing this to an RFC.
> 
> When defining OUI you might want to include this URL:
> "http://standards.ieee.org".  It's easy to find OUI from there, and
> I hope that this URL is stable enough to document.
> 
> Jeff
> 
> At 04:18 PM 7/3/2002, Tony Przygienda wrote:
> 
> 
> >Philip Christian wrote:
> >
> >>So I am just writing something at the moment based on OUIs.
> >>
> >>Two questions.
> >>
> >>1. What TLV number shall be assigned as the proprietary TLV?
> >you like 250?
> >
> >>2. Does the "locally assigned" bit have any significance in 
> an OUI as it does in a MAC address?
> >>
> >>IEEE assigned OUIs are no problem for vendors, but I am 
> thinking that there is no harm in allowing an individual to 
> use an OUI with "locally assigned" bit set (or something 
> similar) if they do not have an IEEE assigned OUI.
> >>
> >>One scenario is maybe a college student doing a university 
> project for example.  An absolute requirement for an IEEE 
> assigned OUI would be a big deal for them, whilst maybe the 
> loss of an absolute guarantee of uniqueness would not cause 
> them a serious problem.  In any case they can put their own 
> "key" somewhere in the TLV to statistically reduce the 
> problem to next to nothing, for example.
> >>
> >>The draft could clearly state that this SHOULD NOT be used 
> for commercial products intended for deployment in the 
> Internet, if that helps.
> >>
> >>Put another way, it might just stop a student / lab guy 
> from just picked your OUI at random and trampling on it, just 
> because he thinks that it will never get out of the lab...
> >I looked at your draft and looks ok. Actually, MAC addresses 
> have a 'local-valid-only' bit but I forgot whether it
> >was in OUI or not or maybe that's the bit you found.
> >
> >small comment on draft, pls find a reference to OUI 
> description and include it. Many people don't know the
> >concept
> >
> >   thanks
> >
> >   -- tony
> >
> >
> >
> >_______________________________________________
> >Isis-wg mailing list  -  [email-masked]
> >http://spider.juniper.net/mailman/listinfo/isis-wg
> 
> _______________________________________________
> Isis-wg mailing list  -  [email-masked]
> http://spider.juniper.net/mailman/listinfo/isis-wg
> 
_______________________________________________
Isis-wg mailing list  -  [email-masked]
http://spider.juniper.net/mailman/listinfo/isis-wg

---

From: Tony Przygienda <[email-masked]>
Date: Wed, 03 Jul 2002 15:16:29 -0700

>Americans from the deaths of the killers.
no politics, no drunks, no dirty jokes, pls, this is too close to the 
line Jeff

Anybody appealing to the first or any other amendement will be 
unsubscribed! ;-)

    thanks

    -- tony