Subject: [Isis-wg] Level in IPRA Table

From: Jeff Parker <[email-masked]>
Date: Mon, 29 Jul 2002 14:53:20 -0400

> Hi Jeff,
> 
> I am working on the IPRA table. I had a slight doubt. While 
> injecting routes when configuring the IPRA table, I got 
> into a slight confusion. Which level should the information 
> be injected into -  Level 1 and/or Level 2.
> 
> Do we require a level field in the index too?
> 
> Thanks,
> Vishwas

Vishwas -
	I think the original intent was to introduce such 
routes into L1 and let them leak up to L2.  But I suspect
that many products today can be configured to leak a 
route directly into L2.  If someone is running at L2 only,
this would be required.    

All -
	Is there any objection to adding a field to the 
IPRA entry that dictates which level it should be introduced
into?  Perhaps something like the following.  I'd suggest
L1 or L2, as L1L2 is redundant.  If we add it to Level 1,
then it will pass through the summary check and emerge
at the right level of summarization into L2.  

- jeff parker

    IsisIPRAEntry ::=
        SEQUENCE {
            isisIPRAIndex
                Integer32,
            isisIPRAType
                INTEGER,
            isisIPRADestType
                InetAddressType,
            isisIPRADest
                InetAddress,
            isisIPRADestPrefixLen
                InetAddressPrefixLength,
            isisIPRAExistState
                RowStatus,
            isisIPRAAdminState
                AdminState,
            isisIPRAMetric
                DefaultMetric,
            isisIPRAMetricType
                MetricType,
            isisIPRAFullMetric
                FullMetric,
            isisIPRASNPAAddress
                OSINSAddress,
		isisIPRALevel
		    INTEGER			-- 1 or 2
        }

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Tue, 30 Jul 2002 10:36:39 -0400

> > route directly into L2.  

> Suryaa>> If the system is L1 or L12 then, all the IPRA info will 
> go in L1 LSPs and leak up to L2, if the system is L2 only then, 
> IPRAs could go directly in L2 LSPs. so do we really require 
> Level for IPRAs  ????

Suryaa 
	I'm not sure that there is a crying need for the IPRA Table
in the first place, but let's assume for now that we need it.

	Here is an application for the Level.  System is L1L2,
and we want to introduce a route into L2, but not into L1.  

- jeff parker

---

From: "appallar" <[email-masked]>
Date: Wed, 31 Jul 2002 09:24:36 +0530

Hello Jeff,

I don't see any problem if the Type of IPRA Entries are Manual as you said, but if the IPRAs are of type automatic

and if they are learnt from an another routeing protocol, then how could we decide about level?

Regards

suryanarayana

"Jeff Parker" wrote:

&gt; &gt; Vishwas -
&gt; &gt; I think the original intent was to introduce such 
&gt; &gt; routes into L1 and let them leak up to L2. But I suspect
&gt; &gt; that many products today can be configured to leak a 
&gt; &gt; route directly into L2. 

&gt; Suryaa&gt;&gt; If the system is L1 or L12 then, all the IPRA info will 
&gt; go in L1 LSPs and leak up to L2, if the system is L2 only then, 
&gt; IPRAs could go directly in L2 LSPs. so do we really require 
&gt; Level for IPRAs ????

Suryaa 

- jeff parker 

Get Your Private, Free E-mail from Indiatimes at  http://email.indiatimes.com
Buy Music, Video, CD-ROM, Audio-Books and Music Accessories from http://www.planetm.co.in
Change the way you talk. Indiatimes presents "Valufon", Your PC to Phone service with clear voice at rates far less than the normal ISD rates. Go to http://www.valufon.indiatimes.com. Choose your plan. BUY NOW.