Subject: [Isis-wg] Doubt Regarding isisCircTable of ISIS MIB

From: "ARAVIND R" <[email-masked]>
Date: Wed, 24 Jul 2002 12:59:19 +0530

Hi,

In isisCircTable of ISIS MIB there is no variable that can tell the actual
down layer status (UP/DOWN) of the interface.
So do the values of isisCircAdminState and isisCircExistState depends on the
actual status of the interface?

I mean to say, if down layer indicate that interface is not usable
Then do we need to forcefully change isisCktAdminState to OFF from ON and/or
change isisCircExistState to notInService/ notReady from ACTIVE?

Thanks
Aravind

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Jeff Parker <[email-masked]>
Date: Wed, 24 Jul 2002 09:29:09 -0400

> In isisCircTable of ISIS MIB there is no variable that can 
> tell the actual down layer status (UP/DOWN) of the interface.
> So do the values of isisCircAdminState and isisCircExistState 
> depends on the actual status of the interface?
> 

Aravind -

	You can use isisCircIfIndex to lookup the current status
in MIB-II.  I don't see the point of duplicating that functionality
in the IS-IS MIB.   
	If the circuit's AdminState is 'on', then the circuit will
be operational if/when the interface is up.  You shouldn't have 
to take any special MIB actions.  You implementation may need
to do something special when the interface comes up again, but 
that is outside the scope of the MIB.

- jeff parker
- axiowave networks