Subject: RE: [Isis-wg] isisISAdjProtSuppEntry index

From: Jeff Parker <[email-masked]>
Date: Tue, 13 Aug 2002 15:59:22 -0400

> I have another question, this time is isisISAdjProtSuppEntry.
> Current draft says we have four indexes shown below but I 
> think this is not good enough. We should have isisISAdjIndex 
> like other isisISAdj*Entries and we doesn't need 
> isisISAdjProtSuppProtocol as index.
> 
>      isisISAdjProtSuppEntry OBJECT-TYPE
>          SYNTAX IsisISAdjProtSuppEntry
>          MAX-ACCESS not-accessible
>          STATUS current
>          DESCRIPTION
>              "Each entry contains one protocol supported by a
>              neighboring Intermediate System as reported in its IIH
>              PDUs."
>          INDEX {  isisSysInstance,
>              isisCircIndex,
>              isisISAdjProtSuppIndex,
>              isisISAdjProtSuppProtocol }
>      ::= { isisISAdjProtSuppTable 1 }
> 
> So we should change isisISAdjProtSuppEntry's index like below.
> Can we?
> 
>      isisISAdjProtSuppEntry OBJECT-TYPE
>          SYNTAX IsisISAdjProtSuppEntry
>          MAX-ACCESS not-accessible
>          STATUS current
>          DESCRIPTION
>              "Each entry contains one protocol supported by a
>              neighboring Intermediate System as reported in its IIH
>              PDUs."
>          INDEX {  isisSysInstance,
>                   isisCircIndex,
>                   isisISAdjIndex,
>                   isisISAdjProtSuppIndex }
>      ::= { isisISAdjProtSuppTable 1 }
> 
> Thank you,
> 
> 								kay

Kay -

I have checked my current copy of the MIB.  Someone else
has suggested the change to to use the ISAdjIndex.  The
current table is shown below.

Help me understand how a ProtSuppIndex will be an
improvement over simply listing the protocols 
supported.  The protocols are one byte values,
and should be easy to walk such a table.  

- jeff parker

     isisISAdjProtSuppEntry OBJECT-TYPE
        SYNTAX IsisISAdjProtSuppEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry contains one protocol supported by a
             neighboring Intermediate System as reported in its IIH
             PDUs."
        INDEX {  isisSysInstance,
            isisCircIndex,
            isisISAdjIndex,
            isisISAdjProtSuppProtocol }
    ::= { isisISAdjProtSuppTable 1 }

    IsisISAdjProtSuppEntry ::=
        SEQUENCE {
            isisISAdjProtSuppProtocol
                SupportedProtocol
        }

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Noguchi Kay <[email-masked]>
Date: Thu, 15 Aug 2002 23:14:58 -0700

Hi Jeff,

It's cool to use isisISAdjProtSuppProtocol as the index of
isisISAdjProtSuppEntry as you pointed out in the new draft
like isisSysProtSuppEntry.

Thank you,

								kay