Subject: [Isis-wg] To standardize or not?

From: "Tony Li" <[email-masked]>
Date: Mon, 2 Feb 2004 21:25:18 -0800

Gents,

I've been asked to again provoke a discussion about whether
or not we should be putting our changes to IS-IS on the 
standards track.  Opinions?

Thanks,
Tony & Tony

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Naiming Shen <[email-masked]>
Date: Mon, 02 Feb 2004 22:03:11 -0800

Tonys,

I'm for putting IETF ISIS documents on standards track. This will
simplify everyone's life. Providers will trust the features they
deploy following the "standards"; ITU can reference them as nomative
instead of copying IETF RFCs and making minor changes in order
to avoid the copyright issues, which in turn was going to create
inconsistency between IETF RFCs and ITU papers.

Since most of the recent ISIS related work is done in IETF, we should
take this chance and get this done once for all.

thanks.

 ]
 ]Gents,
 ]
 ]I've been asked to again provoke a discussion about whether
 ]or not we should be putting our changes to IS-IS on the=20
 ]standards track.  Opinions?
 ]
 ]Thanks,
 ]Tony & Tony
 ]
 ]_______________________________________________
 ]Isis-wg mailing list
 ][email-masked]
 ]https://www1.ietf.org/mailman/listinfo/isis-wg

- Naiming

---

From: Danny McPherson <[email-masked]>
Date: Tue, 3 Feb 2004 05:33:10 -0700

> take this chance and get this done once for all.

I have to agree.  It'll likely be a pain getting there but once
we do it'll be well worth it.

-danny

---

From: stefano previdi <[email-masked]>
Date: Tue, 3 Feb 2004 14:35:09 +0100

On Feb 3, 2004, at 1:33 PM, Danny McPherson wrote:

>> simplify everyone's life.

I rarely noticed a simplification of my life due
to standardization processes...

>> Providers will trust the features they
>> deploy following the "standards";

I believe providers trust implementations and proven
interoperability more than theoretical standard
documents.

This interoperability and functionality can be
described in any document (standard or not) as long
as it is agreed by the community of companies
supposed to implement them.

... but I may be wrong of course...

s.

>> ITU can reference them as nomative

---

From: David Hudek <[email-masked]>
Date: Tue, 03 Feb 2004 23:32:22 -0500

>standards track.  Opinions?

I'm for it.

As I recall, when this was brought up the last time
there was a general consensus that this made sense
to do from a pragmatic point of view
(most of the active work on ISIS is being
  done under the IETF; "standards track" has more
  clout than "informational"; if put on standards track,
  the ITU can then make normative references to the
  RFCs instead of trying to paraphrase their content; etc.).

The only fly in the ointment was the issue of
potentially hurt feelings by members of another
group (JTC1/SC6/WG7) who might, or might not,
feel that the IETF was treading on their turf.

Things then stalled out on that point.

I would be in favor of moving things along,
going ahead and putting the ISIS RFCs on standards track,
and then dealing with the hypothetical hurt feelings
only if they actually come up.

In any event, it certainly seems reasonable for the
IS-IS WG to put on the standards track RFCs which cover
the use of ISIS **in IP networks**. It seems unreasonable
for another group to say it cannot be done.

My $0.02,
dave hudek
[email-masked]
http://www.bhawktech.com

---

From: Naiming Shen <[email-masked]>
Date: Tue, 03 Feb 2004 22:36:53 -0800

I must be dense and missed your point. Not sure you
were saying the current situation was the best thus no
change was needed or you were saying you didn't care.
ISIS working group is under IETF, I don't see why it
should not follow the Internet standard process as defined
in RFC2026. I also don't see how making the ISIS
documents on stardards track could compromise the
"provider's trust" or "interoperability" or the
"functionality". But I could be wrong...

 ] 
 ] On Feb 3, 2004, at 1:33 PM, Danny McPherson wrote:
 ] 
 ] >
 ] > On Feb 2, 2004, at 11:03 PM, Naiming Shen wrote:
 ] >
 ] >>
 ] >> Tonys,
 ] >>
 ] >> I'm for putting IETF ISIS documents on standards track. This will
 ] >> simplify everyone's life.
 ] 
 ] I rarely noticed a simplification of my life due
 ] to standardization processes...
 ] 
 ] >> Providers will trust the features they
 ] >> deploy following the "standards";
 ] 
 ] I believe providers trust implementations and proven
 ] interoperability more than theoretical standard
 ] documents.
 ] 
 ] This interoperability and functionality can be
 ] described in any document (standard or not) as long
 ] as it is agreed by the community of companies
 ] supposed to implement them.
 ] 
 ] ... but I may be wrong of course...
 ] 
 ] s.
 ] 
 ] 
 ] >> ITU can reference them as nomative
 ] >> instead of copying IETF RFCs and making minor changes in order
 ] >> to avoid the copyright issues, which in turn was going to create
 ] >> inconsistency between IETF RFCs and ITU papers.
 ] >>
 ] >> Since most of the recent ISIS related work is done in IETF, we should
 ] >> take this chance and get this done once for all.
 ] >
 ] > I have to agree.  It'll likely be a pain getting there but once
 ] > we do it'll be well worth it.
 ] >
 ] > -danny
 ] >
 ] >
 ] > _______________________________________________
 ] > Isis-wg mailing list
 ] > [email-masked]
 ] > https://www1.ietf.org/mailman/listinfo/isis-wg
 ] >
 ] 
 ] 
 ] _______________________________________________
 ] Isis-wg mailing list
 ] [email-masked]
 ] https://www1.ietf.org/mailman/listinfo/isis-wg

- Naiming

---

From: stefano previdi <[email-masked]>
Date: Wed, 4 Feb 2004 11:39:29 +0100

> change was needed or you were saying you didn't care.

a kind of combination of both...

> "functionality".

I didn't mean that. I just meant that I doubt it
will bring us much improvement while I see from
here the time and energy this will require.

Anyway, I won't fight against it.

s.

> But I could be wrong...