Subject: [Isis-wg] Review of: draft-ietf-isis-wg-mib-18.txt

From: [email-masked]
Date: Fri, 11 Mar 2005 13:41:28 -0800 (PST)

Here are my observations about the ISIS-draft-18 MIB.

1)	I noticed that two table has index defined as OCTET
STRING of SIZE (0..20). 
	isisManAreaAddrEntry OBJECT-TYPE
        SYNTAX IsisManAreaAddrEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry contains one area address
manually configured
             on this system"
        INDEX { isisManAreaAddr }
	   ::= { isisManAreaAddrTable 1 }

	IsisManAreaAddrEntry ::=
        SEQUENCE {
            isisManAreaAddr              
IsisOSINSAddress,
            isisManAreaAddrExistState     RowStatus
            }

	isisAreaAddrEntry OBJECT-TYPE
        SYNTAX IsisAreaAddrEntry
        MAX-ACCESS not-accessible
        STATUS current
        DESCRIPTION
            "Each entry contains one area address
reported in a
             Level 1 LSP generated or received by this
Intermediate
             System."
        INDEX { isisAreaAddr }
	    ::= { isisAreaAddrTable 1 }

	 IsisAreaAddrEntry ::=
        	SEQUENCE {
           	 isisAreaAddr IsisOSINSAddress
               }

	IsisOSINSAddress ::= TEXTUAL-CONVENTION
        STATUS current
        DESCRIPTION
            "OSI Network Service Address, e.g. NSAP,
SNPA, or Network
             Entity Title"
        SYNTAX OCTET STRING (SIZE(0..20))

A table with index of zero does not look correct to
me.
2)	I have noticed that most of tables do not follow
the naming convention defined in section “Appendix C: 
Suggested Naming Conventions” of
http://www.ietf.org/internet-drafts/draft-ietf-ops-mib-review-guidelines-04.txt

- The descriptor associated with the MODULE-IDENTITY
invocation should be of the form xxxMIB, xxxMib, or
xxxMibModule, where xxx is a mixed-case version of XXX
starting with a lower-case letter and without any
hyphens. For example, the OPT-IF-MIB uses the prefix
optIf, and the descriptor associated with its
MODULE-IDENTITY invocation is optIfMibModule.

   I have to list whatever I could find in the MIB:
a)	isisManAreaAddr in isisManAreaAddrTable.
Suggest name is isisManAreaAddrAddress
b)	isisAreaAddr in isisAreaAddrTable.
   Suggest name is isisAreaAddrAddress
c) isisSummAddressType and isisSummAddress in
isisSummAddrTable.
	     Suggest names are isisSummAddrType and
isisSummAddrAddress.
d)	Most of column in isisSystemCounterTable table do
not follow the naming convention.
e)	Most of column in isisCircuitCounterTable table do
not follow the naming convention.
f)	Most of column in isisPacketCounterTable table do
not follow the naming convention.

I not sure if these comments have been made by someone
or not. Please excuse me if somebody else has already
reported about this or if the above listed comments
are not valid.

Regards,
Amit

__________________________________ 
Do you Yahoo!? 
Yahoo! Mail - Helps protect you from nasty viruses. 
http://promotions.yahoo.com/new_mail

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "Don Goodspeed" <[email-masked]>
Date: Fri, 11 Mar 2005 13:55:57 -0800

Amit,

I'll let Jeff comment on issue #2.

On issue #1, the TC is correct in it's size but we should
add a range constraint on the table indices of SIZE(1..20).

Thanks,
Don

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of [email-masked]
Sent: Friday, March 11, 2005 1:41 PM
To: ISIS WG
Subject: [Isis-wg] Review of: draft-ietf-isis-wg-mib-18.txt

	IsisManAreaAddrEntry ::=
        SEQUENCE {
            isisManAreaAddr
IsisOSINSAddress,

	 IsisAreaAddrEntry ::=
        	SEQUENCE {

A table with index of zero does not look correct to
me.
2)	I have noticed that most of tables do not follow
the naming convention defined in section Appendix C:
Suggested Naming Conventions of
http://www.ietf.org/internet-drafts/draft-ietf-ops-mib-review-guidelines-04.
txt

Regards,
Amit

---

From: "C. M. Heard" <[email-masked]>
Date: Fri, 11 Mar 2005 23:44:47 -0800 (PST)

> 1)	I noticed that two table has index defined as OCTET
... 
> A table with index of zero does not look correct to me.

Actually, there is nothing wrong with this.  These are variable
length strings without the IMPLIED keyword, so the length will be
included as a sub-identifier in the instance identification part of
a column's OID.

//cmh