Subject: Re: [Isis-wg] Review of: draft-ietf-isis-wg-mib-18.txt

From: [email-masked]
Date: Sun, 13 Mar 2005 15:01:42 -0800 (PST)

[ Whether there is any real-world situation where the
it
[ makes sense for the object isisAreaAddr to have zero
[ length is a separate question. ]

You are right in case of Index being zero, I am
talking from implementation point of view because if
we go by MIB definition it seems that no value is also
a valid value.

In case of isisAreaAddrTable it is still ok as this is
read-only. But in isisManAreaAddrTable we have
read-create situation with INDEX of type
IsisOSINSAddress. In case of isisManAreaAddrTable then
a no index value will also be a valid value and an
entry should be created.

Expert opinion is required here, I am not able to
figure out how to implement this.

Thanks for pointing out about the IMPLIED keyword. I
realised it later, it was an error from my side in
saying that as we cannot do that, because if we do
that managers will not know what is the length of the
Area Address.

I have one more question related to the
isisAreaAddrTable, in this table we have INDEX as
isisAreaAddr whose MAX-ACCESS is read-only. Since this
is an INDEX in the table shouldn't the MAX-ACCESS be
not-accessible based on SMIv2.
I understand that if we make this not-accessible then
the MIB compilation may fail as some compilars assume
that there should be atleast on not-accessible
paramters in the Table.
Pardon my ignorance here, could you help me in
understanding this.

Regards,
Amit

--- "C. M. Heard" <[email-masked]> wrote:
> On Sat, 12 Mar 2005 [email-masked] wrote:
> > I agree to whatever you are saying, but the
> variable I
> > am talking about is an Index in one table and
> there is
> > only one Index for the table. Please see below for
> the
> > table.
> 
> [ the table in question is isisAreaAddrTable, whose
> only   ]
> [ index is the object isisAreaAddr.  That object is
> also   ]
> [ the only column in the table and to its MAX-ACCESS
> is    ]
> [ read-only.  Its type is IsisOSINSAddress, which
> resolves ]
> [ to OCTET STRING (SIZE(0..20)).                    
>       ]
> 
> > I think that if we have a OCTET STRING as a only
> INDEX
> > then the minimun STRING length should be 2 (If
> IMPLIED
> > keyword is not used).
> > First OCTET to represent the length and second is
> the
> > value, as you mentioned.
> 
> Why do you think that?  It is not a requirement of
> the
> SMI, as far as I can tell from reading RFC 2578, and
> there is no reason why a zero-length instance of
> isisAreaAddr could not be successfully retrieved
> with
> an SNMP get request.
> 
> Whether there is any real-world situation where the
> it
> makes sense for the object isisAreaAddr to have zero
> length is a separate question.
> 
> > Then if I think again it seems that in this table
> > there is only one OCTET STRING Index and that too
> > read-only so we should add IMPLIED keyword.
> 
> IMPLIED is generally NOT RECOMMENDED anymore ... see
> 
> draft-ietf-ops-mib-review-guidelines-04.txt section
> 4.6.4.
> 
> Mike Heard
> 
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: "C. M. Heard" <[email-masked]>
Date: Sun, 13 Mar 2005 17:30:47 -0800 (PST)

On Sun, 13 Mar 2005 [email-masked] wrote:
> [ Whether there is any real-world situation where it

OK.  The only INDEX object in isisAreaAddrEntry is the
the columnar object isisManAreaAddr, which as you say
has a MAX-ACCESS value of not-accessible.  So to create
a row a manager has to specify an <instance, value> pair
for the status column isisManAreaAddrExistState.  In
particular, if it is desired for some reason to create
a row where the value of isisManAreaAddr is a zero-length
OCTET STRING, then the manager would issue a set request
varbind whose name field is { isisManAreaAddrExistState 0 }
and whose value field is createAndGo(4) (createAndWait(5)
would also be legal, although there is not much point to
that).  The agent should then create the specified instance
of isisManAreaAddrExistState if it can do so.

If this is still not clear I suggest that we take the
discussion off-line.

//cmh