Subject: RE: [Isis-wg] I-D ACTION:draft-ietf-isis-caps-05.txt

From: "Les Ginsberg \(ginsberg\)" <[email-masked]>
Date: Wed, 14 Dec 2005 23:59:42 -0800

> -----Original Message-----
> From: Hannes Gredler [mailto:[email-masked]]
> Sent: Wednesday, December 14, 2005 11:06 PM
> To: Les Ginsberg (ginsberg)
> Cc: Naiming Shen (naiming); [email-masked]
> Subject: Re: [Isis-wg] I-D ACTION:draft-ietf-isis-caps-05.txt
> 
> > Hannes -
> >
> > I would rather NOT add a description of sub-TLV format here as two
> > normative descriptions in different documents is a recipe for
ambiguity.
> 
> we already do have some inconsistency in the existing darft base in
that
> respect ...
> for example the admin-tags draft also contains some sort a subTLV
format
> description.

In the admin tags draft, specific new sub-TLVs are being defined.
Clearly in doing so the format of those sub-TLVs must be specified.

In the capabilities draft we are merely saying "sub-TLVs go here". We
are not defining any specific sub-TLVs in the document - therefore we do
not need to discuss their format.

   Les

> 
> > If the consensus is that clarification is needed we could add a
> > reference to RFC 3784. So, we could change the following sentence in
> > Section 2:
> >
> >    "A set of optional sub-TLVs may follow the flag field."
> >
> > To
> >
> >    "A set of optional sub-TLVs may follow the flag field. Sub-TLVs
are
> > formatted as described in RFC 3784."
> >
> > Would that suffice?
> >
> >    Les
> 
> i am happy either way -
> 
> a. with an description or
> b. reference to rfc3784
> 
> /hannes

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Hannes Gredler <[email-masked]>
Date: Thu, 15 Dec 2005 09:39:40 +0100

> Clearly in doing so the format of those sub-TLVs must be specified.

sorry for not being clear:

agreed, in a descendant doc the typecode, length and *value* of a subTLV needs
to be defined. - what the admin-tags-draft in additon does:
is to specify the length of the type field and the length of the lengthfield
(= subTLV format).

the general subTLV format (type-field length, length-field length)
for the extd IP reach TLV #135 was described in the base spec (= RFC3784)

and it got redefined (1-octet type, 1 octet length ...)
in the admin-tags draft and this is also an overspecification.
(altough i am not aware of any confusion b/c of this)

---

anyway, for the isis-caps draft, adding a paragraph pointing to rfc3784 is
good enough for me.

/hannes

---

From: JP Vasseur <[email-masked]>
Date: Tue, 20 Dec 2005 08:04:42 -0500

Hi Hannes,

sounds like we can now close on this ?

Thanks.

JP.