Subject: RE: [Isis-wg] I-D ACTION:draft-ietf-isis-caps-05.txt

From: "Les Ginsberg \(ginsberg\)" <[email-masked]>
Date: Wed, 14 Dec 2005 13:03:48 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Hannes Gredler
> Sent: Wednesday, December 14, 2005 9:53 AM
> To: Naiming Shen (naiming)
> Cc: [email-masked]
> Subject: Re: [Isis-wg] I-D ACTION:draft-ietf-isis-caps-05.txt
> 
> naiming, et al,
> 
> can you add a paragraph about the subTLV encoding format:

Hannes -

I would rather NOT add a description of sub-TLV format here as two
normative descriptions in different documents is a recipe for ambiguity.
If the consensus is that clarification is needed we could add a
reference to RFC 3784. So, we could change the following sentence in
Section 2:

   "A set of optional sub-TLVs may follow the flag field."

To

   "A set of optional sub-TLVs may follow the flag field. Sub-TLVs are
formatted as described in RFC 3784."

Would that suffice?

   Les

> 
> i'd assume its in the IS-IS tradition of 1-octet type, 1-octet length
> (excluding type and length field), however thats just my guessing
> and neither the capability draft nor any of the referenced docs
> does explicityly mention this.
> 
> ---
> 
> for example rfc3784 is explicit about subTLV format encoding:
> 
> [ extd IS reach TLV ... ]
> 
>             where each sub-TLV consists of a sequence of
>                  1 octet of sub-type
>                  1 octet of length of the value field of the sub-TLV
>                  0-242 octets of value
> 
> [ extd IP reach TLV ... ]
> 
>        0-250 optional octets of sub-TLVs, if present consisting of
>             1 octet of length of sub-TLVs
>             0-249 octets of sub-TLVs,
>                  where each sub-TLV consists of a sequence of
>                       1 octet of sub-type
>                       1 octet of length of the value field of the
sub-TLV
>                       0-247 octets of value
> 
> [ ... ]
> 
> 
> /hannes
> 
> [email-masked] wrote:
> > A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> > This draft is a work item of the IS-IS for IP Internets Working
Group of
> the IETF.
> >
> > 	Title		: IS-IS Extensions for Advertising Router
Information
> > 	Author(s)	: J. Vasseur, et al.
> > 	Filename	: draft-ietf-isis-caps-05.txt
> > 	Pages		: 8
> > 	Date		: 2005-12-13
> >
> > This document defines a new optional IS-IS TLV named CAPABILITY,
> >    formed of multiple sub-TLVs, which allows a router to announce
its
> >    capabilities within an IS-IS level or the entire routing domain.
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/isis-wg

_______________________________________________
Isis-wg mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/isis-wg

---

From: Hannes Gredler <[email-masked]>
Date: Thu, 15 Dec 2005 08:05:55 +0100

> normative descriptions in different documents is a recipe for ambiguity.

we already do have some inconsistency in the existing darft base in that respect ...
for example the admin-tags draft also contains some sort a subTLV format description.

> formatted as described in RFC 3784."

i am happy either way -

a. with an description or
b. reference to rfc3784

/hannes